PPP Link Quality Monitoring

PPP Link Quality Monitoring

During PPP Link Establishment Phase, the link may be tested to see if link is sufficient for operation. This testing is optional. If a peer at one of point-to-point link wish to use link quality monitoring protocol, it must be negotiated during Link Establishment Phase.

Packets can be dropped or corrupted for various reasons like noisy link, equipment failure, flapping link, etc. The process of determining data loss is called Link Quality Monitoring (LQM). After determining the status of the link, a router may switch to an alternate link.

PPP LQM mechanism measures data loss in units of packets, octets and Link Quality Report packets. Each measurement is made separately for inbound and outbound directions. All measurements are communicated to both ends of the link.

LQM maintains a count of the number of packets and octets transmitted and successfully received, and periodically transmits this information to its peer in a Link Quality Report packet. Comparing these numbers gives an indication of a link's quality.

One Link Quality Report packet is encapsulated in the Information field of PPP frame. The Protocol field is set to 0xC025.

Calculations:

Each time an LQR packet is received from the inbound link, the fields of previous LQR is subtracted from current LQR values. This allows comparison of the changes seen by each end of the link.

When the LQR packets are not received in expected time, atleast one more LQR should be sent.

Network topology:

Only one link is active at a time. If the active link fails due to poor link quality, the backup link will come UP. The minimum link quality is set to 99%.

PPP LQM Configuration

R1 router:
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!
interface Serial 0/0
 description PRIMARY LINK
 ip address 10.1.1.1 255.255.255.252
 encapsulation ppp
 ppp quality 99
 ip ospf 1 area 0
!
interface Serial 0/1
 description BACKUP LINK
 ip address 10.2.2.1 255.255.255.252
 encapsulation ppp
 shutdown
 ip ospf 1 area 0
!
R2 router:
interface Loopback 0
 ip address 2.2.2.2 255.255.255.255
 ip ospf 1 area 0
!
interface Serial 0/0
 description PRIMARY LINK
 ip address 10.1.1.2 255.255.255.252
 encapsulation ppp
 ppp quality 99
 ip ospf 1 area 0
!
interface Serial 0/1
 description BACKUP LINK
 ip address 10.2.2.2 255.255.255.252
 encapsulation ppp
 shutdown
 ip ospf 1 area 0
!

EEM Configuration:

Cisco IOS EEM applet will be used on both routers to detect PRIMARY link failure and active BACKUP link.