IS-IS Areas

IS-IS Areas

This article will demonstrate IS-IS area(s) and the adjacencies formed in different scenarios. All Cisco IOS routers are IS-IS Level-1-2 routers by default. A Level-1 router can form adjacency with another Level-1 or Level-1-2 router only, and a Level-2 router can form adjacency with a Level-2 or Level-1-2 router only.

By default, a Level-1-2 router does not forward Level-2 routes to Level-1 routers. However, Level-1 routes are forwarded to Level-2 routers. For a Level-1 router to reach a prefix in Level-2 area, it must forward the packets to Level-1-2 router.

All Level-1 routers within an area (including Level-1-2 routers) maintain an identical LSDB.

In IS-IS, a router resides completely within a single area, the Area ID is associated with the entire router rather than an interface.

Scenario 1: R1 is a Level-1 router, R2 is a Level-1-2 router and R3 is a Level-1-2 router

The IS-IS configuration on the routers is as below:

R1 router
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip router isis
!
interface Serial 1/0
 ip address 10.1.1.1 255.255.255.0
 ip router isis
!
router isis
 is-type level-1
 net 49.0001.1111.1111.1111.00
 passive-interface Loopback 0
!
 
 R2 router
interface Loopback 0
 ip address 2.2.2.2 255.255.255.255
 ip router isis
!
interface Serial 1/0
 ip address 10.1.1.2 255.255.255.0
 ip router isis
!
interface Serial 1/1
 ip address 10.2.2.1 255.255.255.0
 ip router isis
!
router isis
 net 49.0001.2222.2222.2222.00
 passive-interface Loopback 0
!
 R3 router
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ip router isis
!
interface Serial 1/0
 ip address 10.2.2.2 255.255.255.0
 ip router isis
!
router isis
 net 49.0001.3333.3333.3333.00
 passive-interface Loopback 0
!

The following output shows the adjacencies formed between R1, R2 and R3 routers. Notice that a Level-1 adjacency is formed between R1 and R2. But a Level-1-2 adjacency is formed between R2 and R3 as they are both L1/L2 routers.

Adjacencies formed

R1# show isis neighbors
System Id      Type Interface   IP Address      State Holdtime Circuit Id
2222.2222.2222 L1   Se1/0       10.1.1.2        UP    21       00
R2# show isis neighbors
System Id      Type Interface   IP Address      State Holdtime Circuit Id
1111.1111.1111 L1   Se1/0       10.1.1.1        UP    29       00
3333.3333.3333 L1L2 Se1/1       10.2.2.2        UP    23       00
R3# show isis neighbors
System Id      Type Interface   IP Address      State Holdtime Circuit Id
2222.2222.2222 L1L2 Se1/0       10.2.2.1        UP    25       01

R1 router learns about prefixes beyond R2 router as Level-1 prefixes. R2 and R3 routers have both Level-1 and Level-2 LSDBs, and hence, R1 learns the prefixes.

R1 routing table

R1# show ip route isis | begin Gateway
Gateway of last resort is not set
     
      2.0.0.0/32 is subnetted, 1 subnets
i L1     2.2.2.2 [115/10] via 10.1.1.2, 00:15:52, Serial1/0
      3.0.0.0/32 is subnetted, 1 subnets
i L1     3.3.3.3 [115/20] via 10.1.1.2, 00:00:03, Serial1/0
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1     10.2.2.0/24 [115/20] via 10.1.1.2, 00:00:27, Serial1/0

Scenario 2: R1 is a Level-1 router, R2 is a Level-1-2 router and R3 is a Level-2 router

The IS-IS configuration on the routers is as below:

R1 router
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip router isis
!
interface Serial 1/0
 ip address 10.1.1.1 255.255.255.0
 ip router isis
!
router isis
 is-type level-1
 net 49.0001.1111.1111.1111.00
 passive-interface Loopback 0
!
 
 R2 router
interface Loopback 0
 ip address 2.2.2.2 255.255.255.255
 ip router isis
!
interface Serial 1/0
 ip address 10.1.1.2 255.255.255.0
 ip router isis
!
interface Serial 1/1
 ip address 10.2.2.1 255.255.255.0
 ip router isis
!
router isis
 net 49.0001.2222.2222.2222.00
 passive-interface Loopback 0
!
 R3 router
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ip router isis
!
interface Serial 1/0
 ip address 10.2.2.2 255.255.255.0
 ip router isis
!
router isis
 is-type level-2-only
 net 49.0001.3333.3333.3333.00
 passive-interface Loopback 0
!

Since R3 is only a Level-2 router (essentially, link between R2 and R3 forms a Backbone Link), a L2 adjacency is formed between them.

Adjacencies formed

R1# show isis neighbors
System Id      Type Interface   IP Address      State Holdtime Circuit Id
2222.2222.2222 L1   Se1/0       10.1.1.2        UP    25       00
R2# show isis neighbors
System Id      Type Interface   IP Address      State Holdtime Circuit Id
1111.1111.1111 L1   Se1/0       10.1.1.1        UP    26       00
3333.3333.3333 L2   Se1/1       10.2.2.2        UP    26       00
R3# show isis neighbors
System Id      Type Interface   IP Address      State Holdtime Circuit Id
2222.2222.2222 L2   Se1/0       10.2.2.1        UP    28       01

Since Level-2 routes are not leaked into Level-1 area, R1 does not learn of prefixes on R3. However, R3 will learn about prefixes in Level-1 area(s).

R1 and R3 routing tables

R1# show ip route isis | begin Gateway
Gateway of last resort is not set
      2.0.0.0/32 is subnetted, 1 subnets
i L1     2.2.2.2 [115/10] via 10.1.1.2, 00:57:58, Serial1/0
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1     10.2.2.0/24 [115/20] via 10.1.1.2, 00:42:33, Serial1/0
R3# show ip route isis | begin Gateway
Gateway of last resort is not set
      1.0.0.0/32 is subnetted, 1 subnets
i L2     1.1.1.1 [115/20] via 10.2.2.1, 00:10:18, Serial1/0
      2.0.0.0/32 is subnetted, 1 subnets
i L2     2.2.2.2 [115/10] via 10.2.2.1, 00:17:37, Serial1/0
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L2     10.1.1.0/24 [115/20] via 10.2.2.1, 00:17:37, Serial1/0

Notice that R1 (Level-1-only) router has no visibility of routes in other areas within the same domain. It relies on a default-route to R2 router to reach prefixes beyond R2 router.

Scenario 3: R1 is a Level-1 router in Area 49.0001, R2 is a Level-1-2 router in Area 49.0001 and R3 is a Level-1-2 router in Area 50.0001

The configuration on routers is as below:

R1 router
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip router isis
!
interface Serial 1/0
 ip address 10.1.1.1 255.255.255.0
 ip router isis
!
router isis
 is-type level-1
 net 49.0001.1111.1111.1111.00
 passive-interface Loopback 0
!
 
 R2 router
interface Loopback 0
 ip address 2.2.2.2 255.255.255.255
 ip router isis
!
interface Serial 1/0
 ip address 10.1.1.2 255.255.255.0
 ip router isis
!
interface Serial 1/1
 ip address 10.2.2.1 255.255.255.0
 ip router isis
!
router isis
 net 49.0001.2222.2222.2222.00
 passive-interface Loopback 0
!
 R3 router
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ip router isis
!
interface Serial 1/0
 ip address 10.2.2.2 255.255.255.0
 ip router isis
!
router isis
 net 50.0001.3333.3333.3333.00
 passive-interface Loopback 0
!

Although the Area IDs dont match on R2 and R3 routers, they still form a Level-2 adjacency between each other.

Adjacencies formed

R1# show isis neighbors
System Id      Type Interface   IP Address      State Holdtime Circuit Id
2222.2222.2222 L1   Se1/0       10.1.1.2        UP    29       00
R2# show isis neighbors
System Id      Type Interface   IP Address      State Holdtime Circuit Id
1111.1111.1111 L1   Se1/0       10.1.1.1        UP    25       00
3333.3333.3333 L2   Se1/1       10.2.2.2        UP    28       00
R3# show isis neighbors
System Id      Type Interface   IP Address      State Holdtime Circuit Id
2222.2222.2222 L2   Se1/0       10.2.2.1        UP    27       01

Notice in below output that both routers learn about their neighbor's Area IDs in IS-IS Hello messages.

CLNS neighbor output

R2# show clns neighbors detail
System Id      Interface   SNPA                State  Holdtime  Type Protocol
1111.1111.1111 Se1/0       *HDLC*              Up     24        L1   IS-IS
  Area Address(es): 49.0001
  IP Address(es):  10.1.1.1*
  Uptime: 00:02:21
  NSF capable
  Interface name: Serial1/0
3333.3333.3333 Se1/1       *HDLC*              Up     21        L2   IS-IS
  Area Address(es): 50.0001
  IP Address(es):  10.2.2.2*
  Uptime: 00:02:09
  NSF capable
  Interface name: Serial1/1
R3# show clns neighbors detail
System Id      Interface   SNPA                State  Holdtime  Type Protocol
2222.2222.2222 Se1/0       *HDLC*              Up     22        L2   IS-IS
  Area Address(es): 49.0001
  IP Address(es):  10.2.2.1*
  Uptime: 00:02:25
  NSF capable
  Interface name: Serial1/0

R2 (L1/L2) router signals R1 router that it can reach other area(s) by setting the Attached (ATT) Bit in the Level-1 LSPs. This causes R1 router to install a default-route to R2 router.

ATT bit

R1# show isis database
IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
1111.1111.1111.00-00* 0x00000065   0x37B1        971               0/0/0
2222.2222.2222.00-00  0x0000006A   0xF635        978               1/0/0
R1# show ip route isis | begin Gateway
Gateway of last resort is 10.1.1.2 to network 0.0.0.0
i*L1  0.0.0.0/0 [115/10] via 10.1.1.2, 00:19:37, Serial1/0
      2.0.0.0/32 is subnetted, 1 subnets
i L1     2.2.2.2 [115/10] via 10.1.1.2, 00:33:50, Serial1/0
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1     10.2.2.0/24 [115/20] via 10.1.1.2, 00:33:50, Serial1/0