Redistribution between IS-IS and OSPF

Redistribution between IS-IS and OSPF

Network topology:

Configuration task:

RA router is running OSPF and RC router is running IS-IS. At RB router, all the IS-IS routes are Level 1. Configure mutual redistribution at RB router by using summarization wherever possible. The OSPF routes should be advertised into the IS-IS domain as external routes.

Configuration:

OSPF Configuration on RA

interface fastethernet 0/0
 ip address 172.16.1.145 255.255.255.240
 ip ospf 1 area 0
!
router ospf 1
 router-id 1.1.1.1
!

OSPF and ISIS Configuration on RB

interface fastethernet 0/1
 ip address 172.16.1.146 255.255.255.240
 ip ospf 1 area 0
!
interface fastethernet 0/0
 ip address 172.16.1.97 255.255.255.224
 ip router isis
!
router ospf 1
 router-id 2.2.2.2
 redistribute connected subnets   ! Required to advertise the network connected to RC router.
 redistribute isis metric 30 level-1 subnets   ! This redistributes all ISIS Level-1 routes learnt by RB into OSPF domain
!
router isis
 net 49.0001.2222.2222.2222.00
 redistribute ospf 1 metric 100 match internal   ! This redistributes all OSPF internal (intra and inter-area) routes into ISIS domain
!

ISIS Configuration on RC

interface fastethernet 0/0
 ip address 172.16.1.98 255.255.255.224
 ip router isis
!
router isis
 net 49.0001.3333.3333.3333.00
!

Routing tables:

The following output shows OSPF and ISIS routes learned by RB router.

OSPF and ISIS routes

RB# show ip route ospf
     172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
O       172.16.1.160/28 [110/65] via 172.16.1.145, 00:06:50, FastEthernet0/1
O       172.16.1.128/28 [110/65] via 172.16.1.145, 00:06:50, FastEthernet0/1
O       172.16.1.224/28 [110/65] via 172.16.1.145, 00:06:50, FastEthernet0/1
O       172.16.1.192/28 [110/65] via 172.16.1.145, 00:06:50, FastEthernet0/1
RB# show ip route isis
     172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
i L1    172.16.2.128/27 [115/20] via 172.16.1.98, FastEthernet0/0
i L1    172.16.2.32/27 [115/20] via 172.16.1.98, FastEthernet0/0
i L1    172.16.2.64/27 [115/20] via 172.16.1.98, FastEthernet0/0

OSPF External routes on RA

RA# show ip route ospf
     172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
O E2    172.16.2.128/27 [110/30] via 172.16.1.146, 00:01:47, FastEthernet0/0
O E2    172.16.2.32/27 [110/30] via 172.16.1.146, 00:01:47, FastEthernet0/0
O E2    172.16.1.96/27 [110/20] via 172.16.1.146, 00:00:01, FastEthernet0/0
O E2    172.16.2.64/27 [110/30] via 172.16.1.146, 00:01:47, FastEthernet0/0

ISIS Level-2 routes on RC

The following output shows ISIS External routes learnt by RC router as redistributed by RB router.
RC# show ip route isis
     172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
i L2    172.16.1.160/28 [115/40] via 172.16.1.97, FastEthernet0/0
i L2    172.16.1.144/28 [115/40] via 172.16.1.97, FastEthernet0/0
i L2    172.16.1.128/28 [115/40] via 172.16.1.97, FastEthernet0/0
i L2    172.16.1.224/28 [115/40] via 172.16.1.97, FastEthernet0/0
i L2    172.16.1.192/28 [115/40] via 172.16.1.97, FastEthernet0/0

Summarization:

As seen above, the subnetworks 172.16.1.128/28, 172.16.1.144/28, 172.16.1.160/28, 172.16.1.192/28 and 172.16.1.224/28 can be summarised into ISIS domain at RB router with a supernet 172.16.1.128/25 which encompasses all the subnetworks.

Summarization at RB

router isis
 summary-address 172.16.1.128 255.255.255.128
!

This causes RB router to advertise only the summarised route to RC router. The RB router also points this summarized route towards Null0 interface so if any packets match to this summarised route, it will be dropped. "su" indicates IS-IS summary route.

RC routing table

RB# show ip route isis
     172.16.0.0/16 is variably subnetted, 10 subnets, 3 masks
i su    172.16.1.128/25 [115/30] via 0.0.0.0, Null0
i L1    172.16.2.128/27 [115/20] via 172.16.1.98, FastEthernet0/0
i L1    172.16.2.32/27 [115/20] via 172.16.1.98, FastEthernet0/0
i L1    172.16.2.64/27 [115/20] via 172.16.1.98, FastEthernet0/0
RC# show ip route isis
     172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
i L2    172.16.1.128/25 [115/40] via 172.16.1.97, FastEthernet0/0