EoMPLS Carrying Simple Ethernet

EoMPLS Carrying Simple Ethernet

Network topology:

The Attachment Circuit (AC) can be Ethernet port or 802.1Q sub-interface (VLAN). For each AC, LDP signals different VC type via the targeted LDP session. VC Type 5 for Ethernet Port mode and VC Type 4 for Ethernet VLAN mode.

Here, Ethernet Port mode is described. In Ethernet Port mode, a VLAN header might or might not be present on the frame. In any case, the PE router carries the frame transparently. This allows an Ethernet Trunk to be carried over a single Pseudowire.

Configuration:

The xconnect <peer-ip-address> <vcid> encapsulation mpls command establishes a targeted-LDP session between the peers.

PE1 & PE2 Configuration

PE1 router:
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
!
pseudowire-class MPLS_Encapsulation
 encapsulation mpls
!
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!
interface Fastethernet 0/0
 description Connected to CE1
 no ip address
 xconnect 3.3.3.3 2000 pw-class MPLS_Encapsulation
!
PE2 router:
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
!
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ip ospf 1 area 0
!
interface Fastethernet 1/0
 description Connected to CE2
 no ip address
 xconnect 1.1.1.1 2000 encapsulation mpls
!

CE1 & CE2 Configuration

CE1 router:
interface Fastethernet 0/0
 description Connected to PE1
 ip address 10.10.1.1 255.255.255.252
!
CE2 router:
interface Fastethernet 0/0
 description Connected to PE2
 ip address 10.10.1.2 255.255.255.252
!

VC Status:

The debug mpls l2transport signalling message command displays the VC labels exchanged between peers after the targeted-LDP session is established. It also shows each peer sends a Label Mapping message which contains FEC TLV, Label TLV and optional interface parameters. VC Type 5 indicates Ethernet Port mode.

Exchange of Label Mapping messages

23:59:19.883: %LDP-5-NBRCHG: LDP Neighbor 3.3.3.3:0 (2) is UP
23:59:19.911: AToM LDP [3.3.3.3]: Sending label mapping msg
23:59:19.911: AToM LDP [3.3.3.3]: Sending label mapping msg vc type 5, cbit 1, vc id 2000, group id 0, vc label 20, status 0x7/LDP 0x1/ADJ 0x0, mtu 1500, vc handle 0x1
23:59:19.955: AToM LDP [3.3.3.3]: Received label mapping msg, id 321, GR instance 2
23:59:19.955: AToM LDP [3.3.3.3]: Received label mapping msg, id 321, GR instance 2 vc type 5, cbit 1, vc id 2000, group id 0, vc label 19, status 0x7/LDP 0x1/ADJ 0x0, mtu 1500, vc handle 0x1

The following commands show the VC status. It also indicates the Label Stack that will be imposed upon packets going through L2 circuit.

VC Status verification

PE1# show mpls l2transport vc
Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Fa0/0          Ethernet                   3.3.3.3         2000       UP
PE1# show mpls l2transport vc detail
Local interface: Fa0/0 up, line protocol up, Ethernet up
  Destination address: 3.3.3.3, VC ID: 2000, VC status: up
    Output interface: Fa1/0, imposed label stack {17 19}
    Preferred path: not configured
    Default path: active
    Next hop: 10.1.1.2
  Create time: 00:34:58, last status change time: 00:07:13
  Signaling protocol: LDP, peer 3.3.3.3:0 up
    Targeted Hello: 1.1.1.1(LDP Id) -> 3.3.3.3, LDP is UP
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last local SSS circuit status rcvd: No fault
      Last local SSS circuit status sent: No fault
      Last local  LDP TLV    status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 20, remote 19
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  Control Word: On (configured: autosense)
  VC statistics:
    transit packet totals: receive 48, send 123
    transit byte totals:   receive 5272, send 16104
    transit packet drops:  receive 0, seq error 0, send 0