6PE: Crossing Multiple AS - Part 2

6PE: Crossing Multiple AS - Part 2

Approach 3:

In the approach, IPv6 prefixes are not maintained or distributed by ASBR routers. The ASBR routers are not dual-stack capable. The inter-ASBR link is IPv4 and MPLS enabled. An ASBR needs to maintain labeled IPv4 /32 routes to the 6PE routers within the AS. It uses eBGP to distribute these routes to other ASes. ASBRs also uses eBGP to pass along the labeled IPv4 /32 routes. This results in creation of LSP from 6PE1 router to 6PE2 router. Now, a multihop eBGP connection can be established between these 6PE routers and exchange IPv6 prefixes with IPv4-mapped IPv6 next-hop address.

Network topology:

Multihop eBGP connection between 6PE routers:

Multihop eBGP

6PE1 router:
router bgp 100
 neighbor 6.6.6.6 remote-as 200
 neighbor 6.6.6.6 update-source Loopback 0
 neighbor 6.6.6.6 ebgp-multihop 10
 !
 address-family ipv6
 neighbor 6.6.6.6 activate
 neighbor 6.6.6.6 send-label
 redistribute connected
 exit-address-family
!
6PE2 router:
router bgp 200
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback 0
 neighbor 1.1.1.1 ebgp-multihop 10
 !
 address-family ipv6
 neighbor 1.1.1.1 activate
 neighbor 1.1.1.1 send-label
 redistribute connected
 exit-address-family
!

After eBGP connection is established between 6PE routers, they exchange IPv6 prefixes with IPv4-mapped IPv6 address as the next-hop address ::FFFF:1.1.1.1 when 6PE1 router advertises IPv6 prefixes to 6PE2 router over multihop eBGP connection.

6PE1 router advertises Label 20 to 6PE2 router over eBGP for IPv6 prefix 2001:1::/124.

6PE1 router labels

6PE1# show mpls forwarding-table 2001:1::/124
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
20     Aggregate   2001:1::/124      2080

IPv6 prefix and labels on 6PE2

6PE2# show bgp ipv6 unicast labels
   Network          Next Hop      In label/Out label
   2001:1::/124     ::FFFF:1.1.1.1  nolabel/20
   ABCD::1/128      ::FFFF:1.1.1.1  nolabel/19
   ABCD::6/128      ::              25/nolabel
6PE2# show ip cef 1.1.1.1
1.1.1.1/32, version 15, epoch 0, cached adjacency 10.2.2.5
0 packets, 0 bytes
  tag information set
    local tag: 20
    fast tag rewrite with Fa0/0, 10.2.2.5, tags imposed: {19}
  via 10.2.2.5, FastEthernet0/0, 0 dependencies
    next hop 10.2.2.5, FastEthernet0/0
    valid cached adjacency
    tag rewrite with Fa0/0, 10.2.2.5, tags imposed: {19}
6PE2# show ipv6 cef 2001:1::/124
2001:1::/124
     nexthop ::FFFF:1.1.1.1
    fast tag rewrite with Fa0/0, 10.2.2.5, tags imposed: {19 20}