IPv6 over AToM

IPv6 over AToM

Here, IPv6 traffic is transported between CE1 and CE2 routers over Any Transport over MPLS (AToM) Layer-2 circuit. PE routers are not required to be dual-stack routers. A Layer-2 circuit is established between PE1 and PE3 routers.

CE1 & PE1 Configuration

CE1 router:
interface Serial 0/0
 encapsulation ppp
 ipv6 address 2001:1::1/124
 ipv6 ospf 1 area 0
!
interface Loopback 0
 ipv6 address ABCD::1/128
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 10.210.0.1
 no shutdown
!
PE1 router:
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!
interface Serial 0/0
 encapsulation ppp
 no ip address
 xconnect 3.3.3.3 100 encapsulation mpls
!

PE3 & CE2 Configuration

PE3 router:
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ip ospf 1 area 0
!
interface Serial 0/0
 encapsulation ppp
 no ip address
 xconnect 1.1.1.1 100 encapsulation mpls
!
CE2 router:
interface Serial 0/0
 encapsulation mpls
 ipv6 address 2001:1::2/124
 ipv6 ospf 1 area 0
!
interface Loopback 0
 ipv6 address ABCD::2/128
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 10.210.0.2
 no shutdown
!

Verifying Layer-2 circuit:

The debug mpls l2transport vc event command displays the events when a Layer-2 MPLS circuit is established. It also shows the labels exchanged. An LDP session is also established between PE routers.

Debug command

PE3#
03:23:49.567: %LDP-5-NBRCHG: LDP Neighbor 2.2.2.2:0 (1) is UP
PE3# debug mpls l2transport vc event
03:23:55.443: AToM MGR [1.1.1.1, 100]: Advertise local vc label binding
03:23:56.251: AToM MGR [1.1.1.1, 100]: Remote end up, inst 2
03:23:56.255: AToM MGR [1.1.1.1, 100]: Validate vc, activating data plane
03:23:56.255: AToM MGR [1.1.1.1, 100]: Failed to update AToM client's interwork type
03:23:56.263: AToM SMGR [1.1.1.1, 100]: Event Imposition Enable, action 0x101, imp flags 0x9 remote vc label 18
03:23:56.263: AToM SMGR: Programming impose rewrite 0x66903CC0: control_flag 0x83 resolve status 1
03:23:56.263: AToM SMGR [1.1.1.1, 100]: State [Provisioned->Imposition Rdy]
03:23:56.267: AToM SMGR [1.1.1.1, 100]: Event Disposition Enable, action 0x101 flags 0x1, local vc label 16
03:23:56.267: AToM SMGR: Updating dispose_rewrite 0x66184E80: control_flag 0x3 resolve status 1
03:23:56.267: AToM SMGR [1.1.1.1, 100]: State [Imposition Rdy->Imposition/Disposition Rdy]
03:23:56.271: AToM SMGR [1.1.1.1, 100]: sucessfully processed SSM SW class provision, pwid 0x1001
03:23:56.271: AToM SMGR [1.1.1.1, 100]: Notify SSM SW class ready from provision
03:23:56.279: AToM SMGR [1.1.1.1, 100]: put rewrite 0x66184E80 into SSM hdl=0x661238E4
03:23:56.283: AToM SMGR [1.1.1.1, 100]: Sucessfully processed SSM SW class bind for pwid 0x1001
03:23:56.287: AToM MGR [1.1.1.1, 100]: Receive SSM dataplane up notification
03:23:56.287: AToM MGR [1.1.1.1, 100]: Dataplane activated

The show mpls l2transport vc [detail] displays the state of Layer-2 circuit.

Verifying L2 circuit

PE1# show xconnect all detail
Legend: XC ST=Xconnect State, S1=Segment1 State, S2=Segment2 State
UP=Up, DN=Down, AD=Admin Down, IA=Inactive, NH=No Hardware
XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP     ac   Se0/0(PPP)                   UP mpls 3.3.3.3:100                  UP
            Interworking: none                   Local VC label 18
                                                 Remote VC label 16
                                                 pw-class:
PE3# show xconnect all detail
Legend: XC ST=Xconnect State, S1=Segment1 State, S2=Segment2 State
UP=Up, DN=Down, AD=Admin Down, IA=Inactive, NH=No Hardware
XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP     ac   Se0/0(PPP)                   UP mpls 1.1.1.1:100                  UP
            Interworking: none                   Local VC label 16
                                                 Remote VC label 18
                                                 pw-class:

OSPFv3 Adjacency between CE routers:

Once the Layer-2 MPLS circuit is established between PE routers, the CE routers form OSPFv3 adjacency over the circuit and exchange IPv6 prefixes.

OSPFv3 Adjacency

CE2#
00:40:50.323: %OSPFv3-5-ADJCHG: Process 1, Nbr 10.210.0.1 on Serial0/0 from LOADING to FULL, Loading Done
CE2# show ipv6 route ospf
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
O   ABCD::1/128 [110/64]
     via FE80::C600:12FF:FEC4:0, Serial0/0

Labels imposed over IPv6 traffic:

The PE routers will impose label stack for any traffic that flows over the L2 circuit. The following output shows the label stack that will be imposed for traffic flowing over L2 circuit from PE3 router to PE1 router. The bottom Label 18 is the VC label as advertised by PE1 router, while the top Label 16 is the IGP label as advertised by the downstream router- P router.

Label stack imposed by PE3

PE3# show mpls l2transport vc detail
Local interface: Se0/0 up, line protocol up, PPP up
  Destination address: 1.1.1.1, VC ID: 100, VC status: up
    Next hop: 10.2.2.1
    Output interface: Fa0/0, imposed label stack {16 18}
  Create time: 00:24:08, last status change time: 00:21:01
  Signaling protocol: LDP, peer 1.1.1.1:0 up
    MPLS VC labels: local 16, remote 18
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  VC statistics:
    packet totals: receive 447, send 430
    byte totals:   receive 30056, send 28186
    packet drops:  receive 0, seq error 0, send 0

The following packet capture shows the label imposed on the traffic flowing over L2 circuit. Also, note the encapsulations in MPLS network.