BGP Confederation in Multiple IGP environment
PE1 router:
ip vrf CUST1
rd 1:1
route-target both 1:1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 65001 area 0
!
interface serial 0/0
ip vrf forwarding CUST1
ip address 172.16.1.1 255.255.255.252
!
router bgp 65001
bgp confederation identifier 100
neighbor 2.2.2.2 remote-as 65001
neighbor 2.2.2.2 update-source Loopback 0
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute connected
exit-address-family
!
P1 router:
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 65001 area 0
!
router bgp 65001
no bgp default route-target filter
bgp confederation identifier 100
bgp confederation peers 65002 65003
neighbor 1.1.1.1 remote-as 65001
neighbor 1.1.1.1 update-source Loopback 0
neighbor 192.168.1.2 remote-as 65002
neighbor 192.168.2.2 remote-as 65003
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 192.168.1.2 activate
neighbor 192.168.1.2 next-hop-self
neighbor 192.168.2.2 activate
neighbor 192.168.2.2 next-hop-self
exit-address-family
!
router ospf 65001
redistribute connected subnets
!
PE3 router:
ip vrf CUST1
rd 1:1
route-target both 1:1
!
ip vrf CUST2
rd 2:2
route-target both 2:2
!
interface Loopback0
ip address 7.7.7.7 255.255.255.255
ip ospf 65003 area 0
!
interface serial 0/0
ip vrf forwarding CUST1
ip address 172.17.1.1 255.255.255.252
!
interface serial 0/1
ip vrf forwarding CUST2
ip address 172.17.2.1 255.255.255.252
!
router bgp 65003
bgp confederation identifier 100
neighbor 6.6.6.6 remote-as 65003
neighbor 6.6.6.6 update-source Loopback 0
!
address-family vpnv4
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute connected
exit-address-family
!
address-family ipv4 vrf CUST2
redistribute connected
exit-address-family
!
PE2 router:
ip vrf CUST2
rd 2:2
route-target both 2:2
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip ospf 65002 area 0
!
interface serial 0/0
ip vrf forwarding CUST2
ip address 172.17.1.1 255.255.255.252
!
router bgp 65002
bgp confederation identifier 100
neighbor 3.3.3.3 remote-as 65002
neighbor 3.3.3.3 update-source Loopback 0
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf CUST2
redistribute connected
exit-address-family
!
P2 router:
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip ospf 65002 area 0
!
router bgp 65002
no bgp default route-target filter
bgp confederation identifier 100
bgp confederation peers 65001 65003
neighbor 4.4.4.4 remote-as 65002
neighbor 4.4.4.4 update-source Loopback 0
neighbor 192.168.1.1 remote-as 65001
neighbor 192.168.2.6 remote-as 65003
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 next-hop-self
neighbor 192.168.2.6 activate
neighbor 192.168.2.6 next-hop-self
exit-address-family
!
router ospf 65002
redistribute connected subnets
!
P3 router:
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip ospf 65003 area 0
!
router bgp 65003
bgp confederation identifier 100
bgp confederation peers 65001 65002
neighbor 7.7.7.7 remote-as 65003
neighbor 7.7.7.7 update-source Loopback 0
neighbor 192.168.2.1 remote-as 65001
neighbor 192.168.2.5 remote-as 65002
!
address-family vpnv4
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community both
neighbor 192.168.2.1 activate
neighbor 192.168.2.1 next-hop-self
neighbor 192.168.2.5 activate
neighbor 192.168.2.5 next-hop-self
exit-address-family
!
router ospf 65003
redistribute connected subnets
!