BGP RR using ORF capability

PE1 router:

ip vrf CUST1

rd 1:1

route-target both 1:1

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

ip ospf 1 area 0

!

interface serial 0/0

ip vrf forwarding CUST1

ip address 172.16.1.1 255.255.255.252

!

interface FastEthernet0/0

ip address 10.1.1.1 255.255.255.252

ip ospf 1 area 0

!

router bgp 100

neighbor 5.5.5.5 remote-as 100

neighbor 5.5.5.5 update-source Loopback 0

!

address-family vpnv4

neighbor 5.5.5.5 activate

neighbor 5.5.5.5 send-community both

neighbor 5.5.5.5 capability orf prefix-list send

neighbor 5.5.5.5 prefix-list CUST1_ROUTES in

exit-address-family

!

address-family ipv4 vrf CUST1

redistribute connected

exit-address-family

!

ip prefix-list CUST1_ROUTES seq 5 permit 172.16.2.0/30

!

PE3 router:

ip vrf CUST1

rd 1:1

route-target both 1:1

!

ip vrf CUST2

rd 2:2

route-target both 2:2

!

interface Loopback0

ip address 4.4.4.4 255.255.255.255

ip ospf 1 area 0

!

interface serial 0/0

ip vrf forwarding CUST1

ip address 172.17.1.1 255.255.255.252

!

interface serial 0/1

ip vrf forwarding CUST2

ip address 172.17.2.1 255.255.255.252

!

interface FastEthernet0/0

ip address 10.3.3.2 255.255.255.252

ip ospf 1 area 0

!

router bgp 100

neighbor 5.5.5.5 remote-as 100

neighbor 5.5.5.5 update-source Loopback 0

!

address-family vpnv4

neighbor 5.5.5.5 activate

neighbor 5.5.5.5 send-community both

neighbor 5.5.5.5 capability orf prefix-list send

neighbor 5.5.5.5 prefix-list CUST_ROUTES in

exit-address-family

!

address-family ipv4 vrf CUST1

redistribute connected

exit-address-family

!

address-family ipv4 vrf CUST2

redistribute connected

exit-address-family

!

ip prefix-list CUST_ROUTES seq 5 permit 172.16.1.0/30

ip prefix-list CUST_ROUTES seq 15 permit 172.17.1.0/30

!

PE2 router:

ip vrf CUST2

rd 2:2

route-target both 2:2

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

ip ospf 1 area 0

!

interface serial 0/0

ip vrf forwarding CUST2

ip address 172.17.1.1 255.255.255.252

!

interface FastEthernet0/0

ip address 10.2.2.1 255.255.255.252

ip ospf 1 area 0

!

router bgp 100

neighbor 5.5.5.5 remote-as 100

neighbor 5.5.5.5 update-source Loopback 0

!

address-family vpnv4

neighbor 5.5.5.5 activate

neighbor 5.5.5.5 send-community both

neighbor 5.5.5.5 capability orf prefix-list send

neighbor 5.5.5.5 prefix-list CUST2_ROUTES in

exit-address-family

!

address-family ipv4 vrf CUST2

redistribute connected

exit-address-family

!

ip prefix-list CUST2_ROUTES seq 5 permit 172.17.2.0/30

!

Route_Reflector router:

interface Loopback0

ip address 5.5.5.5 255.255.255.255

ip ospf 1 area 0

!

interface serial 0/0

ip address 10.2.2.6 255.255.255.252

!

router bgp 100

neighbor 1.1.1.1 remote-as 100

neighbor 1.1.1.1 update-source Loopback 0

neighbor 3.3.3.3 remote-as 100

neighbor 3.3.3.3 update-source Loopback 0

neighbor 4.4.4.4 remote-as 100

neighbor 4.4.4.4 update-source Loopback 0

!

address-family vpnv4

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 capability orf prefix-list receive

neighbor 1.1.1.1 route-reflector-client

neighbor 3.3.3.3 activate

neighbor 3.3.3.3 capability orf prefix-list receive

neighbor 3.3.3.3 route-reflector-client

neighbor 4.4.4.4 activate

neighbor 4.4.4.4 capability orf prefix-list receive

neighbor 4.4.4.4 route-reflector-client

bgp rr-group 1

exit-address-family

!

ip extcommunity-list 1 permit rt 1:1 rt 1:2

!