Inter-AS MPLS VPN

Inter-AS MPLS VPN

PE1 router:

mpls label protocol ldp

mpls ldp router-id Loopback 0 force

!

ip vrf CUST1

rd 1:1

route-target both 1:1

!

interface Loopback 0

ip address 1.1.1.1 255.255.255.255

ip ospf 1 area 0

!

interface serial 0/0

ip vrf forwarding CUST1

ip address 172.16.1.1 255.255.255.252

!

interface fastethernet 0/0

ip address 10.1.1.1 255.255.255.252

ip ospf 1 area 0

mpls ip

!

router bgp 100

neighbor 2.2.2.2 remote-as 100

neighbor 2.2.2.2 update-source Loopback 0

!

address-family vpnv4

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 send-community both

exit-address-family

!

address-family ipv4 vrf CUST1

redistribute connected

exit-address-family

!

PE1_ASBR router:

mpls label protocol ldp

mpls ldp router-id Loopback 0 force

!

interface Loopback 0

ip address 2.2.2.2 255.255.255.255

ip ospf 1 area 0

!

interface fastethernet 0/1

ip address 192.168.1.1 255.255.255.252

!

router bgp 100

neighbor 1.1.1.1 remote-as 100

neighbor 1.1.1.1 update-source Loopback 0

neighbor 192.168.1.2 remote-as 200

neighbor 192.168.1.2 password cisco

no bgp default route-target filter

!

address-family vpnv4

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-community both

neighbor 1.1.1.1 next-hop-self

neighbor 192.168.1.2 activate

neighbor 192.168.1.2 send-community both

exit-address-family

!

PE2 router:

mpls label protocol ldp

mpls ldp router-id Loopback 0 force

!

ip vrf CUST1

rd 1:1

route-target both 1:1

!

interface Loopback 0

ip address 4.4.4.4 255.255.255.255

ip ospf 1 area 0

!

interface serial 0/0

ip vrf forwarding CUST1

ip address 172.16.2.1 255.255.255.252

!

interface fastethernet 0/0

ip address 10.2.2.2 255.255.255.252

ip ospf 1 area 0

mpls ip

!

router bgp 200

neighbor 3.3.3.3 remote-as 200

neighbor 3.3.3.3 update-source Loopback 0

!

address-family vpnv4

neighbor 3.3.3.3 activate

neighbor 3.3.3.3 send-community both

exit-address-family

!

address-family ipv4 vrf CUST1

redistribute connected

exit-address-family

!

PE2_ASBR router:

mpls label protocol ldp

mpls ldp router-id Loopback 0 force

!

interface Loopback 0

ip address 3.3.3.3 255.255.255.255

ip ospf 1 area 0

!

interface fastethernet 0/0

ip address 192.168.1.2 255.255.255.252

!

router bgp 200

neighbor 4.4.4.4 remote-as 100

neighbor 4.4.4.4 update-source Loopback 0

neighbor 192.168.1.1 remote-as 100

neighbor 192.168.1.1 password cisco

no bgp default route-target filter

!

address-family vpnv4

neighbor 4.4.4.4 activate

neighbor 4.4.4.4 send-community both

neighbor 4.4.4.4 next-hop-self

neighbor 192.168.1.1 activate

neighbor 192.168.1.1 send-community both

exit-address-family

!