EoMPLS Carrying One VLAN

EoMPLS Carrying One VLAN

Network topology:

Here, an 802.1Q trunk is established between CE and PE. Each VLAN is mapped to one Pseudowire.

Configuration:

CE Configuration

CE1 router:
interface Fastethernet 0/0
 no ip address
!
interface Fastethernet 0/0.100
 encapsulation dot1q 100
 ip address 10.100.1.1 255.255.255.252
!
interface Fastethernet 0/0.200
 encapsulation dot1q 200
 ip address 10.200.1.1 255.255.255.252
!
CE2 router:
interface Fastethernet 0/0
 no ip address
!
interface Fastethernet 0/0.100
 encapsulation dot1q 100
 ip address 10.100.1.2 255.255.255.252
!
interface Fastethernet 0/0.200
 encapsulation dot1q 200
 ip address 10.200.1.2 255.255.255.252
!

A unique Pseudowire is configured for each VLAN.

PE Configuration

PE1 router:
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!
interface Fastethernet 0/0
 no ip address
!
interface Fastethernet 0/0.100
 encapsulation dot1q 100
 no ip address
 xconnect 3.3.3.3 1000 encapsulation mpls
!
interface Fastethernet 0/0.200
 encapsulation dot1q 200
 no ip address
 xconnect 3.3.3.3 2000 encapsulation mpls
!
PE2 router:
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ip ospf 1 area 0
!
interface Fastethernet 1/0
 no ip address
!
interface Fastethernet 1/0.100
 encapsulation dot1q 100
 no ip address
 xconnect 1.1.1.1 1000 encapsulation mpls
!
interface Fastethernet 1/0.200
 encapsulation dot1q 200
 no ip address
 xconnect 1.1.1.1 2000 encapsulation mpls
!

VC Status verification:

The debug mpls l2transport signaling message command shows Label Mapping messages exchanged for each Pseudowire between PE1 and PE2 routers. The VC Type is 4 which indicates Ethernet VLAN mode. VC IDs should match on each side for successful VC establishment.

Label Mapping messages

04:46:37.811: %LDP-5-NBRCHG: LDP Neighbor 3.3.3.3:0 (2) is UP
04:46:37.867: AToM LDP [3.3.3.3]: Sending label mapping msg
04:46:37.875: AToM LDP [3.3.3.3]: Sending label mapping msg vc type 4, cbit 1, vc id 1000, group id 0, vc label 18, status 0x7/LDP 0x1/ADJ 0x0, mtu 1500, peer vlan id 0   , vc handle 0x5A000002
04:46:37.883: AToM LDP [3.3.3.3]: Sending label mapping msg
04:46:37.887: AToM LDP [3.3.3.3]: Sending label mapping msg vc type 4, cbit 1, vc id 2000, group id 0, vc label 19, status 0x7/LDP 0x1/ADJ 0x0, mtu 1500, peer vlan id 0   , vc handle 0xB4000003
04:46:37.975: AToM LDP [3.3.3.3]: Received label mapping msg, id 64, GR instance 2
04:46:37.983: AToM LDP [3.3.3.3]: Received label mapping msg, id 64, GR instance 2 vc type 4, cbit 1, vc id 2000, group id 0, vc label 16, status 0x7/LDP 0x1/ADJ 0x0, mtu 1500, peer vlan id 0   , vc handle 0xB4000003
04:46:37.995: AToM LDP [3.3.3.3]: Received label mapping msg, id 65, GR instance 2
04:46:37.999: AToM LDP [3.3.3.3]: Received label mapping msg, id 65, GR instance 2 vc type 4, cbit 1, vc id 1000, group id 0, vc label 17, status 0x7/LDP 0x1/ADJ 0x0, mtu 1500, peer vlan id 0   , vc handle 0x5A000002

The following output shows successful Pseudowire setup.

Pseudowires

PE1# show mpls l2transport vc
Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Fa0/0.100      Eth VLAN 100               3.3.3.3         1000       UP
Fa0/0.200      Eth VLAN 200               3.3.3.3         2000       UP
PE1# show mpls l2transport vc detail
Local interface: Fa0/0.100 up, line protocol up, Eth VLAN 100 up
  Destination address: 3.3.3.3, VC ID: 1000, VC status: up
    Output interface: Fa1/0, imposed label stack {17 17}
    Preferred path: not configured
    Default path: active
    Next hop: 10.1.1.2
  Create time: 00:13:11, last status change time: 00:03:17
  Signaling protocol: LDP, peer 3.3.3.3:0 up
    Targeted Hello: 1.1.1.1(LDP Id) -> 3.3.3.3, LDP is UP
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last local SSS circuit status rcvd: No fault
      Last local SSS circuit status sent: No fault
      Last local  LDP TLV    status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 18, remote 17
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  Control Word: On (configured: autosense)
  VC statistics:
    transit packet totals: receive 0, send 0
    transit byte totals:   receive 0, send 0
    transit packet drops:  receive 0, seq error 0, send 0
Local interface: Fa0/0.200 up, line protocol up, Eth VLAN 200 up
  Destination address: 3.3.3.3, VC ID: 2000, VC status: up
    Output interface: Fa1/0, imposed label stack {17 16}
    Preferred path: not configured
    Default path: active
    Next hop: 10.1.1.2
  Create time: 00:12:48, last status change time: 00:03:17
  Signaling protocol: LDP, peer 3.3.3.3:0 up
    Targeted Hello: 1.1.1.1(LDP Id) -> 3.3.3.3, LDP is UP
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last local SSS circuit status rcvd: No fault
      Last local SSS circuit status sent: No fault
      Last local  LDP TLV    status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 19, remote 16
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  Control Word: On (configured: autosense)
  VC statistics:
    transit packet totals: receive 0, send 0
    transit byte totals:   receive 0, send 0
    transit packet drops:  receive 0, seq error 0, send 0

The following output shows the MPLS LFIB table on PE1 router. It indicates two point-to-point L2 circuits i.e. Pseudowires.

LFIB on PE1

PE1# show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  2.2.2.2/32       0             Fa1/0      10.1.1.2
17         Pop Label  10.1.1.4/30      0             Fa1/0      10.1.1.2
18         No Label   l2ckt(1000)      0             Fa0/0.100  point2point
19         No Label   l2ckt(2000)      0             Fa0/0.200  point2point
20         17         3.3.3.3/32       0             Fa1/0      10.1.1.2

VLAN ID Rewrite:

VLAN ID Rewrite is a feature (enabled by default, and cannot be disabled) where if the Ethernet 802.1Q VLAN ID is different at both sides of the AToM network, then the 802.1Q tag might be rewritten. Here, one 802.1Q trunk between PE2 and CE2 routers is changed to VLAN 1000.

VLAN 1000

PE2 router:
interface Fastethernet 1/0.100
 encapsulation dot1q 1000
 xconnect 1.1.1.1 1000 encapsulation mpls
!
CE2 router:
interface Fastethernet 0/0.100
 encapsulation dot1q 1000
 ip address 10.100.1.2 255.255.255.252
!

Although the VLAN IDs do not match, the VC is still UP.

VC Status

PE1# show mpls l2transport vc
Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Fa0/0.100      Eth VLAN 100               3.3.3.3         1000       UP
Fa0/0.200      Eth VLAN 200               3.3.3.3         2000       UP
PE2# show mpls l2transport vc
Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Fa1/0.100      Eth VLAN 1000              1.1.1.1         1000       UP
Fa1/0.200      Eth VLAN 200               1.1.1.1         2000       UP