Hands-On Final

Hands On Final

CNT150AA

Given:

200.0.0.0/24, subnet this setup so that all networks can work. There is one way out to the Internet and that is through the ISP (the Network number for that link is 177.43.33.76/30). Also configure passwords for network and console access. All PCs should be able to ping each other and they should send to the ISP any packets destined for other networks other than 200.0.0.0.x. Since the link through the border router is faster then the 64 K link, all traffic between New York and Chicago should go through the Border router. Use OSPF for routing within the 200.0.0.0 networks but don't use OSPF for 177.43.33.76.

My Solution

IP Scheme

Network Topology

Router Configurations & Routing Tables

ISP Router

ISP#show run

Building configuration...

Current configuration : 728 bytes

!

version 12.2

no service password-encryption

!

hostname ISP

!

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

no ip domain-lookup

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0

description Connection to Border

ip address 177.43.33.77 255.255.255.252

clock rate 4000000

!

interface Serial0/1

no ip address

shutdown

!

interface Loopback0

description Out to the Internet

ip address 10.0.0.1 255.255.255.252

!

router ospf 1

log-adjacency-changes

network 177.43.33.76 0.0.0.3 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 Loopback0

ip route 200.0.0.0 255.255.255.0 Serial0/0

!

!

!

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

!

end

ISP#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

10.0.0.0/30 is subnetted, 1 subnets

C 10.0.0.0 is directly connected, Loopback0

177.43.0.0/30 is subnetted, 1 subnets

C 177.43.33.76 is directly connected, Serial0/0

S 200.0.0.0/24 is directly connected, Serial0/0

S* 0.0.0.0/0 is directly connected, Loopback0

ISP#

Border Router

Border#show run

Building configuration...

Current configuration : 951 bytes

!

version 12.2

no service password-encryption

!

hostname Border

!

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

no ip domain-lookup

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0

description Connection to Chicago

ip address 200.0.0.225 255.255.255.252

clock rate 4000000

!

interface Serial0/1

description Connection to New York

ip address 200.0.0.237 255.255.255.252

clock rate 4000000

!

interface Serial0/2

description Connection to ISP

ip address 177.43.33.78 255.255.255.252

!

interface Serial0/3

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 200.0.0.224 0.0.0.3 area 0

network 200.0.0.236 0.0.0.3 area 0

default-information originate

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/2

!

!

!

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

!

end

Border#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

177.43.0.0/30 is subnetted, 1 subnets

C 177.43.33.76 is directly connected, Serial0/2

200.0.0.0/24 is variably subnetted, 11 subnets, 4 masks

O 200.0.0.0/25 [110/65] via 200.0.0.226, 01:16:30, Serial0/0

O 200.0.0.128/27 [110/65] via 200.0.0.238, 01:16:30, Serial0/1

O 200.0.0.160/28 [110/129] via 200.0.0.238, 00:42:44, Serial0/1

O 200.0.0.176/28 [110/193] via 200.0.0.238, 00:42:44, Serial0/1

O 200.0.0.192/28 [110/193] via 200.0.0.238, 00:42:44, Serial0/1

O 200.0.0.208/28 [110/129] via 200.0.0.238, 00:42:44, Serial0/1

C 200.0.0.224/30 is directly connected, Serial0/0

O 200.0.0.228/30 [110/1626] via 200.0.0.238, 01:16:30, Serial0/1

[110/1626] via 200.0.0.226, 01:16:30, Serial0/0

O 200.0.0.232/30 [110/128] via 200.0.0.238, 00:42:54, Serial0/1

C 200.0.0.236/30 is directly connected, Serial0/1

O 200.0.0.240/30 [110/192] via 200.0.0.238, 00:42:44, Serial0/1

S* 0.0.0.0/0 is directly connected, Serial0/2

Border#

Chicago Router

Chicago#show run

Building configuration...

Current configuration : 823 bytes

!

version 12.2

no service password-encryption

!

hostname Chicago

!

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

no ip domain-lookup

!

!

interface FastEthernet0/0

description Connection to Network A

ip address 200.0.0.1 255.255.255.128

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0

description Connection to Border

ip address 200.0.0.226 255.255.255.252

!

interface Serial0/1

description Connection to New York

bandwidth 64

ip address 200.0.0.229 255.255.255.252

clock rate 4000000

!

router ospf 1

log-adjacency-changes

network 200.0.0.224 0.0.0.3 area 0

network 200.0.0.228 0.0.0.3 area 0

network 200.0.0.0 0.0.0.127 area 0

!

ip classless

!

!

!

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

!

end

Chicago#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 200.0.0.225 to network 0.0.0.0

200.0.0.0/24 is variably subnetted, 11 subnets, 4 masks

C 200.0.0.0/25 is directly connected, FastEthernet0/0

O 200.0.0.128/27 [110/129] via 200.0.0.225, 01:16:34, Serial0/0

O 200.0.0.160/28 [110/193] via 200.0.0.225, 00:42:58, Serial0/0

O 200.0.0.176/28 [110/257] via 200.0.0.225, 00:42:58, Serial0/0

O 200.0.0.192/28 [110/257] via 200.0.0.225, 00:42:58, Serial0/0

O 200.0.0.208/28 [110/193] via 200.0.0.225, 00:42:58, Serial0/0

C 200.0.0.224/30 is directly connected, Serial0/0

C 200.0.0.228/30 is directly connected, Serial0/1

O 200.0.0.232/30 [110/192] via 200.0.0.225, 00:43:08, Serial0/0

O 200.0.0.236/30 [110/128] via 200.0.0.225, 01:16:44, Serial0/0

O 200.0.0.240/30 [110/256] via 200.0.0.225, 00:42:58, Serial0/0

O*E2 0.0.0.0/0 [110/1] via 200.0.0.225, 00:45:36, Serial0/0

Chicago#

New York Router

NewYork#show run

Building configuration...

Current configuration : 983 bytes

!

version 12.2

no service password-encryption

!

hostname NewYork

!

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

no ip domain-lookup

!

!

interface FastEthernet0/0

description Connection to Network E

ip address 200.0.0.129 255.255.255.224

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0

description Connectio to Chicago

bandwidth 64

ip address 200.0.0.230 255.255.255.252

!

interface Serial0/1

description Connection to Border

ip address 200.0.0.238 255.255.255.252

!

interface Serial0/2

description Connection to Seattle

ip address 200.0.0.234 255.255.255.252

!

interface Serial0/3

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 200.0.0.236 0.0.0.3 area 0

network 200.0.0.228 0.0.0.3 area 0

network 200.0.0.232 0.0.0.3 area 0

network 200.0.0.128 0.0.0.3 area 0

!

ip classless

!

!

!

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

!

end

NewYork#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 200.0.0.237 to network 0.0.0.0

200.0.0.0/24 is variably subnetted, 11 subnets, 4 masks

O 200.0.0.0/25 [110/129] via 200.0.0.237, 01:16:52, Serial0/1

C 200.0.0.128/27 is directly connected, FastEthernet0/0

O 200.0.0.160/28 [110/65] via 200.0.0.233, 00:43:16, Serial0/2

O 200.0.0.176/28 [110/129] via 200.0.0.233, 00:43:16, Serial0/2

O 200.0.0.192/28 [110/129] via 200.0.0.233, 00:43:16, Serial0/2

O 200.0.0.208/28 [110/65] via 200.0.0.233, 00:43:16, Serial0/2

O 200.0.0.224/30 [110/128] via 200.0.0.237, 01:17:02, Serial0/1

C 200.0.0.228/30 is directly connected, Serial0/0

C 200.0.0.232/30 is directly connected, Serial0/2

C 200.0.0.236/30 is directly connected, Serial0/1

O 200.0.0.240/30 [110/128] via 200.0.0.233, 00:43:16, Serial0/2

O*E2 0.0.0.0/0 [110/1] via 200.0.0.237, 00:45:54, Serial0/1

NewYork#

Seattle Router

Seattle#show run

Building configuration...

Current configuration : 923 bytes

!

version 12.2

no service password-encryption

!

hostname Seattle

!

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

no ip domain-lookup

!

!

interface FastEthernet0/0

description Connection to Network G

ip address 200.0.0.161 255.255.255.240

duplex auto

speed auto

!

interface FastEthernet0/1

description Connection to Network K

ip address 200.0.0.209 255.255.255.240

duplex auto

speed auto

!

interface Serial0/0

description Connection to New York

ip address 200.0.0.233 255.255.255.252

clock rate 4000000

!

interface Serial0/1

description Connection to Portland

ip address 200.0.0.241 255.255.255.252

clock rate 4000000

!

router ospf 1

log-adjacency-changes

network 200.0.0.232 0.0.0.3 area 0

network 200.0.0.240 0.0.0.3 area 0

network 200.0.0.160 0.0.0.15 area 0

network 200.0.0.208 0.0.0.15 area 0

!

ip classless

!

!

!

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

!

end

Seattle#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 200.0.0.234 to network 0.0.0.0

200.0.0.0/24 is variably subnetted, 11 subnets, 4 masks

O 200.0.0.0/25 [110/193] via 200.0.0.234, 00:43:04, Serial0/0

O 200.0.0.128/27 [110/65] via 200.0.0.234, 00:43:04, Serial0/0

C 200.0.0.160/28 is directly connected, FastEthernet0/0

O 200.0.0.176/28 [110/65] via 200.0.0.242, 01:17:49, Serial0/1

O 200.0.0.192/28 [110/65] via 200.0.0.242, 01:17:49, Serial0/1

C 200.0.0.208/28 is directly connected, FastEthernet0/1

O 200.0.0.224/30 [110/192] via 200.0.0.234, 00:43:04, Serial0/0

O 200.0.0.228/30 [110/1626] via 200.0.0.234, 00:43:04, Serial0/0

C 200.0.0.232/30 is directly connected, Serial0/0

O 200.0.0.236/30 [110/128] via 200.0.0.234, 00:43:04, Serial0/0

C 200.0.0.240/30 is directly connected, Serial0/1

O*E2 0.0.0.0/0 [110/1] via 200.0.0.234, 00:43:04, Serial0/0

Seattle#

Portland Router

Portland#show run

Building configuration...

Current configuration : 796 bytes

!

version 12.2

no service password-encryption

!

hostname Portland

!

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

no ip domain-lookup

!

!

interface FastEthernet0/0

description Connection to Network J

ip address 200.0.0.193 255.255.255.240

duplex auto

speed auto

!

interface FastEthernet0/1

description Connection to Network I

ip address 200.0.0.179 255.255.255.240

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

!

interface Serial0/1

description Connection to Seattle

ip address 200.0.0.242 255.255.255.252

!

router ospf 1

log-adjacency-changes

network 200.0.0.240 0.0.0.3 area 0

network 200.0.0.176 0.0.0.15 area 0

network 200.0.0.192 0.0.0.15 area 0

!

ip classless

!

!

!

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

!

end

Portland#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 200.0.0.241 to network 0.0.0.0

200.0.0.0/24 is variably subnetted, 11 subnets, 4 masks

O 200.0.0.0/25 [110/257] via 200.0.0.241, 00:43:26, Serial0/1

O 200.0.0.128/27 [110/129] via 200.0.0.241, 00:43:26, Serial0/1

O 200.0.0.160/28 [110/65] via 200.0.0.241, 01:18:11, Serial0/1

C 200.0.0.176/28 is directly connected, FastEthernet0/1

C 200.0.0.192/28 is directly connected, FastEthernet0/0

O 200.0.0.208/28 [110/65] via 200.0.0.241, 01:18:11, Serial0/1

O 200.0.0.224/30 [110/256] via 200.0.0.241, 00:43:26, Serial0/1

O 200.0.0.228/30 [110/1690] via 200.0.0.241, 00:43:26, Serial0/1

O 200.0.0.232/30 [110/128] via 200.0.0.241, 00:43:36, Serial0/1

O 200.0.0.236/30 [110/192] via 200.0.0.241, 00:43:26, Serial0/1

C 200.0.0.240/30 is directly connected, Serial0/1

O*E2 0.0.0.0/0 [110/1] via 200.0.0.241, 00:43:26, Serial0/1

Portland#

Network Test Performed By Doing TRACERT To And From Various Locations

From 200.0.0.190

From 200.0.0.126