Transfer LDOM

How to Transfer Solaris LDOMs from old Netapp filer to the new Netapp filer

Connecting Hypervisor to the new filler

  • Change the MTU:
# dladm set-linkprop -p mtu=9000 net12
# dladm show-linkprop -p mtu net12
  • Other networking stuff:
# snoop -d net12                              (Check net12 physical connectivity)
# dladm show-link                             (Determine the types of links that are in use on the system)
# dladm create-vlan -l net12 -v 300 iscsi1    (Create a VLAN link over a datalink)
# dladm create-vlan -l net12 -v 310 nfs1
# dladm show-vlan                             (Verify the VLAN configuration)
# snoop -d nfs1                             
# snoop -d iscsi
# ipadm create-ip iscsi1                      (Create an IP interface over the VLAN)
# ipadm create-addr -T static -a 192.168.3.148/24 iscsi1/v4
# ipadm create-ip nfs1
# ipadm create-addr -T static -a 192.168.5.102/24 nfs1/v4
# ipadm
# ping 192.168.5.8
# ping 192.168.3.1
# route get 192.168.5.8                       (Verify if the traffic go trough new net12 not old net11) 
# route get 192.168.3.1
# route get 192.168.3.150
# route get 192.168.3.152
  • Configuring iscsi devices and then print the output:
# devfsadm -i iscsi
# devfsadm -vC
# echo | format | more
# iscsiadm add static-config  iqn.1992-08.com.netapp:sn.26431c2a630611e6999690e2bac619dc:vs.4,192.168.3.150
# iscsiadm add static-config iqn.1992-08.com.netapp:sn.26431c2a630611e6999690e2bac619dc:vs.4,192.168.3.152
# iscsiadm list static-config

Moving Ldoms

We moved our test LDom aproposdb4_cl from old netapp filler to the new one using snap mirror tool on Netapp on February 2017.

  • Kartik shutdown the machine and the stopped and unbound the LDOM:
# ldm stop aproposdb4_cl
# ldm unbind aproposdb4_cl
  • Rey moved the LUN from old filler to the new one and assign the number 91.
  • Using the following command we found that Solaris mapped that LUN 91 to c0t600A09803830376C585D4963556B7357d0s2
# iscsiadm list target -vS|egrep 'LUN:|rdsk'

LUN: 91                OS Device Name: /dev/rdsk/c0t600A09803830376C585D4963556B7357d0s2
  • then it was time to identify and remove old boot disk:
# ldm ls -o disk aproposdb4_cl

NAME
aproposdb4_cl

DISK
   NAME         VOLUME                 TOUT ID   DEVICE  SERVER         MPGROUP
   bootdisk     aproposdb4_clboot-disk0@primary-vds0      1
   sol-11-sparc-aproposdb4_clb.iso sol111iso_aproposdb4_clb@primary-vds0      0
# ldm rm-vdisk bootdisk aproposdb4_cl
  • We specified the device to be exported by the virtual disk server as a virtual disk to the guest domain:
# ldm add-vdsdev /dev/rdsk/c0t600A098038303759463F49657A69376Ed0s2 aproposdb4cl_boot-disk0@primary-vds0
  • And added a virtual disk to the guest domain:
# ldm add-vdisk aproposdb4cl_boot-disk0 aproposdb4cl_boot-disk0@primary-vds0 aproposdb4_cl
  • We needed to bind and start the LDom:
# ldm bind aproposdb4_cl
# ldm start aproposdb4_cl
  • And finally boot the VM:
# telnet localhost 5001
{0} ok boot

The new changes to persists across reboots must be saved to system controller (SC).

# ldm add-config config_03_01_2017                          #you can put whetever number/name for that
# ldm list-config

Changing virtual switch settings

We added new virtual switch to handle Jumbo Frame and send out the packets via net 12. The purpose of adding this virtual switch is connectivity of LDOMs like tstallocdb5 to new filler to nfs shares via net12 interface (new interface)

# ldm list-netdev
# ldm add-vsw vid=310 net-dev=net12 linkprop=phys-state id=2 inter-vnet-link=on primary-vsw2 primary     #and to remove simply run ldm rm-vsw primary-vsw2
# ldm set-vsw mtu=9000 primary-vsw2

Virtual Switch is ready now. We are going to create a link from our LDOM to the virtual switch:

# ldm rm-vnet vnet2 tstallocdb5

You may see the changes by running this command:

# ldm list -o network -l tstallocdb5

Next step would be moving LDOM's 192.168.5.x IP from its old net1 to new net1. So we delete the LDOM's ip after logging to tstallocdb5

tstallocdb5# ipadm
tstallocdb5# ipadm delete-ip net1

Go back to the hypervisor and add the link again:

# ldm add-vnet pvid=310 id=1 vnet2 primary-vsw2 tstallocdb5  
# ldm add-config config_03_06_2017
# ldm list -o network -l tstallocdb5             (to check if the new link is using the new virtual switch to route the packets)

Now go to the LDOM and create the link again

tstallocdb5# dladm set-linkprop -p mtu=9000 net1         (if needed)
tstallocdb5# ipadm create-ip net1
tstallocdb5# ipadm create-addr -T static -a 192.168.5.98/24 net1/v4
tstallocdb5# ipadm
tstallocdb5# ping 192.168.5.155                  (ping nfs address of new filler)