General Solaris Cheat Sheet


Networking

To show the ip address use one of these:

# ifconfig -a
# dladm show-link
# ipadm show-if
# ipadm show-addr

To show all physical interfaces:

# dladm show-phys

Show all physical interfaces including the physical bus (pci):

# dladm show-phys -L

Display current MTU size (for net12 interface):

# dladm show-linkprop -p mtu net12

Display current MTU size and other properties (for net12 interface):

# dladm show-link net12

Change the MTU size to 9000, the setting for Jumbo frames (see the note below for error!)

# dladm set-linkprop -p mtu=9000 net12

Create IP interface:

# ipadm create-ip net12

Give it an IP:

# ipadm create-addr -T static -a 10.10.1.2/35 net12/v4

Note: If it says the link is busy,

  • Remove the IP interface:
# ipadm delete-ip net12
  • Change the link's MTU size:
# dladm set-linkprop -p mtu=9000 net12
  • Create the IP interface agian:
# ipadm create-ip net12

For more information on Solaris 11 networking consult its official page at http://www.oracle.com/technetwork/articles/servers-storage-dev/s11-network-config-1632927.html

iscsi

Show target parameters:

# iscsiadm list target-param -v

Check if it is connected to the target:

# iscsiadm list target -v

Disks

# zpool listman prtdiag
# zpool status
# zpool status -v

To list all disks:

# iostat -eE

or

# format
# echo | format