Carrier Supporting Carrier

Carrier Supporting Carrier

R0 router:

interface Loopback0

ip address 11.1.1.1 255.255.255.255

!

interface Serial0/0

ip address 172.16.1.2 255.255.255.252

!

ip route 0.0.0.0 0.0.0.0 172.16.1.1

!

R1 router:

ip vrf CUST1

rd 1:1

route-target export 1:1

route-target import 1:1

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

ip ospf 1 area 0

!

interface Serial0/0

ip vrf forwarding CUST1

ip address 172.16.1.1 255.255.255.252

!

interface Serial0/1

ip address 10.1.1.1 255.255.255.252

ip ospf 1 area 0

mpls ip

!

router bgp 65100

neighbor 6.6.6.6 remote-as 65100

neighbor 6.6.6.6 update-source Loopback0

!

address-family vpnv4

neighbor 6.6.6.6 activate

neighbor 6.6.6.6 send-community extended

exit-address-family

!

address-family ipv4 vrf CUST1

redistribute connected

redistribute static

exit-address-family

!

ip route vrf CUST1 11.1.1.1 255.255.255.255 172.16.1.2

!

R2 router:

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

ip ospf 1 area 0

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.252

ip ospf 1 area 0

!

interface Serial0/0

ip address 10.1.1.2 255.255.255.252

ip ospf 1 area 0

mpls ip

!

router ospf 1

redistribute bgp 65100 metric 10 subnets

!

router bgp 65100

redistribute ospf 1 metric 10 match internal external 1 external 2

neighbor 192.168.1.2 remote-as 100

neighbor 192.168.1.2 send-label

!

R3 router:

ip vrf C_CUST1

rd 1:2

route-target export 1:2

route-target import 1:2

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

ip ospf 2 area 0

!

interface FastEthernet0/0

ip vrf forwarding C_CUST1

ip address 192.168.1.2 255.255.255.252

!

interface Serial0/0

ip address 20.1.1.1 255.255.255.252

ip ospf 2 area 0

mpls ip

!

router bgp 100

neighbor 4.4.4.4 remote-as 100

neighbor 4.4.4.4 update-source Loopback0

!

address-family vpnv4

neighbor 4.4.4.4 activate

neighbor 4.4.4.4 send-community extended

exit-address-family

!

address-family ipv4 vrf C_CUST1

redistribute connected

neighbor 192.168.1.1 remote-as 65100

neighbor 192.168.1.1 activate

neighbor 192.168.1.1 as-override

neighbor 192.168.1.1 send-label

exit-address-family

!

R7 router:

interface Loopback0

ip address 12.1.1.1 255.255.255.255

!

interface Serial0/0

ip address 172.16.2.2 255.255.255.252

!

ip route 0.0.0.0 0.0.0.0 172.16.2.1

!

R6 router:

ip vrf CUST1

rd 1:1

route-target export 1:1

route-target import 1:1

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

interface Loopback0

ip address 6.6.6.6 255.255.255.255

ip ospf 1 area 0

!

interface Serial0/0

ip vrf forwarding CUST1

ip address 172.16.2.1 255.255.255.252

!

interface Serial0/1

ip address 10.2.2.2 255.255.255.252

ip ospf 1 area 0

mpls ip

!

router bgp 65100

neighbor 1.1.1.1 remote-as 65100

neighbor 1.1.1.1 update-source Loopback0

!

address-family vpnv4

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-community extended

exit-address-family

!

address-family ipv4 vrf CUST1

redistribute connected

redistribute static

exit-address-family

!

ip route vrf CUST1 12.1.1.1 255.255.255.255 172.16.2.2

!

R5 router:

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

interface Loopback0

ip address 5.5.5.5 255.255.255.255

ip ospf 1 area 0

!

interface FastEthernet0/0

ip address 192.168.2.2 255.255.255.252

ip ospf 1 area 0

!

interface Serial0/0

ip address 10.2.2.1 255.255.255.252

ip ospf 1 area 0

mpls ip

!

router ospf 1

redistribute bgp 65100 metric 10 subnets

!

router bgp 65100

redistribute ospf 1 metric 10 match internal external 1 external 2

neighbor 192.168.2.1 remote-as 100

neighbor 192.168.2.1 send-label

!

R4 router:

ip vrf C_CUST1

rd 1:2

route-target export 1:2

route-target import 1:2

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

interface Loopback0

ip address 4.4.4.4 255.255.255.255

ip ospf 2 area 0

!

interface FastEthernet0/0

ip vrf forwarding C_CUST1

ip address 192.168.2.1 255.255.255.252

!

interface Serial0/0

ip address 20.1.1.2 255.255.255.252

ip ospf 2 area 0

mpls ip

!

router bgp 100

neighbor 3.3.3.3 remote-as 100

neighbor 3.3.3.3 update-source Loopback0

!

address-family vpnv4

neighbor 3.3.3.3 activate

neighbor 3.3.3.3 send-community extended

exit-address-family

!

address-family ipv4 vrf C_CUST1

redistribute connected

neighbor 192.168.2.2 remote-as 65100

neighbor 192.168.2.2 activate

neighbor 192.168.2.2 as-override

neighbor 192.168.2.2 send-label

exit-address-family

!