EoMPLS Carrying Ethernet Trunk

EoMPLS Carrying Ethernet Trunk

Network topology:

Here, the AC is an Ethernet Trunk. The CE interfaces connected to PE routers are configured with 802.1Q sub-interfaces. Hence, the Ethernet frames are tagged when the PE router receives them. This results in a PE router carrying the whole 802.1Q trunk across the MPLS Pseudowire.

Configuration:

The CE routers are configured with 802.1Q sub-interfaces.

CE Configuration

interface Fastethernet 0/0
 no ip address
!
interface Fastethernet 0/0.100
 encapsulation dot1q 100
 ip address 10.100.1.1 255.255.255.252
!
interface Fastethernet 0/0.200
 encapsulation dot1q 200
 ip address 10.200.1.1 255.255.255.252
!
CE1# show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES manual up                    up 
FastEthernet0/0.100        10.100.1.1      YES manual up                    up 
FastEthernet0/0.200        10.200.1.1      YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
CE2# show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  up                    up 
FastEthernet0/0.100        10.100.1.2      YES manual up                    up 
FastEthernet0/0.200        10.200.1.2      YES manual up                    up 
FastEthernet0/1            unassigned      YES NVRAM  administratively down down

The PE configuration remain similar to EoMPLS Carrying Simple Ethernet.

PE Configuration

PE1 router:
pseudowire-class MPLS_Encapsulation
 encapsulation mpls
!
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!
interface Fastethernet 0/0
 description Connected to CE1
 no ip address
 xconnect 3.3.3.3 2000 pw-class MPLS_Encapsulation
!
PE2 router:
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ip ospf 1 area 0
!
interface Fastethernet 0/0
 description Connected to CE2
 no ip address
 xconnect 1.1.1.1 2000 encapsulation mpls
!

VC Status verification:

The debug mpls l2transport signalling message command displays the VC labels exchanged between peers after the targeted-LDP session is established. It also shows each peer sends a Label Mapping message which contains FEC TLV, Label TLV and optional interface parameters. VC Type 5 indicates Ethernet Port mode.

Label Mapping message exchange

00:47:08.747: AToM LDP [3.3.3.3]: Sending label mapping msg
00:47:08.751: AToM LDP [3.3.3.3]: Sending label mapping msg vc type 5, cbit 1, vc id 2000, group id 0, vc label 16, status 0x7/LDP 0x1/ADJ 0x0, mtu 1500, vc handle 0x64000001
00:47:08.787: AToM LDP [3.3.3.3]: Received label mapping msg, id 17, GR instance 2
00:47:08.787: AToM LDP [3.3.3.3]: Received label mapping msg, id 17, GR instance 2 vc type 5, cbit 1, vc id 2000, group id 0, vc label 16, status 0x7/LDP 0x1/ADJ 0x0, mtu 1500, vc handle 0x64000001

The VC status can be verified as below. It also shows the Labels exchanged and Label stack that will be imposed on packets transported over L2 circuit.

VC status verification

PE1# show mpls l2transport vc
Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Fa0/0          Ethernet                   3.3.3.3         2000       UP
PE1# show mpls l2transport vc detail
Local interface: Fa0/0 up, line protocol up, Ethernet up
  Destination address: 3.3.3.3, VC ID: 2000, VC status: up
    Output interface: Fa1/0, imposed label stack {17 16}
    Preferred path: not configured
    Default path: active
    Next hop: 10.1.1.2
  Create time: 00:11:30, last status change time: 00:01:03
  Signaling protocol: LDP, peer 3.3.3.3:0 up
    Targeted Hello: 1.1.1.1(LDP Id) -> 3.3.3.3, LDP is UP
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last local SSS circuit status rcvd: No fault
      Last local SSS circuit status sent: No fault
      Last local  LDP TLV    status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 16, remote 16
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  Control Word: On (configured: autosense)
  VC statistics:
    transit packet totals: receive 7, send 7
    transit byte totals:   receive 726, send 903
    transit packet drops:  receive 0, seq error 0, send 0

The following packet capture shows the label imposed on IP packets transported over the L2 circuit.