SSL v. TLS‎ > ‎

TLS Versions and Browser Compatability

The current versions of TLS is 1.2. The IETF considers 1.1 as well as 1.0 to be obsolete. Despite this, only Internet Explorer supports tls 1.2. Google Chrome supports version 1.1 and Safari and Firefox only support version 1.0. The government has mandated support of SHA-256 by the end of 2012, so it can be expected that the other browsers will attempt to implement support shortly.

The main difference between versions 1.0 and 1.1 is that error handling was altered to mitigate a threat. The difference between 1.1 and 1.2 is the support for SHA-256 and other hashing advancements.

<http://code.google.com/p/chromium/issues/detail?id=90392>
<http://tools.ietf.org/html/rfc5246#page-5>
<http://tools.ietf.org/html/rfc4346#page-5>
<http://msdn.microsoft.com/en-us/library/dd208005%28PROT.13%29.aspx>
Comments