
Parallel Iterative Deconvolution 1.9
User Guide

Piotr Wendykier

April 29, 2009

1 Introduction

1.1 What is Deconvolution?
In applications such as astronomy, medicine, physics and biology, scientists use digital images to record and analyze
results from experiments. Environmental effects and imperfections in the imaging system can cause the recorded
images to be degraded by blurring and noise. Image deconvolution (sometimes known as image deblurring) is the
process of reconstructing or estimating the true image from the degraded one. Image deblurring algorithms can be
classified into two classes: spectral filtering methods and iterative methods. Other classification divides the algorithms
into methods that do not require any information about the blur (also called blind deconvolution) and the methods that
need that information. The information about the blur is usually given in the form of a point spread function (PSF). A
PSF is an image that describes the response of an imaging system to a point object. A theoretical PSF can be obtained
based on the optical properties of the imaging system. The main advantage of this approach is that the obtained PSF
is noise-free. The experimental technique, on the other hand, relies on taking a picture of a point object, for example a
distant star. In this work we assume that the PSF is known and given in the form of an image.

1.2 What is Parallel Iterative Deconvolution?
With iterative deconvolution methods, a sequence of approximations is constructed, where hopefully subsequent ap-
proximations provide better reconstructions. Mathematically this is equivalent to solving a particular optimization
problem involving a PSF and a blurred image, which could be formulated as something simple like a least squares
problem, or something more complicated that incorporates (possibly nonlinear) constraints. As with spectral filtering
methods, regularization must be incorporated using, for example, a priori constraints, or through appropriate conver-
gence criteria, or even a combination of such techniques. Well known examples of iterative image reconstruction
algorithms include expectation maximization (EM) type approaches (such as the Richardson-Lucy algorithm), conju-
gate gradient (CG) type methods, and many others. One important advantage of using iterative algorithms is that they
can be used on a much wider class of blurring models, including spatially variant blurs. Although iterative methods
are generally more expensive than spectral filtering methods for simple spatially invariant blurs, they are much more
efficient for difficult spatially variant blurs. Moreover, it is possible to incorporate constraints (e.g., nonnegativity) in
the algorithms. The challenges in iterative algorithms concern the regularization (how to stabilize the iterative method
in the presence of noise), and determination of an appropriate stopping iteration.

Parallel Iterative Deconvolution is an ImageJ plugin for iterative image deblurring. The code is derived from
RestoreTools: An Object Oriented Matlab Package for Image Restoration written by James G. Nagy and several of his
students, including Julianne Chung, Katrina Palmer, Lisa Perrone, and Ryan Wright and also from Iterative Deconvolve
3D written by Robert Dougherty. The current version implements four iterative algorithms: Modified Residual Norm
Steepest Descent (MRNSD), Wiener Filter Preconditioned Landweber (WPL), Conjugate Gradient for Least Squares
(CGLS) and Hybrid Bidiagonalization Regularization (HyBR). Although the plugin can handle arbitrary-sized 2- and
3-dimensional images, its usage is limited to grayscale images. To deconvolve a color image, you would have to split
the channels and deblur each channel separately.
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2 Installation

2.1 Installation of ImageJ
If you have ImageJ already installed, you can skip this step. Otherwise, go to http://rsbweb.nih.gov/ij/download.html
and download ImageJ distribution for your platform. Installation instructions are also available on that website. Once
the installation is successful, you should increase the maximum memory assigned to ImageJ. You can do this using
Edit>Options>Memory & Threads... option from ImageJ menu. More information about increasing the memory in
ImageJ is available here. You may also want to read this wiki about ImageJ performance tuning.

2.2 Installation of the Plugin
To install the plugin, go to the plugin’s website and download a binary distribution. Then, unpack the archive (zip
or tar.bz2) into the plugin’s directory and restart ImageJ. The plugin will appear under Plugins>Parallel Iterative
Deconvolution menu. A graphical user interface (see Fig. 1) for 2D images is available under Plugins>Parallel
Iterative Deconvolution>2D Iterative Deconvolution.... For 3D stacks, you need to choose Plugins>Parallel Iterative
Deconvolution>3D Iterative Deconvolution....

3 Usage

Figure 1: Parallel Iterative Deconvolution - graphical user interface.
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3.1 Available Options
Figure 1 shows a graphical user interface (GUI) for the plugin. There are eight drop-down lists (combo-boxes) available
in the GUI. From the Blurred image list, you can choose a blurred image. PSF list is for selection of a point spread
function image. The content of these two lists depends on what is currently open in ImageJ - if no image windows are
displayed then both lists are empty. The next two lists (Method and Preconditioner) allow you to select an algorithm
used for deconvolution (MRNSD, WPL, CGLS, HyBR) and a preconditioner. The preconditioner is used for speeding
up the convergence (so that you will get a better reconstruction after fewer iterations). Currently only the fast Fourier
transform-based preconditioner is available (WPL uses the Wiener Filter as a preconditioner). The tolerance for the
preconditioner is computed automatically by default (Auto check-box), but it is also possible to specify the value
manually. In the Boundary combo-box you can choose from three types of boundary conditions: Reflexive, Periodic
and Zero. The first ones are usually the best choice. The Resizing combo-box allows you to specify how the blurred
image will be padded before processing. The Minimal resizing means that the pixel data in each dimension of a blurred
image are padded by the size of the corresponding dimension of a PSF image. If the Next power of two option is
selected, then the pixel data in each dimension of a blurred image are padded to the next power-of-two size that is
greater or equal to the size of an image obtained by minimal padding. Finally, the Auto option chooses between the
two other options to maximize the performance. The Output list is used to specify the type of an output (reconstructed
image) and in the Precision combo-box you can choose a floating-point precision used in computations. Practice shows
that a single precision is sufficient for most problems.

There are few other important options in the GUI that require some explanation. The Max number of iterations text
field is used to specify how many iterations a given method should perform. It is a maximal value, which means that the
process of reconstruction may stop earlier (when the stopping criterion is met). When the Show iterations check-box
is selected, then the reconstructed image will be displayed after each iteration. Finally, in the Max number of threads
(power of 2) text field you can enter how many computational threads will be used. By default this value is equal to the
number of CPUs available on your machine.

The Options button (next to the Method combo-box) is used to display a dialog window with advanced preferences
for each algorithm. All of these options are described in the following subsections.

3.1.1 MRNSD Options

MRNSD has only three advanced properties (see Fig. 2). The Stopping tolerance text field allows you to manually
specify the value that will be used as a stopping criterion. By default that value is computed automatically. When
the Threshold option is enabled, then all values in the reconstructed image that are less than the value specified in the
threshold text field are replaced by zero. However, since MRNSD is a nonnegatively constrained algorithm, this option
is not very useful and is disabled by default. Finally, selecting Log convergence effects in displaying the record of the
convergence in a separate Log window.

Figure 2: MRNSD options panel.

3.1.2 WPL Options

WPL (see Fig. 3), similarly to MRNSD, is a nonnegatively constrained algorithm, therefore the Threshold option is
also disabled by default. Moreover, the Log mean pixel value to track convergence has the same functionality as in
the case of MRNSD - the record of the convergence is displayed in the separate Log window. If Normalize PSF is
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selected then the point spread function is normalized before processing. To reduce artifacts from features near the
boundary of the imaging volume you should use the Perform anti-ringing step option. The Detect divergence property
stops the iteration if the changes appear to be increasing. You may try to increase the low pass filter size if this problem
occurs. For WPL, the inputs in decibels are permitted (Data (image, psf and result) in dB). This is uncommon in optical
image processing, but is the norm in acoustics. The Wiener filter gamma is a tolerance for the preconditioner. It is
intended to speed up the convergence, but can produce spurious artifacts. Setting this parameter to zero turns off the
preconditioner (Wiener Filter). The Low pass filter x and y settings, in pixels, provide a way to smooth the results and
accelerate convergence. Choose 0 to disable this function. Finally, the Terminate iteration if mean delta less than x%
is used as a stopping criterion.

Figure 3: WPL options panel.

3.1.3 CGLS Options

CGLS options panel (see Fig. 4) looks exactly the same as the MRNSD options panel. The only difference is that the
Threshold option is enabled by default, since it is not a nonnegativity constrained method.

Figure 4: CGLS options panel.
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3.1.4 HyBR Options

To understand all the details about advanced properties of HyBR you should first read this paper. In the HyBR options
panel (see Fig. 5) the properties relevant to regularization are grouped in the box called Regularization options. The
Method combo-box allows you to decide how the regularization parameter will be computed. If you select None, then
the value of the parameter has to entered in the Parameter text field. When WGCV (Weighted Generalized Cross-
Validation) is chosen then you have to specify the weight (Omega) manually. In the Begin regularization after this
iteration text field you can decide after which iteration the regularization will begin. Before that iteration the QR
factorization is used to solve the least squares problem.

Besides regularization properties, you can adjust five other options. In the Inner solver combo-box you can choose
the solver that will be used at each iteration. Currently it can be either Tikhonov or None. If None is selected as an inner
solver, then the QR factorization is used to solve the least squares problem. In the Stopping tolerance text field you can
enter a value that will be used to detect flatness in the GCV curve as a stopping criteria. If Reorthogonalize Lanczos
subspaces is selected, then during the process of Lanczos bidiagonalization, the subspaces will be reorthogonalized.
Usually this is not required, so by default this option is unused. The Threshold check-box should be selected, because
HyBR does not compute a nonnegative solution. The Log Convergence has the same functionality as for all other
methods.

Figure 5: HyBR options panel.

3.1.5 Spatially Variant PSF

There are three elements in the GUI that have not been described above, namely: Spatially variant PSF check-box,
Define and Edit buttons. These controls allow you to work with spatially variant PSFs (i.e. if you have multiple PSF
images associated with a single blurred image). Fig. 6 shows two dialog windows that appear when you click either
Define or Edit button. In the Create Spatially Variant PSF panel you can specify the number of PSFs in the form of 2D
(or 3D) matrix. Then, after clicking OK button, the Edit Spatially Variant PSF panel will appear. This dialog contains
a grid of buttons that you can use to enter paths to the PSF files.
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Figure 6: Spatially Variant PSF panels.

3.2 How to Obtain a Theoretical PSF?
There are several ImageJ plugins for generating a theoretical point spread function:

• PSF Tool for ImageJ by the ETH Computationnal Biophysics Lab

• Diffraction PSF 3D by Robert Dougherty

• Deconvolution3D by Pierre Besson.

To use these tools you need to know some parameters of your microscope setup and sample like NA, RI of mounting
medium, wavelength, etc.

3.3 2D Spatially Invariant PSF Example
1. Download the grain example.

2. Unpack the archive.

3. Start ImageJ.

4. Use File>Open... from ImageJ menu to open grain-blur.png and grain-psf.png.

5. Run the Parallel Iterative Deconvolution plugin (Plugins>Parallel Iterative Deconvolution>2D Iterative Decon-
volution...).

6. At this point your desktop should look similar to what is displayed in Fig. 7.

7. Make sure that grain-blur.png is chosen in the Blurred image list and grain-psf.png is chosen in the PSF list.

8. Click Deconvolve button.

9. In about a few seconds, a new window with a reconstructed image should appear (see Fig. 8).

10. In this case the automatically chosen tolerance for preconditioner is optimal, but you can change it (uncheck
Auto and enter a new value) and then click the Deconvolve button to see if you like the new image better.
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11. The reconstructed image is not saved. You can save it using File>Save As from ImageJ menu.

Figure 7: 2D Spatially Invariant PSF Example - step 6.

Figure 8: 2D Spatially Invariant PSF Example - step 9.
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3.4 2D Spatially Variant PSF Example
1. Download the star cluster example.

2. Unpack the archive.

3. Start ImageJ.

4. Use File>Open... from ImageJ menu to open star-cluster-blur.fit.

5. Run the Parallel Iterative Deconvolution plugin (Plugins>Parallel Iterative Deconvolution>2D Iterative Decon-
volution...).

6. Select the Spatially variant PSF check-box and click Define button.

7. Enter 5 for the number of rows and columns in the Create Spatially Variant PSF panel.

8. At this point your desktop should look similar to what is displayed in Fig. 9.

9. Click OK button in the Create Spatially Variant PSF panel, the Edit Spatially Variant PSF panel should appear.

10. Define all 25 PSFs as shown in Fig. 10 and click OK button.

11. Make sure that star-cluster-blur.fit is chosen in the Blurred image list.

12. Enter 40 in the Max number of iterations text field.

13. Click Deconvolve button.

14. After some time, a new window with a reconstructed image should appear. You have to adjust the color balance
of both images (Image>Adjust>Color Balance...>Auto from ImageJ menu).

15. At this point your desktop should look similar to what is displayed in Fig. 11.

16. The reconstructed image is not saved. You can save it using File>Save As from ImageJ menu.

Figure 9: 2D Spatially Variant PSF Example - step 8.
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Figure 10: 2D Spatially Variant PSF Example - step 10.

Figure 11: 2D Spatially Variant PSF Example - step 15.
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3.5 3D Spatially Invariant PSF Example
1. Download the head example.

2. Unpack the archive.

3. Start ImageJ.

4. Use File>Open... from ImageJ menu to open head_blur.tif and head_psf.tif.

5. Run the Parallel Iterative Deconvolution plugin (Plugins>Parallel Iterative Deconvolution>3D Iterative Decon-
volution....).

6. At this point your desktop should look similar to what is displayed in Fig. 12.

7. Make sure that head_blur.tif is chosen in the Blurred image list and head_psf.tif is chosen in the PSF list.

8. Select WPL in the Method list and click Options button.

9. Adjust WPL options as shown in Fig. 13.

10. Enter 20 in the Max number of iterations text field.

11. Click Deconvolve button.

12. After some time, a new window with a reconstructed image should appear (see Fig. 14).

13. The reconstructed image is not saved. You can save it using File>Save As from ImageJ menu.

Figure 12: 3D Spatially Invariant PSF Example - step 6.
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Figure 13: 3D Spatially Invariant PSF Example - step 9.

Figure 14: 3D Spatially Invariant PSF Example - step 12.
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