cBook‎ > ‎AutoPilot‎ > ‎

Install APM Planner Ubuntu

posted Apr 30, 2016, 8:21 PM by Javad Taghia
Building on Linux (tested on Ubuntu 14.04 LTS): (Needs update to use Qt5.4.2, 5.2.1 doesn't work anymore)
It's important to have QT5.4.2
For installation of QT5.4 you need to follow the link:
https://www.youtube.com/watch?v=to1qlTUbQ-w
0.

1) Install the required packages:

Be sure to run apt-get update first

sudo apt-get update
sudo apt-get install qt5-qmake qt5-default \
  qtscript5-dev libqt5webkit5-dev libqt5serialport5-dev \
  libqt5svg5-dev qtdeclarative5-qtquick2-plugin
sudo apt-get install git libsdl1.2-dev  libsndfile-dev \
  flite1-dev libssl-dev libudev-dev libsdl2-dev
1. you need QT installer, for that go to http://www.qt.io/download-open-source/ and download QT installer.
2. Install QT5.4
-  sudo apt-get install build-essential
- sudo apt-get install libgl1-mesa-dev-lts-utopic
- go to download file
- chmod a+x qt-opensource.linux.x64-1.6.0.-online.run
- ./qt-opensource.linux.x64-1.6.0.-online.run
- follow instruction in QT settup
3. After that, you need to follow steps below

2) Clone the repository in your workspace:

cd ~/workspace
git clone https://github.com/diydrones/apm_planner

3) Open QTCreator, open the project qgroundcontrol.pro.

In the side menu, go to Projects, change the build to be Desktop QT 5.4.2 GCC 64 bit if it's different. Then Build/Rebuild All

It will take a while.


Alternatively, you need to try below, 

Then you need to go toBuild APM Planner:

cd ~/workspace/apm_planner
qmake qgroundcontrol.pro
make

4) Run APM Planner:

./release/apmplanner2


Comments