Howto TP-LINK TL-WR703N & Fast FWR171-3G



Last update dec 2016 (LEDE, the new openWRT)  
All other sections are from april 2013
feedback and or collaboration : moosylog@gmail.com

About the hardware

The FAST FWR171-3G is a re-branded TP-LINK TL-WR703N portable 3G wireless-N router in a trimmed-down case.
It's sold on eBay for a few dollars. One of my readers recently told me that the 
Mercury MW151RM is another clone.

The main difference is the software in the unit - but as it is software, it can be replaced ;-)
This page will explain howto install English firmware on
FAST FWR171-3G?

Highlights
  • Share a 3G mobile connection, compatible with 120+ UMTS/HSPA/EVDO 3G USB modems
  • Portable design, light and small enough for you to take anywhere (weighs only 1.2oz)
  • Wireless N speed up to 150Mbps
  • Quick security setup, faster and safer
  • IP-based bandwidth control allows administrators to determine how much bandwidth is allotted to each connected device
  • A micro USB port to be connected to your laptop or power adapter for power supply
  • 3G/WAN failover guarantees an "always-online" internet connection
  • Three working modes: 3G Router (for sharing a mobile internet connection through a 3G/4G USB modem), Travel Router (for sharing a wired internet connection), WISP Client Router (for sharing a wireless internet connection).


Fastcom
manufacturer
productpage

TP-Link




Replacing the default Chinese firmware

The FAST FWR171-3G ships with Chinese firmware - English version of the firmware not available from Fast (jan 2013)

Your have several options to replace the device with other software:

dd-wrt
openwrt
original tp-link software

WARNING: please realize that replacing the original firmware can brick your hardware. If it is bricked, your only option is to solder a serial port to the device to get access again and upload new firmware.


Open the management console:
plugin an ethernet cable and point to 192.168.1.1 - username = admin, password = admin
TIP for navigating the CH interface: look at the bottom of your screen if your're mouse slides over the hyperlinks you see the page it is referring to.
also check the US interface here - this will help you navigate.







Install dd-wrt from GUI

June 2013 - DD-WRT is by far the most well known, distributed and tested of the alternative firmwares. It has been in development for a number of years now and is very stable. It is easy to install from your firmware upgrade page and include all of the features listed above. It is free and available for a number of routers – in fact probably the widest number of routers compared to other firmwares.

Howto install dd-wrt on TP-LINK TL-WR703N

Download the correct dd-wrt firmware file here (search for 703) latest builds
I used this version of dd-wrt for my the initial flash from the Chinese version.

Look at the above chinese screen to select the firmware update. This here may help if your Chinese is not that good.
error 11108 - is an incompatible firmware error as the error message clearly tells in chinese ;-)

dd-wrt had the following limitations:
- no or limited 3g/4g support
- the wireless and cable nic interface are on the same network so it acts as a switch / bridge - requires some additional configuration




Router - Fix network ports 

The 703n hardware has a single ethernet port for the RJ45 port and the WiFi interface.
Additional manual configuration is required to separate the wireless interface from the "LAN&WLAN" bridge so that they are on different subnets.
You are then able to control communication between the interfaces.

Option 1: EASY - Use my backup configuration file
You can also download my dd-wrt configuration and restore it into your router.
  • download my wrt703.bin
  • Login to the dd-wrt console with cable or via wifi
  • Navigate to Administration, Backup and select wrt703.bin to restore.
  • reboot and make a wireless connection to ssid: dd-wrt  (no password)
  • browse to http://192.168.2.1 to connect to the dd-wrt management console
  • username = admin, password = admin

Option 2: HARDER - Do the steps yourself
additional manual configuration is apparently required! So AP with masquerade/NAT is not working for me...
Follow these instructions:
http://www.dd-wrt.com/wiki/index.php/Separate_LAN_and_WLAN



Here are some screenshot








Access Point

Dec 2-14 - With the config above your box is acting as a router, routing traffic between your private (wifi) network and the WAN (cable) network.
Below described a true infrastructure access point, using the same ip range on the wifi network as your main router (wan port)

I upgraded the above described configuration with the latest firmware. http://www.dd-wrt.com/site/support/router-database
v24 presp2 (build 21061)

Option 1: EASY - Use my backup configuration file
You can also download my dd-wrt configuration and restore it into your router.
  • download my access point configuration file
  • Login to the dd-wrt console with cable or via wifi
  • Navigate to Administration, Backup and select ddwrt 703 ap.bin to restore.
  • reboot and make a wireless connection to ssid: dd-wrt  (no password)
  • figure out what the ip address is of the ap
  • username = admin, password = admin   (telnet is on)
  • change the password (howto command line)

Option 2: HARDER - Do the steps yourself


Reset all settings, back to factory default
google keywords: ap, access point, accesspoint, no dhcp, same network, same ip range, hack, bundle, wan port, lan, not access, build your own accesspoint, build your own ap, build your own access point, built your own access point dd-wrt 

Below describes how to to set up dd-wrt to be a stand alone access point and use DHCP to get it’s LAN address. No matter where the device is plugged in, it will pull an address and allow remote management.

  1. First do a ‘hard reset’ (look up 30/30/30 on the DD-WRT site)
  2. Connect to the ‘dd-wrt’ device, then connect to the router through a web browser (http://192.168.1.1).  The built in DHCP server will work for now.
  3. Disable the WAN connection (Setup->Basic Setup->WAN Connection Type:  Disabled)
  4. Change the Router Name (Setup->Basic Setup->Router Name: "router_name"
  5. Assign WAN port to Switch (Setup->Basic Setup->Assign WAN Port to Switch: Check – Optional, but I like to do this to gain the extra port)
  6. Disable DHCP Server (Setup->Basic Setup->DHCP Server:  Disable)
  7. Change Operating Mode to ‘Router’ (Setup->Advanced Routing->Operating Mode:  Router)
  8. Set Wireless SSID (Wireless->Basic Settings->Wireless Network Name:  <your SSID>)
  9. Set Wireless Security (Wireless->Wireless Security [It's optional, but just do it.])
  10. Disable DNSMasq (Services->Services->DNSMasq: Disable)
  11. Disable Firewall (Security->Firewall->SPI Firewall:  Disable)
  12. Disable Routing (Administration->Management->Routing:  Disable)
  13. Save & Apply

That was easy – now the tricky bit:

You can’t set DD-WRT to use DHCP for the LAN interface from the web.  You can, however, configure a start-up script to accomplish the same thing.  This is done from Administration->Commands – Copy in the following code and save it as the startup script.

ln -s /sbin/rc /tmp/udhcpc
/usr/sbin/udhcpc -i br0 -p /var/run/udhcpc.pid -s /tmp/udhcpc -H `nvram get router_name`
route add default gw `nvram get wan_gateway`
nvram set wds_watchdog_ips="`nvram get wan_gateway`"

# Config DNS
/bin/cat /etc/resolv.conf | /bin/grep -v nameserver > /tmp/resolv.conf
/bin/echo nameserver `nvram get wan_get_dns` >> /tmp/resolv.conf
/bin/cp /tmp/resolv.conf /etc/resolv.conf

Below some screenshots - How To Use DHCP to Set the WAP's IP Address









Install LEDE project from GUI


Dec 11, 2016: Received several requests to update this page for openWRT (LEDE project) so I migrated one of my dd-wrt units to openwrt. (lede)

from dd-wrt back to stock

option 1: To migrate from dd-wrt to lede or from dd-wrt to openwrt you first need to install the chinese stock firmare.
To migrate back to orginal, download WR703N v1.x Webrevert - Back to stock wr703nv1_webrevert.rar from the dd-wrt website.
You are then back into a chinese firmware, from here you can install another firmware, like openwrt or lede.
click image to enlarge

option 2: Alternative, you can download and mtd directly from dd-wrt, see: http://www.madox.net/blog/2013/03/10/how-to-install-openwrt-on-a-tl-wr703n-that-came-with-dd-wrt/


WARNING NOTE on the standard LEDE image if you want to do more then basic access point
http://downloads.lede-project.org/snapshots/targets/ar71xx/generic/lede-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin

There are limitations in the packages and modules compiled in this standard build. 
Since the memory is full, no additional packages can be installed.
  • USB - Kernel module (kmod-usb-storage) for usb drive and filesystem support (kmod-fs-ext4) are not part of this build and since there is no room to install anything you should google for another build is you need these features.
  • GUI - LuCI is not included in this build.
Howto create your own build and free up some memory: https://www.andrewklau.com/generating-my-own-openwrt-custom-firmware/ https://ohnomoregadgets.wordpress.com/2013/08/20/building-minimal-openwrt-firmware-images/ http://blog.iytc.net/wordpress/?m=20160907 https://fixmynix.com/build-openwrt-minimal-image-custom-firmware/ wget http://downloads.lede-project.org/snapshots/targets/ar71xx/generic/lede-imagebuilder-ar71xx-generic.Linux-x86_64.tar.xz


First time setup:

Create a cable connection between unit and  your pc. Manual set your pc ip address to something 192.168.1.x. Make sure you have PuTTY installed on your pc.

Start a remote session with your box.
putty -ssh 192.168.1.1

# first time login - use the passwd command to set an initial password
Change your ip using the command line interface (cli) to a number for your lan (I use 192.168.1.12 as an example)
uci set network.lan.ipaddr=192.168.1.12
uci set network.lan.netmask=255.255.255.0
uci set network.lan.gateway=192.168.1.1
uci set network.lan.dns="208.67.222.222 208.67.220.220"
uci commit network

/etc/init.d/network restart

# a reboot may be required to have dns working
# reboot
Result of these uci commands: 

root@lede:/dev# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd9c:2fe2:0f8a::/48'
        # fd9c:2fe2:0f8a is your MAC address and may be different !!

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.12'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        option dns '208.67.222.222 208.67.220.220'

Now when the box has a 'good or valid' ip address, connect it to your network to update and install packages
Use ssh to connect to the appliance
putty -ssh 192.168.1.12

login as: root
root@192.168.1.12's password:


BusyBox v1.25.1 () built-in shell (ash)

     _________
    /        /\      _    ___ ___  ___
   /  LE    /  \    | |  | __|   \| __|
  /    DE  /    \   | |__| _|| |) | _|
 /________/  LE  \  |____|___|___/|___|                      lede-project.org
 \        \   DE /
  \    LE  \    /  -----------------------------------------------------------
   \  DE    \  /    Reboot (CURRENT, r2400+49-7c47f43)
    \________\/    -----------------------------------------------------------

root@lede:~# uname -a
Linux lede 4.4.36 #0 Wed Dec 7 08:22:39 2016 mips GNU/Linux
root@lede:~#
My unit does not have enough memory to run luci so we will set everything manual.
You can add a usb stick for the root filesystem: (more)
uci set wireless.radio0=wifi-device
uci set wireless.radio0.type='mac80211'
uci set wireless.radio0.channel='11'
uci set wireless.radio0.hwmode='11g'
uci set wireless.radio0.path='platform/ar933x_wmac'
uci set wireless.radio0.htmode='HT20'
uci set wireless.radio0.disabled='0'
uci set wireless.default_radio0=wifi-iface
uci set wireless.default_radio0.device='radio0'
uci set wireless.default_radio0.network='lan'
uci set wireless.default_radio0.mode='ap'
uci set wireless.default_radio0.ssid='my_lede'
uci set wireless.default_radio0.encryption='psk2+tkip+ccmp'
uci set wireless.default_radio0.key='password'
uci set wireless.default_radio0.country='US'
uci set wireless.default_radio0.txpower='100'
uci commit wireless

# display your IP address, SSID and password
uci get network.lan.ipaddr
uci get wireless.default_radio0.ssid
uci get wireless.default_radio0.key

Result of these uci commands:

root@lede:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+tkip+ccmp'
        option country 'US'
        option txpower '100'
        option ssid 'my_lede'
        option key 'password'

Upgrade:

cd /tmp
wget http://downloads.lede-project.org/snapshots/targets/ar71xx/generic/lede-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin
sysupgrade -v lede-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin





Install OpenWrt software with tftp




http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin

cd /tmp
wget http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin
sysupgrade -v openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-sysupgrade.bin

Use ssh to connect to the appliance
putty -ssh 192.168.1.1


HERE ARE SOME RAW NOTES FROM 2013, THIS IS NOT A COMPLETE HOWTO OR SOMETHING



   _______                     ________        __
  |       |.-----.-----.-----.|  |  |  |.----.|  |_
  |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
  |_______||   __|_____|__|__||________||__|  |____|
           |__| W I R E L E S S   F R E E D O M
  -----------------------------------------------------
  BARRIER BREAKER (Bleeding Edge, r35770)
  -----------------------------------------------------
   * 1/2 oz Galliano         Pour all ingredients into
   * 4 oz cold Coffee        an irish coffee mug filled
   * 1 1/2 oz Dark Rum       with crushed ice. Stir.
   * 2 tsp. Creme de Cacao
  -----------------------------------------------------
 root@OpenWrt:/# passwd
 Changing password for root
 New password: 
 Retype password: 
 Password for root changed by root
 root@OpenWrt:/#
My unit do





see attached the logfile from the tftp process
https://sites.google.com/site/moosyresearch/fast-fwr171-3g/tl-wr703n-unbrick-log.txt?attredirects=0&d=1



List connected devices
''''''''''''''''''''''

When in AP-mode, obtain a list of connected clients in STA-mode::

 iw dev wlan0 station dump

Enabling USB disks
------------------

Install these packages::

 opkg install kmod-fs-ext4 kmod-usb-storage
 opkg install block-mount





PL2303
------

USB/TTL/RS232 Convert Serial Cable Connector

Black --- GND, Green --- RXD, White --- TXD, Red --- +5V

ene eind: GND; midden: TX; andere eind: RX

Links
-----

OpenWRT
"""""""

* Download: http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
* Extend rootfs to usb disk:
  https://forum.openwrt.org/search.php?search_id=2061578473

TL-WR703n
"""""""""

* page on TL-WR703n: http://wiki.openwrt.org/toh/tp-link/tl-wr703n
* PCD details: http://wiki.openwrt.org/toh/tp-link/tl-wr703n/pcb

Video's
"""""""

* Upgrade to 64MB RAM: http://www.youtube.com/watch?v=PYe-gI2ysrw


TL-MR3020
---------

* Official product page: http://www.tp-link.com/en/products/details/?model=TL-MR3020
* Page: http://wiki.openwrt.org/toh/tp-link/tl-mr3020
  also hardware hacks, e.g.:

  * External Antenne
  * Adding I2C Bus
  * USB Hub, incl: SD Card, webcam etc...

TL-WR703n
---------

Root account
""""""""""""

Wireless configuration
""""""""""""""""""""""

The wireless interface is disabled after flashing::

root@OpenWrt:/etc/config# cat wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11ng
        option path     'platform/ar933x_wmac'
        option htmode   HT20
        list ht_capab   SHORT-GI-20
        list ht_capab   SHORT-GI-40
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        # option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

More information:
https://forum.openwrt.org/viewtopic.php?pid=173467#p173467


openwrt-uci-export_mywrt.txt



package dhcp

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

package dropbear

config dropbear
    option PasswordAuth 'on'
    option RootPasswordAuth 'on'
    option Port '22'

package firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'wan'
    option network 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Enforce-ULA-Border-Src'
    option src '*'
    option dest 'wan'
    option proto 'all'
    option src_ip 'fc00::/7'
    option family 'ipv6'
    option target 'REJECT'

config rule
    option name 'Enforce-ULA-Border-Dest'
    option src '*'
    option dest 'wan'
    option proto 'all'
    option dest_ip 'fc00::/7'
    option family 'ipv6'
    option target 'REJECT'

config include
    option path '/etc/firewall.user'

package network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

package system

config system
    option hostname 'MyWRT'
    option timezone 'UTC'

config timeserver 'ntp'
    list server '0.openwrt.pool.ntp.org'
    list server '1.openwrt.pool.ntp.org'
    list server '2.openwrt.pool.ntp.org'
    list server '3.openwrt.pool.ntp.org'
    option enable_server '0'

package ubootenv

package wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr '14:E6:E4:E1:75:76'
    option hwmode '11ng'
    option path 'platform/ar933x_wmac'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option channel '10'
    option country 'NL'
    option txpower '20'
    option disabled '0'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'MyWRT'
    option encryption 'psk2'
    option key 'mywrtrulez!'



The Fast FWR171-3G look very much like the wr703n

Here is an howto unbrick
http://forums.openpilot.org/blog/52/entry-92-unbrick-wr703n-wifi-router/

https://forum.openwrt.org/viewtopic.php?id=36594

good resources:
http://www.siongboon.com/projects/2013-10-06_tl-wr703n_setup/index.html
http://www.siongboon.com/projects/2013-10-06_tl-wr703n_setup/image/TL-WR703N+Schematic.pdf





Install TP-LINK software from GUI

Download the original tp-link software here.

(I only installed  this version from a serial interface and never directly from the Chinese GUI but users reported that this works as well)

browse with a workstation to 192.168.0.254 
username = admin
password = admin

After this you can update the TP-Link software to the latest version.


Install TP-LINK software with tftp

The version available in the link below should also work to upgrade the Chinese software. I have never tried this.
I only did this with my serial interface.
  • Setup serial console 115200 8n1
  • Enter "tpl" as soon as U-Boot announces "Autobooting in 1 seconds"
  • Download the original image here extact to tftp folder
  • Setup your eth0 to 192.168.1.100, you can check detail by 'printenv'
  • Run blow command under U-Boot:
tftpboot 0x81000000 wr703nv1_cn_3_12_11_up(110926).bin
erase 0x9f020000 +0x3c0000
cp.b 0x81000000 0x9f020000 0x3c0000
bootm 9f020000

[restore original tp-link software on tl-wr703n]
browse with a workstation to 192.168.0.254 
username = admin
password = admin

After this you can update the TP-Link software to the latest version.


Howto unbrick 

When things do go wrong with your flash you always can end-up with a bricked device. Below are some notes on howto unbrick your device with an additional
serial cable soldered to the board.

Requirements:
  • Special cable - PL2303, USB/TTL/RS232 Convert Serial Cable Connector
  • Open the casing
  • Very good solder equipment and skills
  • Time

Soldering




click image for large image

  • Black cable-----GND
  • Green cable-----TXD
  • White cable-----RXD
  • Red cable -------VCC

  • More details about the soldering can be found here.



    PuTTY settings:

    Speed (baud)       115200 bps
    Data bits             8
    Stop bits             1
    Parity                  None
    Flow control         None





    Install TFTP a server

    Install a small tftp server on your computer (ex: http://tftpd32.jounin.net/) and plug an ethernet cable between your computer and the Fast FWR171-3G.
    Configure the IP adress of your computer to 192.168.1.100 and put your firmware files on the tftp server.
    todo


    click to enlarge image




    The newest original firmware can be downloaded form here ( Chinese ) or directly form TL-WR703N V1_120228???

    http://wiki.openwrt.org/toh/tp-link/tl-wr703n


    google: dd-wrt tplink tp-link hack mod research error help chinese chineze english us interface uk interface translate hotel home router, change language from Chinese to English


    howto fix router dd-wrt 703n, howto fix dd-wrt 703n, howto router dd-wrt 703n, dd-wrt wr703n, english firmware Fast FWR171-3G, hacking wr703n, fixing network dd-wrt dd-wrt TP-LINK TL-WR703N
    TP-LINK TL-WR703N dd-wrt
    Configuring the TP-Link travel router with DD-WRT (and solving the single port problem)

    Now there is one problem with the MR3020 – in fact it is the same problem with any travel router which has DD-WRT installed on it: there is only a single ethernet port on the device (marked as WAN).



    Antenna mod


    http://blagg.tadkom.net/2012/09/15/better-wr703n-antenna-mod/


    http://www.designspark.com/blog/hacking-the-tp-link-tl-wr703n#.UPRdxqvu7mk.twitter


    index: mercury mw151rm mr3020 lede wr703 Kankun KK-SP3


    ċ
    ddwrt 703 ap.bin
    (20k)
    Moosy Research,
    Dec 11, 2014, 12:03 AM
    ċ
    factory-to-ddwrt.bin
    (3840k)
    Moosy Research,
    Jan 2, 2013, 11:20 AM
    ą
    in1.png
    (4587k)
    Moosy Research,
    Jan 1, 2013, 4:35 AM
    ą
    in2.png
    (5188k)
    Moosy Research,
    Jan 1, 2013, 4:34 AM
    ċ
    Moosy Research,
    Mar 7, 2013, 7:20 AM
    ċ
    wr703n_en.bin
    (3840k)
    Moosy Research,
    Apr 28, 2013, 12:49 AM
    ċ
    wrt703.bin
    (22k)
    Moosy Research,
    Apr 26, 2013, 9:23 AM
    Comments