werk‎ > ‎

LibreOffice Base Java problem

Bij het aanmaken van een LibreOffice base adressen database kwam (op mn laptop) meteen al  deze error :
De verbinding met de externe gegevensbron kon niet tot stand worden gebracht.
Er werd geen SDBC stuurprogramma gevonden voor de URL 'sdc:embedded:hsqldb'.

Hier gezocht :
https://forum.openoffice.org/nl/forum/viewtopic.php?f=13&t=372
Hee dat is open office.

Blijkbaar is er een Java Runtime nodig. Staat ook in genoemde Base Hansleiding
Deze haalt java op bij www.java.com, maar volgens ComputerTip moet je dat niet doen
http://community.linuxmint.com/tutorial/view/1091

ComputerTip : OpenJDK gebruiken :
Primaire-keuze:-OpenJDK-en-niet-Oracle-Sun-Java

Die stuurt door naar http://www.duinsoft.nl/packages.php
En de daarop beschreven installatie procedure heb ik uitgevoerd :
  • neem de regel
    deb http://www.duinsoft.nl/pkg debs all
    op in het bestand /etc/apt/sources.list, via Softwarebronnen uit je Systeemmenu of door het bestand aan te passen in een editor (als root)
  • importeer de gpg-sleutel met de opdracht (alles op één regel)
    sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 0xE18CE6625CB26B26
  • voer de opdrachten (twee regels)
    • sudo apt-get update
    • sudo apt-get install update-sun-jre
      • dat duurt even. enorme listing ... en klaar.


Nou terug naar Libre Office Base ...
ik start mn databeestje weer op,
weer die foutmelding
kijken of we met https://forum.openoffice.org/nl/forum/viewtopic.php?f=13&t=372
verder komen ...
LibreOffice - menu --> extra --> opties --> geavanceerd
Gebruik een Java Runtime Environment, selecteer die met de hoogste versie
In Base klik op Tabellen.
Weer die Foutmelding ...
Wat op https://forum.openoffice.org/nl/forum/viewtopic.php?f=13&t=372 staat, klopt bij mij niet >:-(

Deze proberen :
https://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=69896
ook niet
deze dan ...
https://ask.libreoffice.org/en/question/46269/base-wont-run-errorrequires-a-java-runtime-environment-jre-to-perform-this-task-java-is-already-installed/

Helaas ...
Het aan de gang krijgen van java valt tegen. Al gogelend wel geleerd dat
  • LibreOffice een 32 bit applicatie is en dat daarom ook java 32 bit moet zijn.
  • De standaard database HSQLDB java nodig heeft voor een deel van de functionaliteit
  • Het nieuwere alternatief voor HSQLDB er aan komt : Firebird. Dit heeft geen java meer nodig.

Over Firebird :

probleem gepost op https://forum.openoffice.org/nl/forum/viewtopic.php?f=13&t=2313



zou dit helpen ? :
http://en.libreofficeforum.org/node/6062
https://wiki.documentfoundation.org/Development/Base/FirebirdSQL#Implementing_tips
Comments