Download

Please select your OS:

Requirements for Limera1n:
Device: iPhone 3G, iPhone 3GS, iPhone 4, iPod Touch 3G, iPod Touch 4G, iPad , iPad 2
iOS Version: Everything Up To 4.3.3
Computer: Windows or iMac