Navigation

      Tools in Ubuntu‎ > ‎

      Autokey

      Autokey is my favorite keyboard shortcut manager in Ubuntu. It is a desktop automation utility for Linux and X11 and it allows you to create scripts and assign hotkeys to these scripts, allowing you to execute them on demand in whatever program you are using.
      Now, if you have upgraded your Ubuntu to the latest version – 11.04 Natty, you will find that Autokey no longer works. There is either no icon at the system tray or that you can’t create your own shortcut key. In fact, if you check out the Autokey PPA, you will also find that there is no package for Natty. Luckily, there is a simple way to make it work in Ubuntu Natty.



      1. In Ubuntu Natty, assuming you are using the Ubuntu Classic (without Unity) desktop, first add the “maverick” version of the autokey PPA.
      gksu gedit /etc/apt/sources.list
      2. Add the following lines to the end of the file.
      deb http://ppa.launchpad.net/cdekter/ppa/ubuntu maverick main 
      deb-src http://ppa.launchpad.net/cdekter/ppa/ubuntu maverick main
      3. Save and close the file. Next, in the terminal,
      sudo apt-get update
      sudo apt-get install autokey-gtk
      4. Run Autokey (Applications -> Accessories -> Autokey (GTK)). You should see the Autokey applet in your system tray. Click on it to load the configuration window.
      Go to “Edit -> Preferences” and click the “Interface” tab. Select the first choice “X Record – for X.org server v1.5 or v1.7.6 and above”.
      5. Restart your computer. It should work correctly the next time you login.

      Make Autokey works in Ubuntu Unity

      If you are using the Unity desktop, Autokey will work but the icon won’t appear in the system tray.
      Here’s what you need to do:
      Open a terminal and type:
      gsettings set com.canonical.Unity.Panel systray-whitelist "['Autokey']"
      setsid unity
      That’s it. The icon should appear. You can then follow the above steps to change the interface to “X Record – for X.org server v1.5 or v1.7.6 and above“. Restart the computer and it should work
      Comments