OSPF‎ > ‎

Virtual-links and GRE Tunnels


virtual-link


   Dans notre exemple, l'Area 3 n'a pas de connexion direct (physique ou logique) avec l'Aera0.

   L' Area 1 est donc en charge de créer un lien logique entre R1 et R2 :



R1#conf t
R1(config)#router ospf 1
R1(config-router)#area 1 virtual-link 2.2.2.2
  
R2#conf t
R2(config)#router ospf 1
R2(config-router)#area 1 virtual-link 1.1.1.1

Vérification
R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -           -        10.1.12.1       OSPF_VL0
3.3.3.3           1   FULL/DR         00:00:30    10.1.23.3       FastEthernet0/0
1.1.1.1           0   FULL/  -        00:00:37    10.1.12.1       Serial0/0.21

R2#show ip route ospf
     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/65] via 10.1.12.1, 00:02:15, Serial0/0.21
     3.0.0.0/24 is subnetted, 1 subnets
O       3.3.3.0 [110/2] via 10.1.23.3, 00:02:15, FastEthernet0/0
     4.0.0.0/24 is subnetted, 1 subnets
O IA    4.4.4.0 [110/12] via 10.1.23.3, 00:02:15, FastEthernet0/0
     10.0.0.0/24 is subnetted, 4 subnets
O IA    10.1.1.0 [110/65] via 10.1.12.1, 00:00:17, Serial0/0.21
O IA    10.1.34.0 [110/11] via 10.1.23.3, 00:02:15, FastEthernet0/0
     30.0.0.0/24 is subnetted, 1 subnets
O IA    30.3.3.0 [110/2] via 10.1.23.3, 00:02:15, FastEthernet0/0


GRE Tunnels

   Dans notre exemple, l'Area 4 n'a pas de connexion direct (physique ou logique) avec l'Aera0.
   Il est possible de créer un tunnel GRE entre R4 et R5 afin de "prolonger" l'Area 0 jusqu'a R4

R3#conf t
R3(config)#int tunnel 1
R3(config-if)#ip address 100.0.0.1 255.255.255.0
R3(config-if)#tunnel source 10.1.34.3
R3(config-if)#tunnel destination 10.1.34.4

R3(config)#router ospf 1
R3(config-router)#network 100.0.0.1 0.0.0.0 area 0

R4#conf t
R4(config)#int tunnel 1
R4(config-if)#ip address 100.0.0.2 255.255.255.0
R4(config-if)#tunnel source 10.1.34.4
R4(config-if)#tunnel destination 10.1.34.3

R4(config-if)#router ospf 1
R4(config-router)#network 100.0.0.2 0.0.0.0 area 0


Vérifications:
R3#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           0   FULL/  -        00:00:38    100.0.0.2       Tunnel1
2.2.2.2           1   FULL/BDR        00:00:35    10.1.23.2       FastEthernet0/0
4.4.4.4           0   FULL/  -        00:00:33    10.1.34.4       Serial1/0.34
  
R3#show ip route 5.5.5.5
Routing entry for 5.5.5.0/24
  Known via "ospf 1", distance 110, metric 11113, type inter area
  Last update from 100.0.0.2 on Tunnel1, 00:01:21 ago
  Routing Descriptor Blocks:
  * 100.0.0.2, from 4.4.4.4, 00:01:21 ago, via Tunnel1
      Route metric is 11113, traffic share count is 1
  
R1#ping 5.5.5.5 source 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/128/128 ms