REDES‎ > ‎

Packet tracer

Tweet elparaderodeloseccis



Packet Tracer es la herramienta de aprendizaje y simulación de redes interactiva para los instructores y alumnos de Cisco CCNA. Esta herramienta les permite a los usuarios crear topologías de red, configurar dispositivos, insertar paquetes y simular una red con múltiples representaciones visuales. Packet Tracer se enfoca en apoyar mejor los protocolos de redes que se enseñan en el currículum de CCNA.

Este producto tiene el propósito de ser usado como un producto educativo que brinda exposición a la interfaz comando – línea de los dispositivos de Cisco para practica y aprender por descubrimiento.

Principales funcionalidades:

  • Entre las mejoras del Packet Tracer 5 encontramos:
  • Soporte para Windows (2000, XP, Vista) y Linux (Ubuntu y Fedora).
  • Permite configuraciones multiusuario y colaborativas en tiempo real.
  • Soporte para IPv6, OSPF multiárea, redistribución de rutas, RSTP, SSH y Switchs multicapa.

Soporta los siguientes protocolos:

  • HTTP, TCP/IP, Telnet, SSH, TFTP, DHCP y DNS.
  • TCP/UDP, IPv4, IPv6, ICMPv4 e ICMPv6.
  • RIP, EIGRP, OSPF Multiárea, enrutamiento estático y redistribución de rutas.
  • Ethernet 802.3 y 802.11, HDLC, Frame Relay y PPP.
  • ARP, CDP, STP, RSTP, 802.1q, VTP, DTP y PAgP, Polly Mkt.

Nuevos recursos, actividades y demostraciones:

  • OSPF, IPv6, SSH, RSTP, Frame Relay, VLAN's, Spanning Tree, Mike mkt etc.

No soporta IGRP y los archivos hechos con Packet Tracer 5 no son compatibles con las versiones anteriores.


   CONFIGURAR RUTAS ESTÁTICAS EN PACKET TRACER
Vista de la consola
  • Configuración de interfaces en la consola
interfaz ethernet/fast Ethernet:
  • Router>enable
  • Router#configure terminal
  • Router(config)#interface FastEthernet 0/0
  • Router(config-if)#ip address <dir. ip> <mascara>
interfaz serie o serial (depende de si es DCE o DTE):
  • Router0(config)#interface serial 0/0
  • Router0(config-if)#ip address 172.16.2.1 255.255.255.0
  • Router0(config-if)#clock rate 64000
  • Router0(config-if)#no shutdown
  • En este caso es el DCE (por eso lleva clock rate).
Ver configuración interfaces.
  • Router#show interfaces
El administrador de red configura la ruta mediante el
comando:
  • ip route <red destino> <m´ascara> <gateway>
El router instala la ruta en la tabla de encaminamiento.
Los paquetes se encaminan de acuerdo a la ruta estática.

Ejemplo para Router1

  • Router1>enable
  • Router1#configure terminal
  • Router1(config)#router rip
  • Router1(config-router)#ip route 172.16.1.0 255.255.255.0 172.16.2.1
  • Router1(config-router)#ip route 172.16.5.0 255.255.255.0 172.16.4.2
Un protocolo de encaminamiento es el esquema de comunicacion entre routers.

Un protocolo de encaminamiento permite que un router comparta información con otros routers acerca de las redes que conoce, ası como de su proximidad a otros routers.

La informacion que un router obtiene de otro, mediante el protocolo de encaminamiento, se usa para crear y mantener las tablas de encaminamiento.

Configuración de rutas dinámicas II
Se usan los comandos (para RIP):
  • (config)#router <protocolo>
  • (config-router)#network <direcci ´on red>
  • Donde dirección red especifica una red directamente 
  • conectada.
Por ejemplo:
  • Router1(config)#router rip
  • Router1(config-router)#network 172.16.2.0
  • Router1(config-router)#network 172.16.3.0
  • Router1(config-router)#network 172.16.4.0
Verificación de las rutas
El comando show ip route se utiliza para comprobar que la 
ruta estática se encuentra en la tabla de enrutamiento.
Verificar la 
conexión
En RealTime Mode.
Para verificar la conexión desde un router:
  • ping ip-destino.
  • traceroute ip-destino.
Para verificar la conexi ´on desde una estaci ´on
de trabajo:
  • ping ip-destino.
  • tracert ip-destino.
  • Packet

Comandos Configuración routers Cisco

Comandos generales: 
  • ·Mostrar Tabla de enrutamiento: show ip route 
  • ·Mostrar estado de las interfaces del router: show ip interface nombre 
  • ·Mostrar información de los vecinos: show cdp neighbors detail 
  • ·Inahabilitar cdp: no cdp run 
  • ·Habilitar interfaces: no shutdown 
  • ·Ver cambios: debug ip routing 
  • ·Encriptacion de contraseña: enable password 
  • ·Guardar configuracion: copy running-config startup-config 
  • ·Configuracion NVRAM: show startup-config 
  • ·Configuracion RAM: show running-config 
  • ·Mostrar protocolos: show ip protocols 
Rutas Estáticas: 
  • ·Configuración ruta estatica: ip route red mascara interfaz 
  • ·Borrar ruta estatica: no ip route 
  • ·Habilitar reloj DCE: clockrate 64000 
RIPv1: 

  • ·Habilitar rip: router rip 
  • ·Mostrar actualizaciones: debug ip rip 
  • ·No enviar actualizacion desde una interfaz: passive-interface interface-type interface-number 
  • ·Habilitar rip en todas las interfaces de esta red: network red 
  • ·Desahabilitar rip: no ruoter rip 
  • ·Router va a originar información por defecto mediante la propagación de la ruta estática por defecto en la actualización RIP.: default-information originate 

RIPv2: 
  • ·Difundir ruta estática mediante un protocolo de enrutamiento: redistribute static 
  • ·Habilitar v2: version 2 
  • ·Deshabilitar sumarizacion: no auto-summary 

EIGRP: 
  • ·Habilitar eigrp: router eigrp nombre 
  • ·Habilitar eigrp en todas las interfaces de esta red: network red 
  • ·Comprobar adyacencias con vecinos: show ip eigrp neighbors 
  • ·Cambiar ancho de banda: bandwith kilobits 
  • ·Tabla de topologia eigrp: show ip eigrp topology 
  • ·Analizar maquina estado finito: debug eigrp fsm 
  • ·Ruta por defecto : redistribute static 
  • ·Cambiar porcentage bandwith: ip bandwidth-percent eigrp as-number percent 
  • ·Intervalos de saludo: ip hello-interval eigrp as-number seconds 
  • ·Tiempo de hold: ip hold-time eigrp as-number seconds 

OSPF: 

  • ·Habilitar ospf: router ospf id_del_proceso 
  • ·Funcion network: network dirección de red_máscara wildcard_área ID del área 
  • ·Configurar Id del router: router-id 
Ejemplo de  RUTAS ESTÁTICAS EN PACKET TRACER

  • La finalidad de ejercicio es que se pueda enrutar tráfico entre las redes 192.168.1.0/24, 192.168.2.0/24 y 192.168.3.0/24 sin ningún protocolo de enrutamiento, usando solo rutas estáticas. 
PASO 1 - Configuración de los Hosts 
Host A
 
IP: 192.168.1.2 
Máscara: 255.255.255.0 
Default Gateway: 192.168.1.1 
Host B
 
IP: 192.168.2.2 
Máscara: 255.255.255.0 
Default Gateway: 192.168.2.1 
Host C
 
IP: 192.168.3.2 
Máscara: 255.255.255.0 
Default Gateway: 192.168.3.1 

Observaciones: El default gateway (puerta de enlace) para los hosts es la interfaz del router 
conectada a la red a la cual pertenece el host. En este caso es la FastEthernet 0/0 de cada router. 

PASO 2 - Configuración Básica de los Routers 

Router A 
Router>enable 
Router#config terminal 
Router(config)#hostname RouterA 
RouterA(config)#interface fastethernet 0/0 
RouterA(config-if)#ip address 192.168.1.1 255.255.255.0 
RouterA(config-if)#no shutdown 
RouterA(config-if)#exit 
RouterA(config)#interface serial 0/0 
RouterA(config-if)#ip address 10.0.0.2 255.0.0.0 
RouterA(config-if)#no shutdown 

Router B 
Router>enable 
Router#config terminal 
Router(config)#hostname RouterB 
RouterB(config)#interface fastethernet 0/0 
RouterB(config-if)#ip address 192.168.2.1 255.255.255.0 
RouterB(config-if)#no shutdown 
RouterB(config-if)#exit 
RouterB(config)#interface serial 0/0 
RouterB(config-if)#ip address 10.0.0.1 255.0.0.0 
RouterB(config-if)#clock rate 56000 
RouterB(config-if)#no shutdown 
RouterB(config-if)#exit 
RouterB(config)#interface serial 0/1 
RouterB(config-if)#ip address 11.0.0.1 255.0.0.0 
RouterB(config-if)#clock rate 56000 
RouterB(config-if)#no shutdown 

Router C 
Router>enable 
Router#config terminal 
Router(config)#hostname RouterC 
RouterC(config)#interface fastethernet 0/0 
RouterC(config-if)#ip address 192.168.3.1 255.255.255.0 
RouterC(config-if)#no shutdown 
RouterC(config-if)#exit 
RouterC(config)#interface serial 0/1 
RouterC(config-if)#ip address 11.0.0.2 255.0.0.0 
RouterC(config-if)#no shutdown 


Observaciones: Con los routers así configurados tienen que tener conectividad básica entre todos los dispositivos. 

*Si tienen dudas hagan desde los routers, en el modo exec privilegiado (#), un “show cdp neighbors” y en el resultado, si está todo bien configurado, les deben aparecer los routers y switchs directamente conectados, si no les aparece alguno revisen la configuración porque algo mal hicieron. 

PASO 3 - Configurar Rutas Estáticas
 

Hay dos formas de configurar las rutas estáticas, usando la “IP del siguiente salto” o la “interfaz de salida”, pueden usar cualquiera de las dos. Normalmente se usa la “IP del siguiente salto” que es la IP de la interfaz del router directamente conectado, pero si entre los datos no la tenemos, podemos usar la “interfaz de salida” que es la interfaz del router local. No hay forma de hacer rutas estáticas sin conocer la dirección de red destino, para ese caso se usan “rutas por defecto” o un “default gateway” en el router (ya haré un tutorial sobre estas configuraciones). 

A) Configurar Rutas Estáticas Utilizando la “IP del Siguiente Salto” 

Router A 
RouterA>enable 
RouterA#config terminal 
RouterA(config)#ip route 192.168.2.0 255.255.255.0 10.0.0.1 
RouterA(config)#ip route 192.168.3.0 255.255.255.0 10.0.0.1 

Observaciones: Con estas rutas estáticas le estamos diciendo al RouterA que todo tráfico hacia la red 192.168.2.0 y 192.168.3.0 se debe enviar hacia la interfaz con la IP 10.0.0.1 para que lo resuelva. 

RouterB 
RouterB>enable 
RouterB#config terminal 
RouterB(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.2 
RouterB(config)#ip route 192.168.3.0 255.255.255.0 11.0.0.2 

Observaciones: Con la primer ruta estática le estamos diciendo al RouterB que todo tráfico hacia la  red 192.168.1.0 se debe enviar hacia la interfaz con la IP 10.0.0.2 para que lo resuelva. 
Con la segunda ruta estática le estamos diciendo al RouterB que todo tráfico hacia la red 
192.168.3.0 se debe enviar hacia la interfaz con la IP 11.0.0.2 para que lo resuelva. 

RouterC 
RouterC>enable 
RouterC#config terminal 
RouterC(config)#ip route 192.168.2.0 255.255.255.0 11.0.0.1 
RouterC(config)#ip route 192.168.1.0 255.255.255.0 11.0.0.1 

Observaciones: Con la primer ruta estática le estamos diciendo al RouterC que todo tráfico hacia la red 192.168.2.0 se debe enviar hacia la interfaz con la IP 11.0.0.1 para que lo resuelva. 
Con la segunda ruta estática le estamos diciendo al RouterC que todo tráfico hacia la red 
192.168.1.0 se debe enviar hacia la interfaz con la IP 11.0.0.1 para que lo resuelva. 

B) Configurar Rutas Estáticas Utilizando la “Interfaz de Salida” 

Router A 
RouterA>enable 
RouterA#config terminal 
RouterA(config)#ip route 192.168.2.0 255.255.255.0 s0/0 
RouterA(config)#ip route 192.168.3.0 255.255.255.0 s0/0 

Observaciones: Con estas rutas estáticas le estamos diciendo al RouterA que todo tráfico hacia la red 192.168.2.0 y 192.168.3.0 se debe enviar por la interfaz local s0/0. 

RouterB 
RouterB>enable 
RouterB#config terminal 
RouterB(config)#ip route 192.168.1.0 255.255.255.0 s0/0 
RouterB(config)#ip route 192.168.3.0 255.255.255.0 s0/1 

Observaciones: Con la primer ruta estática le estamos diciendo al RouterB que todo tráfico hacia la red 192.168.1.0 se debe enviar por la interfaz local s0/0. 
Con la segunda ruta estática le estamos diciendo al RouterB que todo tráfico hacia la red 
192.168.3.0 se debe enviar por la interfaz local s0/1. 

RouterC 
RouterC>enable 
RouterC#config terminal 
RouterC(config)#ip route 192.168.2.0 255.255.255.0 s0/1 
RouterC(config)#ip route 192.168.1.0 255.255.255.0 s0/1 

Observaciones: Con la primer ruta estática le estamos diciendo al RouterC que todo tráfico hacia la red 192.168.2.0 se debe enviar por la interfaz local s0/1. 
Con la segunda ruta estática le estamos diciendo al RouterC que todo tráfico hacia la red 
192.168.1.0 se debe enviar por la interfaz local s0/1. 

Comprobación de Conectividad entre Dispositivos 

Antes de configurar las rutas estáticas tienen que estar seguros de que todos los dispositivos vecinos de la topología se están viendo. 
Una de las formas es usando el comando “show cdp neighbors” desde cada router que nos mostrará en su resultado los routers y switchs directamente conectados a el, si no aparece alguno hay algo mal configurado. 
Otra cosa que tienen que probar es que los hosts se comuniquen con el “default gateway” (puerta de enlace) de la red, esto lo pueden hace con un ping desde un host a la IP de la interfaz del router conectada a la red a la que pertenece el host. 

Comments