Knowledge Base and How To's

Ubunt: WUSB600N V2 Fix

posted Oct 8, 2011, 1:03 PM by Chad Slappey   [ updated Oct 8, 2011, 2:40 PM ]

Originally from my old website: http://stu.westga.edu/~cslappe1

Resources:

Charles Slappey
May 26, 2010
Wednesday: 4:26pm

So there are a ton of tutorials online about how to get the Linksys WUSB600N v2 model to work, but I'm a little curious why someone doesn't just post the files already modified online. It is not hard, but for noobs (and for me since I downloaded the wrong ranlink drivers twice) it would be nice to knock it down to 2 steps.

Also I know that an old way to fix it is to use the ndiswrapper fix, but I think that only works with v1 (not sure) plus it seems like it would be better to run my internet without the use of another program. (I don't even like using the linksys software on Windows... just seems to leave more room for something to screw up.)

So without further ado:
(See the Extended/ Noobish ed. below for more details.)

  • Step 1: Download wusbfix and extract it.
  • Step 2: cd to the folder in the terminal.
  • Step 3: type commands: 
      sudo make 
      sudo make install 
      sudo modprobe rt3572sta

Extended/ Noobish ed.

  • Step 1: Download wusbfix and extract it to your desktop.   Double click to open file then drag and drop to desktop. Or put wusbfix.tar.gz on desktop, rightclick and click "Extract Here"
  • Step 2: cd to the folder in the terminal. 
      Open terminal, type: cd Desktop/wusbfix
  • Step 3: type commands: 
      sudo make 
      sudo make install 
      sudo modprobe rt3572sta

Install python3.1 and pygame1.9.1 in Ubuntu

posted Oct 8, 2011, 12:51 PM by Chad Slappey


Author: Chad Slappey
Date: 08/10/2011, Oct 8, 2011

The following instructs how to install python3.1 with pygame in Ubuntu when python3.1 is an alt-install (not default). This is necessary because pygame installs in with the default python build, and will not be accessible from an alt-install.

Solution tested on Ubuntu 10.04 LTS 32-bit ed.

Note: If you are having Idle problems after this, make sure you are using Idle for python 3 and not the one for 2. I saw this a lot in the forums.

<-----------------------------------------------------------------------------
1. Install python3.1 in Synaptic Package Manager

2. Download source for pygame 1.9.1: http://pygame.org/ftp/pygame-1.9.1release.tar.gz

3. Extract to a folder of your choice

4. Open a terminal and cd to the extracted folder: pygame-1.9.1release

5. Run these commands in terminal:
python3.1 config.py #*Note: If dependancies missing see below for corrections
2to3 setup.py -w
python3.1 setup.py build
sudo python3.1 setup.py install
----------------------------------------------------------------------------->

*If there are dependancies missing, type 'n' and look for them in the Synaptic Package manager.
If I remember correctly, the following is what I had to search for and mark for installation. In case I miss something I will paste a copy of packages I installed with Synamptic Package manager today.

<-----------------------------------------------------------------------------
What I think I searched and installed (None of this is necessary if the above worked):
*search
*mark for install

sdl
sdlbrt #(I'm not sure if this one is necessary)

sdl dev
libsdl1.2-dev

sdl font
libsdl-ttf2.0-dev

sdl image
libsdl-image1.2-dev

smpeg
libsmpeg-dev
libsmpeg-mixer1.2-dev

portmidi
libportmidi-dev
----------------------------------------------------------------------------->

<-----------------------------------------------------------------------------
Below is a list of packages I installed (None of this is necessary if the above worked):

Commit Log for Sat Oct  8 14:28:23 2011


Installed the following packages:
libsdl-net1.2 (1.2.7-2)
sdlbrt (0.0.20070714-3)
ttf-dejavu (2.30-2)

Commit Log for Sat Oct  8 14:31:02 2011


Installed the following packages:
libaa1-dev (1.4p5-38build1)
libasound2-dev (1.0.22-0ubuntu7)
libaudio-dev (1.9.2-3)
libaudiofile-dev (0.2.6-8ubuntu1)
libavahi-client-dev (0.6.25-1ubuntu6.2)
libavahi-common-dev (0.6.25-1ubuntu6.2)
libcaca-dev (0.99.beta16-3)
libdbus-1-dev (1.2.16-2ubuntu4.3)
libdirectfb-dev (1.2.8-5ubuntu2)
libdirectfb-extra (1.2.8-5ubuntu2)
libdrm-dev (2.4.18-1ubuntu3)
libesd0-dev (0.2.41-6ubuntu1)
libfreetype6-dev (2.3.11-1ubuntu2.4)
libgl1-mesa-dev (7.7.1-1ubuntu3)
libglib2.0-dev (2.24.1-0ubuntu1)
libglu1-mesa-dev (7.7.1-1ubuntu3)
libjpeg62-dev (6b-15ubuntu1)
libncurses5-dev (5.7+20090803-2ubuntu3)
libpng12-dev (1.2.42-1ubuntu2.2)
libpulse-dev (1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14)
libsdl1.2-dev (1.2.14-4ubuntu1.1)
libslang2-dev (2.2.2-2ubuntu1)
libsysfs-dev (2.1.0-6)
libxext-dev (2:1.1.1-2)
mesa-common-dev (7.7.1-1ubuntu3)
x11proto-xext-dev (7.1.1-2)
zlib1g-dev (1:1.2.3.3.dfsg-15ubuntu1)

Commit Log for Sat Oct  8 14:33:56 2011


Installed the following packages:
libmikmod2-dev (3.1.11-a-6.1ubuntu0.1)
libogg-dev (1.1.4~dfsg-2)
libsdl-mixer1.2-dev (1.2.8-6build1)
libsmpeg-dev (0.4.5+cvs20030824-2.2)
libvorbis-dev (1.2.3-3ubuntu1)

Commit Log for Sat Oct  8 14:34:56 2011


Installed the following packages:
libportmidi-dev (1:200-0ubuntu1)

Commit Log for Sat Oct  8 14:36:27 2011


Installed the following packages:
libsdl-image1.2-dev (1.2.10-1)
libtiff4-dev (3.9.2-2ubuntu0.7)
libtiffxx0c2 (3.9.2-2ubuntu0.7)

Commit Log for Sat Oct  8 14:37:00 2011


Installed the following packages:
libsdl-ttf2.0-dev (2.0.9-1build1)
----------------------------------------------------------------------------->

1-2 of 2