use bifferboard without serial (programming) cable

Firstly follow the "Copying the rootfs" section of these instructions to write the bifferboard's OS to a USB flash drive. Make sure you use the correct device name and don't overwrite your own harddrive ;-)

Then, before umounting it, edit the file /etc/config/network

    • delete the "option type bridge" line

    • set a suitable ipaddr and netmask for your network

    • (optionally) set a gateway address

    • (optionally) set a dns server address

For reference, here's a copy of mine:

# Copyright (C) 2006 OpenWrt.org

config interface loopback

option ifname lo

option proto static

option ipaddr 127.0.0.1

option netmask 255.0.0.0

config interface lan

option ifname eth0

option proto static

option ipaddr 192.168.0.110

option netmask 255.255.255.0

option gateway 192.168.0.254

option dns 192.168.0.254

Or, if you have a dhcp server on your network, you can delete the last 4 lines (ipaddr, netmask, gateway & dns) and set "option proto dhcp". You'd then need to check your dhcp server to find out what ip / hostname has been assigned to your bifferboard.

Then unmount your USB stick and plug it into your bifferboard, plug your bifferboard into your network, and then plug power into your bifferboard.

Wait about 30 seconds for the bifferboard to load up (it doesn't take long!), and then (from another PC on your network) try to ping it, e.g. 'ping 192.168.0.110'. Hopefully you'll get a response!

You can then try telneting to your bifferboard with e.g. 'telnet 192.168.0.110'. If it works you should now be connected directly to your bifferboard, no username or password required.

Read the "IMPORTANT" message that gets displayed, set your root pasword, and then 'exit' from telnet.

From now on you can connect securely to your bifferboard using SSH e.g. 'ssh root@192.168.0.110' using the password you just set.

Without serial access, I guess the only way to reset your root password if you forget it is to write the bifferboard rootfs to your USB drive afresh. - There's an easier way, preserving the data on your USB drive: Connect it to your PC, become root an restore the old password file, like: cp /media/disk/etc/passwd- /media/disk/etc/passwd . "/media/disk" ist the name on which the USB drive is mounted on the PC, it might be different.