
Chapter 1: Introduction to Google Docs 
Overview of Google Docs 
Offering word processing, spreadsheets, presentations, forms, and drawings, Google 
Docs provides an easy-to-use, integrated way for teachers and students to work 
together on projects, reports, and more, and to collect and share information in a secure 
online environment. Some of the advantages of using Google Docs include: 
Anytime, anywhere access   
Web-based Google Docs safely stores documents online, making them accessible to 
authorized users from any computer or mobile device, whenever they're needed. No 
need to save files to a USB thumb drive, you can always access your files from any 
internet browser. 
Collaboration support Google Docs lets users easily invite others to work on the same 
document, at the same time, without the hassle of attaching and sending documents. 
Sharing privileges ensure access by only the right people or groups, and allow either 
editing or read-only access.  
Auto save and revision history Continuous auto save ensures that current work stays 
safe, preserving ongoing drafts and edits. A complete revision history makes it easy to 
review, compare, or revert to a prior version at any point. 
Shared collections Files and docs that are regularly used by teams or groups stay 
organized and up-to-date – without the need to manage and communicate changes. 
Templates Ready-made templates covering a wide range of document and report 

types help jump-start writing projects. You can also create and publish your own 
document templates to establish assignment structures for your students. Templates can 
be copied with one click and then modified like any other document. 
You can access Google Docs from any of your school Google Apps product pages. 
1. In the top left corner of any product main page, you will see a list of links.  
2. Click Documents.   

 
In addition to the links at the top left of any Google Apps page, you can also access 
Google Docs through a custom URL for your school: 

1. Type http://docs.google.com/a/yourschool.org into your browser address bar. 
Please replace yourschool.org with your school Apps domain name 

2. When you are using Apps mail, Google will automatically detect supported file 
types for your attachments and offer an option to open the attachment using Google 
Docs, either as a Google document, spreadsheet, or presentation. When you open the 
attachment in Google Docs, you don't need to download the file to your computer and it 
will be available with the rest of your Google Docs files. 
3. To automatically convert an email attachment to Google Docs, click the "Open as 
a Google spreadsheet" link in the attachment area at the bottom of the message. The 
document will then convert in a new window for you to view and edit as you would with 
any other file in Google Docs. 

 
Access Google Docs 
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» Works for everyone 
Because Google Docs is accessed online via a browser, there are very few compatibility 
issues that exist when you use installed software. This can save time and simplify the 
process of sharing and exchanging files. 
Any computer, any operating system Whether you use a Mac, PC, or Linux computer, 
you access Google Docs the same way – in your browser. Google Docs works with 
most modern browsers. You can start a document on a Mac at school and continue 
editing it on a Home PC with no difference in quality or functionality.  
No need to install upgrades Google Docs is constantly updating new features, but 
because it is accessed online, there is no need to install or upgrade software. Since 
everyone is always using the same version of Google Docs, there are no differences in 
saving or opening files. When viewing files on a different computer, you won't have to 
worry about formatting surprises or compatibility errors. 
Latest version Passing around attachments of files via email or external media can 
cause a confusion with what is the "latest" version of a file. With Google Docs, you 
can share one file which everyone can view and edit.  

import/export options 
Google Docs allows you to easily import and store any file format. In addition, with many 
of the file formats you have the option to convert the file into a Google Doc for editing 
and collaboration. After you're done collaborating and have a finished product, you can 
even export the documents out to be used with other word processing, spreadsheet or 
presentation programs. 

  Docs Spreadsheets Presentations Drawings 

Import 

& 

Convert 

Microsoft Word 

(.doc, .docx) 

OpenDocument text 

(.odt) 

StarOffice text 

(.sxw)  

Rich text (.rtf) 

Plain text (.txt)  

HTML (.htm, .html) 

Microsoft Excel (.xls, 

.xlsx) 

OpenDocument 

spreadsheet (.ods)  

Comma-separated 

values (.csv, .txt) 

Microsoft 

Powerpoint (.ppt, 

.pps) 

Windows 

Metafile 

(.wmf) 

Export Microsoft 

Word(.doc) 

OpenDocument text 

(.odt) 

Rich text (.rtf) 

Plain text (.txt) 

HTML (.htm, .html) 

PDF 

Microsoft Excel (.xls) 

OpenDocument 

spreadsheet (.ods) 

Comma-separated 

values (.csv, .txt)  

PDF, HTML 

Microsoft 

PowerPoint (.ppt) 

PDF (.pdf) 

Text (.txt) 

PNG, 

JPEG, 

SVG, PDF 

You can also convert documents to a Google Docs format if you happened to upload it in 
an unconverted format. While in the document list, right-click on the file you want to 
convert and select Make a Google Docs copy. This doesn‟t modify your original file and 
adds a new Google Docs copy to your docs list.  
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Spreadsheet has an extensive list of import options available for bringing data into a 
Google Spreadsheet. For example, when importing a .csv file, you can create a whole 
new spreadsheet, append to the current sheet, add a new sheet to your existing 
spreadsheet or even replace your entire spreadsheet with this new version. 
A custom delimiters option is also available which allows users to what character to 
parse the data file with, giving users maximum flexibility when dealing with data files. 
The Import dialog is available from the File menu from within Spreadsheets. 

 
» Google Cloud Connect for Microsoft Office 
Google Cloud Connect is a plug-in for Microsoft® Office 2003, 2007, and 2010 that lets 
you share and simultaneously edit Microsoft Word, PowerPoint®, and Excel® 
documents with other people in your organization. You get the collaboration benefits of 
Google Docs, while continuing to use Microsoft Office. 
System requirements 
Google Cloud Connect works for Microsoft Word, PowerPoint, and Excel files for users 
of Microsoft Office 2003, 2007, and 2010. It supports Windows XP, Windows Vista, and 
Windows 7. It is currently not available for Macs. For more details, see System 
requirements. 
Syncing and sharing documents 
Google Cloud Connect tracks, manages and syncs all changes on your Microsoft Office 
documents into one updated version for each document. Each document that you sync 
through Google Cloud Connect gets a unique URL, or web address, that you can share 
with collaborators through IM or email. Depending on the privacy setting you‟ve selected 
for the document, other people will be able to click this link and view the document in the 
browser. 
Collaborating simultaneously on documents 
Google Cloud Connect for Microsoft Office lets you easily share documents with other 
people. When you add someone as an editor in a document, they receive an e-mail 
letting them know that a document has been shared with them. From there, they can 
open a link to view the document in the browser, or if they want to make edits, they can 
download the document and open it in Microsoft Office. When another editor edits a 
document in Microsoft Office, all changes get synced to and will be reflected on your 
screen. 
Revision history 
Using Google Cloud Connect, you can edit a document both online and offline. Every 
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time you sync a document, the revisions of a document are stored so you can easily roll 
back to a previous version. You can retrieve and revert to any prior revision of a 
document at any time. 

 Chapter 2: Sharing, Privacy, Printing & Publishing 
Share and access docs in your school 
In Google Docs, when you want to send a document for others to see or edit, you don‟t 
need to email an attachment or upload a file for others to access. Instead, you can share 
one online version of your document and specify who has permission to make changes 
and who has permission only to view. 
Many people can access a Google Doc at the same time, just like many people can look 
at the same webpage or the same photo shared online. With everyone seeing the same 
thing, at the same time, you can start collaborating in real-time. Sharing documents 
online makes it easier for groups to work together, wherever they are. 
Google Docs lets you know who else is looking at the document and exactly where they 
are making changes. 

 
You can also start a discussion with others in the document using the built-in chat 
feature.  

 
With Google Docs you have 2 types of settings for making your document available to 
others which we will review in the next steps: 

 Visibility settings: how people can access your document 
 Sharing settings: who can make changes or only view the document 

Share and access docs in your school 
Online collaboration 
Sharing online documents 

You can share your docs with just the people you want, and you can specify exactly 
what level of access (view or edit) each person has for each document. For example, a 
teacher might give students view-only access to a written assignment document so that 
students cannot edit the description, but edit-access to a fellow teacher who is teaching 
the same subject and giving the same assignment. When you create a new doc, you are 
automatically the owner and the document is generally only available only to you unless 
your Google Apps administrator has modified the default settings. You can choose to 
explicitly share it with individuals or groups in one of three types of roles with sharing 
privileges:  

Owners 
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 Can edit documents, spreadsheets, presentations, and drawings, and 
invite more editors and viewers. 

 Can delete documents, spreadsheets, presentations, and drawings, 
and thereby remove access for editors and viewers. Please note: To 
fully delete a document, spreadsheet, presentation, or drawing, and 
remove access to it, you need to delete it and then Empty Trash. 

Collaborators with edit access (editors) 
 Can edit documents, spreadsheets, presentations, and drawings. 
 Can invite or delete other editors and viewers (if the owner has given 

them permission). 
 Can export a copy of the document, spreadsheet, presentation, or 

drawing to their local hard drive. 
 Can view the list of editors. 
 Can make a copy of a doc, and copy the list of doc's editors. 

Others with view access (viewers) 

 Can see the most recent version of a document, spreadsheet, 
presentation, or drawing but can't make any changes. 

 Can export a copy of the document, spreadsheet, presentation, or 
drawing to their local hard drive. 

 Can not view the list of editors. 
 Can make a copy a doc, but can't copy the list of doc's editors. 
» Visibility settings 
In addition to explicitly sharing your document with individuals or Groups(LINK) in 
your domain, you can choose to make your document more widely accessible via 
links or search. These visibility settings are detailed in the video and text below: 
Visibility options: Private, Anyone with the link, and Public on the web 
There are up to 5 different visibility options: private; people at my organization with a 
link, people at my organization can find and access, anyone with the link; and public 
on the web. And you can see how your doc is set by looking at the icon right next to 
its title. 

 
 Private 

When you create a private doc, you are the only person with access to it. And 
from there, you can grant access to other people. Anyone trying to access the 
document will have to sign in to their Google Account to verify that they have 
access to the doc. 
Private is the best setting for your own private documents, like a list of contacts or 
a resume. It's also good if you want to collaborate within a closed circle of people -
- for example, if you and a friend or family member are working together on a 
private letter or working on taxes. 
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People at your organization with the link 
Docs set to this option are accessible to anyone inside the domain who knows the 
URL of the file. If you also select the „Allow anyone to edit‟ option, anyone with the 
URL will be able to view and edit your file. This option allows you to easily copy 
and paste the file‟s link into chat, email and calendar invites for quick access and 
feedback. 
People at your organization can find and access 
Docs set to this option will be indexed by Google Docs search and may be opened 
by anyone in your organization. 
If your Google Apps administrator allows sharing outside of your organization, you 
will also be able to make a file Public on the web or available to Anyone with the 
link (no sign in required). Administrators can also control the default visibility 
setting from the control panel. 
Anyone with the link (must be enabled by Google Apps administrator) 
A doc set to Anyone with the link is like an unlisted phone number. In the same 
way that anyone who knows an unlisted phone number can call it, anyone who 
knows the web address of a doc in this category can view it. If you also select the 
'Allow anyone to edit' option, anyone with the URL will also be able to view and 
edit your document. Sign-in is not required, so viewers and editors may show up 
as anonymous. 

 Anyone with the link is a great setting if you want to give easy access to 
information to a bunch of people (as long as the contents of the doc aren't 
sensitive). For example, if you want to share a syllabus and a book list, you could 
put that info into doc set to anyone with the link and send your students the link. 
Docs in this category are generally not indexed by search engines, but they may 
show up in search results if the doc URL appears on another webpage that is 
indexed. 

 Public on the web (must be enabled by Google Apps administrator) 
Set a doc to public if you want to make it publicly available to anyone. Public docs 
may get indexed by search engines (like Google Web Search), can show up in 
search results, and anyone who finds the web address of the doc can access it. If 
you also select the 'Allow anyone to edit' option, anyone that finds the document 
will also be able to view and edit your document. 

 Public on the web is a great setting if you're trying to get the word out about 
something. For example, you could create a flyer for a school event, save it as a 
public doc, post a link to it on your blog, and maybe ask other teachers or students 
to do the same. 

Sharing limitations 
You can explicitly share a doc or file with 200 viewers and editors 
(combined), or you can make your doc available to anyone by changing its 
visibility option. 
50 may edit and view a spreadsheet, document, or drawing. 10 people may 
edit and view a presentation or a document in the older version of Google 
documents. 
Publishing vs. Sharing 
When you publish a doc, Google Docs creates a separate, lightweight webpage where 
anyone with the link can view the contents of your document. Because the published 
version of a doc is its own webpage with its own URL, that version isn‟t affected by the 
visibility option you choose for your document. 
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However, with Google Apps Education Edition, Admins can control the main settings for 
whether documents are published to the world (available to anyone) or published to the 
domain (available to only those with a school Apps account). Having a document 
published to the domain is still like a webpage, no one can edit it as they might if you 
shared the document, but only those with an Apps account can view it.  
With publishing settings, you can have a private document - a document in which you 
select who can edit - and still have it published to either the world or your domain 
(depending on the settings selected by your Apps administrator). In that case, only users 
to whom you've given permission would be able to view or edit the full original doc; 
however, anyone with the separate link to the published version of the doc would be 
able to view that published content. 
As an example, here‟s what the two separate URLs look like in a Google document: 
URL of the full doc: 

 
URL of the published webpage: 
(The differences between the URLs vary a bit among the different document types.) 

 
Publishing is useful, because it lets you do the following things: 

 Create an embeddable HTML version of a doc. The HTML version can be 
embedded in blogs, Google Sites, and more. 

 Show your doc to large web audiences. Only 50 people can view a full-form doc at 
a time, but a lightweight webpage has much, much higher limits. 

 Provide quick access to file downloads, and publish individual sheets or even cell 
selections (Google spreadsheets only) 

 Publish a one-time snapshot of a living document. To create such a snapshot, 
make sure you un-check “Automatically republish” when you publish your doc 

 
Share and access docs in your school 
With Google Apps Education Edition, you will always be able to share a document with 
others at your school who have a Google Apps account.  
When you share with an individual you can select what level of access (view or edit) 
each person has. 
For example, you can share a syllabus document with another teacher and give them 
edit access to make changes. You can then also share the document with your students, 
giving them only view access where they are unable to make changes. 



Here's how to add specific editors and viewers: 
Open the doc you want to share. 

1. Click Share in the upper-right corner of the doc. 
2. At the bottom of the Sharing settings window, under 'Add people,' type the email 

addresses of the people you want to share with. You can add a single person, 
multiple people, or even choose from a list of your contacts. 

 
3. To the right of the list of names, choose 'Can view' or 'Can edit' from the drop-

down. 

 
4. Two quick options to consider (to share with default settings, feel free to skip this 

note): 
o By default, people who can edit your doc will also be able to share it with 

additional people. You can remove that ability by clicking Change next to 
'Editors will be allowed to add people...' before you click Share. 

 
o By default, everyone you share a doc with will get an invitation email. If 

you'd rather not notify them, un-check the 'Send email notifications' box. 
They'll have access the next time they sign in. 

5. Click Share. 
When you share the document with an individual directly, they will notice the document 
appear in their Google Docs doclist, withNew placed next to the document name, and 
the document name bolded. 

 
 
If they do not see the doc yet, they may need to refresh their doclist. 



 
 If you selected to have an email notification sent, the individual will receive an email 
message with a link to the shared document: 

 
Groups at school 

Sometimes you want to share documents with specific groups at your school 
– a department, a class, a grade level, club, or any other type of group. 
Instead of having to enter names individually for every common document, 
you can take advantage of Groups in Google Apps. 
Groups in Google Apps can be created by the domain administrator or the 
administrator can make it possible for individuals to create their own groups. 
A group is a single email address that includes multiple members from an 
Apps domain and can be used to share calendars, sites, and documents. 
When something is shared with that single group address, it is then shared 
with all the group members.  
Sharing with a group follows the same steps as following an individual. You 
can also assign whether the group has edit or view access. Please note that 
the access level is the same for every member in the group.  
For more information about creating a Group on your Apps domain, view 
these help documents. 
To share documents with a Group created in Google Apps, follow these 
steps:  

1. Open the doc you want to share. 
2. Click Share in the upper-right corner of the doc. 
3. At the bottom of the Sharing settings window, under 'Add people,' type the email 

address of the group you want to share with.  

 
4. To the right of the group name, choose 'Can view' or 'Can edit' from the drop-

down. 

http://edutraining.googleapps.com/Training-Home/module-4-docs/chapter-2/2-2


 
5. Two quick options to consider (to share with default settings, feel free to skip this 

note): 
o By default, people who can edit your doc will also be able to share it with 

additional people. You can remove that ability by clicking Change next to 
'Editors will be allowed to add people...' before you click Share. 

o By default, everyone you share doc with will get an invitation email. If you'd 
rather not notify them, un-check the 'Send notifications' box. They'll have 
access the next time they sign in. 

6. Click Share. 

Please note: When you share the document with a group email alias, they 
will need to first open the document before it will appear in their doclist. 
Once they open the document, it will always appear in their doclist. You can 
share the document URL in an email, post it on a website, or send it in a 
chat. If you are often sharing documents with the same group, you might 
want to consider using a shared folder. If you selected to have an email 
notification sent, all the individuals in the group will receive an email 
message with a link to the shared document: 

Once they open the document, the document 
will stay in their doclist. 
Everyone at school 

If you have a document that you would like everyone at your school to be 
able to view, you can select it to be available to everyone in your school 
Apps domain.  
To do this, you can change your document visibility settings to the option:  

 People at your organization with the link: With this setting, your 
document will be accessible to anyone within your school domain who 
knows the URL of the file. If you also select the „Allow anyone to edit‟ 
option, anyone with the URL will be able to view and edit your file. This 
option allows you to easily copy and paste the file‟s link into chat, email 
and calendar invites. You would then have to make sure all at your 
school had access to this link (either on a website or sent via email) for 
them to be aware of the document. This document will not 
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automatically appear in everyone‟s doclist, it will only appear if they 
have opened the document. 

 People at your organization can find and access: With this setting, 
your document will be indexed by Google Docs search within your 
domain and may be opened by anyone in your school Apps domain. 
This means that if someone was searching Google Docs your 
document could show up as a result. However, the document will not 
automatically appear in their doclist until they have opened the 
document. 

In both of these options, you will need to share the link with your school for 
them to be able to access the document – it will not automatically appear in 
their doclist. 
The sharing limitation for viewing the document does not apply with visibility 
settings, however, the limitation for editing a document still applies. Only 50 
people can be editing a document at any given time. However, if you gave 
your school domain only View access, then you shouldn‟t run into this 
problem. 
Share docs outside your school 
To share docs with individuals or groups without a school Apps account, your domain 
administrator have the setting enabled to allow sharing outside your school domain. 
Review how to change service settings ». 
If your domain administrator has enabled the setting to share outside the domain, then 
you will be able to share just as you would with any other individual or group.  Review 
sharing with individuals » and groups ». 
You may see a warning if your domain administrator has selected this to appear: 

 
If your domain administrator does not allow you to share outside your school Apps 
domain, you will see an error message if you enter in an email address that is not 
associated with your domain:  

 
 Groups in Google Apps 
As reviewed previously in the section about sharing and accessing docs within your 
school, you can easily share with Groups created in Google Apps just as you would with 
an individual.  
If members to those groups are added or removed, their access to the document will 
also change accordingly. This is useful if you want a certain group, like faculty, to always 
have access to document. As faculty leave or join, you can modify the group and know 
that the right people will still have access to the document. Review Module 1, Chapter 
3 for more information. 
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To share documents with a Group created in Google Apps, follow these steps: 
Open the doc you want to share. 

1. Click Share in the upper-right corner of the doc. 
2. At the bottom of the Sharing settings window, under 'Add people,' type the email 

addresses of the single group alias you want to add as a collaborator. 

 
3. To the right of the group name, choose 'Can view' or 'Can edit' from the drop-

down. 

 
4. Two quick options to consider (to share with default settings, feel free to skip this 

note): 
o By default, people who can edit your doc will also be able to share it with 

additional people. You can remove that ability by clicking Change next to 
'Editors will be allowed to add people...' before you click Share. 

o By default, everyone you share doc with will get an invitation email. If you'd 
rather not notify them, un-check the 'Send notifications' box. They'll have 
access the next time they sign in. 

5. Click Share. 

Please note: When you share the document with a group email alias, they 
will need to first open the document before it will appear in their doclist. 
Once they open the document, it will always appear in their doclist. You can 
share the document URL in an email, post it on a website, or send it in a 
chat. If you are often sharing documents with the same group, you might 
want to consider using a shared folder. If you selected to have an email 
notification sent, all the individuals in the group will receive an email 
message with a link to the shared document: 

 
Once they open the document, the document will stay in their doclist. 
Google Groups 
Google Groups is a separate product that exists outside of Google Apps 
at http://groups.google.com 
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It is similar to Groups in Google Apps in that you can add and remove members and the 
set of members can be accessed via a single email address (i.e. 
period1parents@googlegroups.com). It also will grant edit or view access to every 
member of the group. 
However, it is different from Groups in Google Apps in that they are not created in 
Google Apps and they can contain email addresses of anyone, anywhere. 
Sharing with a Google Group email address is the same as sharing with someone 
outside your school, since it is not a school Apps mail address. 
If your domain administrator has enabled the setting to share outside the domain, then 
you will be able to share just as you would with any other individual or group.  Review 
sharing with individuals » and groups ». 
You may see a warning if your domain administrator has selected this to appear: 

 
If your domain administrator does not allow you to share outside your school Apps 
domain, you will see an error message if you enter in an email address that is not 
associated with your domain:  

 
To share the document with an outside Google Group, follow these steps: 
Open the doc you want to share. 

1. Click Share in the upper-right corner of the doc. 
2. At the bottom of the Sharing settings window, under 'Add people,' type the email 

addresses of the Google Group (i.e. period1parents@googlegroups.com) 

 
3. To the right of the group name, choose 'Can view' or 'Can edit' from the drop-

down. 

 
4. Two quick options to consider (to share with default settings, feel free to skip this 

note): 
o By default, people who can edit your doc will also be able to share it with 

additional people. You can remove that ability by clicking Change next to 
'Editors will be allowed to add people...' before you click Share. 
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o By default, everyone you share doc with will get an invitation email. If you'd 
rather not notify them, un-check the 'Send notifications' box. They'll have 
access the next time they sign in. 

5. Click Share. 

Please note: When you share the document with a group email alias, they 
will need to first open the document before it will appear in their doclist. The 
doclist will be the associated with the account that is subscribed to the 
Google Group. The member must sign into Google Docs using the same 
account in the Google Group. Once they open the document, it will always 
appear in their doclist. You can share the document URL in an email, post it 
on a website, or send it in a chat. If you are often sharing documents with 
the same group, you might want to consider using a shared folder. If you 
selected to have an email notification sent, all the individuals in the group will 
receive an email message with a link to  
the shared document: Once they open the document, the document will stay 
in their doclist. 

 
Shared folders with individuals and groups 
» Overview of shared collections 

If you are sharing documents often with the same group or individual, it may be useful to 
setup a shared collection. A shared collection is a collection that exists in the doclist and 
appears for everyone that has access to it - much the same as a shared document. 
If you add documents to a shared collection, the collection is automatically shared with 
everyone who has access to the shared collection, with the same access level. For 
example, if students had only view access to the “Assignments” shared collection, 
students could only view every document that was added to that collection. However, if a 
teacher had edit access to the “Assignments” shared collection, that teacher could edit 
every document that was added to that collection. 
The advantage of a shared collection with Groups is that you do not need to send an 
email notifications or post a document URLs on a site – especially useful if you are not 
using Apps mail for your school domain. Because the shared collection will always 
appear in a user‟s doclist, every time a new document is added they will have access to 
it - regardless of whether they have opened the document yet or not. 
Shared collections can then act as a common place to collect files for groups or with a 
teammate. You can include any kind of file that exists in Google Docs. 
Create a shared collection 
Any collection can be a shared collection. To share a collection with an individual or 
group, follow these steps: 

 
1. To create a collection, first select Collection from the Create new drop-down 

menu. 
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2. Enter a name for your collection and click OK. 

 
3. To share the collection, click My collections in the navigation pane on the left of 

your docs, select the collection you'd like to share, and then select the drop down 
menu by hovering your cursor to the right of the folder. You will now click 
theShare link to access the Sharing settings and invite people to view your 
collection or even contribute to it. 

 
4. At the bottom of the Sharing settings window, under 'Add people,' type the 

individual group email addresses of anyone you'd like to share the collection with. 
To the right of the list of names, select 'Can view' or 'Can edit' from the drop-down 
menu. 

5. Click Share to send editors and viewers an email with a link to your collection. If 
you'd rather not notify people, deselect the 'Send email notifications' checkbox. 
Contributors and viewers will still be able to access the collection from their Docs 
lists the next time they sign in. 

You can access the shared collection by looking in the "My collections" section if you 
created the folder, or the "Collections shared with me" section if it was shared with you. 
You can tell which collections are shared as they will have "shared" labelled to the right 
of the collection.  

 
You could also color code your shared collections (or any collection for that matter) by 
selecting Change color from the same drop down menu you accessed when sharing 
the collection. 



 
Please note: when you share a folder, the new permissions are pushed to all sub-
folders and docs within the folder. Normally this happens quickly, but occasionally, it 
could take a couple of minutes. 
Access shared collections 
Collections that are shared will appear in your Docs list with a "shared" label to the right 
of the collection.  
to distinguish them from folders that aren't shared with others.  

 
The collections you share appear in the 'My collections' section. Collections others share 
with you will appear in the 'Collections shared with me' section underneath 
'My collections.' 

 
Add or remove documents 
To add items to your shared collections or collections shared with you, you have a few options. 

1. You can drag each doc from your Docs list to the collection (it's listed in the 
navigation pane on the left of your docs).  

 
2. You can also use the Organize feature. To do this, highlight the document in your 

doc list by clicking on it, then select Organize. You would then mark the 
checkboxes next to each collection you would like the document in. 

  

3. This can also be accomplished by selecting the Organize link that appears in the 
summary details for the document. This view is also available when you highlight 
the document in your docs list. 
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3. You can also import files to a collection by using the Upload button, but the 
easiest method is dragging them from your desktop directly into the collection. To 
do so requires that you use a web browser that supports this feature such as 
Google Chrome, Firefox or Safari.  

 

 

Fore more information on uploading files directly to your doc list, please 
visit http://docs.google.com/support/bin/static.py?page=guide.cs&guide=1247871&answ
er=1250382. 

Advanced sharing permissions 
» See who has access 
You can check to see who has edit or view access to your document at any time, simply 
click the Share button in the top right corner of the doc. 
Here you will see a full list of all the individuals or groups who have access to the 
document as well as their access level. 

 
» Change sharing access levels 
The owner of a document, spreadsheet, presentation, or drawing can always control 
exactly who has access to their doc and how much access each person has. By default, 
those that you invite to edit the document may also add additional collaborators and set 
sharing access levels.  
If you leave the setting for editors to invite others and make changes, you may have 
more people accessing your document than you intended. If you wish to have full control 
over who can access the document and exactly how they access it (with editing or 
viewing rights), you would want to change the setting for invited editors.  
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To change the sharing access level of any individual or collaborator, follow these steps: 

1. Click on the Share button in the top right corner your document. 
2. In the window that appears you will see a list of individuals and groups who have 

sharing access. 
3. To change sharing access for an individual or group, click the drop down menu to 

the right of the individual or group name and select the new sharing access level. 
The sharing access level change is effective immediately.  
To change the setting so editors cannot invite others or change permissions, follow 
these steps: 

1. Click on the Share button in the top right corner of your document. 
2. In the window that appears, click the Change link at the bottom, adjacent to the 

sentence Editors will be allowed to add people and change permissions. 
3. Select the setting: Only the owner can change the permissions. 

Now editors will only be allowed to edit the document and will not be allowed to add new 
collaborators or change sharing access levels.  
» Remove collaborators 
The owner of a document, spreadsheet, presentation, or drawing can always control 
exactly who has access to their doc and how much access each person has. As 
reviewed previously, someone with editing rights to a doc can control who else has 
access if the owner has enabled editors to change permissions.  
When you remove a collaborator, the change is effective immediately and they will no 
longer have access to the document.  
Please note: If you remove a collaborator from edit/view access but you have shared 
the document with a group of which they are a member, they will still have access to the 
doc based on the group access level. Alternatively, if you have removed a collaborator 
and have set the document visibility to be accessible to the entire domain, the removed 
user can still view/edit your document. Finally, if you have removed a collaborator from 
the document but have published your document to the domain or to the world, the 
removed collaborator will still be able to see the document, as it behaves as a standard 
web page.  
There are three ways to remove collaborators from a shared doc:  
One at a time To remove individual editors and viewers, follow these steps: 

1. Click Share to open the Sharing settings window. 
2. Click the X next to the editors/viewers you want to remove. You can also change 

edit access to view access for individual editors by clicking the down arrow next to 
'Can edit.' 

3. Click Save changes. 
Change the visibility option of the doc You can control how many people have 
access to your doc by changing the visibility option of the doc. For example, if your doc 
is set to People at my organization with a link, you can change it to Private and no 
one without explicit edit or view access will be able to see the doc.  
Follow these steps to change your doc's visibility option: 

1. Click Share to open the Sharing settings window. 
2. Next to the current visibility option (above the list of editors and viewers), 

click Change. 
3. Select the radio button next to the visibility option you'd like to use. Review 

document visibility options » 
4. Click Save. 
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5. Click Close to close the Sharing settings window and return to your doc. Or you 
can make more changes. 

Reset the link to the doc  
If your Apps domain administrator allows you to share documents outside of your 
domain, you may of selected the option to have your doc visibility set to Anyone with a 
link. With this option, you can choose reset the URL of the doc that people use to 
access it on the web. Anyone using the old link will no longer be able to access the doc, 
unless they have been explicitly added as a viewer or editor.  
Here's how to reset the link. 

1. Click Share in the top-right corner of the doc. 
2. Just below the URL that appears in the Sharing settings window, click Reset link. 

 
3. Click OK to confirm. The new link will be displayed in the Sharing settings window. 

» Make a document private 
You can always keep your documents completely private, not sharing it with anyone in 
your domain and preventing users in your school domain from viewing.  
 
Ensuring your document is private can be important for sensitive documents or files for 
personal use that you do not need others to access.  
If you want to limit access to your doc to people to whom you give permission, set your 
doc to Private by following these steps: 

1. Click Share in the top-right corner of your doc. 
2. Next to the current visibility option, click Change. 
3. Select Private. 
4. Save your choice. 

Please note: If you have published your doc, you may also want to un-publish it, or else 
people may still be able to view the published version of the doc.  
Follow these steps to un-publish a doc: 

1. In the top-right corner of your doc, click the down arrow next to Share. 
2. Click Publish as a webpage or Publish/Embed. 
3. Click Stop publishing. 
4. Close the publishing dialog. 

» Reset a document public web address 
If your Apps domain administrator allows you to share documents outside of your 
domain, you may have selected the option to have your doc visibility set to Anyone with 
a link. With this setting, documents can be viewed (or edited, depending on the owner's 
preference) by anyone who knows the unique URL of the doc.  
If the link to your doc has been distributed more widely than you'd like, or you prefer to 
limit access to only those you choose instead of the entire public web, you can reset that 
URL. Resetting the link replaces the URL of your doc with a brand new one, which 
means that existing links to your doc will no longer work. Changing the URL works the 
same as if you deleted a webpage in a site, it no longer exists and cannot be seen.  
Here's how to reset the link to your doc. (Please note: resetting the link is only available 
to docs set to Anyone with the link. If your Apps domain administrator does not allow 
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you to share documents outside of your domain, you do not have this document visibility 
setting and thus do not have the option to reset the link.) 

1. Click Share in the top-right corner of the doc. 
2. Just below the URL that appears in the Sharing settings window, click Reset link. 

 
3. Click OK to confirm. The new link will be displayed in the Sharing settings window. 

Resetting the link to your doc won't affect users with whom you've specifically shared 
yorr doc (these users are listed in the Sharing settings, below the visibility option). Users 
who had the old link to the doc but were not manually added as editors or viewers will no 
longer have access.  
» Transfer document ownership 
By default, you are the owner of every doc you create. However, you can transfer 
ownership to anyone you'd like, as long as that person has an Apps mail address. If your 
domain administrator allows sharing outside the domain, you can let anyone with an 
email address become owner of your documents.  
 
Being the owner of a doc gives you a lot of control over the doc, and once you change 
owners, you give up those controls -- so make the decision to change owners carefully. 
Consider the following:  

 The owner is the only person who can delete a doc. Once a doc is deleted, no one 
can access it, including those it was shared with.  

 When a user's account is deleted, all of that person's docs are deleted. Once docs 
are deleted, no one can access them, including those they were shared with.  

 The owner is the only person who can always control how much access other 
users have to the doc. They can remove editors and viewers, they can share with 
as many people as they like, they can change the visibility option, and they can 
limit or activate the ability for editors to share the doc with other users.  

If your account, or an account in your organization, is being deleted, it's often a good 
idea to transfer ownership of that user's docs to an account that will remain active. For 
example, if a departing instructor has a wealth of lesson plans and assignments created 
and saved in Google Docs, s/he could transfer ownership to a new teacher so the 
documents. Or a graduating student leader of a club might want to transfer ownership of 
essential documents to others so that others can continue to control and share the 
documents.  
To change ownership of a document, follow these steps: 

1. Open the doc that you don't want to own anymore. 
2. Click Share in the top-right corner. 

o If the new owner already has access to the doc, skip to Step 3.  
o If the new owner does not already have access to the doc, follow these 

steps before moving on to step 3:  
 Click the white space below 'Add people.'  
 Type the email address of the new owner.  
 Click Share.  

3. Click the drop-down to the right of the new owner's name; choose 'Is owner.'  
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4. Click Save changes.  

 After you switch owners, you'll have access to the doc as an editor (but the new owner 
can take it away!).   
It should be noted that you cannot transfer ownership to another person who is not a 
member of your Google Apps domain. Doing so will produce this error: 

 
Email docs as attachments 
In addition to sharing an online, live version of a document, spreadsheet, presentation, 
or drawing with other Apps users, you can also send an email attachment to anyone in 
the world directly from Google Docs with a formatted attachment of your document.  
This can be handy for those that may not have access to a reliable internet connection 
or those that do not have school Apps accounts.  
To send your document as an attachment, follow these steps:  
Click the Share drop-down menu, and select Email as attachment... 

 
1. Select a file type from the drop-down menu:  

o Documents: Microsoft Word, Open Office, PDF, HTML, Rich Text, or Plain 
Text.  

o Spreadsheets: Microsoft Excel, Open Office, or PDF (Please note: 
embedded objects such as charts, gadgets, and images may be lost when 
sending spreadsheets as attachments)  

o Presentations: PDF, Power Point, or Plain Text Enter an email address.  
2. If you'd like, you can also add a subject and a message. You can even send a 

copy to yourself by checking the box. 
3. Click Send.  
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 People to whom you're emailing this doc will receive it as a downloadable attachment in 
the file format you selected.  
 
Although the file sent as an email attachment is editable offline by each recipient, these 
edits won't be reflected in the original Google document or spreadsheet. 
Email contents of document 
The word processing document type in Google Docs also allows an additional option to 
paste a document directly into an email instead of sending an attachment.  
This can be useful to compose newsletters or other updates that you prefer to send in an 
email format rather than sharing or publishing a document.  
To send an email with the contents of the document, follow these steps: 

1. Click the Share drop-down menu, and select Email as attachment... 
2. Select the “Paste the item itself into the email” option 
3. Enter an email address, or multiple addresses. If you'd like, you can also add a 

subject and a message. 
4. Click Send.  

 
People to whom you're emailing will receive the document contents in the email 

Publish docs to the web 
» About publishing 
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Publishing allows you to make your Google Docs available as a webpage that anyone in 
your domain or the world can view (depending on your domain settings) without 
specifically inviting them to collaborate. Once you publish your document, spreadsheet, 
presentation, or drawing to a webpage, you get a URL that can then be shared, 
bookmarked, and sent as you would any other webpage address. It‟s also necessary to 
publish documents if you wish to embed them on blogs or other websites.  
Please note: Your Apps domain administrator controls whether you can publish your 
Google Docs to the public web or only to your domain. If someone who does not have 
an Apps account is unable to view your published document, you will need to contact 
your domain administrator directly to modify the Google Docs publishing settings.  
Even after you publish your documents, spreadsheets, presentations, or drawings, they 
won't appear in the Google search index; however, other search engines may potentially 
index published docs.  
If you send the URL of the published version of your document, spreadsheet, 
presentation, or drawing to others, they won't be able to make any edits.  
This is what they'll see: 

 Documents: a version with no toolbar available 
 Spreadsheets: no toolbar available. Viewers will be able to see charts, cell 

formatting, and the values of cells; they won't be able to view or edit formulas. 
 Presentations: view-only version or in presentation mode (full-screen slides) 
 Drawings: a PNG image version of the drawing 

 Please note: 
 It's not possible to publish PDFs. 
 After you publish a drawing, any changes you make will be updated automatically. 

However, this won't happen instantaneously. Allow a few minutes for changes to 
be reflected at the published URL. 

» Publish a doc 
If you're the owner of a spreadsheet, document, presentation, or drawing, you can 
publish it to the Web at any time. If you selected the 'Editors will be allowed to add 
people and change the permissions' option, those who have edit access can also 
publish the document. Review how to change these sharing settings » 
To publish any of your docs, just follow these steps: 

1. Open the doc you'd like to publish. 
2. Click the Share drop-down menu on the top right of the page and select Publish 

to the Web.... 

 
3. You can choose whether you would like the published doc to be automatically 

updated if you make any changes. This can help keep your published, webpage 
documents as up to date as possible. However, if you wish to control when a new 
version of a document becomes this published webpage, you may want to 
deselect the option: Automatically republish when changes are made. 

4. You can also ensure secure access to your document by requiring those at your 
school Apps domain to sign in before viewing the document. 
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5. Click the Start publishing button. A link to the published doc appears in the 

publishing dialog. 
6. Send this link to anyone you'd like to access your doc. 

Your doc will be accessible from this URL until you either delete your doc or choose to 
stop publishing. 
Types of publishing 
Documents, presentations, and drawings are all published as an HTML file, just like a 
webpage.  
Spreadsheets, however, can be published as multiple types including: 

 HTML 
 CSV (comma separated values) 
 TXT (Plain text) 
 PDF 
 XLS (Microsoft Excel) 
 ODS (Open Document Spreadsheet 

When publishing a spreadsheet, Under 'Get a link to the published data, ' you can select 
a format from the drop-down menu to get a unique public URL for the sheets or range of 
data you've selected to publish. 
Stop publishing 
You can stop publishing documents at any time, just follow these steps: 

1. Open the doc you'd like to publish. 
2. Click the Share drop-down menu on the top right of the page and select Publish 

to the Web.... 

 
 

3. Click the Stop publishing button. 

 
Now anyone clicking the link to the published doc will no longer be able to access it. 
» Tracking visits to published documents 
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You now have the ability to track how much traffic a particular published word 
processing document is getting through Google Analytics, just as you might on a 
traditional webpage.  
 
To start tracking traffic to your docs: 

1. Go to your Docs list and click Settings. 

 
 

2. In the Track published documents section, do the following three things: 
o Check the box that says 'Track visits to my Google Documents using 

Google Analytics.' 
o Enter your Google Analytics tracking code. This help article will assist you in 

finding this information. 
o Finally, to find this tracking information, sign in to your Google 

Analytics account. Click View reports to see visitor stats for your published 
docs. 

3. Once you've filled in this information on the settings page, click Save. 

 
Please note: This feature isn't currently available for spreadsheets and presentations. 

Embed docs into a blog or website 
In addition to publishing Google Docs as a webpage, you can also access a snippet of 
code to embed a published doc onto your blog or website.  
 
If you are using Google Sites, you can always insert documents, spreadsheets, 
presentations, and forms directly from the insert menu.  
 
If you are using another website software or blog, you can find the embed code for a doc 
by following these steps: 

1. Open the doc you'd like to publish. 
2. Click the Share drop-down menu on the top right of the page and select Publish 

to the Web.... 
3. If you have not already published your document, click the Start 

publishing button. 
4. Beneath the “Document link” box is the embed code. Copy and paste this code 

onto the appropriate part of your blog or site. 
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Print options 
» Word processing documents 
Printing documents in Google Docs generates a PDF file that you can then open and 
select to print.  
 
If you want to print directly to a PDF without choosing Print settings: 

1. From within the document you'd like to print, select Print from the File menu. 

 
2. A PDF is downloaded in your browser. 

If you'd like to change your print settings before printing, follow these steps: 
1. Choose Print settings or Page setup from the File menu. 
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2. In the Print settings menu you can select if and where you want to print your 

page annotations (like page numbers) 
3. In the Page setup you can choose how your document will appear with the 

following specifications:  

 
o Page orientation: landscape or portrait 
o Paper size: Letter (8.5" x 11"), Legal (8.5" x 14"), or A4 (210mm x 297mm) 
o Margins: top, bottom, left, and right 
o Page color 

4. Once you've selected your specifications, click Print at the bottom of the settings 
window. A PDF will be downloaded in your browser. 

» Spreadsheets 
Printing spreadsheets in Google Docs generates a PDF file that you can then open and 
select to print.  
 
If you want to print directly to a PDF without choosing Print settings: 

1. From within the document you'd like to print, select Print from the File menu. 
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2. Click the Print button. 
3. A PDF is downloaded from your browser and you can open and print. 

If you'd like to change your print settings before printing, follow these steps: 
1. Choose Print from the File menu. 

 
2. Select the following options  

 
 



o Print one sheet or all sheets in a single spreadsheet. 
o Adjust the size to 'fit to width' or 'actual size.' 
o Choose either a landscape or portrait layout. 
o Select your paper size - Letter, Legal, or A4 (standard for most European 

printers). 
o Options such as excluding gridlines when printing, repeat row headers, etc. 

3. Click Print at the bottom of the settings window. A PDF will be downloaded in your 
browser. 

Please note: If your spreadsheet has sheets with full-page charts and gadgets, those 
sheets won't be printed. All other sheets in your spreadsheet, however, can be printed.  
Printing documents in Google Docs generates a PDF file that you can then open and 
select to print. 
Presentations 
To print a presentation, follow these steps: 

1. Click Print... from the File menu of the presentation you'd like to print. 

 
2. A new window opens, displaying your presentation as it will appear when printed. 

From the Layout menu, select the number of slides you'd like to appear on each 
page. 

 
3. Click Print. 
4. Open and print this PDF with Adobe Acrobat. 

Drawings 
At this time it is not possible to specify print settings for drawings.  
To download a PDF file you can print, follow these steps: 

1. From within the drawing you'd like to print, select Print from the File menu. 
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2. A PDF is downloaded in your browser which you can open and print. 

Print preview 
You can preview a word processing document before printing it by selecting Print 

preview from the File menu.   
You will then be directed to a page that shows you how your document will look when it‟s 
downloaded as a PDF and ready to print.  

 

 
On the right margin, you'll see smaller images of the document pages. You can navigate 
through the pages by clicking them or by using the arrows at the top right of the 
document.  
 
If you want to zoom in or out on a document, click the + or - buttons underneath the 
navigation arrows. If you have four pages and would like to see all pages on one screen, 
keep zooming out until you can see them all. You can also click the buttons in between 
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the zoom in/out keys to see either one or two pages per screen view.  

 

 
From the print preview page, you can go back to editing your document, access your 
print settings, or print the document. 

 Chapter 3: Documents 

Docs in the classroom 
The real-time collaboration of documents in Google Docs makes it ideal for group 
assignments, revision cycles, and shared notes. Built-in tools like autosave and revision 
history, comments, and an equation editor are useful for students and teachers alike.  
Some examples of how teachers can use online documents: 

 Collaborate and share curriculum plans 
 Consolidate notes for department or faculty meetings 
 Create a simple webpage with docs publishing 
 Share and collect assignments without printing 
 Provide instant feedback to students 

Some examples of how students can use online documents: 
 Improve writing skills through peer editing and feedback 
 Access documents in class or at home 
 Work on reports, research, or papers together with peers in different classes, 

schools, countries 
 Keep a continuous, running log for assignments such as journal entries, writing 

samples, etc. 

Work with documents 
» Start a new document 
There are different ways of getting started using Google documents: you can create a 
new online document, you can upload an existing one, or you can use a template from 
our templates gallery.  
From your Docs list 
To create a new document, go to your Docs list, click the Create new drop-down menu, 
and select Document.  
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From an existing Doc 
You can also create a new document while in an existing document, spreadsheet, 
presentation, or drawing. Simply click the Filemenu, select New and choose Document. 

 
Upload and convert 
You can also upload a variety of file types into Google Docs and have it automatically 
convert into a document. Review accepted imported data types »  
When you upload a file, a box that indicates the progress of the upload appears in the 
bottom right of your screen. You can minimize the box or move it to the left or right of the 
screen. When you‟re done, you can click the document title to open the uploaded file or 
close the box by clicking the x in the upper right of the box. 

 
To add items to your docs list, you have a few options. 
Drag and Drop 
You can drag-and-drop your files directly from your computer into your Documents List, 
and even straight into a collection. This feature is available only in the latest versions of 
Chrome, Safari, and Firefox. If you aren‟t working in the latest version of one of those 
browsers, you can click the Upload button and select either Files... or Basic... from the 
drop-down menu. 
File upload 
To manually select files from your computer to upload to Google Docs, follow these steps: 

1. In your Documents List, click the Upload button and select Files from the drop-
down menu. 

2. Select the file you‟d like to upload to Google Docs. To select multiple files, press 
Shift or Ctrl and click all the files to upload. 

3. Your file will appear in your Documents List. 

Basic upload 
Click the Upload button on the Documents List and select Basic... from the 
drop-down menu. Here, you‟ll have two options for uploading your files: 
Dragging files directly from your desktop 
Select one or more files from your computer and drag them to the dotted-line 
box. This option is available in recent versions of Chrome, Firefox, and 
Safari only. 
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When you're finished dragging all of your files into the dotted-line box, click the Start 
upload button. 

Clicking "Select files to upload" 
Simply click the Select files to upload link that appears below the dotted-
line box. 

 
When the Browse dialog is open, select the file you'd like to upload to Google Docs. To 
select multiple files, press Shift or Ctrl and click all the files to upload. If you first select 
one file and then decide to upload more, click the Select more files link that appears 
after you upload the first file. 
When you've selected all of the files you‟d like to upload, click the Start upload button. 
Your files will appear in your Documents List. 
Find and open documents 
Documents that you have created will always be saved in your Docs list.  
You can easily search for documents by starting to type a search term, Google Docs will 
start to suggest documents from your list.  

 
If you do not see the document you‟re looking for in the suggestions, click the Search 
Docs button to see a full list of results.  
There are also sections of the doc list that can help you find your documents based on 
how you view the document, such as which documents are Owned by me, Opened by 
me, and Shared with me and so forth. Some documents may exist in more than one 
section, such as a document someone shared with you that you have opened.  

 
You can also browse documents in your Docs list by file type or other saved searches. 
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Because Google Docs allows you to store any digital media, you can also browse for 
images and video in your docs list and collections. 

 
Finally, you can additional filters in your doc list to locate your documents. You can view 
your doc list in either the minimal list view or in the Details view which shows who owns 
the document and when it was last updated. 

 
Rename a document 
When you create a new document, Google Docs will start saving it as either Untitled or 
will create a title from the first few words entered in the document.  
To choose a name other than Untitled, click the File tab from your doc, and 
select Rename. From here you can choose and confirm your document's title.  

 
You can also edit the name by clicking the title displayed at the top of the page, and 
making your changes in the dialog that appears. 

 
Finally, you can access the Actions menu when your docs list is set to list view. From 
there, you can rename the document. 
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Please note: titles can be up to 255 characters long. 
Save documents 
Because Google Docs saves to a secure, online storage facility, you can create 
documents, spreadsheets and presentations without the need to save to your local hard 
drive. You can also access your documents from any computer. In the event of a local 
hard drive crash, you won't lose your saved content.  
If your browser or computer crashes, your document has been automatically saved and 
you will still be able to recover it – on any computer. Google Docs also keeps a complete 
revision history of your document, so you can revert to any version at any time.  
You‟ll see the status of your save up in the top right corner of your document, near the 
share button.  

 
 While we can't give you exact figures, please be assured that we back up data almost 
as often as you can change it. 
Copy and paste in documents 
Google Docs is designed to let you copy and paste text and images between all of your 
online documents – even if you're going from one document type to another. 
This can be useful for collecting information across a variety of media or the process of 
outlining and drafting in a document, while moving content over to a presentation. 
And since the copying and pasting takes place online, you can copy on one computer, 
then sign in and paste on another one. Here are some examples of things you can do: 

 Copy a set of cells in a spreadsheet, and paste it into a document as a properly 
formatted table. 

 Copy something in your school computer and paste it into another when you 
access your Google Account from your home computer. 

 Access items you previously copied, as long as you were signed in. 
There are two ways to copy and paste: keyboard shortcuts and the server clipboard 
menu. 
Keyboard shortcuts: Ctrl-C and Ctrl-V For most copying and pasting, you can use the 
familiar keyboard shortcuts, Ctrl-C(Copy) and Ctrl-V (Paste). This even works when 
going from one doc type to another. But there are a couple of exceptions in which 
keyboard shortcuts don't work as well (yet). In these cases, you should use the server 
clipboard menu: 

 If you're copying between presentations and another doc type 
 If you want to copy on one computer and paste on another 
 If you want to copy something you aren't going to paste right away 

The server clipboard menu 
There are a few specific cases in which the best way to copy and paste is using the 
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server clipboard menu. When you copy a selection using this menu, the content you 
copy is stored and associated with your school Apps Account. That means you can copy 
more than one selection and then choose which one to paste later; it also means you 
can copy something on one computer and then paste it on another.  
To copy a selection using the server clipboard menu, follow these steps: 

1. Select what you'd like to copy. 
2. Click the Server clipboard menu that appears in the toolbar of your doc. 

 
3. Click Copy selection to server clipboard. 
4. In the destination document, click the server clipboard menu; you'll see the 

selection that you previously copied. If you copied multiple things, you'll see a list 
of the items you've recently copied. 

5. Place the cursor where you want to paste the content. 
6. Click the Server clipboard menu. 
7. Select what you want to paste. Depending on your selection, you'll see different 

formats that you can choose from to paste what you've copied (for example, 
HTML or plain text). 

8. Select a format. 
Please note: You can't use the server clipboard to copy and paste regular text and 
images in Google Docs presentations yet. You can select entire shapes on a single 
slide, and if the shape is a text shape, then the text will be copied to the server clipboard. 
How content on the server clipboard is stored and protected 
You can access the content copied to the server clipboard only by signing in to the same 
Google Account you used to copy the content originally. 
Content you copy to the server clipboard is stored on Google's servers and remains 
there until 30 days have passed since you last took action on (for example, copied) a 
given content selection. Even if a document is deleted, anything you copied from that 
document to the server clipboard will still exist on Google's servers for that 30-day 
period. You can delete all items stored on the server clipboard by clicking the drop-down 
menu and selecting Clear all items. 

Manage documents with multiple editors 
» Benefits of collaboration 
Google Docs enables multiple people in different locations to collaborate simultaneously 
on the same doc from any computer with Internet access. 
For example, teachers can work together on a single document to develop curriculum 
plans for the year. No one has to compile all the edits together, since everyone is 
making changes to a single doc. Because the document is online, teachers can 
collaborate beyond the school and start sharing with others in the district. With everyone 
contributing ideas and comments, everyone benefits from a more collaborative 
curriculum. 
Another example is for students paired with another class for a group assignment. While 
the students may never have class together, they can start a document and edit it at any 
time. After class, they can even open the document and write together, chatting about 
the project directly in the doc. They can then share the document with a few classmates 
for peer editing. When they complete the project, they can share the final version or 
create a copy to share with the teacher, who can also provide the grade and feedback 
directly in the document. 
With everyone working on the same doc, there‟s no back and forth of versions and edits. 
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This can also accelerate the feedback and revision process, allowing teachers to provide 
quick comments and students to incorporate changes as they‟re writing. 
View and edit together 
To learn how to share documents with individuals or groups, review previous chapter on 
sharing » 
If you and another collaborator are editing the same document at the same time, a box 
with the name of the collaborator appears at the top of the screen. 

 
If other people are editing a document simultaneously with you, you'll see their edits in 
real time. You can also see the text that other editors are highlighting as they select it. If 
someone is about to delete something on your screen or drag text somewhere else, you‟ll see 
them highlight that text before anything changes.  

 
You also have the ability to see their names listed at the top of a document. Click the 
arrow to the right of the names to open a tab where you can chat with other editors 
within the document. 

 
Please note: Up to 50 people can edit a document at the same time. You can share a 
document with up to 200 people. 
View and revert to previous version 
Working in groups makes the autosave and revision history feature especially helpful. 
Since copies of your document are saved anytime a collaborator makes edits, it‟s easy 
to check and see who made what edits and when.  
To browse previous versions of a shared document, follow these steps: 

1. From your document, click File > See revision history. 
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2. Changes are color-coded based on each collaborator, making it easy to tell what has 
been added or deleted. This is perfect for evaluating group projects, participation, 
and more. 

 
3. While viewing the revision history, you can show more detailed revisions by 

selecting Show more detailed revisions. 

 
If you change your mind about the most recent edits you or your collaborators made to 
the document, simply revert to an older version by following these steps: 

1. Click down through the edits until you find the version you want. 
2. Click Restore this revision. 

 
Your document is reset to the version you selected. Now, when your collaborators view 
this document, they'll see the version you selected. 
Add and reply to comments 

Comments are a convenient way of adding notes to your regular document 
text and are visible to viewers and collaborators. These can be invaluable for 
communicating with collaborators about specific parts of the document, as 
well as making notes about changes you've made or would like to make. 
Comments are useful for the feedback and revision process, as teachers or 
peer editors can add ideas or questions without disrupting the contents of 
the document. You can highlight as many or as few words you want to begin 
a comment.  
Because a comment often leads to explanations or additional comments, 
Google Docs makes it easy to reply to a comment in the same format, 
allowing you to read a “conversation” of comments or have a discussion.  
This new type of comments and discussions will only be available on newly created 

documents, and in the new version of Google documents. Eventually, we’ll let you 

add the new type of comments to your older documents. 

Inserting Comments 

Comments are a handy way of adding notes to your regular document text and are 

visible to viewers and collaborators. These can be invaluable for communicating 

with collaborators about specific parts of the document, as well as making notes 

about changes you've made or would like to make. 
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To add a comment to your document, follow these instructions: 

1. Place your cursor or highlight the text where you'd like your comment to 

appear. 

2. From the Insert menu, select Comment. 

3. You can also use the keyboard shortcut Ctrl+Alt+ M (Cmd+Option+M for 

Mac) to insert a comment. 

4. Type your comment in the box that appears to the right of the document. 

 

  

 
 
Working with Comments 
After inserting a comment, there are two main places you can work with it inside the 
document: within the comment or in the discussions thread, accessible from 
the Discussions drop-down menu in the top right of your document. 
You can reply to a comment with a new post, edit or delete a previous comment you‟ve 
inserted, and resolve the discussion when you‟re ready to remove it from the document. 
Resolving a discussion removes the discussion from the document, but resolved threads 
will always be available under the Discussions drop-down menu. 

 
Document discussions 



From the Discussions drop-down menu in the top right of your document, you can 
review all discussions, including those discussions that have been resolved. From this 
menu, you can also change the notification settings for discussions. 

 
 
Sometimes it can be cumbersome to have to scan through your document to view all 
discussions. If you select the Show discussions menu option, you can keep track of all 
discussions throughout the document, including those that have already been resolved. 
In this view, you can also make comments about the entire document. 

 

Notifications and engaging with others 
Comments are most useful when you leave them for others to review. You can easily 
target your comments at particular students, respond to comments from within email, 
and easily keep track of the comments people leave in your document without having to 
continuously return to the document. 

Adding others to a comment 
You can easily add others to a comment by typing '@' followed by a contact‟s name or 
email address into a comment. For example, I would type @johndoe if my contact was 
johndoe@myschool.org. Your contacts will auto-populate when you start typing. 

 
Adding someone to a comment will email them a notification containing the comment 
thread. If that collaborator doesn‟t want email notifications, they can always mute or 
change their notification settings by selecting Mute updates from this comment at the 
bottom of the email or by selecting Discussion notification settings... from 
the Discussions drop-down. If you have been added to a comment and aren't receiving 
email notifications, you may want to check your email spam folder. 



 
Changing discussion notification settings 
You can control your discussion notifications. From the Discussions drop-
down menu, select Discussion notifications... A dialog will open, and you 
can select if you‟d like to receive email notifications. If you opt to receive 
email notifications, you can also select what type of notifications you‟d like to 
receive. 
Built-in chat 
Google Docs now supports chat directly in the document without interfering with the 
contents of the document itself. 
Chats are not saved with the document like comments or regular edits, but are primarily 
used for discussing a document among editors. Chats and real-time editing combined 
together can allow groups to work and communicate together without meeting face to 
face. 
To start chatting with collaborators in a document, follow these steps: 

1. Find the list of names at the top of the document – if there are no names, then no 
one else is editing the document and you cannot begin a chat. 

2. Click the arrow to the right of the names to open a tab. 

 
3. The names of those editing the document will appear in the chat window. 
4. Begin typing and chatting! 

 
Email collaborators 
Communicating with other collaborators is useful when you want to notify others of 
changes you made or send a message about the document. 
You can easily email other collaborators directly in the document, just follow these steps: 

1. Click the down arrow on the right side of the Share button in your document. 
2. Select Email editors/viewers from the drop down menu. 
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3. Choose the collaborators you wish to notify using the checkbox next to their name. 

There are also shortcuts to select or deselect all. 
4. You can modify the subject (by default it is the name of the document) and enter a 

message to the collaborators. 
5. Click the Send button. 

Basic formatting 
» Text formatting 
Editing text in Google Docs is similar to using editors of other word processing software. 
The Styles toolbar menu at the top of your document displays the style of your text 
selection in a document, and lets you change the style or clear the formatting of your 
text. 

 
To change the font or text size, simply select the text that you'd like to change and click 
either the font menu, which lists Arial as the default font, or the text-size drop-down 
menu, set to 11pt by default. Choose a new font or text size and the changes are 
applied to the selected text. 
Please note: Arial and Times New Roman only appear as options in the font menu if 
you have these fonts installed on your computer. 
To view a list of heading available, click the menu that appears right before 
the Font drop-down menu, or click Format and selectParagraph styles. Then, choose 
one of the styles, which range from 'Heading 1,' the biggest, to 'Heading 6,' the 
smallest. 

 
 The styles toolbar also lets you choose a text color or highlight color: 

1. Highlight the text. 
2. Click the 'A' drop-down menu and choose a color for text color, or click the drop-

down menu with the highlighter pen (it's next to the text color menu) and choose a 
color. 
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To see which menu option corresponds to the text you're using, simply click the text in 
your document. The color on the text color and highlighted color menus will reflect the 
color you're using. If you click the drop-down menus, the color in use will have a check 
mark next to it. 
Paragraph formatting 
Google Docs has standard selections for line spacing, paragraph alignment, and lists. 

 
If you'd like to change the spacing of the document, follow these steps: 

1. Click the line spacing button on the far right of the toolbar 

 
2. Select an option from the menu. 

 
If you‟d like to change the alignment of a paragraph, place your cursor somewhere in the 
paragraph and click one of the alignment buttons. 

 
Start a numbered or bulleted list by clicking on one of the list icons. 

 
Pagination 
Pagination adds visual page breaks while you‟re editing your documents, so you can see 
how many pages of that report you‟ve actually finished. With pagination, you‟re able to 
see headers at the top of each page in your document, manual page breaks move text 
onto a new page, and footnotes appear at the bottom of the page automatically. 
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Hide page breaks 
If you prefer editing documents with a continuous layout, you can hide page breaks by 
going to the View menu and selecting the Compact from the Document view option. 

 
Add images 
You can enhance your document by inserting images. Google Docs also lets you choose 
to display the image inline or fixed. 
To insert an image, follow these steps: 

1. Click the Insert drop-down menu from the toolbar and select Image. 

 
2. Depending on what image you'd like to add to the document, 

click Upload, URL, Google Image Search, or Picasa Web Album and follow 
these instructions: 

o Upload: Choose an image from your computer and click the Upload button. 
o URL: Type the URL of a an image from the Web and click Select. 
o Google Image Search: Enter a search term to find an image using Google 

Image Search, and click Search images. Once you've found what you were 
looking for, click the image and the Select button. 

o Picasa Web Album: Your web albums will automatically be displayed when 
you select this option. You can then scroll through an album to find the 
image you are looking for. 

 
 

Drag and Drop Images 
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Images can also be inserted into Documents directly from your desktop through drag 
and drop. This feature is a great time saver! For now, you can use image drag and drop 
with the latest versions of Google Chrome, Firefox, and Safari. 

 
Insert links 
Auto-Linking 
When you type something that documents recognizes as a link, it will become a link 
automatically. Try typing “docs.google.com”, “www.google.com,” or an email address in 
a document to try it out. 
If you don‟t want your text to be a link, you can undo the auto-linking by pressing Ctrl Z 
(Cmd Z on a Mac). And if you think you‟ll never want automatic link detection, you can 
disable it by opening the Preferences dialog from the Tools menu. 

 
 
 
 
If you want to insert a link to a website or an online document as a reference, follow 
these steps: 
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1. Click anywhere in your document where you'd like the link to appear. 
2. Click the Insert drop-down menu and select Link..., or click the link icon in the 

toolbar. The 'Edit Link' window appears. 

 
3. Type the text you'd like to be displayed as the link (if you selected specific text, it 

will already appear in the 'Text to display' field). Leave this field blank if you want 
the full link to be displayed in your document. 

4. Select either 'Web address' or 'Email address.' 
5. Enter a URL (or an email address if you selected 'Email address') in the second 

text box. 
6. Click OK. 

Add drawings 

Drawings can also be added to your document to support brainstorming, 
mind maps, and more. 
To add a drawing, follow these steps: 

1. Click the Insert drop-down menu from the toolbar and select Drawing. 
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2. Create your drawing using the shapes and options in the toolbar. 

 
3. Add the image to your document, spreadsheet or presentation by 

selecting Save and Close 

 
There is also the ability to copy an existing Google drawing into a document. 
From inside drawings click on the web clipboard icon and select Copy entire 
drawing to web clipboard. 

 
 
Insert equations 
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You can easily insert mathematical equations into your documents, and collaborate on a 
single equation at once with multiple people. Follow these steps to add an equation to 
your doc: 

1. Click the Insert drop-down menu and select Equation. 

 
2. Select the mathematical symbol you want to add from one of these menus:  

o Greek letters 
o General operators 
o Comparison and inclusion operators 
o Operators with variables 
o Arrows 

1. Click the symbol you'd like to include, and add numbers or substitute variables in 
the box. If you delete the box by mistake, simply click New equation, and then 
select an option from one of the menus. 

 
 
 

2. If you'd like to edit the equation afterwards, simply click the equation within the 
document and change it. If you don't see the equation toolbar, click View and 
select Show equation toolbar. 

Using automatic equation shortcuts 
LaTeX is a document markup language that‟s often used by academics to quickly type 
out complex formulas. In Google Docs, when you‟re inside an equation you can type 
'\sqrt' followed by a space or a parenthesis to automatically convert the text into a square 
root sign √. Other examples of useful shortcuts are '\frac' for a fraction and shorthands 
like '\epsilon' for Greek symbols. Full list of equation shortcuts here. 

Advanced formatting 
» Table of Contents 
The table of contents in Google Docs can be generated to help keep the information in 
your document organized and easy to navigate. The table of contents automatically links 
to different parts of your documents and also works if you have your document 
published. 
Please note: The formatting and contents of a table of contents are based on the 
headings in your document. To change the text of the table of contents, you will need to 
edit the headings. If you make changes to the formatting of your document, you may 
need to update your table of contents to reflect the latest organization. 
To create a table of contents, follow these steps: 
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1. Add headings to your document by clicking Format > Paragraph styles in the 
toolbar, and selecting a heading, or by selecting from the dropdown in 
the Styles toolbar. 

 
 

 
2. Place your cursor where you would like the Table of contents to appear. 
3. Click Table of contents from the Insert menu.  



 
If you need to move the table of contents, select it as you would select text and either 
move it with your cursor or cut it and paste it. 
 
You can continue to add headings to your document or change current headings. 
However, if you'd like a change to become part of the table of contents, you need to click 
first the table and then the Update now button.  

 

 
 
 
Each item in your table of contents links to the titled sections of your document that use 
the heading styles (that you added in step 1 above).  
Bookmarks 

Bookmarks are shortcuts to specific places within a document, acting like hyperlinks. 
They can be very useful when you need to make a table of contents that‟s not based on 
paragraph heading styles, or when you want to jump from one part of a long document 
to another without scrolling. 
For example, if you have a running document of notes, you could bookmark the date or 
agenda for each section or specific important parts and have them prominently displayed 
at the top of the document. You would not have to alter the font style as you would for a 
table of contents. 
To create a bookmark in your document, follow these steps: 

1. Click where you want to place the bookmark in your document. 
2. Click the Insert drop-down menu. 
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3. Select Bookmark. 

 
A bookmark is only useful when you can link to it, otherwise there‟s no way for anyone to 
jump to your bookmarked section. 
To create a link to a bookmark in your document, follow these steps: 

1. Highlight the text you'd like to link from. You can also just click anywhere in your 
document to create a link there. 

2. Click the Insert drop-down menu and select Link, or click the link icon in the toolbar. 

 
3. In the 'Edit Link' window, select the 'Bookmark' option to see the bookmarks 

you've created. 

 
4. Click the bookmark you'd like to link to. 
5. Click OK. 

If you need to edit or remove the link, click on the bookmark link and the 'Go to link' 
window appears. In this window, you can see the bookmark you're linking to, and 
the Change and Remove links.  
Headers and footers  

To insert headers and footers in your doc, click the Insert drop-down menu and 
select Header or Footer.  
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Type the text for your header or footer in the area with dotted lines. 
To exit the header or footer, click anywhere else in your document. 
To remove your header or footer, simply delete the text within the header or footer and 
then click anywhere in the main document editing space.  
Citations with footnotes 

Citations are commonplace in the classroom – in Google Docs, you can use footnotes to 
capture references. 
Footnotes are a little like comments in that while you‟re in the browser, they appear on 
the side of the document. Comments appear in yellow on the right, while footnotes show 
up in grey on the left.  
 
When printed, footnotes will appear at the bottom of the page. You can use the print 
preview function to see how they look. 
There will also be a footnote marker within the actual document designated by a pound 
sign (#).  
To insert footnotes in your document, follow these steps: 

1. In the place you want to insert a footnote, click the Insert menu and 
select Footnote. 

 
2. Type your footnote in the text box that appears in the document margin. When 

you're finished, click inside the main document. 

http://edutraining.googleapps.com/Training-Home/module-4-docs/chapter-3/5-4
http://edutraining.googleapps.com/Training-Home/module-4-docs/chapter-2/10-5
http://edutraining.googleapps.com/Training-Home/module-4-docs/chapter-2/10-5
http://edutraining.googleapps.com/Training-Home/module-4-docs/chapter-2/10-5


 
 
To edit the footnote, you can either click on the grey text box on the left margin of your 
document, or you can place your cursor in front of the small pound sign and continue 
typing in the highlighted grey box. 
 
To move a footnote, simply select, drag, and drop the pound sign (#) anywhere you'd 
like in the document. 
 
To delete a footnote, click the trash can icon in the top right corner of the footnote or 
delete the pound sign (#) in the document. 
 
Footnotes in downloaded or exported docs: 

 When you download a document as a PDF, footnotes appear at the bottom of the 
page (as when printed from Google Docs). 

 When you download a document as a Microsoft Word, OpenOffice, RTF or HTML 
file, footnotes are displayed as endnotes; this means that they appear at the end 
of your document, rather than at the bottom of the page. 

Rulers and margins 

With Google documents, you can have full control of the location of your text. The ruler 
at the top of the document editing space is the starting point to control where your text 
appears. From the ruler you can adjust margins, indents, and tabs. 
 
Margins 
Margins affect the formatting of an entire document. You can adjust them by dragging 
the gray area on either side of the ruler, or by adjusting the margins by 
selecting File > Page setup from the toolbar. 
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Indents 
You can change indentations at the paragraph level. To adjust indentations across 
several paragraphs, select the relevant text and adjust the specific indent. 
First line indent: This small rectangle on the ruler adjusts the beginning position of a 
paragraph and can be changed for each paragraph. 

 Left indent: The leftmost indent adjusts the second and subsequent lines of a 
paragraph; this indent is controlled by dragging the downward facing triangle 
along the ruler. 

 Right indent: This indent, the rightmost downward facing triangle, adjusts how far 
toward the right side of a page a particular paragraph extends. 

Tab stops 
Like indents, tab stops affect documents at the specific paragraph level. Each tab stop 
determines how text is aligned relative to it: a left tab stop left aligns particular text to 
the tab stop, a center tab stop center-aligns it, and a right tab stop right aligns that 
text.  
To add a tab stop, just click anywhere in the ruler and select a tab stop. You can move 
text between tab stops affecting the same line by pressing the Tab key on your 
keyboard. 

 
Create and share document templates 
» About document templates 
Google Docs allows you to save any document, spreadsheet, presentation, drawing, or 
form as a template for others to use. Templates are available in the template gallery, 
linked in Google Docs, and can be found by searching, browsing categories or clicking 
directly to the template preview. 
With Google Apps Education Edition, you can create templates specifically for use at 
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your school Apps domain. Your school Apps domain has its own template gallery that is 
separate from the general public gallery. You cannot submit a template to the public 
gallery with your school Apps account, just the gallery for your school. If you'd like to 
submit a template to the public gallery, first sign in to your personal Google Account. 
When you use a template, you create your own copy, so it doesn't matter if the template 
owner changes or deletes the original template; your copy remains unchanged. 
Classes often have several common formats that can take advantage of shared 
templates for any student or teacher to use. For example, a teacher could allow students 
to easily create a predetermined format for bibliographies, book reports, research 
papers, presentations, or any other type of assignment. Student government could 
create common documents for club budgets or newsletters. Administrators could create 
a standard format for reporting absences, grades, or behavior logs. If there‟s a document 
format that can be used by multiple people, it may be helpful to save it as a template.  
Create a template  

Creating a template is no different from creating a regular document. You may want to 
keep the information anonymous or unidentifiable, since it will be available to your 
domain (or the world, depending on how you choose to submit the template). Including 
instructions can be helpful for those who use the template, to provide cues for how the 
document flows or is formatted.  
Please note: When someone uses your template, they are creating a copy of the 
document into their own Docs account. If you make changes later, they will not see 
those changes since they already made the copy.  
Submit a template for your school domain  

Once you have created the document you wish to use as a template, you can submit it 
to the template gallery for your school domain. 
Please note: You cannot submit a template for public use with your school Apps 
account. If you'd like to submit a template to the public gallery, first sign in to your 
personal Google Account. 
You can submit your template either from the main template gallery page or from your 
Docs list. 
To submit a template from the template gallery page, follow these steps: 

1. Go to your Docs list home 
(http://docs.google.com/a/myschool.org where myschool.org is your school 
Apps domain) 

2. Click the Browse template gallery link to access your school Apps domain 
template gallery. You should be in the tab labeled “My School Templates” - where 
My School is the name of your Apps domain. 
 

 
 

3. Click Submit a template on the top right of the templates main page. 

 
4. Click Choose from your Google Docs and select the document from your 

Google Docs that you'd like to submit as a template. 
5. Click Select. 
6. Enter a short description, pick one or two categories for the template, and select a 

language. 
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7. Click Submit template. 
To submit a template from your Docs list, follow these steps: 

1. Go to your Docs list home (http://docs.google.com/a/myschool.org where 
myschool.org is your school Apps domain) 

2. To do this, select the document in your doc list by clicking on it, then 
select Actions then Submit to Template Gallery. 

 
3. This will take you to the submission page where you can enter a short description, 

pick one or two categories, and select a language. 
4. If you wish to change the document you are submitting, you can click the Choose 

a different item link near the top of the page. 
5. Click Submit template. 

Your submitted template will appear within your domain tab and the My Templates tab.  

 
It may take up to several minutes for the template to appear. 
Please note: When you submit a template to the gallery within your domain, the name 
on your Google Apps account should be displayed.  
Update or remove a template 

You can make changes or remove templates you have submitted to your school Docs 
template gallery at any time. 
Please note: If you make changes to your template, those that have already used your 
template will not see those changes, only those that use the template after you have 
made the modifications. 
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To delete or edit a template that you've submitted to your domain template gallery, follow 
these steps: 

1. Go to your Docs list home 
(http://docs.google.com/a/myschool.org where myschool.org is your school 
Apps domain) 

2. Click the Browse template gallery link to access your school Apps domain 
template gallery. You should be in the tab labeled “My School Templates” - where 
My School is the name of your Apps domain. 

 
 

3. Now click on the My Templates tab. 

 
4. To edit a template, click the Edit details link to the right of 'Owner options' and 

make your edits. You can also change the content of your template by 
clicking Edit this document. Once you make changes to the actual document, 
save and close it to return to the Edit menu. Your changes will appear within the 
template in the gallery. 

 



 
5. To delete a particular template, click the Remove from gallery link to the right of 

'Owner options,' and then you'll be able to remove the template from the gallery. 
After you delete a template, no user can preview or use the template. However, those 
that have already copied the template to their own Docs account will still have access to 
those documents.  
Share your template with others 

To share the template you have made with your students or others at your school, you 
can provide the direct link where a user can preview the template and select to use it. 
 
To find the link for your templates, follow these steps: 

1. Go to your Docs list home 
(http://docs.google.com/a/myschool.org where myschool.org is your school 
Apps domain) 

2. Click the Browse template gallery link to access your school Apps domain 
template gallery.  

 
 
 
You should be in the tab labeled “My School Templates” - where My School is the 
name of your Apps domain. 
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3. Click on the My Templates tab. 

 
4. In the list of templates, click on the Preview link next to the Use this template 

button. You can also click on the thumbnail of the template. 

 
5. Copy the URL of this page, it is the direct URL to the preview of your template. 

Others can also find your template by searching the template gallery or browsing the 
gallery categories. 
 
To use a template, click the Use this template button, either in the template gallery or 
on the template preview page, and a copy of the template is created and added to your 
Docs list.  
 
Users will then start editing their own copy of the document directly in Google Docs and 
can share with others just as they would any other document.  

Improve the writing process with Docs 
» Access anywhere 
With Google Docs, files are accessible from any computer connected to the internet. 
This opens up many possibilities for starting and continuing the writing process.  
Online documents take out the hassle of remembering thumb drives or having to use the 
same computer to access a file. There‟s no risk of forgetting or losing the document, 
because everything is stored online. 
With access to your files readily available wherever you are, it‟s easy to find time to 
create or revise documents and share it with others. It doesn‟t matter if your 
collaborators are in the same room or the same country, everyone can edit at his or her 
convenience.  
Feedback and revision  

The ease of sharing and ability to view comments and feedback on a single version of a 
document makes Google Docs an ideal platform for peer reviews and revision cycles. 
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Instead of arranging set days for peer reviews and edits, students can share early drafts 
with others when they‟re ready for feedback. Writers can also start making changes 
before the reviewer has finished editing – as comments and changes appear in real-
time, students can begin incorporating the feedback immediately.  
Learn how to provide comments » 
Because sharing a document means everyone views a single version, Google Docs 
makes it easy to have multiple peer reviews without having to consolidate feedback over 
different copies. With more review cycles and ongoing feedback, students can continue 
to fine-tune their drafts.  
Learn how to share documents with others » 
An advantage for teachers is to jump in the writing process earlier. When a document is 
shared, teachers can provide feedback whenever it's important in the revision cycle – 
not just at designated due dates.  
Track progress  

Comprehensive document revision history – made possible by nearly continuous 
autosave – is helpful for both teachers and students.  
When a student shares a document with a teacher, the teacher can look at a document 
and understand how the document has evolved from early drafts or how peer reviews 
and comments were incorporated into the final product.  
Learn how to view a document‟s revision history » 
Students themselves can compare different versions to reflect on the changes and 
lessons learned throughout the process that they can apply to future assignments.  
Publish work 

Sharing your final written work with the school has much more weight than simply 
printing out a paper that is submitted in class.  
Teachers might encourage students to publish their work, so that anyone in the school 
can find and read it, to provide external motivation beyond an assignment grade. 

 
Learn how to publish a document »  

Create a central archive with Docs 
» Types of document archives 
Documents that repeat the same format and are used on a regular basis can benefit 
from a central document archive created in Google Docs. 
Learn how to create a new document in Google Docs » 
For example, meeting notes taken weekly or monthly can all exist in a single document, 
making it easy to review past notes and top issues. It‟s much easier to keep track of a 
single document then to hunt for emails or search for one of many files. 
Daily or weekly journal entries can also be saved in a single document, making it easy 
for others to review the latest work but still have the option of viewing previous entries. If 
the document is being assessed on a regular basis, a single document archive simplifies 
the process. Teachers can always open the same document to go in and review the 
latest contents. 
Learn how to share documents in Google Docs » 
Other types of documents that could be kept in a single doc: 

 Progress reports 
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 Project status updates 
Organize an archive 

Google Docs has bookmarks and paragraph headings that can help keep your single 
document archive organized and easy to navigate. 
For example, if you were keeping meetings notes in a document, you could add 
bookmarks for each entry, or for specific times (the beginning of the 
month/semester/quarter). You could then add links to these bookmarks at the top of the 
document so others could jump to areas of interest. 
If you had a progress report, you could generate a table of contents based on heading 
styles for each of the different grading periods, and then segmented into the areas of 
evaluation. A parent, shared as a viewer on the document, could then easily jump to 
various parts of the report and be able to track progress over time. 
Learn how to create a table of contents » 
Learn how to add a bookmark »  

Run a paperless classroom with Docs 
You can use a fully online process to post assignments, and accept student work using 
Google Docs. 
Below is a sample workflow for a teacher using an assignment flow in Google Docs: 
Share assignment 
A teacher could create and edit the assignment in a document (or a presentation) and 
share it with the class either as a group with view access, embed it into the class site, or 
publish it to the school domain and provide students a link to the assignment.  
Learn how to share and publish documents » 
Copy assignment/template 
If the document was a standard format for students to use, the teacher could publish it 
as a template and include the link to the template in the assignment document. 
Learn how to create and submit templates » 
Complete assignment 
Students would be able to read the assignment online and start their work in Google 
Docs. If the teacher provided a template, they could copy the template and begin adding 
their work in the correct format. 
Submit assignment 
When students are ready to submit the assignment, they can share the document with 
the teacher. For organization purposes, the teacher could require a standard document 
naming format (i.e. LastnameFirstnam_period_assignmentnumber). Alternatively, 
students can drag the file into a shared „Completed Assignments‟ folder with the 
teacher.  
Learn how to add documents to a shared folder » 
Grade assignment 
The teacher can then begin grading documents as they are shared by the students, 
providing comments directly into the document. The teacher knows a file is ready to be 
graded only when the document is shared with the proper name format, or when it is 
dropped into the student‟s Completed Assignments folder.  

Chapter 4: Spreadsheets 

Spreadsheets in the classroom 
Spreadsheets in Google Docs allows teachers and students to easily aggregate, 
organize, and analyze information in one place. With advanced tools for sorting, 
formatting, creating charts, visualizing information with gadgets, and entering formulas, 
shared, online spreadsheets can be used in a variety of settings. 
Some examples of how teachers can use online spreadsheets: 
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 Create a seating chart 
 Record grades with an organized gradebook 
 Track attendance, missing assignment, behavior reports 
 Store a database of contact information for students and parents 
 Use a word cloud gadget to visualize written responses 

Some examples of how students can use online spreadsheets: 
 Collect data from across the web for research 
 Create interactive flashcards with a spreadsheet gadget 
 Format a weekly class schedule 

 
Enter data into spreadsheets 
» Edit a cell 
cell and start typing.  
Please note: Each spreadsheet can be up to 256 columns, under 400,000 cells, or 100 
sheets, whichever is reached first, to be converted to Google Docs format. There's no 
limit on rows. Uploaded spreadsheet files that are converted to Google spreadsheets 
format cannot be larger than 20MB.  
To edit a cell that already has content, follow these steps: 

1. Choose one of the options below to place the cursor in the cell: 
o Double-click the cell. 
o Click the cell and press Enter. 
o Click the cell and press F2. 

2. Edit the cell's content. 
You can create lines (new lines, or line breaks) within a cell while editing; this is helpful 
when you want to improve the look of text that involves distinct lines, such as addresses. 
Here's how: 

1. Place the cursor in the appropriate cell. 
2. Use one of these browser-specific options to create lines: 

o In Internet Explorer 7, click Ctrl+Enter. 

o In other IE versions, or in Mozilla Firefox, click Alt+Enter or Ctrl+Enter.  
Change cell data type  

There are several different data types a cell can be, including various currencies, date, 
time, percentages, and rounding  
The data type of a cell applies to the whole cell. For example, you cannot have one part 
of the cell be a currency and the other a percent.  
To select a different data type for a cell, follow these steps: 

1. While editing the spreadsheet, select the cell/s you'd like to change 
2. Open the 123 drop-down menu. 
3. Select the desired data type. 
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There are shortcuts for the percent and US currency data type changes right in the Edit 
toolbar as well. 

 
Copy and paste  

Google Docs is designed to let you copy and paste text and images between all of your 
online documents – even if you're going from one document type to another. 
 
This can be useful for collecting information across a variety of media or the process of 
outlining and drafting in a document, while moving content over to a presentation. 
 
And since the copying and pasting takes place online, you can copy on one computer, 
then sign in and paste on another one. Here are some examples of things you can do: 

 Copy a set of cells in a spreadsheet, and paste it into a document as a properly 
formatted table. 

 Copy something in your school computer and paste it into another when you 
access your Google Account from your home computer. 

 Access items you previously copied, as long as you were signed in. 
There are two ways to copy and paste: keyboard shortcuts and the server clipboard 
menu. 
 
Keyboard shortcuts: Ctrl-C and Ctrl-V For most copying and pasting, you can use the 
familiar keyboard shortcuts, Ctrl-C (Copy) and Ctrl-V (Paste). This even works when 
going from one doc type to another. But there are a couple of exceptions in which 
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keyboard shortcuts don't work as well (yet). In these cases, you should use the server 
clipboard menu: 

 If you're copying between presentations and another doc type 
 If you want to copy on one computer and paste on another 
 If you want to copy something you aren't going to paste right away 

The server clipboard menu 
There are a few specific cases in which the best way to copy and paste is using the 
server clipboard menu. When you copy a selection using this menu, the content you 
copy is stored and associated with your school Apps Account. That means you can copy 
more than one selection and then choose which one to paste later; it also means you 
can copy something on one computer and then paste it on another.  
 
To copy a selection using the server clipboard menu, follow these steps: 

1. Select what you'd like to copy. 
2. Click the Server clipboard menu that appears in the toolbar of your doc. 

 
3. Click Copy selection to server clipboard. 
4. In the destination document, click the server clipboard menu; you'll see the 

selection that you previously copied. If you copied multiple things, you'll see a list 
of the items you've recently copied. 

5. Place the cursor where you want to paste the content. 
6. Click the Server clipboard menu. 
7. Select what you want to paste. Depending on your selection, you'll see different 

formats that you can choose from to paste what you've copied (for example, 
HTML or plain text). 

8. Select a format. 
Please note: You can't use the server clipboard to copy and paste regular text and 
images in Google Docs presentations yet. You can select entire shapes on a single 
slide, and if the shape is a text shape, then the text will be copied to the server clipboard. 
How content on the server clipboard is stored and protected 
You can access the content copied to the server clipboard only by signing in to the same 
Google Account you used to copy the content originally. 
Content you copy to the server clipboard is stored on Google's servers and remains 
there until 30 days have passed since you last took action on (for example, copied) a 
given content selection. Even if a document is deleted, anything you copied from that 
document to the server clipboard will still exist on Google's servers for that 30-day 
period. You can delete all items stored on the server clipboard by clicking the drop-down 
menu and selecting Clear all items. 
Add links in a spreadsheet  

Since Google Spreadsheets are created and accessed online, you can include 
hyperlinks to websites just as you might when creating a webpage.  
Links in your spreadsheet can be useful for directly referring to your data sources. By 
keeping information in a spreadsheet, you maintain the ability to sort and analyze your 
information while including easy access to your references.  
For example, if you were collecting research from all around the web in a structured 
format, a spreadsheet could store the data and you could add a links to data in a 
“reference” column. Unlike listing entries in a word processing document, with a 
spreadsheet you can sort all the entries and perform analysis (such as averages, sums, 
etc). Anyone viewing your spreadsheet can view your data sources. 
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Please note: Like the other types of data and cell formatting, links in spreadsheets must 
be assigned to an entire cell, you cannot have just part of the text inside a cell be 
hyperlinked. 
There are two ways to enter links into a spreadsheet: 

1. Enter the full URL into a desired cell, and the entire cell will become a hyperlink. 
This is the quickest way to add a URL to your spreadsheet. With this method, the 
text inside the cell is the URL. 

2. Enter the hyperlink formula, and you can specify the URL but assign separate text. 
Instead of displaying the full link URL in the cell, it can display the specific text you enter. 
In this example, the first two links are using the hyperlink formula, and the last has just a 
URL pasted in. 

 
With either method, whenever this cell is selected, a small "pop-out" icon will appear to 
the left of the cell. Click on this icon to open a new browser window linking to the 
included URL. 
To use the hyperlink formula, follow these steps: 

1. Navigate to the cell you wish to edit. 
2. Double-click the cell, click the cell and press Enter, or click the cell and press F2 

to edit. 
3. Use the hyperlink formula in this format: =hyperlink(“website URL”, “cell text”). 

o For example, 
=hyperlink(“www.google.com”, “search the web”)  

would display the text search the web as a link to www.google.com 
Add images in a spreadsheet  

Users can now upload images directly into to Google spreadsheets. With this feature, 
you can upload an image already stored on your computer, search for an image online, 
or add personal photos directly from one of your Picasa Web Albums. The possibilities 
are endless! To upload an image, go to the Insert menu, select Image. Next, choose an 
image file to upload into your spreadsheet. 
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Insert and modify an image with formulas When inserting a publicly accessible image 
inside of a cell in your spreadsheet, you have some options for changing the way the 
image appears through the use of formulas. There are four options for modifying the 
appearance of images in a spreadsheet 

 =image("URL") or =image("URL", 1): Inserting this formula into a cell will scale the 
image to fit inside of the selected cell. If the cell is bigger than image you're 
inserting, the remainder of the cell will be white.  

 =image("URL", 2): Inserting this formula will stretch the image to fit inside of the 
selected cell. The aspect ratio (height vs. width) of the image won't be preserved. 

 =image("URL", 3): This formula will insert the image into the cell at its original size. 
If the image is bigger than the cell, some of the image may be cut off. 

 =image("URL", 4, height, width): Inserting this formula allows you to customize the 
size of the image by specifying the height and width of the image in pixels. The 
height and width parameters are required for this option. 

The image in the cell can be aligned in many ways, just as text in a spreadsheet cell can 
be by using the alignment controls in the toolbar. 
 

 
 
Check it out for yourself in this template. 

Repeat or extend patterns with auto-fill 
Auto-fill in spreadsheets allows you to repeat information with the drag of a mouse. 
However, with Google Docs, it goes one step further. It is able to complete a pattern of 
content in a spreadsheet based on knowledge of commonly known series, genres, and 
data sets. 
For example, Auto-fill can be be used for entering a series of odd numbers. Start 
entering odd numbers in a few cells, then select the set and try Auto-fill. Google will then 
complete the pattern, listing odd numbers just as you did before. The same can go for 
counting with other patterns.  
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Or you can try it with words, such as entering the days of the week, you can enter the 
first 3 days and then use the Auto-fill function to extend the pattern for the next 4. If you 
go beyond the 7 days of the week, Google will simply repeat the pattern. The same 
functionality would apply to names of the month. 
Auto-fill can save time in entering these types of patterns. 
To use auto-fill in your spreadsheet, follow these steps: 

1. Enter your content. Auto-fill usually needs about 3 cells of data to learn the 
pattern. 

 
2. Highlight the cells. A small blue box appears in the lower-right corner. 

 
3. Click the blue box and drag it to select additional cells where you'd like your 

content to repeat. (When you place your cursor over the blue box, the cursor 

arrow changes to an x-y axis.)  
Please note: When dragging the blue box, you can only select those cells that are 
directly above, beneath, or beside the highlighted cells. 
If Auto-Fill recognizes a pattern in the content of the selected cells, it fills in the 
remaining items to complete the pattern. In the example shown here, it finished the 
pattern by auto-filling Thursday, Friday, Saturday, etc. If Auto-Fill doesn't recognize a 
pattern, it will just repeat the content that was highlighted. 
Share and collaborate with spreadsheet data 
» View and edit spreadsheets together 
To learn how to share spreadsheets with individuals or groups, review previous chapter 
on sharing » 
Spreadsheets and documents have the same sharing interface. 
If you and another collaborator are editing the same spreadsheet at the same time, a 
box with the name of the collaborator appears at the top of the screen. Additional 
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collaborators that join will also be listed in this box 

 
Click the arrow to the right of the names to open a tab where you can chat with other 
editors within the spreadsheet 
Please note: A total of 50 people can edit a spreadsheet simultaneously. You can share 
a spreadsheet with 200 collaborators and/or viewers. 
You can also send collaborators or those with viewing access a direct link to a sheet 
within your spreadsheet. This is useful if you have several sheets in a spreadsheet but 
want to direct viewers to a specific sheet of interest (i.e. the summary sheet instead of a 
sheet with all the data). 
You don't need to do anything special to generate a link to a sheet. Just navigate to the 
sheet you want to link to, copy the URL from your address bar, and send that link to 
someone who has access to your spreadsheet. The link should look like this, with the 
'#gid=' parameter at the end of it: 
https://spreadsheets.google.com/a/myschool.org/ccc?key=1234567890#gid=5 
Please note: Those who click a direct-sheet link need to be signed in to their school 
Apps account with access to the spreadsheet for the link to work. Review document 
visibility settings to learn how to make your spreadsheet available to anyone in your 
school. 
Even if a school has enabled the ability to share outside of the domain, users outside of 
the domain will still need to sign in with a Google Account. If they attempt to access a 
direct-sheet link without signing in, they will be asked to sign in, after which they will be 

re-directed to the first sheet in the spread sheet.  
Prevent others from editing the same cell 

If you have multiple collaborators on a spreadsheet at the same time, it‟s important to 
know where others are editing so you don‟t overwrite their data. 
With the cell-presence indicator, you and your collaborators can avoid editing a cell at 
the same time. Just look for a uniquely colored cell border: the cells that you're working 
in will continue to have a blue border, but the borders of the cells that your collaborators 
are working in will be marked by one of ten different colors. 

 
View and edit comments in cells 

Comments in spreadsheets are a helpful way to leave notes to other collaborators about 
your spreadsheet data. Comments can only be added to individual cells. 
Both collaborators and viewers can see comments that have been added to a 
spreadsheet. Collaborators can edit or delete comments as well as view them, while 
viewers can only see comments. 
Insert comments 
To add a comment to your spreadsheet, please follow these steps: 

1. From the "Edit" screen, click the cell where you'd like to insert a comment. 
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2. Choose one of the following methods to insert a comment: 

 
o Right-click and choose Insert comment.  
o Click the Insert drop-down menu and choose Comment.  

 
3. A Comment box appears with your username included. 
4. Enter the text of your comment. 
5. To save your comment and close the Comment box, click another cell in the 

spreadsheet. 
An orange mark now appears in the top-right corner of the cell where you inserted the 
comment. 

 To view a comment after it's been inserted, hover your mouse over the orange 
comment indicator. Click the Comment box to keep it visible on the screen. 

 Use the keyboard shortcut Shift-F2 to quickly insert a comment in your 
spreadsheet. 

 When you add a comment to a spreadsheet, your nickname appears in the 
Comment box to let collaborators and viewers know who added that comment. If 
you don't want collaborators and/or viewers to know that you've added a 
comment, you can manually delete your nickname from the Comment box. Just 
select the text that you want to delete and press Delete. 

Edit coments 
To edit a comment inserted in a spreadsheet, follow these steps: 

1. Hover your cursor over the orange comment indicator in the cell of the comment 
you'd like to edit. 

 



2. The Comment box appears and shows the text of your comment. 

 
3. Click the Comment box and enter your desired edits. 
4. To save and close the Comment box, click another cell in the spreadsheet. 

The edited text now appears in the Comment box. 
Delete comments 
To delete a comment, follow these steps: 

1. Hover your cursor over the orange comment indicator. 
2. Click the Comment box and choose one of the following options to delete: 

o Select all of the text in the Comment box, including your email address or 
nickname, and press Delete. 

o Right-click on the cell and select "Clear comments". 
3. Click another cell in the spreadsheet. 
4. The orange comment indicator disappears from the cell since your comment was 

deleted. 
Chat with other collaborators 

discuss changes that are being made in real-time.  
The chats are not saved and do not interrupt the content of the spreadsheet. 
When more than one person is viewing a spreadsheet, a box with the name of the 
collaborator appears at the top of the screen. Additional collaborators that join will also 
be listed in this box 

 
Click the arrow to the right of the names to open a tab where you can chat with other 
editors within the spreadsheet. 
If you do not have the chat window open and someone sends a message, the box with 
collaborators will be highlighted in orange. 

 
Prevent others from editing specific sheets 

If you want to restrict your collaborators from editing specific sheets of your spreadsheet, 
you can protect those sheets in your workbook.  
This feature is useful if you have a spreadsheet with information on sheets divided for 
different classes and you want only those in a class to edit their specific spreadsheet. 
You can then protect the sheets from the wrong people making changes. The same can 
be done for any spreadsheet in which you want to control who has access to which 
sheets. 
To protect a sheet, click the sheet's tab at the bottom of your spreadsheet (next to the 
Add sheet button) and select Protect sheet. 
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On the window that appears, select one of these options: 

 
 Any collaborator can edit the sheet 
 Only you can edit 
 You and specific collaborators can edit 

Only owners can set editing permissions for individual sheets. Your collaborators and 
viewers will still be able to view the data on the protected sheet, but depending on the 
permission you set for each sheet, they won't be able to make any changes or delete a 
protected sheet. 
If a collaborator duplicates the protected sheet, copies the workbook, or uploads a new 
version, sheet protection will be disabled. Similarly, if a viewer creates a copy of the 
spreadsheet, the data on the protected sheet can be edited in the copy. Both of these 
scenarios are creating a separate version of the spreadsheet, though, and your original, 
sheet-protected spreadsheet will remain secure. 
Stay informed when other modify a spreadsheet 

You can set notifications to find out when your collaborators have modified your 
spreadsheets, and learn what sheets or cells they've modified. 
In the notifications, collaborators will see the usernames of people who have made 
changes. Viewers can set notifications but can't see usernames. 
 
You won't be sent notifications about your own changes. You'll only receive notifications 
when your collaborators make changes. 
 
You can also choose how often you'd like to be notified.  
Here's how you can enable notifications: 

1. Click Share at the top right of the spreadsheet and select Set Notification Rules.  

 
2. In the window that appears, select when and how often you want to receive 

notifications: 
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o When changes are made to the entire spreadsheet 
o When changes are made to a specific sheet 
o When changes are made to specific cells 
o When collaborators are added or removed 
o When changes are made to forms 
o By 'daily digest' or 'right away'  

 
3. Click Save. 

Ensure entered data is the right format 

Data validation helps you control what data you and your collaborators enter in your 
spreadsheets. If you have specific requirements for how your content should appear (for 
sorting or other analysis), you can make sure other collaborators follow your format. 
This is useful to make sure everyone entering information is using the correct input. With 
data validation you can: 

 Validate numbers, dates, and text. 
 Prevent users from entering text that doesn't match your criteria, or show them a 

comment on the cell when the data doesn't match the validation rule. 
 Add text to the cells you add validation to, to help your collaborators enter the right 

type of data. 
Please note: Data validation doesn't support boolean operators. 
To set-up cells to have specific formats, follow these steps: 

1. Go to Tools and select Data validation. 
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2. Highlight cells to select a range you want to apply data validation to. A new 
window appears. 

 
3. Select your validation criteria. A help tip is generated as you type. 

Reset link 
that appears when you edit the help text to make sure the text gets automatically 
generated. 

4. Select the level of strictness: strict or lenient. If you select the first level, people 
can enter data that matches the validation criteria only. If you select the second 
level, people can enter invalid data, but they'll see a warning whenever the data 
doesn't match the criteria. 

 
5. Click Save. 

To remove data validation, simply select the range of cells and click Remove validation. 
If you'd like to remove validation from the entire worksheet, select the whole sheet by 
clicking the upper left corner of the sheet. Then, select Tools > Data validation, and 
click the Remove validation button. 
 
Please note: 

 If data validation is applied to cells containing data, rules won't be applied until the 
data is modified. 

 Collaborators can change validation rules.  
 Cells with data validation are skipped in List view and spreadsheets populated by 

a form. 
 When you import an .xls file containing data validation into Google Spreadsheets, 

validation rules will be ignored. 
Similarly, when exporting a Google Spreadsheets file into an .xls or .ods, validation rules 
won't be exported. 

Useful functions and formulas 
» About formulas 
One of the primary differences between a table you create in a word processing document 
to segment data and a spreadsheet is the ability to evaluate data that is entered into cells 
with formulas. These can include the typical mathematical formulas (add, subtract, 
multiple, divide) to comparisons (greater than, less than) to more complex statistical and 
engineering concepts. You can use formulas with text, too, for things like finding a 
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character, splitting the text in a cell, forcing the cell uppercase or lowercase, etc. 
To add formulas to your spreadsheets, follow these steps: 

1. Double-click an empty cell. 
2. Click the Formulas button on the toolbar. 
3. Select a formula from the list that appears. 

 
4. Click the More link to see additional formulas. 

 
The formula is inserted into the cell you selected in step 1 and you can begin to enter 
symbols and attributes to see the formula computation. 
 
If you're using Google Chrome, Internet Explorer or Safari, you may have noticed that 
cells referenced by formulas get highlighted when you edit the cell with the formula in  it. 
 



 

 

For a full list of available functions, browse this page ».  
 
Shortcuts for entering formulas 

Besides inserting formulas from the Insert menu, you can also add formulas by entering 
them directly in the cell, starting with the = sign. 
 
If you're tired of typing long formulas, or you don't remember the exact syntax, you can 
use the auto-complete feature. Just enter the first few characters of the formula you want 
to use, and a list of relevant formulas automatically appears below the cell you're typing 
in. To use a formula, just select it from the list and enter the desired values. 
 
The formula autocomplete also tells you the necessary values and format to complete 
the function. 

 
Additionally, for some formulas, auto-complete selects values based on the data in your 
spreadsheet. In this example, auto-complete is adding the following text from the 
spreadsheet: 'settlement,' 'maturity,' and 

'frequency.'  
Quick sum 

One of the most common functions in spreadsheets is to add up values in cells. If you 
just want to see a sum of a few cells but don‟t need to record the answer in a formula, 
you can use the Quick sum feature. 
 
Quick sum lets you see the sum of selected cells right in the spreadsheet, without 
entering any functions or formulas. 
 
To use this feature, first go to File > Spreadsheet settings and make sure that your 
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spreadsheet's Locale setting is United States. Then, highlight the cells of data that you'd 
like to total: 

 
The sum appears in the bottom-right corner of the page: 

 
 
Please Note: The quick sum feature is enabled based on your location and may not 
work in number/currency formats other than English. However, if you chose a non-
English language in the Spreadsheets language settings, you can still use the quick sum 
feature when you're working with a spreadsheet that's in English. Additionally, the quick 
sum feature can't be used for more than 1000 cells. 
Find facts fast with Google Lookup 

One of the advantages of using spreadsheets online is the ability to link and find data on 
the web. GoogleLookUp is a function that takes advantage of Google‟s search 
knowledge and can help you enter data into a spreadsheet faster. Using the Web, the 
GoogleLookup function attempts to find the values for straightforward facts about 
specific things. Keep in mind that while the GoogleLookup function knows quite a bit, it 
doesn't know everything. Although not all of the formulas you try will work, we encourage 
you to experiment. 

 
When GoogleLookup isn't sure if an answer isn't the best one for your entry, you'll see a 
dialog box with a handful of possible answers that you can choose from. Just select the 
cell and click More Options... to select a different value. 
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Below are instructions to use the GoogleLookup function and a list of common Lookup 
functions. 
 
To use the GoogleLookup function, enter the following formula in the desired 
spreadsheet cell: 
Syntax: =GoogleLookup("entity"; "attribute") where "entity" represents the 

name of the entity that you want to access, like Kuala Lumpur, Audrey Hepburn, or 
oxygen, and "attribute" is the type of information that you want to retrieve. 
 

 
Different attributes apply to different entities. For example: 

 Boston has a population. 
 Kofi Annan has a place of birth. 
 The Mississippi River has an origin. 

Here are a couple of examples: 
 To insert the number of Internet users in Paraguay: 
 =GoogleLookup("Paraguay"; "internet users") 

 To insert the Earned Run Average of Roger Clemens: 
 =GoogleLookup("Roger Clemens"; "earned run average") 

Please note: In order for the formula to compute properly, quotation marks must be 
used around both the "entity" and the "attribute." 
 
Here are some of the types of entities you can access using GoogleLookup, and a few 
popular attribute names (some entities won't have all these attributes, and some will 
have more, so feel free to experiment): 

 Countries and Territories (like "Burkina Faso"): population, capital, largest city, 
gdp 

 U.S. States (like "Tennessee"): area, governor, nickname, flower 
 Rivers (like "Amazon River"): origin, length 
 Cities and Towns (like "Chicago"): state, mayor, elevation 
 Musicians (like "John Lennon"): date of birth, place of birth, nationality 
 Actors (like "Audrey Hepburn"): date of birth, place of birth, nationality 
 Politicians (like "Anwar Al-Sadat"): date of birth, place of birth, nationality 
 U.S. Presidents (like "Zachary Taylor"): date of birth, place of birth, political party 
 Baseball Players (like "Wade Boggs"): games, at bats, earned run average, 

position 
 Chemical Elements (like "Helium"): atomic number, discovered by, atomic weight 
 Chemical Compounds (like "Isopropyl Alcohol"): chemical formula, melting point, 

boiling point, density 
 Stars (like "Betelgeuse"): constellation, distance, mass, temperature 
 Planets (like "Saturn"): number of moons, length of day, distance from sun, 

atmosphere 
 Dinosaurs (like "Velociraptor"): height, weight, when it lived 
 Ships (like "USS Chesapeake"): length, displacement, complement, 

commissioned 
 Companies (like "Hewlett-Packard"): employees, ceo, ticker 

Please note: This function is only available in English at this time. 
Import data from webpages 
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Some webpages have statistics or data that you might want to use in your spreadsheet. 
Instead of having to manually copy and paste all the information over, you can use a 
feature in spreadsheets lets you get information from filetypes such as xml, html, csv, 
tsv, as well as RSS and Atom feeds that you might read today in Google Reader. 
Please note: The functions listed here can only read publicly available files by default. 
Data in other spreadsheets can only be referenced after the relevant spreadsheet has 
been published. If a file is behind a corporate firewall, the firewall administrator will need 
to provide Google with access using Secure Data Connector. 
Additionally, the limit on functions per spreadsheet is 50. However, after you import the 
data, you can also choose to select the new information, and then Paste values only. 
Then you are no longer using a formula but still have the data imported into your 
spreadsheet. 
Functions: 
=importXML("URL";"query") 

 URL - the URL of the XML or HTML file 
 query - the XPath query to run on the data given at the URL. For example, 

"//a/@href" returns a list of the href attributes of all <a> tags in the document (i.e. 
all of the URLs the document links to). Each result from the XPath query is placed 
in its own row of the spreadsheet. For more information about XPath, please visit 
http://www.w3schools.com/xpath/ 

 Example: =importXml("www.google.com"; "//a/@href"). This returns all of the href 
attributes (the link URLs) in all the <a> tags on www.google.comhomepage 

=importData("URL") 
 URL = the URL of the CSV or TSV file. This imports a comma- or tab-separated 

file. 
=ImportHtml(URL; "list" | "table"; index). This imports the data in a particular table or 
list from an HTML page. The arguments to the function are as follows: 

 URL - the url of the HTML page 
 either "list" or "table" to indicate what type of structure to pull in from the webpage. 

If it's "list," the function looks for the contents of <UL>, <OL>, or <DL> tags; if it's 
"table," it just looks for <TABLE> tags. 

 index - the 1-based index of the table or the list on the source web page. The 
indices are maintained separately so there might be both a list #1 and a table #1. 

 Example: =ImportHtml("http://en.wikipedia.org/wiki/Demographics_of_India"; 
"table";4). This function returns demographic information for the population of 
India. 

=ImportFeed(URL; [feedQuery | itemQuery]; [headers]; [numItems]). This function 
imports an RSS or ATOM feed, just as you can in Google Reader. The arguments to the 
function are as follows: 

 URL - the url of the RSS or ATOM feed 
 feedQuery/itemQuery - one of the following query strings: "feed", "feed title", "feed 

author", "feed description", "feed url", "items", "items author", "items title", "items 
summary", "items url", or "items created". The feed queries return properties of the 
feed as a whole: the feed's title, the feed's author, etc. Note: To get the data 
included in the feed, you need to do an "items" request. 

 the "feed" query returns a single row with all of the feed information. 
 the "feed <type>" query returns a single cell with the requested feed information. 
 the "items" query returns a full table, with all of the item information about each 

item in the feed. 
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 the "items <type>" query returns a single column with the requested information 
about each item. 

 if a query is given that begins with "feed", the numItems parameter isn't necessary 
and is replaced by the option headers param. 

 if a query is given that begins with "items", the numItems parameter is expected 
as the 3rd param, and headers as the 4th. 

 headers - "true" if column headers is desired. This will add an extra row to the top 
of the output labeling each column of the output. 

 Example: =ImportFeed("http://news.google.com/?output=atom") 
Translate text and detect language in cells 

You can use functions in your Google spreadsheet to translate text and detect the 
language in any of the cells.  
The translation appears as a comment for the cell. One way you might use this is to 
study a selection of foreign language phrases 
GoogleTranslate function 
Use this function to translate text from and into one of over 40 languages using Google 
Translate: 
=GoogleTranslate("text", "source language","target language") 
For example: 
=GoogleTranslate("Hola, ¿cómo estás?","es","en") translates into 

"Hi, how are you?" 

 
Please note: You can leave out the target language (in this case, "en") and the function 
automatically selects the default language of your spreadsheet. 
DetectLanguage function 
In addition to translating, you can also use a function to find out what languages is being 
used in a cell: 
=DetectLanguage("text") 
For example: 
=DetectLanguage("Hola, ¿cómo estás?") would give "es" as a 

result. 

 
Split cell text into multiple cells 

The SPLIT function is useful for modifying both text and number entries. It takes two 
arguments (the first is a string, and the second is a delimiter) and breaks up the string 
using the delimiter. If you have ever used a spreadsheet to open a comma-separated 
value document, it works much in the same way; separating text based on a given 
delimiter.  
The delimiter for this function does have some restrictions: it can't be a number or date, 
but can be anything that would be parsed as a string in your system. For example, things 
like "," or ";" or even characters like "a" will work. 
Using the Split function can be useful to parse out information that may exist in a single 
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cell into multiple for sorting or other purposes. For example, you could split a “Name” cell 
into first and last names using a space as a delimiter. Or you could separate an area 
code from a phone number using a parenthesis delimiter.  
Some things to note about the Split function: 

 The delimiter and string can't be null or empty strings (invalid arg is returned). 
 If the delimiter doesn't appear in the string, the whole string is returned. 
 The function takes two args, if one or both are missing or too many args are 

entered in, you'll get a 'incorrect number of args' error. 
Here are some examples: 

 
The formula is in A1. Notice in this example, the function split the string based on the 
placement of the “!” and entered the 2 parts in 2 cells, A1 and B1. 

 
The formula is still in A1. There is nothing in B1 because the delimiter (a comma) doesn't 
appear in the string "hello". 

 
The formula is in A1. Here the string is split based on the placement of the semicolon, 
returning 5 cells of data instead of the original 1. 

 
Here A1 is text. The formula is B1, with a function to split the phrase in A1 by spaces. B1 
and C1 are the split product. 
This type of format can be useful for other types of strings such as names, addresses, 
phone numbers, etc. 
Combine text into a single cell 

If instead of splitting cell data you want to combine them, you can use the concatenate 
function or the & operator. 
Using these will bring values together into a single cell. This can be useful if you want to 
take information that is separate, like an address, and build it into a single cell with a 
mailing address label. 
If you have a spreadsheet with many email addresses that you will be sending a 
message, you could concatenate the email address with a comma so you can easily 
copy and paste the list into your email message window. 
To use the concatenate function, enter =CONCATENATE(value_1, value_2) into a cell, 
where value_1 and value_2 are text or numbers you wish to combine.  
Please note: If you want to have spaces between your values, you will need to add that 
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in as well.  
For example: =CONCATENATE(firstname, “ “, lastname) would take the first value, add 
a space, then insert a second value. The final text would appear in the cell with the 
formula. 
To insert a line break with the CONCATENATE function, you can use CHAR(10). 
For example, to assemble a mailing address based on individual cells. 
The formula in A1 is =CONCATENATE(B1, " ", C1, CHAR(10), D1, CHAR(10), E1, ", ", 
F1, " ", G1). 

 
This puts B1 and C1 on the same line, then a line break, then D1 on its own line, then 
finally E1, F1, and G1 separated either by spaces or commas. 
You can also use the & operator to the same effect, i.e. =value_1&value_2 
To have multiple values, you can continue to use multiple & operators, 
=value_1&value_2&value_3 etc. 
Manage your spreadsheet 
» About sheets 
Sheets in a spreadsheet can help you organize and manage different sets of data in a 
single spreadsheet. 
 
By default, a new spreadsheet has only one sheet. You can easily add additional sheets 
by clicking the plus button on the bottom right of your spreadsheet. 

 
To rename a sheet, click on the button at the bottom-left of your screen for the particular 
sheet and select Rename, then enter the new name for the sheet. 

 
To delete a sheet, click on the button of that sheet in the bottom-left of your screen and 
select the Delete option. Click on this option and a window asking you to confirm your 
intention to delete will be opened. In this window, click "OK" to confirm, and the selected 
sheet will be deleted. 
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You can also quickly jump to one sheet in your spreadsheet by clicking the menu button 
in the bottom right of your spreadsheet. This will display a menu with the list of all the 
sheet names. Click on the desired sheet name. 

 
Move or copy sheets 

If you're working on a spreadsheet that contains more than one sheet, you can change 
the order of these sheets. The placement of each individual sheet, represented by a 
button along the bottom of the page, can be adjusted by clicking on this button. Select 
"Move right" or "Move left" after you've clicked on the button corresponding to the 
appropriate sheet. The order of your multiple sheets will be changed accordingly. 
Alternately, you can simply drag and drop the sheet into the order you prefer.  
 
Clicking on these sheet buttons will also allow you to delete or rename the selected 
sheet. 

1. On the bottom-left side of your spreadsheet, click the tab of the sheet you'd like to 
copy (i.e. "Sheet1"). 

2. Select Duplicate from the pop-up menu. 

 
 
A duplicate sheet (which contains the exact formatting) now appears in a tab beside the 
original sheet; it's labeled Copy of Sheet. 
 
Sometimes you want to have a copy of a sheet in a different spreadsheet. Creating a 
copy of the sheet means that the data won‟t be updated, but it‟s an easy way to copy 
data from one spreadsheet to another.  
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To copy a sheet to another spreadsheet in your Docs list, follow these steps: 

1. Click the down arrow next to the sheet name. 
2. From the menu, click Copy to... 

 
3. Choose the destination spreadsheet from the list. 
4. Click Select. 

The sheet you copy will be duplicated into the destination spreadsheet and positioned as 
its first sheet. If there's already an existing sheet with the same name, the copied sheet 
will be named "Copy of sheetname," using the same logic as the current Duplicate 
option. 
Hide sheets 

Sometimes you want to hide sheets from view in a workbook. Fortunately, this is easily 
accomplished. You can click on a sheet tab and select “hide sheet” to remove a sheet 
from view. 

 
 
The sheet can still be seen in the list of sheets and any editor can click on this sheet to 
bring this back to view. Sheets can also be accessed from the Hidden sheets option in 
the View menu. Learn more about sheet hiding here. 
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Adjust rows and columns 

Drag and Drop allows you to move selected cells, rows, or columns without having to 
copy and paste. 
To move rows or columns: 

1. Select the row or column you would like to move by clicking on its number/letter. 
2. Grab the row by pressing on the left mouse button and drag it to its new location. 

To move selection of cells: 
1. Select the cell(s) you'd like to copy and move. 
2. Point your cursor to the top of the selected cell(s). The pointer turns into a 

hand.  
3. Drag the data to its new location, and release the mouse to drop it there. 

To change row height or column width in one click, follow these instructions: 
1. Place your cursor at the outlying border, next to either the number or label, of the 

row or column you'd like to re-size. 
2. Adjust your cursor so that it rests on the dividing line between the row or column 

you'd like to change, and the next row or column. When this is done, your cursor 
will turn into a double-sided arrow. 

3. Click your mouse and drag the arrow in the direction you'd like your row or column 
to expand or contract. 

You can also select multiple rows and columns and the changes will affect each that was 
selected. 
 
Another way to resize rows or columns is using the pull down menu that appears next to 
the row or column name or right-clicking somewhere in the selection. Follow these 
instructions: 

1. Make a selection of rows or columns by clicking on the row or column label (ex: 
Column A or Row 12) and dragging your cursor to where you'd like to end the 
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selection. Alternatively, you can click on a row or column label and use the Shift + 
arrow keys to complete the selection. 

o If you would like to select all columns in your spreadsheet, select Column A 
and press Ctrl + Shift + Right Arrow. 

o If you would like to select all rows in your spreadsheet, select Row 1 and 
press Ctrl + Shift + Down. 

2. Using your mouse, right-click anywhere in the selection and select Resize 
columns... or Resize rows... from the menu. You can also access this menu by 
selecting the pull down menu that appears next to row and column names. 
Accessing the menu of one of the columns/rows will affect all selected 
columns/rows. 

 
3. Enter a new size in the Input box, and click OK. 

o The current size of the first row or column in the selection is the value 
already in the input box. 

 
Show, hide, and freeze rows and columns 

Sometimes you have data in rows and columns that is needed for formulas or charts, but 
is not necessary to see in the sheet. You can choose to hide one or more of these 
rows/columns from view in spreadsheets.  
Freezing rows and columns makes it so that the frozen areas remain constant for 
sorting. They also stay in place while scrolling left or right and can be useful if you have 
a large sheet spanning many rows and columns and want to see the identifying names 
of the rows/columns. 
Rows 
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To hide a row, right-click the number of the row to highlight the entire row. Select Hide 
row from the drop-down menu.  

 
An icon appears over the hidden row, and the row's number is no longer visible.  

 
To unhide a row, just click the icon and the row reappears on the spreadsheet. 
There are two methods to freeze rows in a spreadsheet: 

 Dragging the Sort Bar. The Sort Bar is a horizontal bar that separates active rows 
from frozen ones. Using its handle (found at left, by the row numbers), you can 
drag the Sort Bar up or down to the last row you'd like to freeze, 10 rows 
maximum.  

  
 Using the Tools tab. Click the Tools tab and then click the "Freeze rows" drop-

down menu. From the menu, select the number of rows you want to freeze. Note 
that you can only freeze ten rows using this method. 

 
Columns 
To hide a column, right-click the letter of the column to highlight the entire column. 
Select Hide column from the drop-down menu. You can also click the menu available in 
the top of the column next to the letter name. 



 
An icon appears, showing the letter of the column that's been hidden. Note: If you have 
two or more adjacent columns hidden, the icon will show the range of letters, such as B-
E. 

 
To unhide a column, click the letter icon and the column reappears. 
There are also two methods to freeze columns in a spreadsheet: 

 The Column Bar is a vertical bar that separates active columns from frozen ones. 
Using its handle (found at top, by the column headers), you can drag the Column 
Bar left or right to the last column you'd like to freeze, 5 columns 

maximum.  
 Click the Tools tab and then click the "Freeze columns" drop-down menu. From 

the menu, select the number of columns you want to freeze, 5 columns maximum. 
Multiple rows or columns 
To hide multiple, adjacent rows or columns all at once, follow these steps: 

1. Click the row number or column letter of the first row/column you want to hide. The 
row/column is highlighted. 

2. Press and hold Shift on your keyboard while clicking the last row number or 
column letter you want to hide. 

3. All rows or columns in the range are highlighted. 
4. Right-click anywhere in the highlighted range, and choose Hide rows from the 

drop-down menu. 
To unhide several hidden rows or columns all at once, just highlight the range and select 
Unhide rows/columns. For example, if you have columns C and H hidden, you can select 



columns B-I, right-click anywhere in the selected range, and choose Unhide columns. All 
hidden columns in the range will reappear. 
Spreadsheet formatting and rules 

You can format data in your spreadsheets in a variety of ways. You'll find the standard 
formatting options on the Edit toolbar.  

 
In your spreadsheet, just point your cursor to an icon on the toolbar to see a message 
describing what that option can do. 
Formatting is performed on only a complete cell. It is not possible to format only parts of 
a cell (for example, bolding one word in the cell). 
Here are the main formatting options: 

 print 
 undo or redo last operation 
 format cell contents 
 change font size 
 add bold 
 change color of the text or a background color 
 add borders 
 align text 
 merge cells horizontally in selected rows 
 wrap text 
 add formulas 

In addition to general formatting, you can also set specific rules for formatting cells 
based on values. By setting text and background colors with rules, you can create styles 
that offer a visual summary of complex or changing data.  
 
To setup formatting rules for your spreadsheet, follow these steps: 

1. Highlight the cell or range of cells that you want to apply formatting rules to. 
2. From the toolbar, select the background-color palette button (shown below), or 

right-click the cell or selected range of cells.  

 
3. In the palette drop-down menu or the right-click menu, select Change with 

rules..., or Change format with rules. 
4. In the window that appears, define the conditions for specific text colors and/or cell 

background colors. 
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o Rules can be based on matching text, checking the date, or evaluating 
numbers (less than, greater than, etc) 

 
5. The rules shown above indicate that cells containing "x" will be formatted as cells 

with a red background. This is an attendance sheet and will help visually identify 
the truancies. 

You can choose from multiple rules and select up to five for a given cell or range. To 
remove a rule, just click the "X" to the right of that rule. 
 
Please note: 

 When you specify multiple rules, they are evaluated in the order listed. This 
means that the first rule found to be true will define the format of the cell or range. 

 If you copy and paste from a cell or range that has formatting rules, these rules 
will be applied when you paste the copied data. 

 If you're importing a spreadsheet, any conditional formatting it contains won't be 
imported. 

Copy cell formatting with format painter 

You can apply formatting or conditional formatting rules you've used on one set of cells 
to another separate set of cells using the Paint Format tool, where "paint" is used 
figuratively to describe copying the formatting rules.  
 
The types of formats that you can paint are style, fonts, number formats and conditional 
formatting. 
Please note: If the range of cells you're painting the formatting across is larger than the 
source area, the formatting will tile across the target area. 
 
To paint formatting from one area across another area, follow these steps: 

1. Select the range of cells that contain the formatting and/or conditional formatting 
rules you'd like to paint across another range of cells. 

 
2. Click the Paintbrush toolbar icon. 

o Doing this will enter the spreadsheet into painter mode until you complete 
copying the cell formats or click the Paintbrush toolbar icon a second time. 
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o Your selection will have an orange border around it. 

 
3. Select the range of cells you'd like the formatting to be copied across. The cell 

formatting will then be applied to the range of cells you've selected. 
o This action will override any existing formatting set for the selected cells. 
o The range of cells you want the formatting to be copied across doesn't need 

to be adjacent to your original selection of cells. 

 
List view for simple spreadsheet display 

If you are using a spreadsheet for basic sorting and editing, you may want to try the 
spreadsheet List view.  
 
List view is a simple, fast-loading view of a spreadsheet, with basic editing, sorting, and 
filtering capabilities.  

 
Having a list available for others to edit allows more structure than an empty sheet. It 
can be helpful if you‟re collecting basic data. 
 
Here's what you can do with list view: 

 Sort and filter without modifying underlying data. 
 Get a simple view of your data with or without formatting. 
 Provide a simple method of data entry for novice users. 
 Share a read-only spreadsheet, but allow sorting and filtering. 
 View your spreadsheets on a slow Internet connection. 
 View your spreadsheets from some mobile phones. 
 Give more than 50 users access to the same spreadsheet at a time. 

When you're on a slow Internet connection, you'll see a prompt to use list view. If you're 
trying to access a spreadsheet with more than 50 users currently viewing it, you'll be 
automatically redirected to list view. 
To access list view from your desktop computer, go to the View menu in your 
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spreadsheet and select List view.  
If your phone has a Webkit-based browser (iPhone, Android, Nokia S60, Palm Pre), 
Opera Mobile, or Opera Mini, you'll be able to access list view and edit your 
spreadsheets from your mobile phone. Just go to your mobile Docs list at 
http://docs.google.com/m. 
You can bookmark or share any list view URL for quick access later. All editing and 
viewing permissions set in the Share menu apply to list view just as they do to normal 
spreadsheet view. 
List view provides a few basic ways to manipulate data: 

 edit cells 
 add rows 
 filter and sort data (won't permanently affect the spreadsheet) 
 add formulas (you won't be able to edit cells with formulas while in list view) 

In list view you can't select cells, rename sheets, format data, use auto-fill, edit formulas, 
add comments, add new collaborators and viewers, or insert images, charts and 
gadgets. But you can always switch back to normal spreadsheet view by clicking the Go 
to spreadsheet view link. 
Check spelling 

Correct spelling is an essential part of document creation. Fortunately, Spreadsheets 
has the ability to check the spelling throughout a document so your data will look perfect!  
To launch the spell checker, go to Tools > Check spelling. The tool will go through all 
the cells on your sheet, highlighting each cell which has a misspelled word in red. Words 
that might be misspelled in each cell are underlined in red and can be changed by 
clicking on them and selecting the right spelling. 

 
Cell data validation 

Data validation makes it easy to constrain the values of an individual cell to a specific 
range or list. For example, if you are building a spreadsheet gradebook, you can now 
limit the options in the grade column to a select set of values via dropdown lists. 
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In-cell dropdowns also make input easier by reducing unnecessary typing and errors in 
processing. You can create dropdown lists in individual cells through the data validation 
tool by validating against a range of cells in your sheet or by creating a custom list. 

 
Follow these steps to create an in-cell dropdown list through validation against a range. 

1. Enter data into a range of cells. 
o For example, create a series of grades (A, A-, B+ and so forth) on your 

spreadsheet. 
2. Select the cell(s) you would like to validate. 
3. Under the Data menu, select Validation... 
4. Change the Criteria to „Items from a list.‟ 
5. Click the button next to the „Create list from range‟ option and select the range of 

cells you entered data in during Step 1.  
6. Click Save and the cell you chose to validate will have a dropdown arrow in it with 

the data in your cell range as the potential input values. If you want, you can set a 
cell to allow invalid data. 

You can also create an in-cell dropdown using a custom list. 
1. Under the Data menu, select Validation... 
2. Change the Criteria to „Items from a list.‟ 
3. Click the button next to the 'Enter list items' option. 



4. Enter a set of custom values, separated by commas. For example, you could 
enter "A, A-, B+, B, B-" 

5. Click Save and the cell you selected will have a dropdown list with the values you 
entered as potential input values  

 
Analyze spreadsheet data 
» Basic sorting 
One of the primary benefits to entering data in spreadsheets is the ability to quickly and 
easily sort information. Spreadsheets in Google Docs has a couple of options for 
performing basic sorting on your data, by either using the commands available from the 
View and Data tabs 
With the View tab, you can do the following: 

 Freeze rows: Click the View tab. Use the Freeze rows drop-down to select up to 
10 rows at the top of the current sheet that you want to remain unsorted. 

 Freeze columns: Click the Views tab. Use the Freeze columns drop-down to 
select up to five columns on the left on the current sheet that you want to remain 
unsorted. 

 Sorting data: You can use your cursor and select the cell that you want sorting to 
start in. Next, hover your cursor to the right side of the cell and then click the arrow 
that appears. A dropdown menu will appear with the option to select either Sort 
by column A->Z (ascending order) or Sort by column Z->A (descending order). 
The Sort feature will order all rows of a spreadsheet, except any "frozen rows," 
using the column or the currently selected cell (or the first cell in a range, if a 
range is selected). The Sort feature also won't sort "frozen columns." Note: this 
can also be accomplished by selecting the Data tab.  

 
Filter data 

Collecting data is often much easier than analyzing or understanding it, especially for 
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large data sets. The Filter feature in Google spreadsheets makes it easier to analyze 
and view your data by hiding the data that you temporarily want to take out of view. 
When you want all of your data to be visible again, all you have to do is disable the filter. 
Please note: When you enable the Filter feature, it will filter the data for all of your 
spreadsheet‟s viewers and collaborators. Any editor has the ability to disable the filter. 
Enabling and disabling a filter 
To enable autofilter, follow these steps: 

1. Select the range of cells you‟d like to apply the filter to. 
2. From the Data menu, select Filter. Alternatively, you can select the Filter toolbar 

icon  
3. The filter will be applied to your selected range of cells. 
4. To help you see what cell ranges have a filter applied, the column and row labels 

are colored green. Additionally, the Filter toolbar icon will also change to green 

 

5. Clicking the drop down icon  
6. From the drop-down menu, you can uncheck the data points that you want to hide 

from view and check data points that you want to keep in view. Once you‟ve done 
so and clicked OK, the icon in the header row will change to a filter. 

 
Note: Only one filter is allowed per spreadsheet in order to prevent collaborators from 
overwriting each other‟s data. The filter will show for all editors and viewers, and it can 
be added or removed by any person with editing rights. 
To disable autofilter, follow these steps: 

1. From the Data menu, select Filter. Alternatively, you can deselect the Filter icon 

 
2. The filter will be removed from your selected range of cells. Drop-down menus 

 
3. All filtered rows will be visible again, but data you‟ve sorted will remain sorted. 

Filtering your data 
Filtering will temporarily hide some of the rows in your spreadsheet, allowing you to view 
only the data you‟d like to see. Once you‟ve enabled the filter, click the drop down icon 



 
If you want to complete a bulk action, you can click Select all or Clear to either check or 
uncheck all of your data points in a given column. 
You also have the ability to search for particular data points within a column that has a 
filter applied. Typing "P," for example, will shorten the list to just the names that start with 
P. You can click on Select all or Clear to perform bulk actions on the visible items. For 
example, clicking Clear would deselect Peter and Phil. 
Sorting data with Filter enabled 
When you have a filter applied to a range of cells, you can also sort the data. When you 
sort your data using the drop-down menu, only the data contained in the filter range will 
be sorted. You can sort a particular column by selecting the drop-down menu and 
clicking either Sort A → Z or Sort Z → A. 

 
Advanced sorting 

If you wish to sort your spreadsheet by different columns in varying priority, you can take 
advantage of the advanced sorting options. You can sort a range of cells according to 
rules set for one or more columns.  
For example, you might want to have your gradebook sorted by Class period, then by 
grade, then by last name. You could set up each of these rules by following the steps 
below. 
To sort your data, follow these steps: 

1. Highlight the group of cells you'd like to sort. To sort the entire sheet, click the top 
left corner of the sheet to select all cells. 
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2. Click Tools>Sort. 

 
3. Check Data has header row if your columns have titles. 
4. Select the column you'd like to be sorted first and whether you would like that 

column sorted in ascending or descending order. 
o Click +Add another if you'd like another sorting rule added. Sorting will be 

prioritized according to the order of your rules. 
o Click the X to the left of your rule to eliminate it. 

 
5. Click Sort and your range will be sorted. 

About charts 

Charts are an easy way to understand the data in your spreadsheet and can also be 
shared in a variety of ways. You can insert a chart onto a sheet, create a chart on a 
separate sheet, or save a chart as an image and insert it into a document.  
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With Google Docs, you can choose from one of the six chart types listed below: 

 Columns (plus four sub types, including 3-D) 
 Bars (plus four sub types including 3-D) 
 Lines (plus five sub types) 
 Area 
 Pie (plus two sub types) 
 Scatter (plus three sub types) 

Review the next section for more details about using charts in spreadsheets » 
Use gadgets to visualize data 

Gadgets are another way to visualize data in your spreadsheet. Although you can insert 
charts and gadgets in the same way, gadgets offer even more possibilities. 

 
Both: 
• Update as you update data 
• Can be saved as a png 
• Can be published 
• Can be seen by collaborators 
Gadgets: 
• Can be made by users 
• Can be inserted into iGoogle pages 
Charts: 
• Generally used within a spreadsheet. 
Some examples of education-friendly gadgets you can add to a spreadsheet: 

 Motion chart: A dynamic flash based chart to explore several indicators over 
time.  

 Word Cloud: Displays text with words highlighted/enlarged based on their 
frequency in the source range of cells. Great with forms, to quickly highlight 
popular words across all responses. 
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 Advanced Word Cloud: Create a word tag cloud from cells in your spreadsheet. 
Popular words are bigger and bolder. Choose the color, exclude common words 
like "or" and "the", and best of all, turn each tag into a link with an easy-to-use 
search string. 

 Word Search Gadget: Create an interactive word search from a column of words 
in a spreadsheet, with a user-specified number of rows or columns 

 Flash Cards Gadget: Easily create flashcard sets. HTML is allowed. Ideal for 
foreign language vocabulary sets, AP Chemistry common ions... anything you'd 
use flashcards for. Remove cards from view once you know them well enough, 
shuffle the remaining cards, change languages and more! 

 Word Study Gadget: Create interactive flash cards. You can guess using word 
jumbles, type-ins, or multiple choice, and you can choose to have the hints come 
from Google images, Google translation, or your own spreadsheet. 

 Map: Each row represents an address to display on the map, and the last column 
can be used for tooltips. 

To add these gadgets, or browse other gadgets you can use in your spreadsheet, follow 
these steps: 

1. Select Insert > Gadget. The Add a Gadget window appears, where you can 
select gadgets in a number of categories, including charts, tables, and maps.  

2. Click Add to your spreadsheet to insert a gadget. 
When you click a gadget in your spreadsheet, a gray border appears around the gadget, 
along with a Gadget drop-down menu. Click Gadget to open the menu and select Edit, 
Delete, Publish, or Add to iGoogle. 
If you prefer, you can have a gadget move to its own sheet instead. Here's how to do it: 

1. Click the grey triangle in the upper-right corner of your gadget to open a drop-
down menu. 

2. Select Move to own sheet from the menu. 
3. Your gadget will now become a sheet in a spreadsheet. 

Create and publish charts 
» Create charts from spreadsheet data 
Charts are a convenient way to analyze spreadsheet data visually and come built-in to 
Google Docs. There are 7 standard types of charts to choose from: line, area, column, 
bar, scatter, pie, and trend. In addition, there are even more options to choose from 
under More in the Chart Editor. 
Data displayed in charts is selected from the spreadsheet and updated whenever the 
spreadsheet is modified. This way your chart always has the most accurate information. 
To create a chart in your spreadsheet, follow these steps: 

1. From the Edit page of your spreadsheet, select the cells of data you'd like to 
include in the chart. 
Please note: It helps to label the data in your spreadsheet before creating a chart. 
For example, if you want to chart your expenses, you might have a row of 
numbers labeled 'Rent' and another labeled 'Groceries.' Then you might label 
columns by month or week, etc. These labels will appear automatically in the 
window where you create and preview your chart.  
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2. Go to the Insert menu and select Chart. The 'Chart Editor window appears. In the 

Data section, make sure the range of data is correct and specify if you want to 
switch rows/columns. You can even select multiple ranges. Note: If you included 
labels in your spreadsheet, you can specify that you want to use the second row 
and first column as labels.  

 
3. Under the 'Charts' tab, select the type of chart you'd like to create: line, area, 

column, bars, scatter, etc.  
 

 



4. Enter labels for your chart in the following fields: Chart title (title of your chart), 
Layout of the legend, Horizontal (what the horizontal axis represents), Vertical 
(what the vertical axis represents). Here, you can also specify the Features and 
Style of various chart components.  

 
5. Preview your chart and edit as necessary. 
6. Click Insert. The chart appears in your spreadsheet. 

Chart multiple ranges 

In charts, you are also able to graph multiple ranges. Take this chart depicting time vs 
distanced traveled. 

 
 
You can add extra ranges by clicking on “Select ranges...” and “add another range.” 
You can also manually add new ranges separated by commas like “Charts!B5:B12, 
Charts!D5:D12, Charts!F5:F12.” 
 

 

 
 

 

https://sites.google.com/a/googleapps.com/edu-training-center/Training-Home/module-4-docs/chapter-4/7-4


 
In this example, here is what the chart with the above data selected looks like. 

 
Edit chart data settings 

After you create a chart, you can always go back and change all of the settings - the 
data selection, chart type, names, etc. 
 
Please be aware that any user added as a collaborator will be able to edit, add, and 
delete charts.  
 
Once you've created a chart in your spreadsheet, you can modify it by following these 
steps: 

1. Click anywhere in the chart.  
2. A Chart drop-down menu appears in a gray border around the chart.  
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3. Select Chart > Edit chart. 
 
 

 
 
 

4. The "Edit chart" window appears. Here, you can modify your chart's type, labels 
(including the chart title), and data range(s). 
 



 
 
 

5. Click Update to apply your changes. 
6. The modified chart appears in your spreadsheet. 

To resize your chart, please follow these steps: 
1. Place your cursor at the corner of your chart. You'll know it's positioned correctly 

when it becomes a diagonal, two-way arrow. 
2. While pressing Crtl+Shift, click and drag the chart's corner to make the chart 

larger or smaller. 
Please note: If you don't press Ctrl+Shift while resizing, the chart will not scale correctly 
to the new size. 
Publish and export charts 

You can export any chart and save it as a .png file. You can then upload this file to any 
document or presentation in Google Docs, email it to others, or save it for other 
purposes. 
 
To save your chart as a .png, please follow these steps: 

1. Click the Chart drop-down menu in the top-left corner. 
2. Select Save image.  
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3. In the window that appears, select Save to disk and click OK. 
4. Your chart will be saved to your local computer. 

Instead of exporting and saving a chart to your hard drive, you can also publish a chart 
to make it viewable like a webpage. Here are two methods you can use to publish a 
chart: 

 Publish both the sheet that contains the chart and the chart itself, then copy and 
paste the chart's HTML code into your webpage or blog. 

 Publish the sheet that contains the chart. Then include that link in your webpage 
or blog. 

To publish a chart by copying and pasting its HTML, follow these steps: 
1. Publish the sheet that contains your chart by clicking Share > Publish as a web 

page. Review how to publish documents » 
2. In your spreadsheet, click the chart to activate the Chart drop-down menu at the 

upper-right of the chart's frame. 
3. Select Chart > Publish chart, or right-click the chart and select Publish chart.  

 
 

https://sites.google.com/a/googleapps.com/edu-training-center/Training-Home/module-4-docs/chapter-2/8-1


4. A dialog box appears, asking if you want to let anyone at your domain see the 
spreadsheet. This step is required to access the code for the image; if you don't 
want others to view your spreadsheet, you can simply not provide them with the 
URL. If you do share the URL, please note that anyone accessing your published 
spreadsheet will see its content along with the chart. 

5. Click OK in the dialog box. 
6. In the window that appears, copy the HTML code and paste it into the code of 

your page or blog.  

 
7. Click Done to close the window. 

To publish a chart's sheet and include that link in your webpage or blog, follow the steps 
below. You can even remove the gridlines so they won't appear when others view the 
published or printed sheet. 

1. Click the Publish tab. 
2. Click Publish now. 
3. Click OK in the dialog box that appears. You'll see a link to your published 

spreadsheet. 
4. Click the link and type "&gridlines=false" at the end of the URL. 
5. Copy and paste this link in the HTML of your webpage or blog. When viewers click 

the link on your page, they'll see your published chart. 

 Chapter 5: Presentations 
Presentations in the classroom 
Developing your slide presentations online in Google Docs makes it easy to share and 
work concurrently on slides with others. With the ability to add drawings, images, and 
video, you can use presentations for a variety of projects. 
Some examples of how teachers can use online presentations: 

 Showcase student work on a class website with embedded presentations 
 Create templates that outline specific topics for student presentations 
 Publish “how-to” presentations with screenshots and videos 
 Design certificates to print or to send virtually 

Some examples of how students can use online presentations: 
 Create a slideshow with pictures for a class project 
 Collaborate easily for group presentations 
 Storyboard videos, comic strips, written assignments 

Create and format presentations 
» Choose a theme 
Themes for your presentation are designs that apply to every slide you add. You can 
either choose one of Google presentations themes or pick your own background image 
and color for your presentation. There are also many presentation theme designs in the 
Google Docs template gallery. 
When you start a new presentation, you have a blank theme with a white background 
and black text. 
You can only select one theme for your presentation, but you can still change the 
background and design of individual slides. 
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To choose a theme for your presentation, follow these steps: 

1. Go to the Format menu, select Presentation settings and click Change theme. 
2. Browse through the themes. When you have found the one you would like to use, 

click it once. 
3. Your presentation now has the new theme automatically applied to all the slides. 

 
You can choose to change the background image of a single slide, or all slides in the 
presentation. When you change the background image, you overwrite whatever theme 
you have selected. 
To change the background of a given slide to a custom image (or to set a custom image 
for all the slides in your presentation), follow these steps: 

1. In the presentation editor, select the slide you want to change and go to the 
Format menu, select Presentation settings then click Change background. 

2. In the window that appears, click Insert image. 

 
3. Click the Choose File button to search for an image. 

o For best results, use images with an aspect ratio of 4:3 and 800x600 
resolution. 

4. If you want to have this background apply to all the slides in your presentation 
(you will not be able to use a theme) check the Apply background to all slides 
box. 

5. Click Save. 
If you wish to only have a background color and not an image for you slide, you can 
select a color for one or all of the slides in your presentation.  
To select a background color only, follow these steps: 

1. Follow steps 1-3 above to open the Change Background window. 
2. Click the paint bucket icon below the Insert Image link. 
3. Select your desired color from the palette. 
4. If you want to have this color aplied to the background of all slides, check the 

Apply background to all slides box. 
5. Click Save. 

Create presentations from templates 

The Google Docs template gallery has several presentation templates that you can use 
a starting point for developing your slides. Each template has standard text that you can 
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replace with your own, and preset design styles that you can reuse. 
Some of the presentation templates are like themes with slides empty of written content, 
but filled with a custom design. Other templates have content ideas or outlines, such as 
a how to create a picture slideshow or create a certificate.   
You can browse the template gallery to preview and select any template in two ways: 

 While in a document, go to the File menu, select New and click From template. 
 From your docs list, click the Create new button and select From template. 

 
Insert and duplicate slides 

When you start a new slide presentation from scratch (not a template) there is only one 
slide to start. 
To start adding new slides, you can choose one of three options: 

 Click the New slide button above the slide sorter. 

 
 Go to the Slide menu and select New slide. 
 Use the Ctrl+M keyboard shortcut. 

When you create a new slide, you are presented 5 options for a slide layout: 

 
Please note: You can always customize the layout of your slide by inserting images, 
drawings, text boxes, tables, and more. If you plan to use a more custom format, you 
may want to select the Blank slide template. 
Review how to edit and format slides in the next section » 
You can also create new slides by duplicating existing slides in your presentation. There 
are a few options to duplicate a slide: 

 From the slide-sorter view, select the slide you want to duplicate and hold down 
the Ctrl key while clicking and dragging the slide. You can also duplicate a 
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sequence of slides by holding down the Shift key to select a group of slides, then 
holding down the Ctrl key while clicking and dragging the slides to a different 
place in the slide sorter. 

 Click the Duplicate slide button directly above the slide sorter. 

 
 Right-click a slide in the slide-sorter view and select Duplicate slide. 
 Go to the Slide menu and click Duplicate slide. 

Copy and paste slides 

Copying and pasting slides is slightly different from duplicating slides because you can 
choose exactly where to insert the copied slide. With duplicating slides, the new slides 
appears directly after the original. 
You can also copy and paste slides from one presentation to another.  
Please note: When you copy and paste slides into a different presentation, the newly 
pasted slides will adopt the theme of the presentation. Some of your designs and colors 
may change because of varying themes. 
To copy a slide in your presentation follow these steps: 

1. From the slide-sorter view, select the slide you'd like to move. You can also press 
the Shift key to select a sequence of slides, or use the Ctrl key to select multiple, 
non-sequential slides. 

2. After you've selected slides, you can copy them by right-clicking the slide(s) in the 
slide-sorter view and selecting Copy slide or use the keyboard shortcut Ctrl-C. 

3. Next, right-click the area in the slide-sorter view where you'd like to paste your 
slides and select Paste slide. You can also select a slide you want to appear 
before the pasted slides and use the keyboard shortcut Ctrl-V. 

Organize and order slides 

The content and outline of a presentation often changes throughout the development 
process, but you can easily move slides around to accommodate any modifications.  
To reorder your presentation slides, follow these steps: 

1. From the slide-sorter view, select the slide you want to move. You can press the 
Shift key to select a sequence of slides, or use the Ctrl key to select multiple, 
non-sequential slides. 

2. Once you've selected your slides, choose one of these options to move them: 
o Drag the slide to a new position in the slide-sorter view. You can also 

duplicate slides by left-clicking on your selected slide(s), then holding down 
the Ctrl key while dragging. 

o Right-click the slide(s) in the slide-sorter view, and select either Move slide 
up or Move slide down. 

The order of the slides is changed according to your selections. 

 

https://sites.google.com/a/googleapps.com/edu-training-center/Training-Home/module-4-docs/chapter-5/2-4
https://sites.google.com/a/googleapps.com/edu-training-center/Training-Home/module-4-docs/chapter-5/2-5


 
Delete slides 

You can easily delete slides from your presentation, but you also have the option of 
recovering removed content at any time by accessing your revision history.  
Choose one of the following options to delete a slide: 

 Click the Delete slide button directly above the slide sorter. 

 
 Click Slide > Delete slide. 
 From the slide sorter, right-click on the slide you want to delete and select Delete 

slide. 

 
Edit and format slides 
» Enter and format slide text 
If you'd like to add new text fields, the following options are available: 

 Click the Insert text button in your presentation toolbar.  

 
 Click Insert > Text. 
 Right-click in your slide and select Insert > Text. 

All the standard text formatting options are available in the presentation toolbar, 
including selecting fonts, size, color, highlighting, indentations, and paragraph alignment. 
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Bulleted and numbered lists are common in presentations. You can easily format some 
or all of your text fields to a list type, just follow these steps: 

1. While editing a text box (or after creating a new one) click the Numbered list icon 
(to the right of the Link icon), or the Bulleted list icon (to the right of the 
Numbered list icon), depending on your preference. 

 
2. The first bullet/number of your list will appear. 
3. To add additional space between your list items, press Shift+Enter. 

Please note: The formatting used in your original text may not be retained when copying 
and pasting text into a bulleted or numbered list. If this occurs, you can work around the 
issue by removing all formatting and then re-adding the desired formatting from within 
the Google Docs presentations editor. 
 
You can remove formatting from your text by highlighting the text and clicking the 
'Remove formatting' button in the Google Docs toolbar, or copy the text and paste it into 
a plain-text editor (like Notepad) in order to discard the formatting. 
Insert images from the web or your computer 

The visual nature of full-screen presentations makes it ideal for displaying images. By 
inserting images into a presentation, you can create slideshows, scrapbooks, or just add 
more interesting elements to a slide. 
 
You can insert images either from the web or upload images from your computer. 
An easy way to insert a web image is to drag it directly from the webpage into your 
presentation. (Note: Some images can't be dragged into your Internet Explorer browser 
window) 
To insert images that you've saved to your computer, follow these steps: 

1. Click the Insert image button in your presentation toolbar. 

 
2. A window will appear, allowing you to select an image file from your local 

computer. Click Choose File and select the file of your choice. 
3. Once you have selected the image, click OK. 

The image will now appear in your presentation. To move the image, and adjust it to fit 
your presentation, simply click and drag it to the desired space within the slide. 
Notes about using images: 

 Images on the internet may be protected under copyright laws. Before you use an 
image in your presentation, please ensure that you have proper rights to use that 
image. If you're unsure whether or not you have the proper rights to use a 
copyrighted image, please don't risk it. Note that there are many sites on the 
internet that offer images under a Creative Commons licenses, which may be 
appropriate for your use. See http://search.creativecommons.org/ for more details. 

 If images aren't appearing while viewing at school, it's likely that the images are 
being blocked by your school's image filter. In order to keep your Google Groups 
filter intact while specifically allowing ONLY the specific URL below, we can 
recommend a filter setting similar to the following, which may differ depending on 
your particular firewall and/or filtering software: "block *.googlegroups.com 
EXCEPT blob-s-docs.googlegroups.com" 
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Insert videos from YouTube 

You can embed YouTube videos and play them directly in your presentation. There are 
many full lectures, tutorial content, and other clips available on YouTube that you can 
include when introducing new materials to your class. Browse videos on YouTube EDU» 
At this time it is only possible to embed YouTube videos in your presentation. 
To add videos to your presentation, follow these steps: 

1. Go to the Insert menu and select Video. 
2. Search for the video you'd like to insert. 
3. Once you've selected the video, check the box next to the video's thumbnail and 

click Insert Video. 

 
The video will now appear in your presentation. You can resize, move, and arrange the 
video much as you would any other slide object. When playing the video in your 
presentation, you can minimize and maximize a video to the full size of a slide by 
clicking the button on the bottom-right of each video. 
Insert tables for structured formatting 

Tables are a useful way to compare and contrast content on a single slide. You might 
also use a table to illustrate steps of a process or status of a project. 
You can add tables in 2 ways 

 Copy spreadsheet data from an existing Google Docs spreadsheet to the web 
clipboard and paste on a slide. Learn more about copying and pasting to the web 
clipboard » 

 Insert a table directly into a presentation. 
To add a table to your presentation, follow these steps: 

1. Open presentation and click Table > Insert table. 
2. Select the dimensions for your table. 

Once your table appears on your slide, you can start editing it. You can use the same 
formatting tools to modify text in the table as you would other text objects. 
 
The Table menu is one way to move, insert, and delete rows and columns. You can 
mouse over the edges of rows and columns to either add or select rows and columns.  
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Resizing rows, columns, and the table 

 To resize your table, you can point your mouse to any of the four corners and 
resize by dragging. 

 To resize rows or columns, point your mouse to the inner borders of a cell. Drag to 
resize the column or row.  

 
Insert shapes and drawings for illustrations or flowcharts 

In addition to images and videos, you can also add custom drawings or preset shapes to 
illustrate concepts in your presentation. 
 
To add shapes to your presentation, just go the Insert menu, click Shape, and select the 
shape you'd like to insert. 
 
You can then resize, move, and arrange the shape the same as you would any other 
slide object. 
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Fill and outline colors for text, shapes, and drawings 

The tools to fill and outline objects are the same for text, shapes, and drawings.  

 
 
To change fill or outline color for any of these objects, follow these steps: 

1. Click on the object. 
2. Select either the Fill color (paint bucket) or the Outline color and size (pencil) 

buttons. 
3. Choose the color you would like to use. If you chose to change the outline color, 

you can also select a the thickness of the border by selecting a Weight option. 
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If you do not see the color you would like to use in the swatches, you can also add a 
custom color that will be available throughout your presentation to use with text and 
shapes. 
 

 

 
To add and use a custom color with your text and shapes: 

1. Select a text or shape object. 
2. Click on either the Fill color (paint bucket) or the Outline color and size (pencil) 

buttons. 
3. Click the Add a color button at the bottom of the color picker. 

 
4. Enter a custom color by name, hex, or rgb value. 

You can continue to use this color for other objects throughout your presentation, 
however saved custom colors will not be available in other presentations unless they 
were copies. 
Organize objects on a slide 

https://sites.google.com/a/googleapps.com/edu-training-center/Training-Home/module-4-docs/chapter-5/3-7


All objects – including video, drawings, images, text, and shapes – can be resized and 
moved in a standard format: 

 Click over an object to change the way it is displayed. A box will appear around 
the object which you can drag anywhere you'd like within the slide. 

 Click and drag one of the resize handles at each corner of the object to resize it. 
The object will expand and contract with your cursor's movement. 

If you have more than one object on a slide, you may want to create a layer effect where 
some appear beneath others. You can get to the Order menu for object in two 
ways:Click the object you wish to arrange.  

 Go to the Format menu, select Order. 

 
 Or right-click the object, select Order 

From there, you can choose to Bring to Front, Send to Back, Bring Forward, and 
Send Backward. This will rearrange your overlapping text and images in the order you 
choose. 
From the same Format menu or right clicking the object, you can also: 

 Click Rotate to flip your object(s) horizontally and vertically. 
 Click Center on slide to place your object at the horizontal or vertical center of 

your slide. 

 
You can perform most of the actions on multiple objects as you can with a single object 
from the Format menu or right clicking.  
To move and resize multiple objects at the same time, hold down the Shift key while you 
click each object, or drag over all of the objects you'd like to select. If an object has 
already been selected, holding the Shift key while clicking an object will deselect it. 
With multiple objects there are a few new arrangement options: 

 Click Arrange and then selecting an alignment option for all the objects. If you've 
selected three or more objects, you'll also be able to evenly distribute the space 



between them horizontally or vertically by selecting the applicable Distribute 
option. 

 
The Snap to grid functionality allows you to easily auto-align text, images, shapes, and 
tables within your slides. Snap to grid is enabled by default. You can disable this option 
by clicking Arrange in your presentation toolbar and then unchecking Snap to grid. 
The following options are available with snap to grid: 

 Turn off the grid and smoothly drag your object: hold the Alt key (Option key if 
using Mac) while dragging an object 

 Turn on vertical and horizontal dragging guides: hold the Shift key while dragging 
 Nudge an object in 1 pixel increments: hold the Shift key while moving an object 

with the arrow keys 
 Preserve an object's aspect ratio while resizing: hold the Shift key while resizing 

an object 
 Create a duplicate of an object while leaving the original in place: hold the Ctrl key 

while moving an object 

Share and publish presentations 
» Share and edit with others 
If other people are editing a presentation simultaneously with you, you'll see their names 
at the top of the page, just as you do with documents and spreadsheets. 
Review how to share Google Docs with individuals and groups » 
You can see where other collaborators are viewing or editing by colored outlines around 
slides in the slide sorter bar. 

 
You'll also be able to chat with other viewers and collaborators in View presentation 
mode (available in the upper-right corner of the edit page). 
Up to 10 people can edit a presentation at the same time. However, you can share a 
presentation with up to 200 people (whether you add collaborators or viewers, the total 
cannot exceed 200 people). When 10 people with edit access are viewing the 
spreadsheet, additional editors will have only view access. If you find you are running in 
to that limit, you can change the document visibility setting to allow school Apps users to 
have edit or view access. 
Review document visibility settings » 
To share your presentation more broadly, you can publish it to your school domain (or 
the world, if your domain administrator has enabled the setting).  
Review how to publish Google Docs » 
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Check revision history 

If you find you have removed or are missing slides you need for your presentation, you 
can quickly look through your revision history to see who made the change or to recover 
the lost content. 
To view or revert to an older version of your document, follow these steps: 

1. Go to the File menu and select See revision history. 

 
2. Click on any of the links to previous revisions to view. It will open in a new window 
3. If you wish to revert to the version, click Revert to this version. 

 
If you chose to revert to a previous version, your presentation is reset to the version you 
selected. Now, when your collaborators view this document, they'll see the version you 
selected. However, the versions that had been created after that version will still be 
available in the revision history. 
To go back to working with the latest version of your document, close the window with 
the previous version and click the Back to editor link. 
Embed presentations in a webpage 

Google Docs has an interactive presentation player that you can add to your website or 
blog. Viewers can click through the presentation, make a copy, or even view it in full 
screen – all from a small embedded version of your presentation. 
 
If you'd like to post a presentation online, you'll need to publish it first. To publish a 
presentation, follow the instructions below: 

1. Click the down arrow in the Share button in the upper-right corner of the screen. 
2. Select Publish to Web.... 

https://sites.google.com/a/googleapps.com/edu-training-center/Training-Home/module-4-docs/chapter-5/4-2
https://sites.google.com/a/googleapps.com/edu-training-center/Training-Home/module-4-docs/chapter-5/4-3


3. After publishing your presentation, use the Select presentation size dropdown 
menu to choose the preferred size of your embedded presentation. 

 
4. If you like, you can have the presentation autoplay and set the time between 

slides (similar to a photo slideshow) and also select whether you want the 
presentation to restart when it advances through the entire presentaiton. 

5. Copy and paste the code that appears into your website to embed it. Small or 
medium sizes work best in blogs, while large is most suitable for onscreen viewing 
and reading. 

 
Once you've embedded a presentation, please keep in mind that others can access the 
code and embed this presentation on additional sites by clicking the Menu button at the 
bottom-right of the embedded presentation. 
Please note: If you are using a site created in Google Sites, the Insert feature of Sites 
must be used to insert a presentation. Just click Edit page > Insert > Presentation from 
within your site. You'll be prompted to provide the URL of your Google Docs 
presentation, at which point your presentation will be embedded. 
Using the embedded presentation player 

The embedded presentation player has a full set of interactive controls for your website 
visitors to view and access your presentation. 
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You can move through the slides using the left and right arrows at the bottom of the 
player. You can also choose the play or pause buttons to allow the presentation to 
advance automatically. 
 
There‟s also a fullscreen button to start the presentation in a new window. 

 
 
The Menu button at the bottom-right of the embedded presentation allows visitors to 
create a copy of the presentation in one click, or copy the embed code to put it on their 
own website. 
 

 

 
Prepare and deliver a presentation 
» Add speaker notes to slides 
Presentations often don‟t include all the information you plan to deliver in front of an 
audience. You may have notes or reminders related to content on different slides. You 
might even be only publishing the presentation and wish to provide viewers with 
additional context. 
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To capture this, you can use speaker notes in Google Docs presentations. Speaker 
notes are specific to each slide and can be formatted the same as any other text in a 
presentation. 
 
Collaborators and viewers will also have access to the speaker notes, as will anyone 
who can view embedded presentations. 
 
To include speaker notes, click the View Speaker Notes button at the bottom-right of a 

presentation while editing.  
This will expand the Speaker notes section, where you can add notes for the current 
slide.  
When you are giving a presentation, you can access your speaker notes either in the 
browser or print them out beforehand. 
To see your notes online, in the browser, you can click the View speaker notes option 
at the top-right of your screen, directly above the chat module, after clicking to expand 
the grey chat bar or clicking the View together link. 

 
To print your speaker notes alongside your slides, follow these steps: 

1. Go to the File menu and click Print. 
2. Select  the checkbox to Include Speaker Notes in your preferred layout. 
3. Click the Print or Save to PDF button. 

 
Control how objects appear during a presentation 

At this time, Google Presentations does not support transitions between slides. 
However, you can control the sequence in which objects appear on your slide. 
To sequentially reveal text and objects when presenting, follow the instructions below: 

1. Click on an object or text box. 
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2. A frame will appear around the item. Right-click anywhere on this frame and select 
Incremental reveal.  

 
3. Repeat the above steps for each text box and object you'd like to animate. 

For text boxes that have been set to 'incremental reveal', bullet and paragraph levels will 
appear one at a time as you advance through your presentation. 
If you have selected more than one shape to be revealed on the slide, a number will 
appear next to the small clock icons assigned to each item, indicating the order they will 
be revealed.  

 
After right-clicking on this icon, you'll be able to: 

 change the order of appearance by selecting a different number 
 remove the item from the reveal queue 

 
You can also remove an item from the reveal queue at any time by right-clicking on the 
item's frame and selecting Immediate reveal. 
When presenting, each object set to 'incremental reveal' will appear in order after every 
click. Your keyboard's arrow keys can also be used to cycle through each increment. 
Use the down or right arrows to advance to the next increment, and the up or left 
arrows to hide items you've revealed. 
If you'd like to advance instantly to the next or previous slide without cycling through 
each animation, you can use the Page Up and Page Down keyboard shortcuts. 
Present your final slides 

When it‟s time to deliver your presentation, you can choose to show your presentation in 
the browser or download it as a PDF or PPT file and use a program on your computer to 
view. 
Review export file types for Google Docs »  
To view your finished presentation in the browser, click the Start presentation button in 
the top-right of the screen. A new window appears, displaying your presentation one 
slide at a time. While in presentation view, you can enter full screen mode by pressing 
F11. 
You can also begin a presentation from a designated slide by right clicking a slide in the 
slide sorter sidebar and selecting Start presentation from this slide. 
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Navigating your slides 
To skip from one slide to the next, use your keyboard's arrow keys, or click the arrow 
icon in the gray bar at the bottom of your presentation. You can also jump to a specific 
slide by clicking the the slide menu at the bottom of your presentation 

 
You can automatically cycle through slides in presentation mode by clicking the Start 
presentation button at the top right of your presentation, and clicking Actions > Play at 
the bottom left of the page. 
Follow a live presentation 

People in different locations can view a presentation simultaneously when each person 
signs in to the presentation and clicks View together at the bottom-right of the screen. 
Viewers can choose to move from slide to slide on their own or follow along with a 
presenter who is controlling the presentation. 

 
If you're a collaborator and would like to take control of the presentation, click Take 
control of presentation at the top-right of your screen. After doing so, viewers will see 
your current slide displayed above their chat modules. Viewers can then click the Follow 
the presenter option (also at the top-right of the screen) if they want to follow along in 
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the main portion of their screens. This option is only available to viewers after a 
collaborator has taken control of the presentation. 

 
Chat with others during a presentation 

The Chat function is available when you access a presentation in View presentation 
mode, not while editing as you can with spreadsheets and documents. 
You can set-up chat during your presentation to be able to answer questions and 
address comments remotely. If you are teaching a class online, the chat box combined 
with students following your presentation can act as a virtual lecture session. 
To hide the chat feature, click the left side of the chat module, in the area beside the 
arrow. When hidden, the chat feature's border is still visible on the right side of your 
screen. 

 
To make the chat feature reappear, simply click this area again. 
Please Note: This feature requires Adobe Flash Player version 8 or above. Linux users 
require version 9. To download Flash Player, please visit the Flash Player download 
page. If you've already installed Flash and would like to check which version you have, 
visit http://www.adobe.com/products/flash/about 

Streamline back-to-back presentations 

If you arrange to have several presentations occur one right after another, it can be 
useful to either consolidate the presentations into a single file or to prepare the 
presentations before hand to simplify the switchover. Google Presentations already 
makes it easier by not having to download documents from external media and start a 
separate program. The following are tips for handling multiple presentations scheduled 
back-to-back. 
To create a master presentation, you can import slides from each of the individual 
presentations. To get started, just follow these steps: 
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1. Make sure that the presentation you wish to import has been shared with you. 
Review how to share Google Docs » 

2. Click on the slide in the slide sorter after which you want the imported slides to 
appear. 

3. Go to the Insert menu and select Import slides.  

 
4. Select the name of the presentation from the list. 
5. Using the slide sort view, you can select slides one by one or select all by clicking 

the Select all slides link beneath the first slide. 

 
6. When you have selected the slides you need, click the Import button. 
7. The slides will be imported beneath the slide you selected in step 1. 

Please note: When you create a master presentation with a theme, even a blank theme, 
any imported slides will adapt to that theme. This means if the other presentations were 
designed with a particular theme, those color and formatting choices will not import over. 
Another option for streamlining back-to-back presentations is to set-up a browser 
window with all the presentations loaded on tabs of a single browser window. You can 
then arrange the tabs of presentations to match the order of the schedule. You will need 
to make sure that all the presentations have been shared with you ahead of time. 
Review how to share Google Docs » 
With your browser window set-up ahead of time, you can quickly navigate to the correct 
tab and click the Start presentation button for each new presentation. 

Design presentation templates for meetings or classes 
If you have a specific format you like to use for meetings or class assignments, you can 
create a template that anyone at your school can use. 
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For example, if there‟s a monthly faculty meeting which showcases a few best practices, 
you could create a standard presentation that follows the usual format. You could do the 
same for a class “show and tell” presentation, where some of same information being 
shared. Students could then copy and customize the presentation with their information. 
 
In addition, you could use presentation templates to standardize class presentations for 
projects. Templates can include instructional information as well as placeholders, but 
those who use the template still have the ability to customize it with themes and other 
objects. 
A template starts as a regular presentation that you can upload to your domain for 
anyone at your school to use.  
Review the full instructions for uploading templates to your school Apps domain template 
gallery » 

 
» Chapter 6: Forms 
Forms in the classroom 
With Google Docs, you can quickly create a form or survey, send it to students, parents, 
teachers, or staff, and keep track of the answers in one spreadsheet. 
Since forms are filled out online, there‟s no need to enter in results manually. Responses 
are collected and displayed immediately in a corresponding Google Docs spreadsheet 
which allows you to sort, analyze, and visualize the information. You can send forms to 
anyone - even those outside of your school Apps domain. Respondents can access the 
form via email, a published webpage, or embedded on a site.  
Forms also generates an automatic summary with charts, graphs, and 
statistics about your form responses and can notify you when new 
responses are submitted. 
In this chapter we will review how to create, customize, and publish forms as well as 
walk through examples of how forms can be used at your school.  
Here are some live examples of forms you can preview and try: 

 Collecting mailing addresses 
 US History pop quiz for grade school 
 Student group welcome form 
 Club event requests 

And other ideas that could be conducted using forms: 
 Structured peer editing and feedback 
 Assignment checklist and submissions 
 Applications for positions in clubs, students, government 

 Create and customize forms 
» Create a new form 
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Although forms are part of spreadsheets, you can also directly select the form type when 
creating a new doc. You can create a new form from your Docs list, from a spreadsheet 
or from a template. 
Create a form from your Docs list: 

1. Click Create new > Form.  

 
2. In the form template that opens, you can add any questions and options you'd like. 

Creating a form from a new or existing spreadsheet: 
1. Click the Tools drop-down menu and select Form then Create a form.  

 
 

2. If you already have names entered in the columns of the active sheet, the form will 
populate with those names as questions. 

3. In the form template that opens, you can add any questions and options you'd like. 
Creating a form from a template: 

1. From your Docs list, click the Create new button and select From template.... 
From within an existing document, click the File menu and select New and then 
From template.... 

2. Click Forms under 'Narrow by type,' on the left side of the page.  



 
3. Browse through the different options. Once you decide what template to use, click 

Use this template next to it. 
Forms have the same limitations as spreadsheets. Each spreadsheet can have up to 
20,000 cells with formulas. Of this total, the following limits apply: 

 Up to 1,000 GoogleFinance formulas 
 Up to 1,000 GoogleLookup formulas 
 Up to 50 Import formulas 

Form question types 

When you create a form, you are automatically provided 2 questions. You can edit these 
questions however you like and add additional questions. To collect the information you 
need, select from 7 different types of questions, see this sample form below: 

 
1. Drop-down lists with options 
2. Single line text box 
3. Multiple choice 
4. Scale, to ask your invitees to grade something in a scale from 1-5, for instance. 
5. Checkboxes 
6. Paragraph text, which allow for long answers 
7. Grid 

Please note: Forms only display in single columns. This image was created just for 
showing the different types of questions. 
 Add and edit questions 

To add questions to your forms, follow these steps: 
1. Clicking Form in your spreadsheet  
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2. Add item at the top of the editing page.  
3. Select the type of question you wish to add. 

 
You can make any question a required question by selecting the option labeled 'Make 
this a required question. 
Use the icons next to each question to edit, delete, or duplicate: 

   

Edit: To edit an existing 
question, just click the Edit 
button to the right of the 
question you want to edit. 

Delete: To delete a 
question, click the Delete 
button to the right of the 
question you want to 
delete. 

Duplicate: To quickly 
duplicate a question, click the 
Duplicate button to the right of 
the question you want to 
duplicate. 

If you are creating a form with your school Apps account, you can also choose to record 
the email addresses of people who fill out your form. This can help you identify who 
submitted the response and also filter to find those who submitted multiple responses. 
To do this, select the checkbox next to 'Automatically collect respondent's myschool.org 
username' - where myschol.org is yous school Aps domain - while you create the form. 
Recipients of your survey will see a message at the top of the form explaining that their 
username will be collected automatically. 

 
You can also require your respondents to sign in to view and fill out a form. This 
provides an additional layer of security for sensitive forms. 
Note: if you're inviting people outside of your domain to fill out your form, make sure you 
don't require them to sign in; otherwise, they'll get to the domain sign-in page and won't 
be able to access the form. 
Format form appearance 

You can modify the layout of your form by rearranging questions, adding section 
headers, or selecting a designed theme.  
Please note: Changing the formatting of your form in this way will not change anything 
in your spreadsheet. Question columns will not move to reflect a new arrangement, 
section headers are not included as a column, and the form does not appear while 
editing the spreadsheet. Making the following changes only reflect how individuals see 
your form. 
Rearrange questions 
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You can move questions around simply by clicking and dragging. Make sure that you are 
not editing the question – if you are, you must click the Done button before rearranging 
your questions. 

 
Section headers 
To help make your form easier to read or to organize sets questions, you can add 
section headers. To add, simply select Section header from the Add item drop-down 
menu. Each section header can have a title, which appears in a larger font, and a 
section description. 

 
Themes 
There are over 70 themes of all different colors and styles you can choose from for 
displaying the form when viewed as a webpage or embedded on a website. Themes will 
not appear within an email client.  

 
To pick a theme for your form, click the Themes button at the top of the form and select 
your favorite theme. 

 
Then, click Apply and edit the form. 



 
Allow respondents to skip or jump to different sections 

Some forms you create for a diverse audience might require different sets of questions 
based on a previous answer.  
Examples of when a form could have different questions for different respondents: 

 Parents filling out information for the school year, with different questions about 
8th grade students versus 6th students. 

 Students completing a writing assessment, with different prompts depending on 
the book or genre selected.  

 Applications for different positions in a club or organization, with some common 
parts like contact information and some role-specific questions depending on the 
application type. 

By adding page breaks into a form, you can separate information and allow respondents 
to skip irrelevant sections and go directly to other parts of the form. 
To allow people to move to different parts of a form, use the multiple choice question 
type and select the option labeled Go to page based on answer. 

 
To add a page, just click the Add item drop-down menu, and select Page break. 

 
Using page navigation, you can redirect form respondents previously split apart back to 
the same page. Under the Add Itemmenu, select Page break. Then, select what page 
you‟d like your form respondents to be directed to under the drop down menu in the 
page break.  
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Provide respondents a custom form submission message 

If you have more instructions to provide after respondents complete a form, provide any 
additional information detailing what will happen next, or explain how you will be using 
the submitted information, you can edit the form confirmation message. 
To customize the confirmation message, follow these steps: 

1. Go to edit your form if you are not already on the editing page (from the 
spreadsheet, click the Form menu and select Edit form). 

2. Click the More actions button at the top right of the form and select Edit 
confirmation from the drop down menu.  

 
3. Enter in your message. You can only include text in this message. 

 
Set default text and answer fields in a form 

You can pre-populate a form with default text and answers using URL encoding.  
Please note: URL encoding only works when users click the direct URL of a form. 
Adding these default values will not appear for forms that are emailed. 
To add pre-defined values to your form, you must append an entry string for each 
response field you'd like to pre-populate. Since each question has an unique id like 
"entry_0", in order to repopulate the entry, append "&entry_0=prepopulated answer" to 
the URL of the published form. 

 The entry numbers do not necessarily correspond to the order of questions on 
your form. To find out the correct entry number, try adding only one string at a 
time using trial and error. For example, if entry_0 does not change the field, try 
entry_1, then entry_2, etc. 

Tips for coding in your answers: 
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 For answers that have spaces, use the + sign, i.e. entry_0=First+Presentation 
 For answers that have multiple selections, use pipe character (“|”) to separate 

your answers. Do not include spaces between the answers, i.e. 
entry+1=Introduction|Preparation|Organization 

 For multiple choice answers, you must match one of the answers exactly with 
correct spacing and capitalization, otherwise “Other” will be selected. 

Here's an example: 
The URL for this form: 
http://spreadsheets2.google.com/a/g1usd.org/viewform?formkey=dDB6

dXlGSGZzNG5vdkRyVFVYZjFKS0E6MQ& 
entry_0=Final+presentation&entry_5=Book+report&entry_2=3 
Adds pre-defined values to the form like this: 

 
Note that the entry numbers do not correspond to the order of the questions. You may 
need to use trial and error, adding just one entry at a time, to correctly populate the 
fields. 
Collect form responses 
» Send form via email 
You can email the form to anyone in the world, even those outside your school Apps 
domain. This makes forms an ideal way to collect information for those outside the 
school such as contact information from parents or survey data for a research project. 
If the individual has a Gmail account, they can actually respond to the form directly in the 
email message. Others can complete the form by clicking the link included in the email 
message. 
The email message you send contains the form title, description, and a link to submit the 
form. At this time, you cannot add a separate email message when you send the form to 
recipients. 
You can email your form as often as you like to recipients from two places: 

1. Response spreadsheet: Click the Form menu and select Send form. Enter the 
email addresses and click Send.  

 
2. Editing form page: Click the Email this form button and enter the email 

addresses of the recipients. Click Send.  
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You can also email recipients again for reminders or other notifications by going to the 
Form menu in your spreadsheet and selecting Email X Recipients, where X is the 
number of email addresses you‟ve already sent the form. 
Mailing to groups 
You can take advantage of Groups in Google Apps or Google Groups to use a single 
email address to send to multiple people. If you view your group discussions on the 
group page only, not in email, you will be able to access the message and click the link 
to complete the form. 
Access the form with a URL 

Whenever you create a form, Google Docs automatically publishes it with a public URL 
that anyone can access. You can then tweet, IM, email, or post the link to inform others 
about your form. 
To find the URL for your spreadsheet, follow these steps: 

1. While in the spreadsheet of form responses, go to the Form menu and select Go 
to live form  

 
o If you are editing the form, click the See responses button and select 

Spreadsheet to get to your main spreadsheet. 
2. Copy the URL of the form. 

This is also how you would get the URL for adding pre-defined answers to your form.  
Review how to add default text and answers » 
Embed the form on a website 

Another way to collect information from your form is to post it on a website. This can also 
be a way to collect information from visitors to your website. 
For example, you can have a volunteer form on a class website or a feedback form on a 
school website. 
If you have a common form that is used for students in your class, you can also post that 
form to the class website so students do not need to search for an email or the original 
URL. This could be useful for things like daily or weekly journal entries, equipment 
check-out forms, or tutoring requests. 
If you'd like to embed your form in a website or blog, after you create and save your 
form, follow these steps: 

 While in the spreadsheet of responses, click the Form menu and select Embed 
form in a webpage.... Copy and paste the code and paste into your site or blog. 

 While editing the form, click the More actions button at the top right of your form 
and select Embed from the drop-down menu. Copy and paste the code into your 
site or blog. 
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Allow individuals to edit form responses 

Google Docs now allows you to change your form response after you have submitted it. 
The modified response will not create a new entry, but modify the existing entry on the 
spreadsheet. These edits will be reflected in your spreadsheet and in your summary of 
responses.  
Please note: If you provide the option to edit a response, an individual can modify their 
response as many times as they like. 
Form respondents will receive a custom URL to access their response and resubmit 
answers on the form submission confirmation page. If you collect their school Apps 
username, they will also be sent an email with the link to edit. 
To enable the option for respondents to edit submitted forms, check the Allow users to 
edit responses box displayed at the top of the form while editing. 

 
All respondents will then have the option of editing their form responses via a custom 
Edit your response link on the form submission confirmation page. These links will be 
different for each respondent. 

 
If you also check the Automatically collect respondent's domain.com username 
box, your respondents will have the option to have a copy of their responses sent to 
them via email. This email will have an Edit your response link that will allow them to 
edit their form responses. 
Edit a submitted form response 

If the creator of a form sent to you has enabled the Allow users to edit responses 
option, you'll be able to edit your responses to a form. There are two ways to do this. 
First, if you check the Send me a copy of my responses box on the form, the you'll 
receive an email confirmation showing your form responses. 
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If you click the Edit your response link in the confirmation email, you will be taken to a 
screen that allows you to edit your responses. 

 
You will be able to see your previous answers and make edits. Once you click Submit, 
these changes will be reflected in the form owner's spreadsheet and summary of 
responses. You can edit your responses as many times as necessary using the Edit 
your response link. 
Second, you can edit your form responses on the form submission confirmation page. 
On the confirmation page, click the Edit your response link. 

 
You will be able to see your previous answers and make edits. Once you click Submit, 
these changes will be reflected in the form owner's spreadsheet and summary of 
responses. You can edit your responses as many times as necessary using the Edit 
your response link, as long as you keep the URL to the confirmation page. 
 
Please note: If you give away the URL from the form submission confirmation page or 
forward your confirmation email, other people will be able to edit your responses. 
Automatically collect username 

At this time, it is not possible to limit responses to one per individual. However, when you 
create a form with your school Apps account, you can select to record the email addresses 
of people who fill out your form, and then easily identify any duplicate responses. 
You can also use the timestamp included with each form entry to identify the earliest (or 
latest) response from a specific individual.  
 
To automatically include a respondent‟s username, select the checkbox next to 
Automatically collect respondent's myschool.org username while you create or edit 
the form, where myschool.org is your school Apps domain. 
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On the published, embedded, or emailed form, individuals will see a message at the top 
of the form explaining that their username will be collected automatically. 
Stop accepting form responses 

When you create a form, you begin accepting responses by default. If you have a 
specific end date or time in mind for accepting responses - as you might for an 
application or assignment - you will need to manually change the setting. 
To stop accepting entries to the form, click the Form menu of your spreadsheet and 
uncheck Accepting responses by clicking on it. 

 
Set notification for new form responses 

You can set notifications to receive emails whenever someone fills out your form. These 
are the same notifications that alert you to changes in a spreadsheet.  
This can be useful if you have embedded a web form that receives only occasional 
responses. The notification will alert you to any new submission. This can also be useful 
for tracking and graphing the rate of response for your forms. 
You can set the frequency of notifications for form responses to be sent right away or 
aggregated into a single daily email. 
To set up notifications for your form, follow these steps: 

1. Click Share at the top right of the form response spreadsheet and select Set 
Notification Rules. 

2. Select When a user submits a form. 
3. Choose the frequency by selecting either daily digest or right away. 
4. Click Save. 

 
View form results and share with others 
» Access form response spreadsheet 
Responses to your form are automatically entered into a spreadsheet where you can 
view, organize, and visualize the data. 
Your form response spreadsheet is created with the same name as your form and acts 
just as any other spreadsheet – in fact, it‟s listed under spreadsheets in your Docs list. 
To access your form response spreadsheet from the edit form page, click the See 
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responses button at the top-right of the form and select Spreadsheet from the drop 
down menu. 

 
Finding a form in your Docs list is the same as finding any other document: you can 
search for the form name, browse files owned by you, or look just at the spreadsheet file 
types. 
Make changes to the form response spreadsheet 

When you create a form, responses are automatically collected into a sheet in a 
spreadsheet. You can insert or move sheets, sort, and perform other operations you 
would in any other spreadsheet. The responses will continue to be collected in the same 
sheet. 
Specifically with the sheet where form data is collected, you can do the following: 

 Insert columns to add your own content, such as calculations, notes, or lookups, 
next to form responses. 

 Add response data directly to the spreadsheet by adding rows above, below, or 
between your existing response rows. You can add data one row at a time, or 
paste it in in bulk. Rows you add will be absorbed into the table that stores your 
form's data. 

Please note: Some changes to your spreadsheet aren't allowed, once your spreadsheet 
is storing form responses in a table. This is so that you don't make changes that would 
stop your spreadsheet from being able to read your form responses properly. For 
example, you can't move columns in the table from side to side, since doing so would 
disrupt the structure of the table. 
Automatic summary of form responses 

Google automatically generates some basic statistics from the responses your receive in 
a form summary. 
The summary will calculate totals, percentages, add graphs, and grab snippets of free 
responses. You will also be able to see a graph charting the daily response rate. 
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To access the summary from your form response spreadsheet, go to the Form menu 
and select Show summary. 

 
The response summary page opens in a new window. 
From the edit form page, you can access the summary by clicking the See responses 
button and selecting Summary from the drop down menu. 

 
If you'd like to print your form responses summary, open your browser's Print menu. 
Please note: Because the summary is automatically generated, there‟s no way to select 
specific entries to be included. This means that if you have multiple responses from the 
same individual, they will all be included in the final summary. If you wish to have more 
control, you can generate charts and graphs as you would with any other spreadsheet data. 
Review how to create charts and graphs in spreadsheets » 
Share automatic summary with others 

You can allow those who filled out your form to see the automatically generated 
summary of the responses. The link will be offered in the form confirmation window. 
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Please note: If you are collecting a username or name, those will also be displayed in 
the summary. However, the answers they submitted will not be associated in the charts 
and graphs.  
 
To allow responders to see the summary, follow these steps: 

1. Go to edit your form if you are not already on the editing page (from the 
spreadsheet, click the Form menu and select Edit form). 
 

2. Click the More actions button at the top right of the form and select Edit 
confirmation from the drop down menu. 

 
3. Beneath the message area, select the option Publish response summary. 

 
If you allow publish your form response summary, you can also generate the URL that 
displays the results, just follow these steps: 

1. Find the URL to your live form from your response spreadsheet (Form > Go to 
live form). It should look something like this: 
http://spreadsheets.google.com/a/myschool.org/viewform?hl=en

&formkey=cnNIUF92UWZ2dDZUc2EweFBJMWpPemc6MA..#gid=0  

2. Replace viewform with viewanalytics. 

3. You can now send or post the URL for everyone to see the form summary.  
Share custom form results 

Google Docs creates an automatic summary that you can share, but you cannot 
customize which data appears and how. 
If you wish to create custom form results, you can add formulas and create charts and 
graphs from your form results just as you would any other data in a spreadsheet.  
Review how to analyze data in spreadsheets » 
Review how to create charts in spreadsheets » 
To share these custom results, you can then publish the charts and graphs to embed in 
websites. 
Review how to publish charts » 
You can also visualize the data with gadgets, then choose to publish or share the 
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gadget. 
Review gadgets in spreadsheets »  

Design and deliver quizzes and tests using forms 
» Deliver quizzes and tests online with forms 
You can use forms to create quizzes and tests with various types of questions. You can 
then post the exam on a website or send it directly to students or other recipients. 
To set up an online quiz or test, follow these steps: 

1. Create a new form 
o From your Docs list, click the Create new button, then select Form. 
o From a spreadsheet, click the Form menu and select Create a form. 
o From any other doc, click the File menu and select New then Form. 

2. Add and arrange questions by clicking the Add item button at the top of the 
editing page.  

o Review question types » 
o Review how to send respondents to different parts of the form » 

3. Add section headers to organize your exam by clicking the Add item button at the 
top of the editing page and selecting Section header. Enter the section header 
and a description 

4. Make the form available to students or recipients: 
o Email the form to your class list or individuals by selecting the Email this 

form button and entering in email addresses. Or select the Send form 
option from the Form menu in your response spreadsheet. 

o Embed the form in your blog or site by clicking the More actions button and 
selecting Embed. Copy and paste the code into your site. 

o Embed the form in a Google Site by going to your site, clicking the Insert 
menu and selecting Form. Pick your form from the list. 

o Post the link to the form. Find the URL in your response spreadsheet by 
clicking the Form menu and selecting Go to live form. Copy the URL of the 
new window. To get to your spreadsheet from the edit form page, click the 
View responses button and select Spreadsheet. 

5. When the time for submitting forms is over, stop accepting responses by going to 
the Form menu in your response spreadsheet and click Accepting responses to 
remove the checkmark. 

Create and use a quiz template 

You can browse the Google Docs template gallery to find existing forms that you can 
customize for your own courses and content. 
Review how to create a form from a template » 
If you have a standard format for a quiz that you think others may benefit from at your 
school, you can also choose to upload the form to your school Apps domain template 
gallery. This way other teachers could take advantage of the quizzes you have created 
for vocabulary, for example. 
Review how to upload docs to the template gallery » 
Tips for automatically grading quizzes 

There are several templates available in the Google Docs template gallery that have pre-
designed quizzes with spreadsheets that calculate the answers. 
Using formulas to grade quizzes works best with the multiple choice, choose from a list, 
grid, and scale questions. You can use the checkboxes as well, but because all the 
selections are stored in a single cell separated by commas, you can‟t easily check for 
partial credit. You can easily compare against an answer key that has the exact correct 
values. 
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If you wish to create your own template or spreadsheet to evaluate your form, here are a 
few useful formulas and tips: 

 Create a separate sheet where you can copy the form data and do the 
calculations. 

 Reference an entire column (like your form responses) in another sheet by using 
the syntax Sheetname!A:A where A is the letter of the column and Sheetname is 
the name of the sheet. Copy that formula for all cells in the column to refer to the 
corresponding cell in the original sheet. 

 Set-up a new row or column that has your Answer key. 
 Use the $ sign in front of the column letter and row name when comparing against 

the answer key. This makes sure that when you copy the formula, the answer key 
reference remains the same. 

 In your clean “calculation” sheet, you can modify the form responses to make it 
easier to compare against an answer key. If you use letters to identify the multiple 
choice (A: answer 1, B: answer 2), you can truncate the form response to be a 

single letter using the LEFT(celltext, number) function. For example, 

LEFT(B3,1) will take the text in B3 and return the first character on the left.  

 Compare a selection of cells directly to an answer key and sum up the number 
that match using the arrayformulas and sum function:  

o Array formulas allows you to compare a set of cells directly against another. 
o Summing a series of comparisons will add the number of comparisons that 

are true. 
o For example for this formula: 

=ARRAYFORMULA(sum($B$2:$E$2=B3:E3)), the answer key would be 

from B2:E2, and the selected student grade would be B3:E3. The number 
returned by the formula would be the total number of cells that matched the 
answer key. 

 Assign grades based on percentages using a series of IF functions. The format for 

IF functions is =IF(comparison, value if true, value if false). 

Structure peer reviews and feedback 

In addition to testing knowledge, forms can be used instructionally to provide feedback 
or conduct peer reviews. Creating forms with a clear structure and detailed step-by-step 
instructions guide students to complete assignments and tasks. 
Here‟s one way you can use forms to conduct peer reviews: 

1. Create a new peer review form 
o From your Docs list, click the Create new button, then select Form. 
o From a spreadsheet, click the Form menu and select Create a form. 
o From any other doc, click the File menu and select New then Form. 

2. Add and arrange questions by clicking the Add item button at the top of the 
editing page. 

o Add “help text” to the questions to provide more context or examples of the 
types of answers you‟re looking for. 

o Include questions to collect information about the reviewed document, 
including name, link to the document, class information, assignment, etc. 

o Include free-form critical thinking questions to help students identify the 
strongest and weakest parts of the assignment (such as strong sentences, 
weak sentences) 

o Include a checklist of necessary organization elements for the assignment 
and have students select if they were included (such as thesis statement, 
conclusion statement, supporting evidence, etc) 



o Include a checklist of formatting/review elements (proper citation or 
bibliography format, spell-check 

3. Add section headers to organize your exam by clicking the Add item button at the 
top of the editing page and selecting Section header. Enter the section header 
and a description. 

o You could include headers like “Formatting,” “Structure,” “Organization,” 
“Content” 

4. Make the form available to students: 
o Email the form to your class list or individuals by selecting the Email this 

form button and entering in email addresses. Or select the Send form 
option from the Form menu in your response spreadsheet. 

o Embed the form on your class site in a common “Peer review” section 
where students can always access. From the form, go to the More actions 
button and selecting Embed. Copy and paste the code into your site. From 
the response spreadshet, go to the Form menu and select Embed form in 
a webpage.... 

o Embed the form in a Google Site by going to your site, clicking the Insert 
menu and selecting Form. Pick your form from the list. 

o Share the direct link to the form (you can then create a shortlink using a 
URL shortner to bookmark) Find the URL in your response spreadsheet by 
clicking the Form menu and selecting Go to live form. Copy the URL of the 
new window. To get to your spreadsheet from the edit form page, click the 
View responses button and select Spreadsheet. 

5. Organize feedback by student, subject, class, or date. 
o View the response spreadsheet and select and sort columns to view 

feedback for the same student/class/etc. 
6. Compile a list of feedback for each student 

o You can quickly filter the results for a single student if the name has been 
consistently entered for all the form data (one reason why you might want to 
consider a drop down menu for student names, so that the name is always 
consistent), using a combination of the filter function and the arrayformula 
function 

o For example, if your form questions use the columns C:L and you want to 
filter to show just the responses corresponding to Stephanie, you could use 
this formula: 
=FILTER(C:L,ARRAYFORMULA(C:C="Stephanie")) 

o Or if you were using this filter on a separate sheet, you would need to add 
the sheet reference: 
=FILTER(Sheet1!C:L, 

ARRAYFORMULA(Sheet1!C:C="Stephanie")) 

o This formula will only return the results in the sheet that belong to 
Stephanie. By specifying the entire columns, even if there are new form 
responses, the formula will still capture the data. 

7. Share feedback with student 
o After you have filtered the feedback for the student, you can copy and paste 

the list of relevant feedback into a separate spreadsheet. You might 
consider having one spreadsheet for each student that tracks the feedback 
for all assignments. You could also paste the feedback into a document and 
share it with the student. 

Check and submit assignments 



Forms can help teachers streamline assignment submissions and ensure that students 
have completed all parts of the assignments. Students will have to review a checklist 
before entering an assignment to be submitted.  
 
You can have a form for each assignment that collects all the student information, and 
then save each of the assignment spreadsheets in a folder for each class. You should 
then be able to easily find information by assignment for any class. 
 
Here‟s one way you can use forms as a way to check assignments before they are 
submitted: 

1. Create a new assignment submission form 
o From your Docs list, click the Create new button, then select Form. 
o From a spreadsheet, click the Form menu and select Create a form. 
o From any other doc, click the File menu and select New then Form. 

2. Add and arrange questions by clicking the Add item button at the top of the 
editing page. 

o Include class and student information for sorting and reviewing later such as 
name, class period, subject, assignment # etc. It is helpful to have drop 
down menus for entries like class periods and subjects. This will make 
sorting your spreadsheet easier because they are set values that students 
will not misspell or forget. 

o Include a checklist for the parts of the assignment you wish to confirm they 
have completed before you grade, like running spell-check. 

o Include any other questions you wish to make sure students review before 
completing an assignment 

o Include a text box for the student to paste in the URL to the assignment (in 
Google Docs) 

3. Make the form available to students: 
o Email the form to your class list or individuals by selecting the Email this 

form button and entering in email addresses. Or select the Send form 
option from the Form menu in your response spreadsheet. 

o Embed the form on your class site. You could include different forms for 
each individual assignment, create forms for types of assignments, or have 
one general assignment form. Depending on the type of form, you might 
place it in different parts of your site. 

 From the form, go to the More actions button and selecting Embed. 
Copy and paste the code into your site. From the response 
spreadshet, go to the Form menu and select Embed form in a 
webpage.... 

o Embed the form in a Google Site by going to your site, clicking the Insert 
menu and selecting Form. Pick your form from the list. 

o Share the direct link to the form (you can then create a shortlink using a 
URL shortner to bookmark) Find the URL in your response spreadsheet by 
clicking the Form menu and selecting Go to live form. Copy the URL of the 
new window. To get to your spreadsheet from the edit form page, click the 
View responses button and select Spreadsheet. 

4. Organize feedback by student, subject, class, or date. 
o View the response spreadsheet and select and sort columns to view 

feedback for the same student/class/etc. 
5. Organize assignment spreadsheets in your Docs list. 



o Create a folder for each class and place the appropriate assignment 
spreadsheet. If you save your spreadsheets by a convention such as 
Date_AssignmentNumber_Class, you can easily find assignment 
information. 

Log reports and information into a single database 
The structured setup of forms makes it easy for teachers to log information into a shared 
database that everyone can search and access. Forms can be filled out anywhere - 
embedded on a website, viewed in an email or published URL, or even on a mobile 
device - allowing teachers the convenience to log this information immediately. 
 
For example, you could create a form and response spreadsheet for school-wide student 
behavioural logs. Teachers could access a single form and file a structured log that is 
added to the spreadsheet database. Each Google Spreadsheet can store up to 200,000 
cells of information. For a row with ten pieces of information (such as first name, last 
name, ID, year, teacher name, subject, period, type of log, log report, and notes), a 
single spreadsheet could store 20,000 students logs. Teachers could then open the log 
and search or filter for a specific student to have relevant information from all the other 
teachers on hand for evaluations or parent teacher conferences. School administrators 
would then also be able to easily analyze the log reports and track patterns. 
 
Here‟s one way you can use forms to create a student log database: 
 

1. Create a new peer review form 
o From your Docs list, click the Create new button, then select Form. 
o From a spreadsheet, click the Form menu and select Create a form. 
o From any other doc, click the File menu and select New then Form. 

2. Add and arrange questions by clicking the Add item button at the top of the 
editing page. 

o Include questions for items that would make it easy to find information in a 
database such as student contact information, ID numbers or usernames, 
teacher and class information.  

o Include drop-downs for the type of log reports - useful for sorting in the 
spreadsheet. 

o Include a text type question for reporting the log, as well as a paragraph 
type for adding additional notes. 

3. Make the form available to teachers: 
o Email the form to the list of faculty (i.e. faculty@myschool.org) that they can 

star and search for in their Apps mail account. 
o Embed the form on your faculty intranet site that is only accessible to 

teachers that are signed into Apps. On a Google Site, click the Insert menu 
and select Form. Pick your student log form from the list. 

o Include the direct link to the form in a faculty handbook document that is 
shared with all faculty. Find the URL in your response spreadsheet by 
clicking the Form menu and selecting Go to live form. Copy the URL of the 
new window. To get to your spreadsheet from the edit form page, click the 
View responses button and select Spreadsheet. 

4. Organize feedback by student, subject, period, teacher, log type, or date. 
o View the response spreadsheet and select and sort columns to view 

feedback for the same student/class/etc. 



5. Compile a list of feedback for each student - useful if evaluating the activities of a 
single student 

o Create a separate tab that is used for teachers to filter information from the 
primary database, such as “Filter for a single student.” 

o The easiest way to identify students would be by an ID or a username 
o For example, if your log information was entered in columns C:L, where the 

student ID or username is in column C and you want to filter to show just 
the responses corresponding to student123, you could use this formula: 

=FILTER(C:L,ARRAYFORMULA(C:C="student123"))or if you wanted 

to compare for First and last name  
o Or if you were using this filter on a separate sheet, you would need to add 

the sheet reference: 
=FILTER(Sheet1!C:L, 

ARRAYFORMULA(Sheet1!C:C="student123")) 

o This formula will only return the results in the sheet that belong to 
student123. By specifying the entire columns, even if there are new form 
responses, the formula will still capture the data. 

File and track school-wide requests 

Forms can bring transparency and organization to administrative processes in a school.  
 
For example, instead of filling out paper requests that could potentially be lost en route 
to the correct department (IT, library, central office), a teacher could submit an online 
form that feeds directly into a spreadsheet. Administrators can then update the 
spreadsheet with the status of the requests and share it with all the faculty so they can 
track the progress as well.  
 
Here‟s one way you can use forms to track and receive school-wide requests: 
 

1. Create a new request form 
o From your Docs list, click the Create new button, then select Form. 
o From a spreadsheet, click the Form menu and select Create a form. 
o From any other doc, click the File menu and select New then Form. 

2. Add and arrange questions by clicking the Add item button at the top of the 
editing page. 

o Include questions to identify the requestor - name from a drop down, 
class/building/school. 

o If the form is for multiple types of requests, create a drop down or multiple 
choice question to select the request type. 

o Include additional information to evaluate the urgency of the request - date 
needed by, severity of issue, etc. 

o Add “help text” to the questions to provide more context or examples of the 
types of answers you‟re looking for. 

3. Add section headers to organize your exam by clicking the Add item button at the 
top of the editing page and selecting Section header. Enter the section header 
and a description. 

o You could include headers like “Request type,” “Contact information.” 
4. Make the form available to students: 



o Email the form to your class list or individuals by selecting the Email this 
form button and entering in email addresses. Or select the Send form 
option from the Form menu in your response spreadsheet. 

o Embed the form on your class site in a common “Peer review” section 
where students can always access. From the form, go to the More actions 
button and selecting Embed. Copy and paste the code into your site. From 
the response spreadshet, go to the Form menu and select Embed form in 
a webpage.... 

o Embed the form in a Google Site by going to your site, clicking the Insert 
menu and selecting Form. Pick your form from the list. 

o Share the direct link to the form (you can then create a shortlink using a 
URL shortner to bookmark) Find the URL in your response spreadsheet by 
clicking the Form menu and selecting Go to live form. Copy the URL of the 
new window. To get to your spreadsheet from the edit form page, click the 
View responses button and select Spreadsheet. 

5. Organize feedback by student, subject, class, or date. 
o View the response spreadsheet and select and sort columns to view 

feedback for the same student/class/etc. 
6. Compile a list of feedback for each student 

o You can quickly filter the results for a single student if the name has been 
consistently entered for all the form data (one reason why you might want to 
consider a drop down menu for student names, so that the name is always 
consistent), using a combination of the filter function and the arrayformula 
function 

o For example, if your form questions use the columns C:L and you want to 
filter to show just the responses corresponding to Stephanie, you could use 
this formula: 
=FILTER(C:L,ARRAYFORMULA(C:C="Stephanie")) 

o Or if you were using this filter on a separate sheet, you would need to add 
the sheet reference: 
=FILTER(Sheet1!C:L, 

ARRAYFORMULA(Sheet1!C:C="Stephanie")) 

o This formula will only return the results in the sheet that belong to 
Stephanie. By specifying the entire columns, even if there are new form 
responses, the formula will still capture the data. 

7. Share feedback with student 
o After you have filtered the feedback for the student, you can copy and paste 

the list of relevant feedback into a separate spreadsheet. You might 
consider having one spreadsheet for each student that tracks the feedback 
for all assignments. You could also paste the feedback into a document and 
share it with the student. 

» Chapter 7: Drawings 
Drawings in the classroom 
With Google drawings, you can create and collaborate on flow charts, design diagrams, and other types of 
drawings. You can also chat with other editors from within Google drawings, publish drawings as images, or 
download drawings to your computer.  
Mind Maps 



 
 
Graphical organizers 

 
 
Labelling activities 

 
 
Timelines 



 
Create a new drawing 
There are a number of ways to get started on a new Drawing in Google Docs.  
 
Start in the Docs List 
To get started on a new drawing go to your Docs list, click Create new and select Drawings 

 
 
Alternately, you can begin a new drawing from inside an existing document by going to File > New > Drawing 

 
 
You can also find user submitted templates for drawings in the public Template Gallery and in the gallery for your 
Apps for Education domain, if your domain administrator has enabled that feature. 

Revision history 
Likes Docs and Spreadsheets, Google Drawings has a revision history pane that allows you to view at a glance all 
changes made to a doc by each collaborator.  
To access revision history in Google documents, drawings, and spreadsheets, follow these steps: 



1. Select File > See revision history.  
2. Click a time stamp in the right column to see what changes were made at a given time or use the arrow 

keys to scan through many revisions quickly. For example, James, whose edits show in orange text, 
deleted and added text while bmichael, whose show in green text, removed a paragraph and added a 
comment.  

 
3. If you'd like to revert to the version you're currently viewing, click Restore this revision. Please note: 

Restoring your document to a previous version does not eliminate any versions of your document. Rather 
this version moves to the top of your revision history, maintaining all previous versions of your document, 
including the current version.  

 
4. If you'd like to return to the the current version of your document to continue editing, click the X in the upper 

right of the 'Document History' pane. 
For all Google Docs types, revisions are grouped into short time periods to make it easier to see the full history of 
changes. If you want to see more fine-grained revisions, click the Show more detailed revisions button in the lower 
right of your document. 

Edit drawings 
» Menu overview 
The menu options and the buttons in the Drawing toolbar provide users with the ability to create flow charts, design 
diagrams, and other types of drawings. 
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Edit 
Click this drop-down menu to cut, copy, paste, duplicate, and change a shape.  
 
 

 
 
Insert 
Use this menu to insert lines, arrows, scribbles, polylines, text boxes, and images. You can also click the individual 
buttons in the toolbar to do this.  
 
 

 
 



 
Once you select an option, follow these instructions: 

 Line: Click to place one end of the line, and drag to the other end. 

 Arrow: Click anywhere to place the end of the arrow, and drag to add the arrowhead. 

 Scribble: Click to choose your start point, and drag to create the scribble. It will be automatically smoothed 
out once you've finished.  

 
 Polyline: Add continuous lines composed of multiple segments by drawing a segment of your polyline, 

clicking to end the segment and beginning your next segment. Learn more about using polylines. 

 Word art: After selecting this option, type your text and press Enter. 

 Text box: Click where you'd like to add the text box, enter your text, and press Enter. Your text will be 
added to your drawing. Use text boxes instead of word art if you'd like to use word wrap or specify a 
different text size. . 

 Image: Enter a URL of an image or do an image search to find what you're looking for, and click Select. 
Learn more aboutadding images to your drawing. 

 
Format 
Click this menu to change the background of your drawing, align and rotate items, select snap to grid or snap to 
guide, change the order of the items (for example, bring a shape forward), and group items. Learn more 
about formatting your drawings. 
» Toolbar buttons 

 
 

 
Undo or redo changes 
You can undo and redo changes by clicking the two arrows to the left side end of the toolbar. 
 

 
Zoom in and out 
To zoom in and out on your drawings, click the Zoom button (the magnifying glass) in the toolbar. 
 

 
Shapes 
Select a shape from the Shape menu in the toolbar. Then, click anywhere in Google drawings to insert the shape in 
the default size, or drag your mouse to change the size of the shape. 

 
Customizing text with Word Art 
Create word art by clicking the Shape menu and selecting Word Art (the letter "T" in the second row of shapes). 
Then, type your text and press Enter. Learn more about using text in Google drawings. 
All of the shape editing options are available with word art, so you can rotate, choose fill and line color, and change 
line width. 
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Fill color, line color, line width, edit text, bold, and more 
These and other editing options are available only when you've selected a specific item. For example, when you 
insert a text box or word art, you'll see the Edit text button at the right end of the toolbar. Click it to change the 
selected text. 
 
Please note: To duplicate a shape, just hold the Ctrl key (Command key for Macs) while dragging the shape. 
Add images 
To insert an image into your drawing, follow these steps:  

1. Click Insert > Image..., or click the Image button in the toolbar.  

 
2. In the window that appears, you can choose one of these options: 

o Click Upload and navigate to the image from your hard drive that you'd like to insert. Choose this 
option for images you have stored on your computer.  

 
o Click URL and paste the web address of the image you'd like to insert. Choose this option if you 

already have an image you'd like to add. 
o Click Google Image Search, type a word and click Search images. Once you find a result you like, 

click the image. Keep in mind that there are specific usage rights that apply. Select only images 
that you've confirmed you can use legally in your intended context, and make sure you include 
appropriate attribution if necessary. 

o Click Picasa Web Albums to access image files you have uploaded to Picasa on the web. 
3. Click Select. 

After inserting the image into your drawing, you can add scribbles, shapes, lines, arrows, and text boxes on top of 
the image. 
You can resize the image by dragging one of the resize (white) handles, and the image will expand and contract 
with your cursor's movement. Images can be resized to scale by holding the Shift key while dragging a corner 
resize handle. To flip an image, click Format -> Rotate, and select one of the options available  

 
Snap to guides 
Snap to guides allows you to align objects with the drawings canvas and other objects. With this option enabled, 
guides appear whenever you move an object into alignment with the border of another object. These guides also 
appear when you move an object to the horizontal or vertical center of the drawings canvas. 
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To enable snap to guides, right-click in the drawings canvas and select Snap to guides, or click Format > Snap to 
guides. 

 

 
 
You can quickly move, drag, resize and rotate objects using keyboard modfiers when performing other actions. 
Polylines 
Polylines are continuous lines composed of multiple segments. To create them, click the Polyline button from your 
drawings toolbar, to the left of the Text box button. 
 
After drawing a segment of your polyline, click to end the segment and begin your next segment. If you want to 
cancel the last segment and go back to selection mode, press Escape on your keyboard. When you've finished, 
connect the endpoint of your last line segment with the origin point of your polyline to create an enclosed shape. 
Alternatively, click near the endpoint of your last line segment to complete the shape. 
 
When you're done drawing the polyline, you remain in polyline mode so you can immediately draw another one. 
Press Escape to return to selection mode. 
 
If you'd like to rearrange the vertices, double-click the polyline. 
Lines, arrows, and scribbles 
Lines, arrows, and scribbles are continuous lines composed of one segment. To create them, click either the Line, 
Arrow, or Scribble button from your drawings toolbar, to the left of the Text box button. 
 
After choosing which object you‟d like to draw, position your mouse and click in the drawing canvas where you‟d 
like the object to begin, move your mouse to draw, and then click to end the segment. 
 
After you have finished drawing, you can click in the canvas again to start drawing another line of that type. If 
you‟re done, you can press the Esc key or select another tool to deselect your object. 
 
When you have a line, arrow, or scribble selected, three buttons appear toward the end of the toolbar that allow 
you to change the style of the line or the endpoints. Click the buttons and select an option from the drop-down 
menus to apply that style to your object. 
Keyboard modifiers  
If you love shortcuts, then you‟ll love the keyboard modifiers in Drawings. There are many useful features available 
if you use keyboard modifiers when performing other actions. Here are some examples: 
 
Moving or dragging 

 Turn off guides or snap to grid and smoothly drag your object: hold the Alt key (Option key if using Mac) 
while dragging an object. 
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 Restrict to vertical or horizontal dragging: hold the Shift key while dragging. 

 Nudge an object in 1 pixel increments: hold the Shift key while moving an object with the arrow keys. 

 Create a duplicate of an object while leaving the original in place: hold the Ctrl key while moving an object. 
Resizing 

 Preserve an object's aspect ratio while resizing: hold the Shift key while resizing an object. 
Rotating 

 Rotate in 15 degree increments: hold the Shift key while rotating an object. 
Line connectors 
Connectors are special lines that stay “glued” to shapes. When you move or rotate shapes that have connectors 
between them, the lines attached will move and stretch with them so the shapes stay connected. 

 
1. Click on the shape tool or go to Insert > Shape to select an object to insert into your drawing. 
2. If you want to use two of the same shape, select the shape, right click + Copy, right click + Paste it into 

your drawing. 
3. Click on the line or arrow tool. 
4. Hover your cursor over a shape, and red connection points will appear. 

 
5. Click on the red connection point that you want your line to connect, and drag your cursor to another 

connection point on a second shape before releasing. 
Please note: Curved and multisegment connectors are currently not supported. If you create your own shape using 
the polyline or curve tool, you will not be able to use line connectors with it. 

Format drawings 
» Move, resize, and rotate objects 
To move, resize and rotate an object, simply click the object you'd like to change. You'll see a green rotate handle, 
white resize handles, and yellow adjustment handles (where applicable). 
Moving objects 
Click any object to select it, then drag it with your mouse or arrow keys. You can hold the Shift key while dragging 
to constrain the movement to the nearest horizontal or vertical axis. You can hold the Shift key while moving with 
the keyboard to move the object by one pixel. 
Snap to Guides is enabled by default in the full editor. Snap to grid is enabled by default in the embedded editor. 
The option Snap to grid allows objects to automatically align to an invisible grid or to other objects when moved, 
resized, or inserted. Click Format > Snap to grid to disable this option, or hold down the Alt key to temporarily 
disable it. 
Resizing objects 
Drag one of the resize (white) handles, and the object will expand and contract with your cursor's movement. 
Objects can be resized to scale by holding the Shift key while dragging a corner resize handle. To flip an object, 
drag a resize handle to the opposite side. 
Reshaping objects 
Objects that can be reshaped will include yellow handles. Drag the adjustment handle(s) to change the appearance 
of your object. 
Rotating objects 
Drag the rotate (green) handle to rotate the object. Hold the Shift key while rotating to constrain the rotation to 15 
degree increments. 
Right-click an object and select Rotate to rotate objects at 90 degree increments and flip them horizontally or 
vertically. 
To move, resize or rotate multiple objects at the same time, hold down the Shift key while you click each object. 
You can also drag your mouse in the drawing background to select multiple shapes. 
If you're in the process of manipulating an object and change your mind, you can cancel any action by pressing the 
Esc key prior to releasing the mouse button. 
See more details about keyboard modifiers. 
Format drawings 
Add text 
Copy formatting with paint format 
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Upload multiple versions of a file 
You can upload different versions of the same file to your Documents List and 
easily keep track of them by selecting the Add or manage versions... option 
(or View versions... if you have viewing permission only). 
This feature lets you upload new versions of a file, as well as download 
previous versions of it, and delete older versions. It makes it easier overall to 
collaborate on a file with other people. Each version counts toward your total 
Google Docs storage quota, so you should clean out older versions every once 
in a while. 
This feature is available for uploaded files that are not in Google Docs format. 
For Google Docs, you can use the revision history, which lets you see all the 
different versions of a doc. 
To upload a new version of your file, right-click the file name and select Add or 
manage versions.... You can also select the file and go to the More drop-
down menu to find this option. You'll see this dialog box: 

 
Here's what you can do once you've clicked Add or manage versions...: 

  See at a glance the different uploaded versions, when they were 
uploaded, their file size, and which one is the most current version. 

 Point your mouse to a version to see its file name. 
 Click any file to download it. 
 Upload additional versions of this file (owners and editors only). 
 Click the “x” to delete one of the versions (owners and editors only). 

File details page 

You can also view and download previous versions of a file by accessing 
the file‟s details page. To get there, select an item in your Documents List, and 
click the Eye icon above your list of items. On the right hand side of the page, 
you‟ll see all the previous versions of the file under Versions. 

http://support.google.com/docs/bin/answer.py?answer=190843
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Sharing settings 

Only the owner or editors can upload a new version of a file or delete prior 
versions. Those with view access can download all versions of a file, but 
cannot upload new versions or delete older ones. If you want to contact the 
owner of a file to request edit rights, you can see who the owner is by looking 
at the details pane for the item. 
Error messages 

Sorry, there was an error when 
uploading your file. 

There are several reasons that you might not be able to upload your file. 
Please check that: 

 The file is less than 1 GB. 
 It's a supported format. 
 You have available storage space. (You can check this in your 

Document Settings.) 
 Your Internet connection hasn't been interrupted. 

Then try uploading the file again. 

Sorry, we were unable to delete the 
selected version at this time. 

Somebody else may have already deleted the selected revision. Please 
select Add or manage versions... again and verify if the file is still there. 

Add images to your drawing 
To insert an image into your drawing, follow these steps: 

1. Click Insert > Image..., or click the Image... button in the toolbar. 
2. In the window that appears, you can choose one of these options: 

o Click Upload and navigate to the image from your hard drive that 
you'd like to insert. Choose this option for images you have stored 
on your computer. 
In order to insert an image, it must be: 

 a .PNG, .JPEG or .GIF (no animated GIFs) file 
 Max 2000 pixels in each dimension 
 Max 2MB 

o Click URL and paste the web address of the image you'd like to 
insert. Choose this option if you already have an image you'd like to 
add. 

o Click Google Image Search, type a word and click Search images. 
Once you find a result you like, click the image. Keep in mind that 
there are specific usage rights that apply. Select only images that 
you've confirmed you can use legally in your intended context, and 
make sure you include appropriate attribution if necessary. 

3. Click Select. 
You can also drag-and-drop an image into your drawing from your computer 
into a drawing. Once you drag-and-drop the image, it'll appear in your drawing. 
After inserting the image into your drawing, you can add scribbles, shapes, 
lines, arrows, and text boxes on top of the image. 
You can resize the image by dragging one of the resize (white) handles, and 
the image will expand and contract with your cursor's movement. Images can 
be resized to scale by holding the Shift key while dragging a corner resize 
handle. To flip an image, click Format -> Rotate, and select one of the options 
available. 

http://support.google.com/docs/bin/answer.py?answer=50092
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Optical Character Recognition (OCR) lets you convert images with text into text 
documents using automated computer algorithms. Images can be processed 
individually (.jpg, .png, and .gif files) or in multi-page PDF documents (.pdf). 
These are some of the types of files suitable for OCR: 
Image or PDF files obtained using flatbed scanners 
Photos taken with digital cameras or mobile phones 

Revision history 
Google Docs has a revision history pane that allows you to view at a glance all 
changes made to a document by each collaborator. While it may not work 
exactly like a track changes tool, Google Docs revision history lets you view 
and revert to earlier versions of your doc, and see which collaborators made 
edits to each of these versions. 
To access revision history in Google documents, presentations, drawings, and 
spreadsheets, follow these steps: 

1. Select File > See revision history. 
2. Click a time stamp in the right pane to see a previous version of the 

document, edited by the collaborators listed below the time stamp. Any 
changes made by a particular collaborator will be shown in the body of 
the document in the color assigned to that individual in the revision history 
pane. For example, James, whose edits show in orange text, deleted and 
added text while bmichael, whose show in green text, removed a 
paragraph and added a comment. 

 
3. If you'd like to revert to the version you're currently viewing, clickRestore 

this revision. 
Note: Restoring your document to a previous version does not eliminate 
any versions of your document. Rather this version moves to the top of 
your revision history, maintaining all previous versions of your document, 
including the current version. 



 
4. If you'd like to return to the the current version of your document to 

continue editing, click the X in the upper right of the 'Document History' 
pane. 

For all Google Docs types, revisions are grouped into short time periods to 
make it easier for the user to identify the slight differences between previous 
document versions. If you want to see more fine-grained revisions, click 
the Show more detailed revisions button in the lower right of your document. 
Google spreadsheets sometimes trims down your revisions over time to save 
storage. If you're working in Google spreadsheets, and your document is either 
large or you created it a long time ago, your revisions may be pruned. Visit 
the Revision Pruning help article to learn more about this process. 
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