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bundled offers in which this ebook is included.

Quick and Easy Tutorials that enable you to discover the wizardry of the
Menus and Plugins in GIMP.

These lessons are designed to be read just like a normal book. They follow
a sequence which may be useful to you as a photographer.

Have Gimp and this book open together, on your desktop, and jump
between the two to practice the simple lessons and commit the skills to
your memory.

Alternatively, you can print the entire book, 83 pages, or print just those
pages that you need.

Have fun and enjoy your voyage of discovery.

Download practice photos from:
http://www.gimp2tutorials.info/downloads.htm
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GIMP has many tools for quick and easy photo transformation. Even a mundane photograph
can be transformed to a beautiful and striking image.

GIMP is designed to be upgraded with plugins and extensions to do just about anything. This
advanced program allows you easily to perform everything from the simplest task to the
most complex image transformation techniques.

The GIMP Photo Editing

If you don’t have the GIMP on your computer, or you have an earlier version of the program,
you need to download the latest version of the program, Gimp 2.8.4 or later. This is a
considerable upgrade from earlier editions.

The link is: http://www.gimp.org/downloads/
This is the Windows XP (SP3), 2000, Vista, Windows 7 and 8 update.

Mac users have their own program available here:
http://www.macupdate.com/app/mac/14597/gimp

The menus we’ll commonly use in
this book are the Colors menu
and the Filters menu.

The Colors menu supplies you
with lots tools, known as dialogs
because you may select from
many options within most of the
tools.

The Filters menu lists all the
plugins which come pre-installed
with your GIMP program.

Plugins are small programs that
work within GIMP to increase the
programs functionality.

You may add further plugins to
GIMP whenever you wish. Where
to find these plugins and how to
install them is explained in this
book.

Here are the menus, on the left,
which you’ll discover among the
menus at the top of your GIMP
interface (work area).

Some tools (not all) have hefty explanations of: presets, sliders, channels and what
have you within a tool. This is useful knowledge but overwhelming until you know how
the tool works. Skip over the list of stuff, if necessary, and concentrate on the
explanation and practice session that enables you to put the tool to work. When you
know how to use the tool the list of functions becomes clear and useful.
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Color Balance Tool
Go to Colors/Color Balance folder for a small selection of work photos. Select and work with
each one in turn. Go to the Colors menu and select 'Color Balance' at the top of the menu a
box (dialog) will open. (See the image below) Tick the boxes 'Preview' and 'Luminosity' if
not already ticked (default). Select the 'Shadows' option.

Butterfly: by Joydeep [CC-BY-SA-3.0 (http://creativecommons.org/licenses/by-sa/3.0)],
via Wikimedia.

Now study your photo and decide what needs to happen to the colors.

For example: the whites may have a blue tint (cold) or they may have a yellow or even red
tint (warm). We'll balance the white color. Let's assume our photo's white areas show a hint
of blue. We need to warm that up to restore true white. Click on the sliders of the warm
colors: red, magenta and yellow. Now drag each slider a very short distance towards the
warm color name. You may need to play with the sliders until you get close to white.

Maybe your picture looks too warm, click and drag the sliders toward ‘Cyan', 'Green' and
'Blue'. Don't drag the sliders too far, too fast; this will corrupt the colors in your photo.
More often than not, you only need to move the sliders in very small increments to remove
a color cast. If you make an error, click the "Reset" button and start over again.

Perhaps your colors are neither warm nor cold you would just like to boost the colors
generally. Study your colors; which color needs to be boosted the most? If it's red, move
the slider gently towards red until the color improves. Repeat with yellow and magenta to
add a little support. If that blue sky could be bluer add a little blue. You know what to do
with green grass and green leaves.
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If the 'Shadows' option did not work for you, go to the 'Midtones' option and make your
adjustments. The 'Highlights' option may help you to lift dull highlights or tone down too
bright whites. It's all about balancing your six colors to get the look you need. By the way,
it's not necessary to click OK between Shadows, Midtones, and Highlights.

When your photo is as good as you can get it, click OK. But maybe one color did not come
to life because it was competing with its opposite color. We'll take care of that. Go to the
Colors menu and select Color Balance again. Now choose the color that needs more work
and bring that color to life. You can repeat the process as often as you want. Work on your
technique and add punch to those colors.

The Color Balance Tool can be very useful, however, it is not the most useful tool in GIMP.
There are many other instruments that are more powerful and precise. Color Balance is
handy to have as long as you know how to use it, occasionally it will be your tool of choice.

The snow on the left has a blue cast.     White snow on the mountains on the right
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Hue & Saturation Tool
Hue-Saturation Tool Practice

The Hue and Saturation dialog is a versatile tool that enables you to change and/or
enhance the colors in a photograph. This means that you need to study your photo and
decide which individual colors you wish to improve. Alternatively, you may wish to saturate
all the colors, or dilute all the colors in your image.

By the way, not all monitors and laptops show colors on the screen in the same way. The
figures given in this tutorial are approximate so don't hesitate to adapt the numbers to suit
your screen.

Go to the Colors/Hue-Saturation folder and open the image 'ville-france-5.jpg'. Go the
Colors menu and select 'Hue-Saturation'. The Hue-Saturation dialog box will open. Click
and drag the box to the right, by the Hue-Saturation title, until you can see the houses in
the photograph.

Check that the ‘Preview’ box has been ticked. Click the Red button next to the red color
block. Go to the 'Saturation' slider and move the slider to the right until the input box reads
35. (See image below.) Notice how any color with red in it has become more vibrant: roofs,
one or two houses, and a few balconies are where the color changes are obvious. If you did
not notice the change, hit the 'Reset Color' button under the saturation input box and do
the example again.

Now repeat the above example first with the color 'Blue' and the Saturation slider at 35;
and again with the color 'Green' at 45. Your image should now be bright and vibrant. If you
wished to keep this photo you would click the OK button - but not yet. Go to the bottom
row of buttons and click 'Reset'. Your colors will return to their original hues.
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The next exercise will help you to understand the 'Overlap' slider. Click the Red button.
Drag the Overlap slider until the input box reads 50. Go to the 'Hue' slider and drag it to
the right until the input box reads 20. (See image below.) Notice how the color Yellow has
overwhelmed the reds in the photo. Not good. Hit the 'Reset Color' button under the
Saturation input box.

What happened? When the Hue slider was moved to the right the Overlap control allowed
too much yellow to flow into the image. This means that when you move the Hue slider to
the right, the Overlap control allows the next color to red to flow in from a clockwise
direction (Yellow flows into Red). Because the Overlap slider was set to 50 we get way too
much yellow.

Drag the Overlap slider back to 5.  Go to the 'Hue' slider and drag it to the Left until the
input box reads -20 (Negative number). Notice how the color Megenta' has overlapped into
the reds. This means that when you move the Hue slider to the left, the Overlap control
allows the next color to red to flow in from an anti-clockwise direction (Magenta flows into
Red). Because the Overlap slider was set to 5 we get a managable amount of magenta.
Now reduce the Hue slider to -10; the rooftops look much more realistic.

Here's what you know about the Overlap slider: Click on any color and set the Overlap
slider to the amount you think you need. Move the Hue slider to the right and you allow
color to flow in from the next color only. The color comes from a clockwise direction. Move
the Hue slider to the left and you allow color to flow in from the next color only. The color
comes from an anti-clockwise direction. Practice using the Overlap slider to become expert
at introducing subtle (or way-out) color changes. When you understand how to use the
Overlap slider, click the 'Reset' button to return to the original image. The Overlap slider
will return to its start position.
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Click the 'Master' button in the center of the colors. Drag the Hue slider to the right and
then the left; you'll see that you get some pretty strange color changes. The Overlap slider
has no effect when the Master button has been clicked.

Go to the 'Lightness' slider, click the 'Master' button in the center of the colors. Drag the
'Lightness' slider to the right and all colors and shadows will be lighter (paler). Drag the
Lightness slider to the left and all colors have a deeper hue and shadows become darker.
The Overlap slider has no effect when the Master button has been clicked.

Click on any individual color and the Lightness slider will work in precisely the same way as
above but it affects that color only. The Overlap slider does blend overlapping colors when
used in conjunction with the Lightness slider.

Aggressive use of the Lightness slider may introduce color distortions: bright spots in an
unexpected color, vivid color deformations, and other unpredictable results.

Go to the 'Saturation' slider, click the 'Master' button in the center of the colors. Drag the
'Saturation' slider to the right and all colors become richer and more saturated. Drag the
Saturation slider to the left and all colors lose their hue until at -100 the photo as no colors
and becomes shades of gray. The Overlap slider has no effect when the Master button has
been clicked.

Click on any individual color and the Saturation slider will work in precisely the same way
as above but it affects that color only. The Overlap slider does blend overlapping colors
when used in conjunction with the Saturation slider.

When you understand the Hue and Saturation dialog, click OK to close the tool.
Save and/or Export your new image. Preserve the original for future practice.
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Hue & Saturation Tool - Functions
The Hue-Saturation tool is used to adjust hue, saturation and lightness levels on a range of
colors in your photo, or for a selected area, or an active layer.

Activating the Tool: Go to the Colors menu, select Hue-Saturation.

Hue-Saturation tool options:
Presets
You can save the color settings of your image by clicking the + (Add settings to favorites)
button. A Preset name box opens, give the preset a name and click OK.

Preset Menu
The Preset menu (the little triangle next to the +) allows you to Import Settings from a File
or Export Settings to a File; you also have access to the Manage Save Settings dialog:
Import settings; Export settings; Delete settings.

Select Primary Color to Adjust
To begin click on the button next to the color block you need to adjust. You can choose six
colors (Red, Green, Blue, Cyan, Magenta and Yellow) to be modified. You'll see the hue of
each color block change as you move the Hue slider. Move the slider slowly or you'll see
weird color changes.

Overlap Slider
This slider lets you set by how much the color ranges will overlap. This effect is very subtle
and works on very next colors only (before and after your chosen color block). Move the
slider slowly or you'll see strange distortions in the colors.
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If you click on the Master button, all colors will be concerned with changes (not just a single
color as when you chose a color block).

Adjust Selected Color
Hue: The slider and the input box allows you to select a hue in the color circle (-180, 180).
Beware of color corruption and/or distortions as you move the slider. A good tip is to move
the slider using the input box, with your image zoomed to as large as possible, to enable
you to see deformations as they appear.

Lightness: The slider and the input box allows you to enhance or dilute the luminosity:
-100, 100.

Saturation: The slider and the input box allows you to increase or reduce the saturation:
-100, 100.

Preview: Tick the Preview button to make all changes visible in your photo, selection or
layer as they occur.

Reset Color Button:
The first ‘Reset Color’ button, under the three input boxes, deletes all changes made with
the selected color block only.

Reset Button:
The ‘Reset’ button, next to the OK button, deletes all changes and restores your photo,
selection or layer to its original colors.

Click the OK button to confirm the changes to your image.
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Rescue Washed Out Color with Hue-Saturation
The problem of washed out colors is easy to solve. Go to the 'Colors' menu, select 'Hue-
Saturation'. Click 'Master’. Reduce the 'Lightness' slider, move to the left, to something that
darkens shadows and increases contrast (-30 approx). Slide the 'Saturation' slider to the
right until the colors are vibrant or realistic - your photo your choice. See below.
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Colorize Tool
The Colorize tool changes your photograph, an active layer or a selection to a one color
image.

Activating the tool: You can get to the Colorize tool in the Colors menu: select Colorize,

Colorize options

Presets: The Preset menu (the little triangle next to the +) allows you to Import Settings
from a File or Export Settings to a File; you also have access to the Manage Save Settings
dialog: Import settings; Export settings; Delete settings.

Select Color:

Hue: The slider and the numeric text box enable you to select a hue. This means change
the color of the entire image, layer, or selection.

Saturation: The slider and the input box permits you to increase or decrease the degree of
color saturation. Saturation means vividness or intensity.

Lightness: The slider and the text box enables you to increase the lightness or darkness of
the entire image, layer, or selection.

Preview: Tick the Preview button to make all changes visible in your photo, selection or
layer as they occur.

Before Colorize After Colorize

Colorize Selection
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Brightness & Contrast Tool
The Brightness-Contrast tool allows you to correct the brightness and contrast levels of
your photograph, an active layer, or a selection. Go to the Colors/Brightness-Contrast
folder and open the image: Italy_canal.jpg.

This instrument is simple to use and uncomplicated. The Brightness and Contrast tool is
ideal for quick and simple changes. This is not the best tool for images that require skill to
produce an impressive photograph. Load a photo of your choice into GIMP.

Activating the Tool: Go to the Colors menu and select Brightness-Contrast

Brightness-Contrast options dialog

Presets: You can save the color settings of your image by clicking the Add settings to
favorites button. The button opens a menu that allows you to Import Settings from File or
Export Settings to File, and gives you access to the Manage Save Settings dialog.

Brightness Slider: Drag the slider to the right and your picture becomes brighter but you
may see a loss of sharpness and what appears to be a slight fogging over the details. Drag
the Brightness slider to the left and your picture gets darker.

Contrast: Drag the slider to the right, after adjusting Brightness, and the contrast
increases (the photo may appear brighter). This often increases the appearance of
sharpness and dispels the slight fogging. Drag the Contrast slider to the left and your
picture becomes duller and may develop fogging.

Edit these settings as Levels: This is where GIMP gets really clever; this bar takes you to
the Levels tool with the same settings.

Preview: The Preview check box allows you to see the effect of your new settings
instantly.
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The Threshold tool transforms your photograph, the current layer or a selection into a stark
black and white image. The Threshold tool can show where your photograph has over-
exposed (blown-out) areas; plus under-exposed (black areas without detail).

You can use it to enhance a black and white image (a scanned text for example) or to
create selection masks.

Note: As this tool creates a black and white image, the antialiasing of the original image
disappears.

Go to the Colors/Threshold folder and open the image ‘threshold-work.jpg’. This photo will
enable you to follow the tutorial in GIMP, or you may use an image of your own choice.

Threshold Tool

Activating the Tool
Go to the Colors menu and select 'Threshold'.

Threshold tool options
Presets
You can save the settings of your image by clicking the + (Add settings to favorites)
button. A Preset name box opens, give the preset a name and click OK.

Preset Menu
The Preset menu (the little triangle next to the +) allows you to Import Settings from a File
or Export Settings to a File; you also have access to the Manage Save Settings dialog:
Import settings; Export settings; Delete settings.

Sliders (See above)
There are two sliders, a black slider in the center and a white slider at the extreme right of
the dialog.
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Sliders in Use
Load your image into GIMP. Move the black slider to the extreme right and you image will
convert to black except for any white areas; these areas show you the precise location of
over-exposed pixels. These blown-out areas are often bright white in your photograph,
however other colors may also appear over-exposed. For example: bright orange is prone
to show up in the Threshold dialog.

Move both the black slider and the white slider individually to the extreme left of the
Threshold dialog. The image will appear black except for any under-exposed areas, which
appear white.

Now that you know if your photo has blown-out highlights and/or under-exposed areas:
dark shadows, black areas, night skies, etc., you may opt to correct the problem.
(Obviously not all dark areas need to be corrected. It may be your intention to have dark
areas in your photo.)

Click the cancel button to close the Threshold tool and return to your photo.
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Open the Levels tool, check the histogram, and adjust the input sliders to improve your
photograph. Now adjust the white Output slider by a small amount to rescue the white
blown-out areas. Adjust the black Output slider by a small amount to add detail to the
under-exposed shadow and black areas, if required.

Levels Tool
The Level tool enables to you change the vividness of your photo. Plus, you can make your
image lighter or darker, adjust the  contrast, or remove a color cast. In short, the Levels
functions offer an easy way to improve a picture. Go to the Colors/Levels folder and open
the image: ville_france-work.JPG

Don't be confused when you open the Levels dialog, in reality it is a very simple tool to use.

The Input Levels show a black graph (the histogram) and below are three sliders: black on
the left, gray in the center, and white on the right. Move the left and right sliders in to
touch the edge of the histogram. The black slider now ensures that your photo has pure
black tones. The white slider ensures that your image has pure white tones. However,
moving the both black and white slider slightly away from the histogram may help to keep
details in your photo and maintain contrast. The middle slider, when moved to the left
lightens the image, move it to the right and your image darkens. The Input Levels sliders,
used in combination, boost the appearance of your photograph.

The Output Levels slider are also useful. Move the white slider to the left to lower the
brightness of over-exposed white pixels. Move the black slider to the right to lighten under-
exposed black pixels. Take care because the Output Levels also lowers the contrast of the
image. This means that you must balance the use of all the sliders to make your image
colorful and attractive to the viewer.
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There is an excellent video tutorial that explains more about the Threshold tool. Go to this
link: http://www.youtube.com/watch?v=aYFaIrlfYlo

http://www.youtube.com/watch?v=aYFaIrlfYlo
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Levels Tool - Functions
The Levels tool provides features similar to the Histogram dialog but can also change the
intensity range of the active layer or selection in every channel. This tool is used to make
an image lighter or darker, to change contrast or to correct a predominant color cast.

Activating the Tool: Go to the Colors menu and select 'Levels'.

Level tool options
Presets: You can save the color settings of your image by clicking the + button (Add
settings to favorites). The Preset Menu allows you to Import Settings from a File or to
Export Settings to File. You also have access to the Manage Save Settings dialog.

Channel: You can select the specific channel which will be modified by the tool:

Value Channel: This channel makes changes to the value of all RGB channels in the
image: the image becomes darker or lighter.

Red, Green and Blue Channels: Select your color channel and your image gets more or
less of that color. Remember that adding or removing a color will also add or remove the
complementary color.

Alpha Channel: works on semitransparent layers or selections only: here, dark means
more transparency, and white is fully opaque. Your image must have an Alpha Channel,
otherwise this layer option is disabled.

Reset channel button: cancels changes to the selected channel.
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The Logarithmic and Linear buttons in the Levels dialog offer alternative Histograms.
Most users prefer the default Linear histogram.

Input Levels: The main area is a black graphic representation of the image, active layer,
or selection. Dark areas (Shadows) are on the left, midtones are in the center, and the
lightest tones (Highlights) are on the right. This representation is known as a Histogram.
The pixel range extends from 'Level' 0 (black) to 'Level' 255 (white). A well balanced
photograph has levels spread across the whole Histogram.

Levels (dark tones, midtones, and highlights) ranges can be changed in three ways: There
are three triangles as sliders: one black for dark tones (Shadows), one gray for midtones
(Gamma), one white for light (Highlight) tones.

The black slider determines the black point : Select the Value channel, drag the black slider
to the left edge of the Histogram.

The white slider determines the white point : Select the Value channel, drag the white
slider to the right edge of the Histogram.

The gray slider determines the mid point. Going to the left, to the black, makes the image
lighter. Going to the right, to the white, makes the image darker. You can see the changes
in your image.

The three numeric text boxes allow you to enter values directly. The numbers will change
as you move the sliders.
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Auto button: Performs an automatic setting of the levels. It's worth trying but it does not
always give an acceptable result.

Three Eyedroppers: This is an alternative adjustment method. The three eye-droppers:
when you click each one in turn the mouse pointer becomes an eye-dropper. Click on the
first eyedropper and find the blackest black in your image. Click on the black to set the best
black point. Click on the end (right) white eyedropper and find the brightest white in your
image. Click on the white to set the best white point. The center eyedropper is for the best
gray in your photo. This can be difficult to find; get it wrong and the colors in the image
look horrible. The Input Levels sliders discussed above are much more reliable.

Output Levels: May be used to lighten or darken shadows (dark tones), or change the
balance of bright and dark tones. Move the black slider to the right to lighten shadows (or
select a color channel to brighten the chosen color and increase its opacity). Move the white
slider to the left to lessen lightness of your image (or select a color channel to lessen the
chosen color and decrease its opacity). The histogram has been squeezed: contrast is
reduced; shadows are made lighter. New details are seen in the shadows but contrast is
less; a compromise may be necessary. Highlights can also be made darker. Output Levels
give you direct control of your histogram, and allow you to set how black your blackest
areas are and how white your highlights should be. Moving the white slider to the left
removes white pixels. Move the black slider to the right and dark pixels become a lighter
shade. By combining the sliders of Input Levels and Output levels, hidden details can be
cajoled out of even obstinate images.

Edit these settings as Curves: To fine tune your work this bar gives you immediate
access to the Curves tool while preserving your settings. (Do not click OK before accessing
the Curves tool because you’ll lose your histogram ‘Value’ line settings.)

Preview: Tick the Preview button and see all changes in your image as they occur.

The Reset button cancels all settings and restores your image to its original state.

Click OK to confirm your changes.
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The GIMP 'Curves Dialog' is probably one of the most innovative tools available in any
photo editing software. It enable you to change the brightness, darkness, saturation,
shadows, contrast, colors, and transparency of most of your photographs.

It will also process, as above, any layer you activate or any selection you choose to make
with any GIMP selection tool. The Curves tool even enables you to adjust the tonal range of
your image. It processes all RGB images saved in almost any format.

To make the most of the 'Curves' tool we need to see how it performs its various functions.
Here's a quick and easy run down on how to make the most of Curves. First, we'll take a
look at the Histogram.

1. The 'Histogram' within the Curves tool is shown in pale grey, maybe this is the reason
why it is often overlooked as an aid to producing a great photo. In the images below the
Histogram is showing you that the photo is comprised of mostly midtones with some
brightness.

2. The bright areas show up on the right of the Histogram irrespective of where they are in
the photograph. The black, or heavily shadowed, areas show up on the left of the histogram
irrespective of where they are in the photograph. Midtones, obviously, show up around the
middle of the Histogram.

Curves Dialog
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3. The image of the Tower has no black or heavily shadowed areas. This is displayed in the
Histogram as a white area. This means there are no black or dark grey pixels in the
photograph.

4. When the Histogram does not butt up against the left or right edge of the Curves Dialog
it shows that the darkest and/or brightest areas contain some details. This means there is
white between the Histogram and the edge of the Dialog. This is desireable as it means no
blocked up black shadows or blown out highlights.

5. The Curves 'Diagonal Line' enables you to make adjustments. To any Photograph of your
choice.
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6. Load a photo of your choice. Go to 'Colors' menu and select 'Curves'. Click on the
diagonal line, in two places, as shown. These selected points are known as 'Anchor Points'.
There is no limit to the number of 'Anchors' you may select. However, two or three
anchors are usually sufficient when you are using the 'Values' channel.

7. Let's assume that you know this nurse and you wish to bring out her true looks and
character: She has auburn hair, hazel eyes and a good complexion. She is an experienced
medic with a strong personality.

8. When you find a good 'Curves' setup you may wish to repeat it with a different photo.
You can save the setup in 'Presets' and give your setup a name. This means you can
always go beck to that 'Preset' as a starting point and make any adjustments you require
without losing the original preset. Here's how:

9. Many online tutorials talk about the 'S' curve as the ideal method of improving many
images. This means that you increase the contrast and saturation of an image, plus add a
little brightness. (As below.) You can also have an 'Inverted S curve', which means the
anchor points are reversed. You may wish to setup a Preset for 'S' curves, too.
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10. In the Curves Dialog 'Histogram' your photograph is shown to have a tonal range. The
'Tonal Range' represents the diverse shades of color between absolute black and absolute
white in your image.

The Tonal Range of an image is wide when it stretches from edge to edge of the Curves
Dialog. If the Tonal Range represented by the Histogram ends before the edge is reached it
is possible to 'Crush' the pixels down, with the diagonal line, and improve the picture. See
below.

The image below shows the effect of crushing the dark pixels from the left of the
histogram. You may also crush the lightest pixels from the right of the histogram, if your
image requires it. You’ll see this happen in a later tutorial.
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11. Here's a harbor scene, in your work photo, where the reflection of the boats in the
water could make this photo great if they where brighter. Go to the Colors/Curves folder
and open the image: Harbor_Scene.jpg. Here's how we do that with the Curves Dialog.

Select the 'Magic Wand' tool and setup the wand as shown below. Click on the shadows
under the boats. Because you selected the 'Add to' option most shadows will be captured in
one or two clicks. You'll see the marching ants of your selections.

12. Go to the 'Colors' menu and click 'Curves'. Adjust the curve to match the one shown
below.

Do not make the reflections in the water too bright, they will be unrealistic. Just enough
brighness to add interest.

Go to the 'Select' menu and click 'None'. Ctrl+Z will take you back if you wish to try again.

Harbor Photo was supplied free by members of:
http://commons.wikimedia.org/wiki/Main_Page
Photographer: Miguel Virkkunen Carvalho from Lahti, Finland.
http://upload.wikimedia.org/wikipedia/commons/c/cc/Harbor_Scene.jpg

Wikimedia is a good site to find free work photos.

http://commons.wikimedia.org/wiki/Main_Page
http://upload.wikimedia.org/wikipedia/commons/c/cc/Harbor_Scene.jpg
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Here's your work photo, the Cataloochee Valley, NC, at dawn. It's a pretty mundane photo
and we'll see if we can make the forest more attractive. Go to the Colors/Curves folder and
open the image: forest.jpg.

In this final tutorial on curves we'll take a look at the Color Channels. In the past we added
color by dragging the Color Channel 'Diagonal Line' up the grid to add a color: red, blue, or
green.

If you drag the color channel diagonal line down the grid you get a different color:

Red Channel: drag up for Red; drag down for Cyan.
Green Channel: drag up for Green; drag down for Magenta.
Blue Channel: drag up for Blue; drag down for Yellow.

Curves Dialog - Color Channels
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When you place two anchor points on a color channel diagonal line you can choose to have
both colors appear on your photograph. As you can imagine this can be very effective. See
above:

You'll see in the image the effect of a small 'S' curve in the diagonal line of the Red
channel. The color Red has appeared in the tree tops and the color Cyan has increased the
green effect in the lower foliage.
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In the previous image is the effect of a small 'S' curve in the diagonal line of the Green
channel.

Green is now evident in the tree tops and Magenta has changed the color of the near tree
tops and the foreground.

Here's the effect of a small 'S' curve in the diagonal line of the Blue channel.

The Blue has tinted the distant hills and Yellow has brightened the tree tops and sent a
shaft across the foreground.

Here's the original photo again, but all three color channels have been used, with two
anchors, to enable the use of both colors on each diagonal line. (I hope that's clear.)
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Clipping Highlights
In a histogram 'Clipped Highlights' usually indicate over-exposure. (The histogram is
pushing against the right side of the graph. This means some highlights have blown-out.)
We are aiming to use deliberate highlight clipping to improve a photo. When other methods
of boosting a photo won't work give this a try.

1. In this exercise we will be working opposite to our normal system. You'll see what this
means shortly. Go to the Colors/Clipping Highlights folder and open the image: Alaska.jpg'
in GIMP. The image is a good exposure but lacks 'pop', that elusive almost 3D effect.

2. Go to the 'Colors' menu and open the 'Curves' dialog. Click and drag the end anchor
point, at top right, along the graph towards the middle. When your highlights burn out pull
back until there is detail in the highlights. You now have a steep straight line. You have
clipped your highlights. You need white snow with details and shadows. Click OK. See the
image above.

3. Go to the 'Colors' menu and open the 'Levels' dialog. Drag the sliders of the Input levels
and Output levels to the left or right until your image is to your satisfaction. See image
below. Click OK.

4. Save and/or Export to the format of your choice.

Job Done.
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Producing stunning photographs is the aim of every photographer. Here's a sequence which
can improve almost any picture which is reasonable or better. For example: in focus, this
means that the subject is not blurred, not blown-out and so widely overexposed everything
is very light. Very black areas, shadows and dark subjects can often be rescued to create
an acceptable image.

Here's a photo which is a pretty average happy-snap. You'll discover how to make it 'Pop'
and be much more colorful and impressive.

How to Make Your Photos ‘Pop’.

Sequence:
1. Go to the Colors/Make Photo Pop folder and open the image: photo_pop1.jpg.

2. Go to the 'Colors' menu, look to the middle of the menu, hover over 'Auto' and select
'White Balance'.

3. Return to the 'Colors' menu and select 'Brightness and Contrast. The box appears. Slide
'Brightness to -2' and 'Contrast to 8. Click on the bar 'Edit these Settings as Levels'.
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4. You'll edit the 'Levels' manually for this exercise. This means using the 'Eyedroppers' to
select: the deepest black with th first eyedropper, the best grey you can find with the
second eyedropper, and the cleanest, brightest white with the last eyedropper. (Tip: avoid
dark grey.)

5. Look for the center slider on the 'Input Levels'. Move this slider, left or right, until the
picture is as good (in your opinion) as you can get it. Notice that there are two sliders at
the extreme left and right of the input levels. The left slider was put there when you
selected the deepest black with the eyedropper. The extreme right slider was put there
when you selected the cleanest white. Click on the 'Edit these Settings as Curves' bar.

(Tip: You may prefer to move all 'Input Levels' sliders without the aid of the eyedroppers.
Slide the left and right sliders to wherever the left and right of the black Histogram is
located. Then adjust the center slider.)

6. The 'Adjust Color Curves' box will open. We're down to fine tuning now. There are three
dots on the diagonal line, click and hold each dot. Move the lower dot to see what effect it
has on the photo. When you find a position that looks good release the dot. Reat with the
center and top dots. Click OK when you have finished with 'Curves'.

7. Go to the 'Colors' menu and select 'Hue and Sauration'. The box will open. Click on
'Master' in the center. Click and hold the 'Saturation' slider. Move the slider slowly to the
right until, in your opinion, the colors are realistic or vibrant, whichever you prefer. Click
OK.
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8. Go to the 'Filters' menu and hover over 'Enhance' select 'Unsharp Mask' from the sub-
menu. Set the 'Radius' to 3.5 and the 'Amount' to 0.50. The 'Threshhold' set at 0. Click on
'Preview' in the box above the sliders and you'll get a view of the degee of sharpening.
(Here's where you think that Unsharp Mask is something of a misnomer. You're right, of
course, but thats what the designer called it.)

9. Compare your final result with the original. You should see a wonderful improvement. A
photograph with much more 'Pop'. Job done.
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For this tutorial you require a plugin script: Fake HDR effect script-fu-v0.2.zip.

Download from here: http://registry.gimp.org/node/11776

There are 4 files, you only need 2. Place the two .scm files in the 'Scripts' folder of GIMP
2.8. Close your GIMP program before the installing scripts.

This is a clever plugin but with some photos it has two problems: skies can become
distorted and/or banded. Dark shadows become solid black and lack detail. Here's a work
around to produce beautiful skies.

Fake HDR Plugin Tutorial

1. Start your GIMP. Load work photo 'boats' into GIMP.

2. Go to the rotate tool and level the horizon. Crop as required.

3. Go to the 'Scissors' tool and make a selection around all of the sky.

4. When you have your marching ants, Go to 'Edit' menu. Click 'Cut'.

http://registry.gimp.org/node/11776
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5. You now should see a transparent area where the sky had been. (It may appear black,
don't worry about it.)

6. Go to the 'Script-Fu' menu. Hover over 'Enhance' and select: HDR Effect. Set the number
to: 35 (Default). Click OK.

7. Go to the 'Filters' menu. Hover over 'Enhance' and select 'Unsharp Mask'. Accept the
default setting and click OK. The boats will appear sharper.

8. Go to the 'Edit' menu and click 'Paste'.

9. Click on the move tool and drag the sky into its original position. Watch out for the sea
horizon and the green hill top. You need to be accurate here. This is a good time for the
Zoom tool.

10. You will have distorted edges. Don't worry about those.

11. Go to the Colors' menu. Click on 'Curves'. Adjust the 'Value' curves as shown. If the sky
turns grey you need to adjust the curve to keep the sky as near blue as possible. Click OK.
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12. Go to 'Colors' menu. Select 'Hue-Saturation'. Click on 'Master'. Slide 'Saturation' to: 60
(approx). Click OK.

13. Go to the 'Filters' menu and hover over 'Blur'. Select Gaussian blur. Apply with default
settings. (You can lower the 'Radius' setting if the blur is too much.)

14. Go the the 'layers pane', right click and select 'Anchor Layer'.

15. Crop as required.
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16. File/ Save As or Export. You select the file format. Preserve the original image to
compare the before and after.

Job done.

Please remember that every photograph is different; so you may have to play around with
the settings I have used as examples in this tutorial.

As you are experienced with GIMP you may consider experimenting with other options:
feathering, saturating other colors, curves colors, add a different sky, etc. Now you have
the basics, you can produce something pretty impressive.

As for the black shadows problem in a photograph, you can take care of that before you do
any of the above. You have the 'Dodge/Burn' tool, or alternatively, make a selection around
the shadow and lighten it with the 'Colors' menu tools, don't forget to give plenty of
feathering to blend those shadows naturally. Getting the shadows just right can take
practice, too.
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Some photos suffer from purple fringing around objects: leaves, buildings, anything against
a white sky or light background. This is caused by an optical aberration in your lens. (AKA
Chromatic aberration) This may affect low cost and expensive lenses. No matter, there are
ways to fix it.

Load tutorial image #1. Zoom to enlarge the tower on the right. Zoom big enough to make
the purple/blue fringing easy to see. Follow the instructions in the second image below. The
purple/blue effect will turn gray, which will make the aberration much less obvious. Zoom
out to see how it looks.

How To Get Rid of Purple/Blue Fringing

Of course, correcting your entire photo in this way will mean that all other objects in purple
or blue will also become gray. Not so good for a blue dress. Here's how to avoid that.

You may have a photo with many purple or blue colors which you desire to keep. To isolate
the purple/blue fringing choose a selection tool and draw the tool around the offending
area. You have now protected the rest of your photo.

The selection tool may be adjusted by using the grab handles on corners and sides. Just as
you did in an earlier lesson (Book #1).

Repeat the method for removing purple/blue: Colors menu, select Hue-Saturation. You may
need to repeat this Selection tool technique in a number of places to remove all fringing.

Now your other purple or blue colors will be unaffected.
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Here's a quick and easy method to replace a bad sky with a good one.

We'll use the 'Single Window Mode'. Go to the 'Windows' menu and click 'Single Window
Mode'. You'll notice there are no floating panels, everything locks into place. You can
expand the toolbox, settings and other panels by clicking the edge and dragging.

1. Go to the 'File' menu, click on 'Open'. Select 'forest2.jpg' and 'sky.jpg'. Click 'Open'.
There are two small photos (Image Tabs) at the top of GIMP. Click on the photo you need
on the main canvas.

2. Click on the 'Forest' image tab.

3. Go to the 'Select by Color' tool. Click 'Feather edges' Set to: 10. Click 'Select Transparent
areas'. Threshold: 20. You may wish to vary these settings after you complete this tutorial.

Replace Sky Tutorial
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4. Select all the colors in the sky. Zoom in. Click the purple hues between the foliage of the
trees. Move the photo from side to side to check that you have clicked between all the
branches of the trees. Take care not to cut too far down into the yellow/green trees. Watch
for the big trees on both sides, get between those branches. Yes, you will lose the purple
hills. Zoom out.

5. Go to the 'Select' menu. Click Invert.

6. Click on the 'Sky' image tab at the top of GIMP.

7. Go to the 'Image' menu. Hover over 'Transform'. Click 'Flip Horizontally'. (This is optional
but interesting for the tutorial.)

8. Click on the 'Forest' image tab.

9. Right click, hover over 'Edit'. Select 'Copy Visible'.

10. Click on the 'Sky' image tab. Brighten the sky with curves. Use the 'Clone' tool to paint
away that dark cloud. (Regarding the settings in the 'Curves' image below. Ignore them
because I went much stronger than that. Your sky, you choose how you want it to look.) By
the way, the colors in the sky must correspond with the colors on the ground. If they don't
your image looks not quite realistic.
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11. Right click with the mouse. Hover over 'Edit'. Hover over 'Paste As'. Select 'New Layer'.
(See image below) BTW, be sure your images are the same percentage in the size slot
bottom left. For Example: 33%.

12. If you have an active selection, go to the Select menu. Click 'None'.

13. You can move the 'Forest' layer by using the 4 way arrows on your keyboard. Use the
'Down' arrow to move the forest layer to the bottom of sky. Hold the key down and let it
roll.

14. Right click in the Layers pane. Select 'Merge Visible Layers'.

15. Crop image if required. Save and/or Export.

Note: You may discover discoloration between the branches in the final image. Ctrl+Z to
get back to the 'Sky' image if you can. (If not start again, good practice.) All you need to
do is use the 'Clone' tool or the 'Paintbrush' tool with a 'Cloud' brush to add the appropriate
color (probably white) at the point where your offending tree will be. A soft 'Cloud'
paintbrush, size 600, can work wonders.
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Sky replaced to improve photograph
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How To Rescue a Flat Photo
Open image: Birds-1.jpg. Work Photo

The photo of the seabirds is very flat and in this state would not make a good image. Here's
how to improve that photograph:

Go to the Colors menu and select 'Brightness-Contrast'. Set to Brightness: -30; Contrast:
20. Click on the 'Edit these Settings as Levels' bar.

The 'Adjust Color Levels' box will appear. You can see from the histogram how flat the
image is.

Adjust the sliders as shown. Because all monitors are different you need to watch for the
highlights: white feathers on birds and white wave caps. Check that there is detail in the
highlights and adjust the settings if necessary. Beware of banding.
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Click the 'Edit these Settings as Curves' bar.

The 'Adjust Color Curves' box will appear. Do not alter the 'Value' channel.

Click on the down arrow and select 'Red'. Click twice on the red line and create a gentle
inverted 'S' shape as shown.

Repeat with the 'Green' channel and the 'Blue' channel. Adjust all channels to your
satisfaction. Click OK.

Go to the 'Colors' menu, select Hue-Saturation. Set 'Lightness' to: 22. Saturation to: 60.
Click OK.

Job Done.
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'Noise' is the popular term to describe digital photo aberrations. Noise appears similar to
'grain' which you may have seen in newspaper photographs. It may also look like
discolored areas or pixels and can spoil a photograph. Noise gets worse when you take
photographs in low light, without a flash.

The degree of noise considered acceptable is subjective, but many advanced photographers
prefer to see photos free from noise.

Here we can get into an argument about the noise reducing ablity of: point and shoot
cameras, bridge cameras, and digital SLRs. I'm not going there. Here's my opinion: low
cost cameras are more prone to noise because of the quality of the lens and the size of the
processor which converts light (a scene or subject) to pixels. More expensive cameras are
an improvement because the lens is superior and the processor is usually bigger and
better, DSLRs are the leaders when it comes to lens and processor quality. Tomorrow? Who
knows? The camera manufacturers may work their magic and develop a camera which does
not produce noise.

Print size is also factor in the 'To much noise?' question. Big prints from low cost cameras
will show more ugly noise than big prints from high quality cameras. Noise which may be
obvious and will ruin a large print may be acceptable on a 4x6-inch print, plus faint noise is
almost invisible on a laptop unless the image is zoomed up to 100%.

What is Noise & How To Get Rid of It

An Example of Noise
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The choice of your ISO setting also a factor. Select the lowest ISO setting your camera will
allow, the risk of noise will be reduced. DSLRs and Mirrorless Interchangeable Lens
Compact cameras, produce lower grain at higher ISOs. Bridge cameras are appearing with
more sensitive sensors every year. This means an improvement in battling the noise
problem. By the way, use your camera's 'noise reduction' settings if you have them.

Current cameras often boast 10 million pixels (megapixesl), or 14 megapixels, or more.
Sounds great, but the performance hangs on the size of the sensor. A small sensor has to
crush each pixel and consequently each pixel gets less light. This means more distortion in
the image and/or more noise. Understandably, a large sensor coping with 14 megapixels
will produce less noise than a small 14 megapixel sensor.

Long exposures often create static, also a cause of noise.

If you are photographing a subject in daylight, with a strong sun shining, at a high ISO,
you may think that noise will be minimal. However, if you check the dark shadow areas
noise may be present because of the extreme contrast. Noise is always more obvious in the
darker areas of your picture.

You can reduce digital noise by shooting at a low ISO whenever possible. You will get to
know the limits of your camera and its ISO settings if you carry out planned experiments. A
little thought and you can be clever and test the ability of your sensor to handle high ISO
settings.

Armed with a DSLR, set at ISO 400 plus, and you should always be sure of a good image
with a low noise factor. If you don't have a DSLR you will probably need a tripod and/or a
flash for low-light photography.

If your photographs suffer from noise, GIMP will rescue your images with its noise-
reduction plugins. There are numerous tools in GIMP to improve your pictures and eliminate
noise and other distortions. The noise reducing plugins (loadable small software programs)
are available now and are excellent. Recommended: Wavelet Denoise. Download here:
http://registry.gimp.org/node/13434  Scroll down the page for the Zip file.

http://registry.gimp.org/node/11776


55
Click Here for Index

we, as photographers, have occasionally taken photographs that did not live up to our
expectations. Of course, portrait viewing is subjective; your opinion may be different from
the next guy's but it's no less valid.

Here's a portrait of a young woman which, in my opinion, could be improved. So, what
could be better with this portrait?

The portrait has been cropped too close to her nose. The focus is on the hair rather than
her eye. The hair is, well . . . . . unfortunate. The picture lacks impact. We may not be able
to transform it into a great portrait but maybe we can produce something more pleasing to
the subject.

In spite of the above the young woman has: beautiful skin, an acceptable pose, and there
is a good background of a complimentary color.

How To Improve a Portrait
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As this is a rescue operation and not a new portrait sitting, this is what I think should be
done and here's how to do it. (That's not to say we don't have other alternatives with all
the options available in GIMP.) Maybe you would like to do it your way after completing this
tutorial?

1. Load GIMP. Go to Windows menu and click 'Single Window Mode'. Go to 'File' menu, click
'Open' and select the 'portrait work photo'. (Do not not 'Open as layers'.)

2. Set your foregound/background colors to white on top and black below. Select the 'Color
Picker Tool' (eye dropper) from the Toolbox. Click at top left corner of the work photo to
select the background color. Your white foreground color will have changed to the selected
color.

3. Go to the 'File' menu and click 'New'. A box will open. Set Width: 1000. Set Height: 800.
Click on 'Advanced Options'. Set 'Fill With' to Foreground Color. Accept all other default
settings. Click OK.

4. You should now have two image tabs at the top of GIMP: young woman photo and the
new background.

5. Click on the young woman image tab. The photo of the girl appears. Select the 'Fuzzy
Selection Tool' (AKA Magic Wand) from the Toolbox. Set the 'Mode' to 'Add to Selection'.
Threshold to 10. Click on background only to create selection. See image below.
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6. Change to the 'Move' tool in the Toolbox. Go the the 'Select' menu and click 'Invert'. Go
to the 'Edit' menu and click 'Copy Visible'.

7. Go to the image tabs and click on the 'Background'. The new background appears. Right
click on the background, hover over the 'Edit' menu, hover over 'Paste As', select 'New
Layer'. The girl will appear on the left side of the background and surrounded by a dotted
yellow line. This yellow line shows that the girl layer is active.

8. Check you are on the 'Move' tool in the Toolbox. Click and drag the photo to the right.
Use the four way arrows on your keyboard to position the girl as shown, if necessary.

9. Go to the 'Filters' menu. Hover over 'Artistic' and select 'Soft Glow'. The Soft Glow plugin
can be very strong at the default setting (great for creating High Key portraits). Set your
Soft Glow as: Radius 1.00, Brightness 0.25, Sharpness 0.00. Click OK. If you want a
stronger glow, go the the top of the Filters' menu and click: 'Repeat Soft Glow'. Ctrl+Z will
take you back one step if the glow is too much for your taste.

The 'Soft Glow' does soften and brighten as the name suggests. When you work on your
own portraits you may feel that your subject's hair has been blurred enough by the Soft
Glow alone. In which case skip the Guassian blur. But for this tutorial carry on as below.
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10. Go to the 'Layers' pane. Check that the girl is at the top. Right click on the top layer
and select 'Merge Down'.

11. Go to the Toolbox and select the 'Scissors' tool. Cilck 'Feather Edges' and set the
'Radius' to 10. Make a selection around the hair as shown below. Click in the center of the
selection to change to marching ants.
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12. Go to the Filters menu, hover over 'Blur' and select 'Gaussian Blur'. Setup: Horizontal 3,
Vertical 3. Click OK.

13. Go to the 'Select' menu and click 'None'.

14. Look bottom left of the girl. The blend with the background should be perfect. However,
you may see the edge of the old girl photo. If so select the 'Paint Brush' from the Toolbox
and carefully paint over the join with the foreground color. Everything should now match
perfectly.

15. Select the 'Zoom' tool from the Toolbox. Zoom in on the girls eye, 300% is good. Now
select the 'Scissors' tool. Click 'Feather Edges' and set the 'Radius' to 10. Create a selection
around the eyelashes and eyeball only, as shown. Click in the center for the marching ants.

16. Go to the Filters menu, hover over 'Enhance' and select 'Unsharp Mask'. Setup; Radius
3, Amount 0.50, Threshhold 0.00. Click OK. The eye is now sharp and the focal point of the
photo. If the eye is too sharp for your taste reduce the settings for the Unsharp Mask.
When you are satisfied with the eye, go to the 'Select' menu and click 'None'.
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17. Zoom back to 66% (approx). Go to the 'Crop' tool in the tool box. Select 'Golden
Sections' and draw the crop tool around the girl as shown. Be sure the lines cross at the
girl's eye. Click in the center of the selection to crop.

Compare the images to see the improvement. If you are happy with the transformation,
Save and/or Export in the format of your choice.

Note: We have lightened the skin with the 'Golden Glow' plugin. If you prefer the original
color you could skip the Golden Glow option.

Alternatively, after all the above, go to the Layers pane. Right click and duplicate the
image. Go to 'Mode' and select 'Multiply'. Adjust the depth of color with 'Curves'. Click OK.
Right click, 'Merge Down'. Save and/or Export.

Yep, from 'Mode', I also played with a Script-Fu plugin: Artist -Water Color, set to 4; plus
Filters plugin: Xero - Soft Vignette. Just have fun!

Job done (In my opinion).
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In this tutorial you'll be using skills you have learned plus a new skill: Airbrushing a
photograph. (There is a tool in the Toolbox named Airbrush but it's basically a drawing tool
and not so good for hiding flaws and producing a flawless complexion.)

Your practice photo: Colors/Flawless Complexion folder - Jackie_Martinez_looking_right.jpg.
Photo by Mark J Sebastian (Jackie Martinez (#13248)) [CC-BY-SA-2.0
(http://creativecommons.org/licenses/by-sa/2.0)], via Wikimedia Commons

To begin you need the 'Heal' tool to hide all the flaws on the girls face and body.

Heal Tool

1. Setup your Heal tool, which you'll recall is easy because all the settings are default
except the brush type and size. To use the Heal tool, first set a soft brush size slightly
larger than the flaw on the skin. Zoom into your photo make viewing easy.

2. Hold down the Ctrl key and click on a perfect area of the skin which must be close to the
flaw.

3. Release the Ctrl key and drag the Heal tool to the flaw. Left click your mouse. If the
defect is slight, and not very different from its surrounding skin, it will be corrected fast.

4. Alternatively, you can correct it with repeated clicks, but with a risk of daubing.

5. Painting with the heal tool is possible if you confine your brushing to a small area.

Smudge Tool
When you are happy with the work you've done with the 'Heal' tool, select the 'Smudge'
tool from the tool box.

1. Set up the Smudge tool as shown below.

2. Zoom in to 150% (approx).

3. Paint over the large areas of her face with a big brush, smooth strokes.

4. Reduce the size of your brush for the nose and around the eyes.

5. Do not paint away all her features, natural is better than plastic skin.

6. Do not smudge her eyebrows, Ctrl+Z for recovery.

Airbrush Away Skin Problems For a Flawless Look
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Sharpen with Ellipse Select Tool

Click on the 'Ellipse Select Tool' in the Tool box.

1. You should still be zoomed in to 150% or larger for this tool.

2. Create an ellipse around one of her eyes. You'll need to capture just her eye and maybe
a little of her eye lashes. Keep it tight to make it realistic. Ctrl+Z if the marching ants are in
the wrong place and start again.

3. Go to the 'Filters' menu, hover 'Enhance' and select 'Unsharp Mask'. Change the Radius
to: 3; Amount: 0.50; Threshold: 0. Click OK.

4. Repeat the above with the other eye.

5. Zoom out to 100%

If you are happy with the result, save to a format of your choice.

Job done.
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Before

After
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How to Create a Vignette Photograph
There are many ways in GIMP to create a vignette around a figure in your photograph. No
one method is wrong they just offer different techniques to achieve a similar result.

This method is quick and easy and you may use any color you wish in your vignette.

Photo: Jackie_Martinez_Street.jpg

By: Mark J Sebastian (Jackie Martinez
(#31106)) [CC-BY-SA-2.0
(http://creativecommons.org/licenses/by-
sa/2.0)], via Wikimedia Commons

1. Load your work photo: ‘Jackie_Martinez_Street.jpg’ into GIMP. Zoom in until you can see
the model’s entire body.

2. Go to the Toolbox and select the “Ellipse Selection Tool’. Click on ‘Feather Edges’, set the
‘Radius’ to: 40. Draw the selection around the model as shown above. Click in the center of
the Ellipse to activate the marching ants. (The Radius size is optional for your own work.)

3. Go to the ‘Select’ menu and click on ‘Invert’ (Ctrl+I keyboard shortcut). The girl is now
protected and you are working on the area outside the selection.

4. Go to the Toolbox and select the ‘Bucket Fill Tool’. Click on the ‘FG Color Fill’, it may
already be activated; if so you’ll see a blue button.

5. Click on the ‘Fill Whole Selection’ button to activate it (blue button).

6. Go to the FG/BG colors and click on the top color. The ‘Change Foreground Color’ box
will open. Select the color ‘White’. Click OK. (Here’s where you would normally select any
color of your choice.)

7. Move your mouse pointer over the photo and you will see that the pointer has changed
to a bucket. Click anywhere in the photo, except over the model, and the picture will flood
with white. You now have your vignette.

8. Go to the ‘Select’ menu and click ‘None’. The selection will vanish.

9. Go to the Toolbox and select the “Crop’ tool. Crop as above. Save the image in a format
of your choice. Job done.
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Convert Your Image with a Spotlight Effect
The aim of this tutorial is to enable you to discover how to create a spotlight on a subject of
your choice. Here's a photo of Jackie Martinez taken by Mark J Sebastian and converted to a
spotlight effect with GIMP. (See below.)

By Mark J Sebastian (Jackie Martinez (#13248)) [CC-BY-SA-2.0
(http://creativecommons.org/licenses/by-sa/2.0)], via Wikimedia Commons.

1. First, study your photo and decide what you want to do. In the work photo we’ll assume
that we want the spotlight effect on the models face and microphone. In addition, you can
see the problems that you need to overcome: her raised forearm, parts of her face and the
microphone are over-exposed. You should confirm this with the Threshold tool. The
photographer also placed a faint weave pattern over the image. Here’s how to correct the
problems.

2. Go to the ‘Colors’ menu and select ‘Levels. On the ‘Input’ levels move the center slider to
reduce the brightness of the highlights: set to 80.

3. On the ‘Output’ levels move the white slider, on the right, inward to correct the over-
exposure: set to 230. (See the next image below.)

4. Click on the ‘Edit these Settings as Curves’ bar. This will take you to the ‘Curves’ dialog.

5. The model’s skin tones are too red in color, we can correct this if we add a dash of green
color which will give a more brown tone to her skin. You need only a tad of green to
achieve this color change.

6. In the Curves dialog select ‘Green’ from the Channels menu. Push the green diagonal
line upward to reduce the red and add a brown tint to the skin. When you are happy with
color, click the OK button. (See the Curves image.)

7. Go to the Toolbox and click on the ‘Ellipse selection tool’. In the Ellipse tool settings click
on ‘Feather Edges’. Set the feathering to: 35. This setting will blend the edges of the
spotlight smoothly into the black background. Adjust the Ellipse selection as shown in the
Ellipse and Curves image. Keep the model’s eyes toward the top left of the selection and
not in the top center. (See the Ellipse and Curves Image.)
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8. Go to the ‘Select’ menu and click on ‘Invert’ (Ctrl+I keyboard shortcut). You are now
working on the area outside the selection and the model’s face within the selection is
protected.

9. Go to the ‘Colors’ menu and select ‘Curves’ again. The channels menu should be set at
‘Value’ (default). Click in the center of the black diagonal line and drag it down toward the
lower right corner of the dialog. The area outside the selection will become darker until you
get a spotlight effect. Set your diagonal line as shown above (approx). Click the OK button.

10. Go to the ‘Select’ menu and click on ‘None’. The Ellipse selection will disappear.

11. Zoom in to the photo until it is at 100%, if you are not already there. Check that the
Foreground/Background colors are black over white (default).

12. Go to the Toolbox and click on the ‘Smudge’ tool. Set the ‘Opacity’ to: 25. This setting
will give you a smooth, smudge free, finish and the model’s skin will look natural.

13. Select a soft brush, don’t go too soft, the soft brush next to the hard brush will be best.

14. Start with the face, choose the size of brush you need for each area, around the eyes
and under the nose will need a tiny brush size. On her forehead and cheeks you can use a
much larger size. You are aiming for a natural smooth look without blurring away her facial
features. The faint weave pattern will disappear under the smudge tool.

15. Now work on the arm, retain the shape and features. Keep the dark edge on the
shadow side and a bright reflection from the light on the inside of the arm. Smooth away
those imperfections and lower the opacity if you feel you need to for a better effect. I took
the opacity as low as 10 in some places. Practice and experience will teach you a lot.

Ellipse and Curves Image
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Stating the obvious, all photographs are different, this means you may have to play around
with various Smudge tool settings to get the final image you want. When you practice
remember that high Opacity settings will get you nothing but ugly smudges.

Backgrounds with a spotlight effect can be pure black or you may prefer to retain a hint of
color if you feel that adds to your image. It’s your photo so it’s whatever you think looks
great that matters.

Go to the ‘File’ menu and click ‘Export’. Enter your new name for this photo in the top
‘Name’ slot and add your preferred file type. For example: myphoto.jpg. Click Export. In
the ‘Export Image as JPEG’ change the default setting to 100% and click the ‘Export’ button
again. Your original image will be restored when you click ‘Close Without Saving’.
Alternatively, ‘Save’ your photo as a GIMP (.xcf) file to a folder of your own..

Job done.
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Converting a colored photo to black and white is not difficult. However, to get the best
possible picture you need to know what to look for in a good B&W image.

A superb monochrome image contains a range of shades from deep black, through shades
of gray, to bright white. The blacks and whites should not be over or under exposed. This
means that the blacks and whites should contain the discernable details that you would
expect to see in a good image. Blown-out whites and solid blocks of black must be avoided.

There are exceptions, of course, if bright whites and/or dark blacks convey mood, keep
what you need in the picture. You are the photographer, you must know why those
extreme highlights and/or blacks are present by choice.

There are several ways to create a B&W image from a color photo: Desaturate, Channel
Mixer, or Hue-Saturation are capable tools for a quick conversion. The problem is these
tools often give you a range of grays and the image is flat. You need to add contrast to
bring out the blacks and whites to give the image shadows and highlights to give your two-
dimensional image the impression of shape and texture.

1. Open Gimp, go to the Windows menu and select ‘Single Window Mode’. Load the
Spanish-window.jpg,  or your own image, into GIMP from the ‘BW Conversion’ folder. Go to
the Image menu and select ‘Duplicate’ (at the top). You now have two images, the image
you are working on is the duplicate; your original image is protected from harm.

2. Go to the Colors menu and select 'Desaturate'. You can see that the photo is B&W but
it's predominately gray with no highlights and even the dark shadows are just dark gray.
Not good enough but we can work on that. Click OK

3. Go to the Colors menu again and select 'Brightness-Contrast'. Click the 'Preview' box if it
is not ticked. Set the Brightness to 25 and the Contrast to 20. Adjust as appropriate for
your own photo. That gives you an improved image but maybe we can do better. Click on
the 'Edit these Settings as Levels' bar.

Convert a Colored Photo to Black and White
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4. The Levels dialog will open. Move the Input and Output sliders to match those shown in
the image below. Click OK. Zoom in to 100%. Take a look at the carvings on each side of
the doors. The detailed carving have shape, depth and texture because of the dark
shadows that enhance the 3D impression. White highlights on the carvings boost the effect.

The leaves on the left have varying degrees of gray going all the way to black in the top left
corner. The shadow under the balcony shows that it has shape and the darker shadows on
the decorative supports add to the effect. This is as far as you may want to go, but as with
all photos it's subjective and it's your opinion that counts.

5. You now have the option of running the image through the Levels tool again or you may
choose to use the Curves tool. The color channels in the Curves tool cannot be used as they
will introduce colors. Your preferred option may be to clip the dark pixels in the histogram
to crush those pixels for further effect. Click OK. See below.
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Note. You can take a look at some superb B&W images by Ansel Adams, study them on
your monitor or laptop, and try to match his mastery of Black and White photography. Take
note of the range of shades as we have discussed above. To see these photos at their best
you should see them printed at an exhibition. Alternatively, buy a quality print to hang in
your own home. By the way, your monitor won’t match the original prints but you’ll get
plenty of clues on black and white photography. Search for ‘Ansel Adams Photographs’
online.

Hue-Saturation Technique
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Above is the Hue-Saturation method in the first step of converting a color photo to black
and white. Go to the Colors menu, select ‘Hue-Saturation. Click on the Master button, move
the ‘Saturation’ slider all the way to the left to remove all color. Adjust the ‘Lightness’ slider
to brighten the highlights to your satisfaction. Click OK. Go to the Levels tool if you wish to
improve the image and continue as previously explained.

Channel Mixer Technique

The Channel Mixer technique is an alternative first step for converting a color photo to black
and white. Go to the Colors Menu, hover over Components and select ‘Channel Mixer’ from
the sub-menu.

Tick the Monochrome box to enable the dialog to make the conversion. Adjust each of the
color sliders until the picture in the preview window looks about right.

The sum of the three color number input boxes should total 100 (approximately). Click OK.

Go to the Levels tool if you wish to improve the image and continue as previously
explained.

There is no reason why you should not mix and match these methods to create
the B&W effect you want, experiment and have fun.
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  Here’s how to install brush files. Check that your GIMP program is closed.

Download your new brushes (Gimp brush files end with .gbr and/or .abr) copy and paste
the brush files in the Gimp brush folder. You'll find the  brush folder here:

Windows 7 and 8 = C:\Users\username\.gimp-2.8\brushes.

Vista and older programs = C:\Program Files\GIMP 2\share\gimp\2.0\brushes.

Start up GIMP, go to the Brushes panel and confirm that your new brushes are listed in
the panel along your original brushes.

Zip Files
Some brush files are packaged in a .zip file. To unpack a zip file in windows just double
click on the zip file and the contents of the file will open. Hold down your Ctrl key on your
keyboard, click on each brush file in turn. Right click and select 'Copy. Go to your Brushes
folder, as above, right click again and select paste.

Here’s How To Install and Use Brushes
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Here’s where to find your free brushes for downloading. You have to scroll down the page
to find the download link. Most brushes are packaged in sets. You can read about the
brushes, and what they do, on the download page.

http://hawksmont.deviantart.com/art/GIMP-Floral-I-56478361

http://hawksmont.com/blog/gimp-brushes-floral-part-2/

http://hawksmont.com/blog/gimp-brushes-pine-mega-pack/

http://project-gimpbc.deviantart.com/art/GIMP-Vector-Foliage-Plants-69681357

http://hawksmont.com/blog/gimp-brushes-moon/

http://hawksmont.com/blog/gimp-brushes-snowflakes/

http://project-gimpbc.deviantart.com/art/GIMP-Water-Brushes-62663732

http://hawksmont.com/blog/gimp-brushes-butterflies-part-i/

http://shiranui.deviantart.com/art/Autumn-Glory-100431092

http://browse.deviantart.com/resources/applications/gimpbrushes/?alltime=yes&order=9

http://browse.deviantart.com/resources/applications/gimpbrushes/?alltime=yes&order=9#
/art/Night-2-GIMP-BRUSHES-fullview-121867399?_sid=145749c0

http://www.smashingapps.com/2012/01/05/60-high-quality-free-gimp-brush-packs.html

http://www.1stwebdesigner.com/freebies/40-free-gimp-brushes/

http://www.gimp.org/tutorials/Custom_Brushes/

Brushes come in various shapes and sizes; most can be adjusted with
your: brush size, color and opacity. You can add clouds, suns and planets

to your photos or create wonderful images for your own pleasure.

http://hawksmont.deviantart.com/art/GIMP-Floral-I-56478361
http://hawksmont.com/blog/gimp-brushes-floral-part-2/
http://hawksmont.com/blog/gimp-brushes-pine-mega-pack/
http://project-gimpbc.deviantart.com/art/GIMP-Vector-Foliage-Plants-69681357
http://hawksmont.com/blog/gimp-brushes-moon/
http://hawksmont.com/blog/gimp-brushes-snowflakes/
http://project-gimpbc.deviantart.com/art/GIMP-Water-Brushes-62663732
http://hawksmont.com/blog/gimp-brushes-butterflies-part-i/
http://shiranui.deviantart.com/art/Autumn-Glory-100431092
http://browse.deviantart.com/resources/applications/gimpbrushes/?alltime=yes&order=9
http://browse.deviantart.com/resources/applications/gimpbrushes/?alltime=yes&order=9#/art/Night-2-GIMP-BRUSHES-fullview-121867399?_sid=145749c0
http://www.smashingapps.com/2012/01/05/60-high-quality-free-gimp-brush-packs.html
http://www.1stwebdesigner.com/freebies/40-free-gimp-brushes/
http://www.gimp.org/tutorials/Custom_Brushes/
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If the plugin ends in .scm, put it in the scripts folder.
If the plugin ends in .exe, put it in the plugins folder.
If the plugin ends in .py (Python) or 8bf (Photoshop) put it in the Plugins folder.
(Not all Photoshop plugins work in GIMP. Those Photoshop plugins that work in many
other programs will also operate in GIMP.)

Note: Some .exe plugins are self-installing when you double click on them. The
instructions (Read Me file) will tell you what to do with your .exe plugin.

How to Install in Windows 7: (This may also work in other Windows operating systems.)

1. Click “Start” and click your user name at the top right corner of the Start menu.

2. Double-click the '.gimp-2.8' folder in the open folder.

3. Look for the 'Scripts' folder. Double-click the 'Scripts'.

4. Drag and drop (or copy + paste) the GIMP scripts ('.SCM') files into the Scripts folder.

5. Open your GIMP program. Click the “Filters” menu in GIMP, select 'Refresh Scripts'.
GIMP adds scripts to the 'Script-Fu' menu. If you don't see your plugin listed under any of
the Script-Fu sub-headings, close GIMP and restart GIMP.

If your plugin is an .exe file, .py file, or 8bf file, follow the same sequence as above but
look for the 'Plugins' folder and place the .exe file, .py file, or .8bf file there.

Here’s How To Install Plugins and Scripts
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Tips & Warnings.

GIMP is a 32bit program, please do not download 64bit plugins (even if your Windows 7 is
64 bit.) as 64bit plugins will not function correctly in Gimp 2.8.Plus at the time of writing.

Not all plugins will run in Windows 7 if the OS is 64bit. If the plugin does not work delete it
from its folder. You don't want it to hog space in GIMP.

You can download scripts from the official (GIMP 2.8.) Plugin Registry website at
http://www.registry.gimp.org.

Take care selecting plugins that are not on the GIMP official site. Some plugins are
recommended by GIMP but have to be downloaded on other websites.

When downloading scripts (.scm files) left click on the script name, a box will open, select
save file, click OK, and the file will download. If a text file appears, hit the go back arrow
on your browser to return to the download page. Right click on the file name and select
the ‘Save Target As’ option. Save to a folder of your choice.

Many plugins arrive in a zip file. Extract the zip file by double clicking. Most Windows
operating systems can open zip files automatically when you double click on them.

GIMP scripts are bundled together occasionally and circulated in 'archive' files. You may
need a file-archiving program to extract the script’s .scm file from the archive before
installing it. Here's a simple to use program: http://www.7-zip.org/

Some Photoshop plugins can be used in GIMP, you need a file installed in the plugins
folder to enable such plugins: PSPI (Photoshop Plugins Interface). Download PSPI here:
http://tml.pp.fi/gimp/pspi.html Select the 'Windows 32 gimp-pspi-1.0.7.win32.zip'. Then
search for 'Photoshop plugins for GIMP' online.
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Photoshop plugins for GIMP are in the .8bf format. (For example: fuzzypicture.8bf)

Only 32bit plugins work with GIMP 2.8 at the time of writing. Avoid all 64bit plugins.

Download the PSPI plugin from the website link: http://tml.pp.fi/gimp/pspi.html . The
download links are at the bottom of the page. When the download is complete, double
click on the zip to open it.

Navigate to the plugins folder as shown in the graphic on installing plugins (above).
Double click on the plug-ins folder and drag or copy the 'pspi.exe' file that you
downloaded into the folder.

You have to tell GIMP where it will find the Photoshop plugins you intend to use.

Now open GIMP. Go to the 'Filters' menu, at the bottom of the menu you'll see:
'Photoshop Plug-in Settings'.

Double click on that name. A box will open. Click the 'New' button, on the left. Now click
the 'Folder' button on the right.

Navigate to the folder for plugins and select it: for example: username/gimp-2.8/plugins .
When you start GIMP it will look in this folder for plugins, adding them to the Filters menu.

How To Make GIMP Work with Photoshop Plugins

http://tml.pp.fi/gimp/pspi.html
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As we discussed, Photoshop plugins may come with an installer; with these, you just
identify your plugins folder as the install location. Installers ask you to browse to the
destination folder. Don't miss this option or your installation will get lost.

Regular Photoshop plugins, which don't have an installer, need to be dragged (or copy and
paste) to your plugins folder.

You need to know that some Photoshop plugins do not function correctly in GIMP. Note the
name and delete it from your plugins folder.

Your Photoshop plugins will be displayed at the bottom of the Filters menu. They are often
listed under the makers name. For example: 'Fotomatic'. By hovering over the name a full
list of filter effects is displayed. Clicking on a filter should apply that effect. If you get a
warning box, or nothing happens, delete that file from the plugins folder.

There are many Photoshop plugins available, install only those you have a use for. Or
download one package, load and try them in GIMP, and keep only those you really like.
Then try another plugin or set of plugins. Have fun.
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Below is a list of websites where you'll find free recommended plugins for GIMP. Obviously,
you will not need them all, and the same plugins show up on a number of sites, but not all.
Download and install the plugins that interest you for future use.

The safe place to download plugins (including scripts) is gimp.org. When you see a plugin
on another site, note the name and format (pictureperfect.exe, or pictureperfect.scm, or
pictureperfect.8bf). Go to: http://registry.gimp.org/ and search for that plugin name. If a
download page comes up, you can download it from there. No problems. However, you
may get a discussion page where other GIMP owners discuss the plugin and give their
opinions.

Many web sites give explanations of the purpose the each plugin, you decide if the plugin
meets your needs.

When you have downloaded and installed your plugin you'll want to know if GIMP
recognizes the plugin. Go to the 'Help' menu and select 'Plugin Browser'. All the plugins,
correctly installed, and accepted by GIMP are listed. Check the list by scrolling down. If
your plugin is not shown it was either not installed correctly or it does not work in GIMP.

Links:

http://registry.gimp.org/popular

http://registry.gimp.org/node/22018

http://registry.gimp.org/node/23203

http://registry.gimp.org/node/11776

http://registry.gimp.org/node/24537

http://www.lightstalking.com/gimp-plugins

http://vicanek.de/plugins/wireworm.htm
Tutorial for Wireworm: http://vicanek.de/plugins/wirewormtutorial.htm

http://davidwoodfx.blogspot.co.uk/2010/04/127-useful-gimp-scripts-and-plugins.html

http://www.techzilo.com/download-free-gimp-plugins/

http://www.brighthub.com/multimedia/photography/articles/16924.aspx

http://plugintop.com/category/design/gimp/

http://www.allisnow.com/bwn4/blog/graphic-design/gimp-plugins-photography-photo-
retouchin...

http://arshamshirvani.blogspot.co.uk/2010/02/top-40-gimp-plugins.html

http://www.gimphelp.org/script24.shtml

http://www.xero-graphics.co.uk/freeware.htm

Recommended Plugins & Scripts for GIMP

http://registry.gimp.org/node/24537
http://vicanek.de/plugins/wireworm.htm
http://vicanek.de/plugins/wirewormtutorial.htm
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FAQs Plugins & Scripts for GIMP
Q. I loaded the scm files into the Scripts but some of the menus are grayed out. What’s
wrong?

A. Load your image into GIMP. Make a duplicate layer in the Layers panel (dialog). Right
click in the layers panel and click ‘Add Alpha Channel’. Your grayed out Scripts menus will
now appear. Many of these scripts are designed for GIMP text or logos, which is why they
are often grayed out for photographs.

Q. My Scripts folder contains many .scm files but the plugins don’t appear under the Script-
Fu menu. How do I make these plugins appear?

A. New updates of GIMP list all plugins supplied with the program under the Filters menu.
You are right to place your .scm files in the Scripts folder. All new plugins you add to the
folder will show up under the Script-Fu menu, if the plugin is a .scm file.

Q. I have .py plugins but I understand that each .py file has to be made executable before
it can be used in GIMP. How do I do that?

A. If you are using windows you don’t need to change the .py plugin, Windows takes care
of everything. If you are using some other operating system, for example: Linux or Ubantu,
add the plugin to the Plugins folder, right click on the .py file, select Properties from the
menu, click the Executable box. Click OK. The plugin is ready to go. (Under Windows there
is no Executables option box. It is not required.)

Q. I copied an .exe file to the Plugins folder. The text (read me) file with it said it was for
GIMP but it does not work. How do I get it to function as it should?

A. You may have copied a self-installing plugin to the folder. Delete the .exe file from the
plugins folder. Go back to the original file, which is probably in your download folder.
Double click on the .exe file and it will open an installation program. Follow the installation
until it asks for the folder name where it is to be installed. Click the browse button and
navigate to your plugins folder. You’ll see something like this for Window Vista: C:\Program
Files\GIMP 2\lib\gimp\2.0\plug-Ins; for Windows 7: Computer name\GIMP 2.8\Plugins.
Start GIMP and you’ll find your plugin name under the Filters menu.

Q. I use a plugin but I get this error message: "procedure entry point gzdirect could not be
located in zlib1.dll".

A. Go to the plugins folder and delete the ‘zlib1.dll’ file. Your plugin should now work. GIMP
is finding two zlib1.dll files, which means it’s confused and does not do anything.

Q. I installed a plugin in the correct folder and I see the name in the menu, but when I use
it I get an error message and the plugin does not work.

A. This means the plugin was not designed for GIMP 2.8 and later. It may be an old .scm
file, which has not been updated. It could also be an .8bf file written specifically for
Photoshop; this file will not function in any other photo-editor. Delete this file from the
folder where it was installed.


