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LAB EXERCISE 1 

Workspaces, Filter Design, and Tuning 

                   
 

Topics:  Basic structure of ADS workspaces, libraries and cells, including basic 
design capture, tuning, simulation, and displaying data for analysis.  

Audience:  New users, including design engineers, technicians, and system 
administrators who need a basic working knowledge of ADS. 

Prerequisites:  None (assumes basic circuit design concepts).    

Objectives: Be able to create a workspace, use palettes for design capture, setup 
and run S-parameter simulations, tune a simple filter, and plot data. 
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 Lab 1: Basics (Part 1):  Workspace for ideal LPF design 
 

IMPORTANT: This lab assumes ADS 2011 is installed on your computer or you have 
access to it.  If you are in a classroom, ask the instructor if you have any questions. 

 

1. Start ADS 2012 on your computer  

a. For PCs:  Click the shortcut icon for ADS if it appears on your 
screen, or use the Start > Programs command to find and start 
Advanced Designs System as shown here.    For UNIX:  type the 
script (command) at the terminal prompt (for example: hpads).  

 

b. After initialization, the Main window appears, and you should also see the 
Getting Started dialog. If it appears, close it – you will learn how to do all of 
the things it asks and much more.  If it does not appear, it has already been 
turned off.  Also, do not be concerned about the File View (it may be blank as 
shown here or it may have some directories depending upon which start-up 
directory ADS was set to use at installation time.  For this course 
C:\users\default is shown but you may use another directory. 
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2. Main window basics 

a.  Click the File View tab and click the icon:  View 
Startup Directory – it is only available in the File 
View tab which is a file browser.  This icon will 
always show you the startup directory (typically: 
C\users\default) where you will create workspaces. 

 

b. Notice the grayed-out icons for schematic, layout, 
symbol and data display, etc.  This will be active 
when you create a workspace in the next steps. 

 

c. Notice the Getting Started icon – that brings back the dialog. 

 NOTE: In ADS, all icons have menu commands but not all menu 
commands have icons. 

Now, it’s time to create a workspace, build a filter and run a simulation.   

 

 
3. Create a new Workspace using the Wizard 

a. In the Main window, click either the either the icon (shown 
here) or the menu command File > New > Workspace to 
create a new workspace.  Note that using icons usually means 
fewer mouse clicks. 

b. When the wizard appears, read 
through the introduction which 
describes the workspace as a 
directory and how libraries, data, and 
other files are used with it.  Then 
click: Next. 
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c. Workspace Name - Type in 
the name shown here: 
My_LPF_wrk.   Also, be sure 
to create it in the start-up 
directory which is typically 
C:\Users\default.   

The wizard is the only way to 
create a workspace.  Click 
Next to continue. 

 

 

d. Add Libraries – Select only 
the Analog/RF library as 
shown here – uncheck all 
others.  

 This means that those 
components, from the 
RF/Analog library, will be 
available for your design.  
Later, you can add 
(reference) other libraries or 
PDKs. 

 Click Next. 

 

 

e. Library Name: This shows the 
default library name (same as 
the workspace) that will be 
used, unless you change it.   

This means that any designs 
you create will be in this 
library and can be used by 
other workspaces if 
referenced.  For now, click 
Next. 

 



Lab 1: Workspaces, Filter Design and Tuning 

Copyright 2012 Agilent Technologies  

6 

 

 

f.  Technology: This dialog 
allows you to select the 
available layout drawing 
layers and resolution.  
Typically, a PDK technology 
would appear here. 

Because you selected the 
Analog/RF library built in to 
ADS, these standard layers 
appear.  Click Next with the 
top layers (using mils) 
selected. 

 

 

g. Summary: This shows all you 
selections for the new 
workspace.  If these are 
correct, click the Finish button. 

 

 

 

 

h. The ADS Main window should 
now show the newly created 
workspace in your specified 
directory.   

 Now you know that the wizard is 
fast and easy to use for creating 
new workspaces. The next step 
is to start designing… 
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4. Creating Cells and Schematic views  

 The first step in starting a design is to begin with a blank schematic.  When 
you create a new schematic, a cell is also created as you will see. 

a. In the Main window, click on the icon: New Schematic    
Window as shown here. 

 

b. When the dialog appears, type in the name LPF_designs instead of the default 
(cell1).  Note that in ADS, underscore characters are recommended instead of 
blank spaces and click OK and the schematic window will open. 

NOTE: The default View name for a new schematic is schematic.   

 

c. In the Main window, expand the cell view - you will see the schematic view 
icon. Also, the library name (My_LPF) may appear as a prefix for the cell 
name.  However, for this workspace, it will be turned off.  To do this:  right-
click on the cell name and uncheck the command:  Show Library Name. 
This is how you turn it on or off to see the cell’s library. Try it now.  
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5. Schematic Window basics for LPF design  

a. Familiarize yourself with the schematic window by quickly locating the 
commands, icons, palette, and cursor location values shown here. 

b. Click the small arrow on the Component Palette list to see other 
palettes. Also, move the Scroll Bar down and up to see how it works.   

 

NOTE: Schematic origin (x-y) crosshair was turned off using 
the command: Options > Preferences > Display tab: 
 
6. Inserting and wiring components  

a. In the Lumped Components palette, select (click) the capacitor C (not the C 
model) and insert it.  Then rotate the capacitor for the correct orientation 
using either the icon or handle as shown here.  
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b. Insert another capacitor - you could 

insert it and rotate again.  However, to 
quickly make a copy with the correct 
orientation, use the copy icon. Also, 
you can use the Esc key to end a 
command. 

 NOTE:  Try using these icons as you 
build the design- they are useful: 

 

c. Continue building the low-
pass filter by inserting the 
inductor and grounds. 
Then wire the components 
together by connecting pins 
or use the wire icon.  Try 
different methods - this will 
give you practice with 
schematic capture.   

d. After the filter is built, edit the value of L1 to be 1.5 nH.  To do this, double 
click the inductor or use the Edit icon (R=17 shown here).  Then, in the dialog, 
change the value and click OK.  Also, change the value of C2 =0.5 pF – do 
this directly on screen. Try both methods of editing values. 
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e. Select the Simulation-S_Param palette (shown here) and insert the S-
parameter simulation controller (gear icon).   

 

f. Insert the port terminations:  Term (Num= 1) and Term (Num=2) and be sure 
to ground them.  

 
7. Schematic Options: Preferences 

Preferences can be used to customize the schematic colors, grid, origin 
crosshair, text, rotation angle, and more.   

a. Click the schematic menu command:  Options > Preferences.   

 

b. When the dialog appears, select the Grid/Snap tab.  You 
can turn the grid dots off from schematic by selecting 
None - then click Apply. This way, you do not have a 
decimal point interferring with a grid dot. This and any 
other settings, such as Display color, are optional if you 
prefer to change them. 
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8. S-Parameter Simulation setup 

a. To setup the simulation, double click on the S-
parameter simulation controller on the schematic. 
When the dialog box appears, change the Step-
size to 0.5 GHz and click Apply.  Notice how it 
updates the value on the screen. The OK button 
does the same thing as Apply and also dismisses 
the dialog box – do not click OK yet. 

b. Click the Display tab and you will see that the 
Start, Stop and Step values have been checked 
(by default) to be displayed on the schematic.  
Later in this course, you will use the display tab 
to check other parameters you want displayed on 
the schematic. 

c. Click the OK button to dismiss the dialog box.  
You are now ready to simulate. 

 

9. Launch the simulation and view the Status window 

a. At the top of the schematic window, click the Simulate icon 
gear (shown here) to start the simulation process. 

b. Next, look for the Status window to appear and you should 
see messages similar to the ones here, describing the results of the 
simulation, the writing of the dataset file, and the creation of a display 
window.  If not, ask the instructor for help. 

 

c. If no simulation errors 
occurred, close the Status 
window. You can always 
recall the status window 
using the schematic 
window command: 
Window > Simulation 
Status (try it). 
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10. Data Display and plotting data 

a. The Data Display window appears with the default dataset ready to plot, 
list, or for use to write equations. Notice also that you can have multiple 
pages of data – here page 1 is blank.  Examine the picture shown here – 
next you will plot the simulation data. 

 

b. To create the plot, click 
on the Rectangular 
Plot icon and move the 
cursor (outlined box) 
into the window and 
click. When the next 
dialog box appears, 
select the S(2,1) data 
and click the Add 
button.  Then select dB 
as the format for the 
data. Click OK in both 
boxes. 
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c. The plot should show a reasonable low pass filter response.  Also, if you 
have a mouse wheel – try using it to zoom in and out. 

d. Use the View all icon to fit the plot in the window.  

 

e. Put a marker on the trace: Click the first 
marker icon on the toolbar (shown here).  
You will be prompted to select a trace to 
insert the marker.   With the marker or 
the marker read-out selected, use the 
arrow keys to find the closest 3 dB 
value. 

 

 

f. Next, try using the other marker icons.  You can also move markers using 
the cursor or the keyboard arrow keys.   

 

g. Notice the asterisk (*) at the top of the window.  For 
all the Data Display, Schematic and Layout 
windows, the asterisk means it has not been saved.  
Save it and the asterisk disappears. 

 

NOTE:  Data Display windows have the file extension .dds which 
means: data display server, and they are always in the 
workspace directory – not in the library. 

h. KEEP THIS WINDOW OPEN for the next steps. 
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11. Tuning parameter values  

This step introduces the ADS tuning feature that allows you to tune parameter values 
see the simulation results in the data display.  You select the tuning feature first and 
then you select the component parameters or the components as you will see. 

a. Position the Data Display window and 
the Schematic window so you can see 
them both on the screen easily – make 
the schematic window active as shown 
here. If necessary, re-size the windows 
and use View All.  

 

b. Now, start the tuner by clicking the Tuning icon (shown here).  
Tuning controls the simulator.  Therefore, a simulation 
controller is always required. 

c. Immediately, the status (simulation) window will appear along with the Tune 
Parameters dialog.  You may have to rearrange the windows to see them. 

d. Go ahead and click on the C =1 pF parameter on the schematic as shown here.  
When you do, the tunable parameter will appear in the Tuner and you will see the 
{t} to show that it is enabled for tuning.    

 

e. Go ahead and add the other capacitor value and the inductor so that all three 
component parameters are tunable.  Try tuning the response to improve it and 
then click Update Schematic and those values will appear on the components. 
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f. Take a few moments to experiment with the Tuner (tune the other capacitor and 
inductor) and watch the data display and schematic as you do.  After 
experimenting with the tuner, click Close – do not be concerned about the final 
values. This was only a starting point using ideal components to show you how 
the tuner works.  If you have time, also try adjusting the other tuner values. Or, 
try using some of the Data Display features. 

 

g. Save and close the schematic window and the Data Display. 

h. Workspace Folder and Library views: The Main 
window should appear with one cell, one schematic, 
and one Data Display in the Folder View.  Verify this 
and also look at the Library View which shows all the 
files for the workspace, including datasets.    

 

At this point, you have created a workspace and a 
library using built-in ADS layers.  You also built a LPF design using ideal 
components in a cell, set up and run an S-parameter simulation and plotted the 
data in the data display. 

 

Those are the basic elements of ADS: workspace and simulation tools. 

END OF LAB EXERCISE 

 


