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Abstract 

The JDBC API provides Java applications with mid-level access to most database systems, via the Structured Query Language 
(SQL). JDBC is a key enterprise API, as it's hard to imagine an enterprise application that doesn't use a database in some way. 
JDBC is a Java-API to execute SQL statements. It is a package of classes and interfaces, programmed in Java. JDBC is a 
standard API to develop instruments for  Databases  with JDBC SQL statements are easily sent to almost all relational Databases. 
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1. Introduction 

JDBC, a Java API which enables Java programs to execute SQL statements. This allows Java programs to 
work together with any SQL-compliant database. Since nearly all relational database management systems 
(DBMSs) maintain SQL, and because Java itself runs on most platforms, JDBC makes it achievable to write a single 
database application that can run on different platforms and cooperate with different DBMSs.  

JDBC is similar to ODBC, however is designed particularly for Java programs, while ODBC is language-
independent. JDBC allows numerous implementations to exist and be used by the same application. The API 
provides a method for dynamically loading the accurate Java packages and registering them with the JDBC Driver 
Manager. The Driver Manager is used as a connection factory for creating. JDBC connections support creating and 
executing statements. These may be update statements such as SQL's CREATE, INSERT, UPDATE and DELETE, 
or they may be query statements such as SELECT. Moreover, stored procedures may be invoked through a JDBC 
connection. JDBC represents statements by means of one of the following classes: 

• Statement– the statement is sent to the database server each and every time. 
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• Prepared Statement– the statement is cached and then the execution path is pre-determined on the 
database server allowing it to be executed multiple times in an efficient manner. 

• Callable Statement– used for executing stored procedures on the database. 

Update statements such as INSERT, UPDATE and DELETE return an update count that indicates how many rows 
were affected in the database. These statements do not return any other information. 

JDBC drivers are client-side adapters (installed on the client machine, not on the server) that convert requests from 
Java programs to a protocol that the DBMS can understand. 

 

2. Types of Drivers 

There are commercial and free drivers available for most relational database servers. These drivers fall into 
one of the following types: 

DRIVER DESCRIPTION 
TYPE 1 Implements JDBC by mapping JDBC calls to other CLI calls. Uses a binary 

library written in another language. Requires software on the client machine, 
for example, the JDBC-ODBC bridge driver. 

TYPE 2 Driver is partially composed of Java code and partially in native code using 
another CLI . Requires some client-side binary code. 

TYPE 3 Pure Java driver; uses middleware to convert JDBC calls to vendor-specific 
calls and protocol required to access the database. 

TYPE 4 Pure Java driver that implements the native protocol. Does not require 
middleware or any client-side binary. Can be downloaded to a client if 
necessary. 

 

3. JDBC Design 

Just as Java was designed to provide platform independence from hardware/software platforms, so too 
JDBC has been designed to provide some degree of database independence for developers. JDBC is designed to 
provide a database-neutral API for accessing relational databases from different vendors. Just as a Java application 
does not need to be aware of the operating system platform on which it is running, so too JDBC has been designed 
so that the database application can use the same methods to access data regardless of the underlying database 
product.  

JDBC was developed to work with the most common type of database: the relational database. This is not 
to say that JDBC cannot be used with another type of database. In fact, there are JDBC drivers that allow the API to 
be used to connect to both high-end, mainframe databases, which are not relational, and to access flat files and 
spreadsheets as databases (which are definitely not relational). But the reality is that JDBC is most commonly used 
with relational databases. 

4. Structured Query Language 

SQL is a standardized query language for requesting information from a database. The original version 
called SEQUEL (structured English query language) was designed by an IBM research center in 1974 and 1975. 
SQL was first introduced as a commercial database system in 1979 by Oracle Corporation. 
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Historically, SQL has been the favorite query language for database management systems running on minicomputers 
and mainframes. Increasingly, however, SQL is being supported by PC database systems because it supports 
distributed databases (databases that are spread out over several computer systems). This enables several users on a 
local-area network to access the same database simultaneously. 

Although there are different dialects of SQL, it is nevertheless the closest thing to a standard query language 
that currently exists. In 1986, ANSI approved a rudimentary version of SQL as the official standard, but most 
versions of SQL since then have included many extensions to the ANSI standard. In 1991, ANSI updated the 
standard. The new standard is known as SAG SQL. 

• SQL SERVER 

Generically, any database management system (DBMS) that can respond to queries from client machines 
formatted in the SQL language. When capitalized, the term generally refers to either of two database 
management products from Sybase and Microsoft. Both companies offer client-server DBMS products called 
SQL Server. 

 

5. Queries 

The most common operation in SQL is the query, which is performed with the declarative SELECT statement. 
SELECT retrieves data from one or more tables, or expressions. Standard SELECT statements have no persistent 
effects on the database. Some non-standard implementations of SELECT can have persistent effects, such as the 
SELECT INTO syntax that exists in some databases.[18]. Queries allow the user to describe desired data, leaving 
the database management system (DBMS) responsible for planning, optimizing, and performing the physical 
operations necessary to produce that result as it chooses. 
 
A query includes a list of columns to be included in the final result immediately following the SELECT keyword. 
An asterisk ("*") can also be used to specify that the query should return all columns of the queried tables. SELECT 
is the most complex statement in SQL, with optional keywords and clauses that include: 
The FROM clause which indicates the table(s) from which data is to be retrieved. The FROM clause can include 
optional JOIN subclauses to specify the rules for joining tables.The WHERE clause includes a comparison 
predicate, which restricts the rows returned by the query. The WHERE clause eliminates all rows from the result set 
for which the comparison predicate does not evaluate to True. 
 
 The GROUP BY clause is used to project rows having common values into a smaller set of rows. 
GROUP BY is often used in conjunction with SQL aggregation functions or to eliminate duplicate rows from a 
result set. The WHERE clause is applied before the GROUP BY clause. The HAVING clause includes a predicate 
used to filter rows resulting from the GROUP BY clause. Because it acts on the results of the GROUP BY clause, 
aggregation functions can be used in the HAVING clause predicate. The ORDER BY clause identifies which 
columns are used to sort the resulting data, and in which direction they should be sorted (options are ascending or 
descending). Without an ORDER BY clause, the order of rows returned by an SQL query is undefined. 
 
The following is an example of a SELECT query that returns a list of expensive books. The query retrieves all rows 
from the Book table in which the price column contains a value greater than 100.00. The result is sorted in 
ascending order by title. The asterisk (*) in the select list indicates that all columns of the Book table should be 
included in the result set. 
 
SELECT * 
 FROM  Book 
 WHERE price > 100.00 
 ORDER BY title; 
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6. Basic JDBC Programming Concepts 
 
6.1 Preparation 
 
DOWNLOAD MY SQL 
 

1. Download and Install MySQL Server 
a. mysql-essential-5.0.67-win32.msi  
b. Username: root; password: root 

2. Download and Install MySQL GUI Tools 
a. mysql-gui-tools-5.0-r12-win32.msi 

3. Download MySQL JDBC Driver 
a. mysql-connector-java-5.1.6-bin.jar  

 
DOWNLOAD ECLIPSE 

 
• Download and Uncompress 

Install Eclipse Data Tools Platform (DTP) Plugin 
1. Running Eclipse 
2. Help > Software Updates… 
3. Available Software > Expand Ganymede 
4. Check Database Development > Install… 
5. Next > I accept… > Finish 

 
• Greeting Problem 

Develop a database called GREETINGS that has a table called Greetings. Try to put “Hello,World!”  to this 
database. After that, try to show all greetings stored in the database, and then delete the Greetings table 
 
Solution to Greeting Problem 
 
Project name: Greetings 
1. Solution Using SQL Script 
2. Solution Using Java 
 

1. Solution using SQL Script 
 
1.1 Creating an Empty Database 
1.2. Creating a Connection Profile 
1.3. Creating a SQL Script 
1.4. Executing the SQL Script 

1.1 Creating an Empty Database 
• Run MySQL Query Browser 
• Right-click to an empty area of Schemata >  Create New Schema 
• Schema name: greetings 
• OK 
 
1.2 Creating a Connection Profile 

• Open Database Development Perspective 
Window > Open Perspective > Other… 
Database Development > OK 

• Data Source Explorer 
1. Databases > Icon New Connection Profile 
2. MySQL > Name: MySQL > Next 
3. Icon New Driver Definition 
4. Name/Type: 5.1 
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5. Jar List: mysql-connector-java-5.1.6-bin.jar 
6. Properties: 

       *Connection URL: jdbc:mysql://localhost:3306/GREETINGS 
*Database:  greetings 
*Password: ??? 
 

1.3 Creating a SQL 
 

• File > New > Other... 
– SQL Development > SQL File > Next 
– File name: greetings.sql 
– Database server type: MySql_5.1 
– Connection profile name: MySQL  
– Database name: GREETINGS 
– Finish 
 

• Content 
DROP TABLE IF EXISTS Greetings; 
CREATE TABLE Greetings( 
  greeting_id INTEGER UNSIGNED 
              NOT NULL 
              AUTO_INCREMENT 
              PRIMARY KEY, 
  message VARCHAR(255)); 
INSERT INTO Greetings(message) 
  VALUES ('Hello, World!'); 
SELECT * FROM Greetings; 
DROP TABLE Greetings; 
 

1.4 Executing SQL Script 
• Right-click to an empty area of greetings.sql >  Execute All 
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2. Solution Using Java 
 
2.1Creating an Empty Database 
 
2.2. Copying the JDBC Driver JAR 
 File to the Project Folder 
 
2.3. Creating a Database  
Configuration File 
 
2.4. Developing a Utility to Get a DB Connection 
 
2.5. Developing the Test Class 
2.1 Creating an Empty Database 
 Same as in the case using SQL Script. 
 
2.2Copying the JDBC Driver JAR File to the Project Folder 
 

• JAR File: mysql-connector-java-5.1.6-bin.jar 
• In Eclipse 

– Create the lib folder: Right-click the project's root folder > New > Folder > Folder name: lib > 
Finish 

– Copy the JAR file to the lib folder 
– Right-click the JAR file > Build Path > Add to Build Path 

 
2.3. Creating a Database Configuration File 
 

• Right-click the project's root folder > New > File > File name: persistence.properties > Finish 
drivers=com.mysql.jdbc.Driver  
url=jdbc:mysql://localhost:3306/GREETINGS 
username=root 
password=root 
 
 
2.4 Developing a Utility to Get a DB Connection 
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2.5. Developing the Test Class 
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7. Executing SQL Statements 

 
• To execute a SQL statement, we first create a Statement object. 

– To create statement objects, use the Connection object that we obtained from 
DriverManager.getConnection. 

Statement stat = conn.createStatement(); 
• Next, place the statement that we want to execute into a string 

String command = “INSERT INTO Greetings(message) VALUES('Hello World!')”; 
String query = “SELECT * FROM Greetings”; 

• Execute a statement: 
    stat.executeUpdate(command); 
    stat.executeQuery(query); 

executeUpdate: 
 
– can execute actions such as INSERT, UPDATE, and DELETE as well as data definition 

statements such as CREATE TABLE and DROP TABLE 
– returns a count of the rows that were affected by the SQL statement, or zero for statements that do 

not return a row count 
 
executeQuery: 

 
• executes SELECT queries 
• returns an object of type ResultSet that you use to walk through the result one row at a time. 
ResultSet rs = stat.executeQuery("SELECT 
                   * FROM Greetings"); 
The basic loop for analyzing a result set looks like this: 

–    while (rs.next()) { 
       //look at a row of the result set 

 
 

8. Result Set 
 

 The order of the rows in a result set is completely arbitrary (unless you specifically ordered the result 
with an ORDER BY clause). When inspecting an individual row, you will want to know the contents of the fields. 
There are accessors for various types, such as getInt, getString and getDouble, getDate .... Each accessor has two 
forms : 

1. one that takes a numeric argument: the first column is 1. 
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2. one that takes a string argument.  
try { 
   Connection conn = . . .; 
   try { 
      Statement stat = conn.createStatement(); 
      ResultSet result = stat.executeQuery(queryString); 
      //process query result 
   } catch(SQLException ex) { 
       for (Throwable t : ex) { 
         //do something with t 
         t.printStackTrace(); 
} finally { 
      conn.close(); 
   } 
} 
catch (SQLException ex) { 
   for (Throwable t : ex) { 
      //do something with t  
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